Welcome to syslog-ng312, trackng syslog-ng the 3.12 branch.

Submitted by:	Peter Czanik (CzP) <peter.czanik@balabit.com>
		Balabit / syslog-ng upstream
This commit is contained in:
Cy Schubert 2017-09-25 18:51:17 +00:00
parent 2e46e22065
commit ae0e4a2976
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=450628
10 changed files with 827 additions and 1 deletions

View file

@ -1143,6 +1143,7 @@
SUBDIR += syslog-ng-incubator
SUBDIR += syslog-ng310
SUBDIR += syslog-ng311
SUBDIR += syslog-ng312
SUBDIR += syslog-ng36
SUBDIR += syslog-ng37
SUBDIR += syslog-ng39

View file

@ -1,6 +1,6 @@
# $FreeBSD$
VERSIONS= 36 37 39 310 311
VERSIONS= 36 37 39 310 311 312
SYSLOG_NG_VERSION?= 311
MASTERDIR= ${.CURDIR}/../syslog-ng${SYSLOG_NG_VERSION}

View file

@ -0,0 +1,172 @@
# Created by: Ivan Lago <ivan.lago@ifom-ieo-campus.it>
# $FreeBSD$
PORTNAME= syslog-ng
DISTVERSION= 3.12.1
CATEGORIES= sysutils
DISTFILES= syslog-ng-${DISTVERSION}.tar.gz
MASTER_SITES= https://github.com/balabit/syslog-ng/releases/download/syslog-ng-${DISTVERSION}/
.if !defined(MASTERDIR)
PKGNAMESUFFIX= 312
.endif
MAINTAINER= cy@FreeBSD.org
COMMENT= Powerful syslogd replacement
LIB_DEPENDS= libpcre.so:devel/pcre \
libuuid.so:misc/e2fsprogs-libuuid \
libbson-1.0.so:devel/libbson
BROKEN_powerpc64= fails to link: Internal error: Segmentation fault (program ld)
BROKEN_sparc64= fails to link: Internal error: Segmentation fault (program ld)
CONFLICTS?= syslog-ng-[0-9]* syslog-ng[0-9]-[0-9]* \
syslog-ng[0-9][0-9]-[0-9]* \
syslog-ng-devel-[0-9]* eventlog*
WRKSRC= ${WRKDIR}/${PORTNAME}-${DISTVERSION}
MAKE_JOBS_UNSAFE= yes
OPTIONS_DEFINE= TCP_WRAPPERS SQL SPOOF IPV6 SMTP JSON GEOIP GEOIP2 DOCS REDIS JAVA PYTHON MONGO CURL JAVA_MOD
OPTIONS_DEFAULT= JSON
TCP_WRAPPERS_DESC= Build with TCP Wrappers
SQL_DESC= Build with database (libdbi) support
SPOOF_DESC= Build with spoof source support
SMTP_DESC= Build with SMTP support
JSON_DESC= Build with JSON-C support
GEOIP_DESC= Build with GeoIP support (depreciated)
GEOIP2_DESC= Build with geoip2 (MaxMindDB) support
REDIS_DESC= Build with Redis support
JAVA_DESC= Build with Java support (no modules)
JAVA_MOD_DESC= Build with Java modules (needs Maven / Internet access)
PYTHON_DESC= Build with Python 2.7 support
CURL_DESC= Build with Curl HTTP support
USES= autoreconf:build gmake libtool pathfix pkgconfig ssl \
gettext-runtime python shebangfix
USE_LDCONFIG= yes
USE_RC_SUBR= syslog-ng
SHEBANG_FILES= lib/merge-grammar.py
SHEBANG_LANG= python
GNU_CONFIGURE= yes
USE_GNOME= glib20
SUB_FILES= pkg-message
INSTALL_TARGET= install-strip
CONFIGURE_ARGS= --sysconfdir=${LOCALBASE}/etc --localstatedir=/var/db \
--enable-dynamic-linking --enable-manpages \
--disable-linux-caps \
--datadir=${PREFIX}/share/
CONFIGURE_ENV+= OPENSSL_CFLAGS="-I${OPENSSLINC}" \
OPENSSL_LIBS="-L${OPENSSLLIB} -lcrypto -lssl"
TCP_WRAPPERS_CONFIGURE_ENABLE= tcp-wrapper
SPOOF_LIB_DEPENDS= libnet.so:net/libnet
SPOOF_CONFIGURE_ENABLE= spoof-source
SPOOF_CONFIGURE_ON= --with-libnet=/usr/local/bin
SPOOF_CONFIGURE_ENV= LIBNET_CFLAGS="-I/usr/local/include" \
LIBNET_LIBS="-L/usr/local/lib -lnet"
IPV6_CONFIGURE_ENABLE= ipv6
GEOIP_CONFIGURE_ENABLE= geoip
GEOIP_LIB_DEPENDS= libGeoIP.so:net/GeoIP
GEOIP_CONFIGURE_ENV= GEOIP_LIBS="-L${LOCALBASE}/lib -lGeoIP"
GEOIP_PLIST_FILES= lib/syslog-ng/libgeoip-plugin.so
GEOIP2_CONFIGURE_ENABLE= geoip2
GEOIP2_LIB_DEPENDS= libmaxminddb.so:net/libmaxminddb
GEOIP2_LDFLAGS= -L${LOCALBASE}/lib
GEOIP2_PLIST_FILES= lib/syslog-ng/libgeoip2-plugin.so
REDIS_CONFIGURE_ENABLE= redis
REDIS_LIB_DEPENDS= libhiredis.so:databases/hiredis
REDIS_PLIST_FILES= lib/syslog-ng/libredis.so
SMTP_CONFIGURE_ON= --with-libesmtp=${LOCALBASE} --enable-smtp
SMTP_CONFIGURE_OFF= --without-libesmtp --disable-smtp
SMTP_LIB_DEPENDS= libesmtp.so:mail/libesmtp
SMTP_PLIST_FILES= lib/syslog-ng/libafsmtp.so
SQL_CONFIGURE_ENABLE= sql
SQL_LIB_DEPENDS= libdbi.so:databases/libdbi
SQL_CONFIGURE_ENV= LIBDBI_LIBS="-ldbi"
SQL_LDFLAGS= -L${LOCALBASE}/lib
SQL_PLIST_FILES= lib/syslog-ng/libafsql.so
MONGO_CONFIGURE_ENABLE= mongodb
MONGO_LIB_DEPENDS= libmongoc-1.0.so:devel/mongo-c-driver
MONGO_PLIST_FILES= lib/syslog-ng/libafmongodb.so
JSON_CONFIGURE_ENABLE= json
JSON_LIB_DEPENDS= libjson-c.so:devel/json-c
JSON_PLIST_FILES= lib/syslog-ng/libjson-plugin.so \
share/syslog-ng/include/scl/cim/template.conf
JAVA_CONFIGURE_ENABLE= java
JAVA_USE_JAVA= yes
JAVA_PLIST_FILES= lib/syslog-ng/libmod-java.so \
lib/syslog-ng/java-modules/syslog-ng-core.jar
JAVA_MOD_CONFIGURE_ENABLE= java-modules
JAVA_MOD_USE_JAVA= yes
JAVA_MOD_BUILD_DEPENDS= gradle:devel/gradle \
bash:shells/bash
JAVA_MOD_PLIST_DIRS= lib/syslog-ng/java-modules/elastic-jest-client
JAVA_MOD_PLIST_FILES= lib/syslog-ng/java-modules/log4j-1.2.16.jar \
lib/syslog-ng/java-modules/elastic-jest-client/jest-2.0.2.jar \
lib/syslog-ng/java-modules/elastic-jest-client/jest-common-2.0.2.jar \
lib/syslog-ng/java-modules/elastic-jest-client/httpcore-nio-4.4.4.jar \
lib/syslog-ng/java-modules/elastic-jest-client/httpclient-4.5.2.jar \
lib/syslog-ng/java-modules/elastic-jest-client/httpasyncclient-4.1.1.jar \
lib/syslog-ng/java-modules/elastic-jest-client/slf4j-api-1.7.13.jar \
lib/syslog-ng/java-modules/elastic-jest-client/guava-19.0.jar \
lib/syslog-ng/java-modules/elastic-jest-client/gson-2.6.2.jar \
lib/syslog-ng/java-modules/elastic-jest-client/commons-lang3-3.4.jar \
lib/syslog-ng/java-modules/elastic-jest-client/httpcore-4.4.4.jar \
lib/syslog-ng/java-modules/elastic-jest-client/commons-logging-1.2.jar \
lib/syslog-ng/java-modules/elastic-jest-client/commons-codec-1.9.jar \
lib/syslog-ng/java-modules/elastic-jest-client/slf4j-simple-1.7.13.jar \
lib/syslog-ng/java-modules/hdfs.jar \
lib/syslog-ng/java-modules/elastic.jar \
lib/syslog-ng/java-modules/elastic-v2.jar \
lib/syslog-ng/java-modules/kafka.jar \
lib/syslog-ng/java-modules/dummy.jar \
lib/syslog-ng/java-modules/http.jar \
lib/syslog-ng/java-modules/syslog-ng-common.jar
PYTHON_CONFIGURE_ENABLE= python
PYTHON_CONFIGURE_WITH= python=2.7
PYTHON_USES= python:2.7
PYTHON_PLIST_FILES= lib/syslog-ng/libmod-python.so
CURL_CONFIGURE_OFF= --with-libcurl=off
CURL_LIB_DEPENDS= libcurl.so:ftp/curl
CURL_PLIST_FILES= lib/syslog-ng/libhttp.so
.include <bsd.port.pre.mk>
post-patch:
@${CP} ${WRKSRC}/scl/syslog-ng.conf ${WRKSRC}/scl/syslog-ng.conf.dist
@${CP} ${WRKSRC}/scl/scl.conf ${WRKSRC}/scl/scl.conf.sample
post-install:
.if ${PORT_OPTIONS:MDOCS}
${INSTALL} -d -o ${SHAREOWN} -g ${SHAREGRP} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/AUTHORS ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/COPYING ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/NEWS.md ${STAGEDIR}${DOCSDIR}
.endif
${INSTALL_MAN} ${WRKSRC}/doc/man/*.1 ${STAGEDIR}${PREFIX}/man/man1/
${INSTALL_MAN} ${WRKSRC}/doc/man/*.5 ${STAGEDIR}${PREFIX}/man/man5/
${INSTALL_MAN} ${WRKSRC}/doc/man/*.8 ${STAGEDIR}${PREFIX}/man/man8/
${INSTALL_DATA} ${FILESDIR}/syslog-ng.conf.sample \
${STAGEDIR}${PREFIX}/etc
${INSTALL_DATA} ${WRKSRC}/scl/syslog-ng.conf.dist \
${WRKSRC}/scl/scl.conf.sample ${STAGEDIR}${PREFIX}/etc
${INSTALL_DATA} ${WRKSRC}/lib/ivykis/src/include/iv*.h \
${STAGEDIR}${PREFIX}/include/syslog-ng/
.include <bsd.port.post.mk>

View file

@ -0,0 +1,3 @@
TIMESTAMP = 1505999152
SHA256 (syslog-ng-3.12.1.tar.gz) = 12d2acb8e292d16068debae7f9a699e791ca497540d28833a694a9a1ccd78f43
SIZE (syslog-ng-3.12.1.tar.gz) = 8905646

View file

@ -0,0 +1,58 @@
--- configure.orig 2016-08-10 07:38:05.000000000 -0700
+++ configure 2016-08-10 12:33:00.605666000 -0700
@@ -10250,7 +10250,7 @@
hardcode_minus_L=no
hardcode_shlibpath_var=unsupported
inherit_rpath=no
- link_all_deplibs=unknown
+ link_all_deplibs=no
module_cmds=
module_expsym_cmds=
old_archive_from_new_cmds=
@@ -11952,6 +11952,7 @@
case $version_type in
freebsd-elf*)
library_names_spec='${libname}${release}${shared_ext}$versuffix ${libname}${release}${shared_ext} $libname${shared_ext}'
+ soname_spec='${libname}${release}${shared_ext}${major}'
need_version=no
need_lib_prefix=no
;;
@@ -13035,7 +13036,7 @@
old_striplib=
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking whether stripping libraries is possible" >&5
$as_echo_n "checking whether stripping libraries is possible... " >&6; }
-if test -n "$STRIP" && $STRIP -V 2>&1 | $GREP "GNU strip" >/dev/null; then
+if test -n "$STRIP" && $STRIP -V 2>&1 | $GREP "strip" >/dev/null; then
test -z "$old_striplib" && old_striplib="$STRIP --strip-debug"
test -z "$striplib" && striplib="$STRIP --strip-unneeded"
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: yes" >&5
@@ -15195,9 +15196,9 @@
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for LIBNET" >&5
$as_echo_n "checking for LIBNET... " >&6; }
if test "x$with_libnet" = "x"; then
- LIBNET_CONFIG="`which libnet-config`"
+ LIBNET_CONFIG="`which libnet11-config`"
else
- LIBNET_CONFIG="$with_libnet/libnet-config"
+ LIBNET_CONFIG="$with_libnet/libnet11-config"
fi
if test -n "$LIBNET_CONFIG" -a -x "$LIBNET_CONFIG"; then
@@ -16424,7 +16425,7 @@
if test -e "$JAVA_HOME_CHECKER"; then
JNI_HOME=`$JAVA_HOME_CHECKER`
else
- JNI_HOME=`echo $JAVAC_BIN | sed "s/\(.*\)[/]bin[/]java.*/\1\//"`
+ JNI_HOME=`echo $JAVAC_BIN | sed "s/\(.*\)[/]bin[/]java.*/\1\/openjdk\*/"`
fi
JNI_LIBDIR=`find $JNI_HOME \( -name "libjvm.so" -or -name "libjvm.dylib" \) \
@@ -16531,7 +16532,7 @@
if test -e "$JAVA_HOME_CHECKER"; then
JNI_HOME=`$JAVA_HOME_CHECKER`
else
- JNI_HOME=`echo $JAVAC_BIN | sed "s/\(.*\)[/]bin[/]java.*/\1\//"`
+ JNI_HOME=`echo $JAVAC_BIN | sed "s/\(.*\)[/]bin[/]java.*/\1\/openjdk\*/"`
fi
JNI_LIBDIR=`find $JNI_HOME \( -name "libjvm.so" -or -name "libjvm.dylib" \) \

View file

@ -0,0 +1,29 @@
syslog-ng is now installed! To replace FreeBSD's standard syslogd
(/usr/sbin/syslogd), complete these steps:
1. Create a configuration file named %%PREFIX%%/etc/syslog-ng.conf
(a sample named syslog-ng.conf.sample has been included in
%%PREFIX%%/etc). Note that this is a change in 2.0.2
version, previous ones put the config file in
%%PREFIX%%/etc/syslog-ng/syslog-ng.conf, so if this is an update
move that file in the right place
2. Configure syslog-ng to start automatically by adding the following
to /etc/rc.conf:
syslog_ng_enable="YES"
3. Prevent the standard FreeBSD syslogd from starting automatically by
adding a line to the end of your /etc/rc.conf file that reads:
syslogd_enable="NO"
4. Shut down the standard FreeBSD syslogd:
kill `cat /var/run/syslog.pid`
5. Start syslog-ng:
%%PREFIX%%/etc/rc.d/syslog-ng start

View file

@ -0,0 +1,185 @@
@version:3.12
@include "scl.conf"
#
# This sample configuration file is essentially equilivent to the stock
# FreeBSD /etc/syslog.conf file.
#
# $FreeBSD: head/sysutils/syslog-ng/files/syslog-ng.conf.sample 340872 2014-01-24 00:14:07Z mat $
#
#
# options
#
options { chain_hostnames(off); flush_lines(0); threaded(yes); };
#
# sources
#
source src { system();
udp(); internal(); };
#
# destinations
#
destination messages { file("/var/log/messages"); };
destination security { file("/var/log/security"); };
destination authlog { file("/var/log/auth.log"); };
destination maillog { file("/var/log/maillog"); };
destination lpd-errs { file("/var/log/lpd-errs"); };
destination xferlog { file("/var/log/xferlog"); };
destination cron { file("/var/log/cron"); };
destination debuglog { file("/var/log/debug.log"); };
destination consolelog { file("/var/log/console.log"); };
destination all { file("/var/log/all.log"); };
destination newscrit { file("/var/log/news/news.crit"); };
destination newserr { file("/var/log/news/news.err"); };
destination newsnotice { file("/var/log/news/news.notice"); };
destination slip { file("/var/log/slip.log"); };
destination ppp { file("/var/log/ppp.log"); };
destination console { file("/dev/console"); };
destination allusers { usertty("*"); };
#destination loghost { udp("loghost" port(514)); };
#
# log facility filters
#
filter f_auth { facility(auth); };
filter f_authpriv { facility(authpriv); };
filter f_not_authpriv { not facility(authpriv); };
#filter f_console { facility(console); };
filter f_cron { facility(cron); };
filter f_daemon { facility(daemon); };
filter f_ftp { facility(ftp); };
filter f_kern { facility(kern); };
filter f_lpr { facility(lpr); };
filter f_mail { facility(mail); };
filter f_news { facility(news); };
filter f_security { facility(security); };
filter f_user { facility(user); };
filter f_uucp { facility(uucp); };
filter f_local0 { facility(local0); };
filter f_local1 { facility(local1); };
filter f_local2 { facility(local2); };
filter f_local3 { facility(local3); };
filter f_local4 { facility(local4); };
filter f_local5 { facility(local5); };
filter f_local6 { facility(local6); };
filter f_local7 { facility(local7); };
#
# log level filters
#
filter f_emerg { level(emerg); };
filter f_alert { level(alert..emerg); };
filter f_crit { level(crit..emerg); };
filter f_err { level(err..emerg); };
filter f_warning { level(warning..emerg); };
filter f_notice { level(notice..emerg); };
filter f_info { level(info..emerg); };
filter f_debug { level(debug..emerg); };
filter f_is_debug { level(debug); };
#
# program filters
#
filter f_ppp { program("ppp"); };
filter f_slip { program("startslip"); };
#
# *.err;kern.warning;auth.notice;mail.crit /dev/console
#
log { source(src); filter(f_err); destination(console); };
log { source(src); filter(f_kern); filter(f_warning); destination(console); };
log { source(src); filter(f_auth); filter(f_notice); destination(console); };
log { source(src); filter(f_mail); filter(f_crit); destination(console); };
#
# *.notice;authpriv.none;kern.debug;lpr.info;mail.crit;news.err /var/log/messages
#
log { source(src); filter(f_notice); filter(f_not_authpriv); destination(messages); };
log { source(src); filter(f_kern); filter(f_debug); destination(messages); };
log { source(src); filter(f_lpr); filter(f_info); destination(messages); };
log { source(src); filter(f_mail); filter(f_crit); destination(messages); };
log { source(src); filter(f_news); filter(f_err); destination(messages); };
#
# security.* /var/log/security
#
log { source(src); filter(f_security); destination(security); };
#
# auth.info;authpriv.info /var/log/auth.log
log { source(src); filter(f_auth); filter(f_info); destination(authlog); };
log { source(src); filter(f_authpriv); filter(f_info); destination(authlog); };
#
# mail.info /var/log/maillog
#
log { source(src); filter(f_mail); filter(f_info); destination(maillog); };
#
# lpr.info /var/log/lpd-errs
#
log { source(src); filter(f_lpr); filter(f_info); destination(lpd-errs); };
#
# ftp.info /var/log/xferlog
#
log { source(src); filter(f_ftp); filter(f_info); destination(xferlog); };
#
# cron.* /var/log/cron
#
log { source(src); filter(f_cron); destination(cron); };
#
# *.=debug /var/log/debug.log
#
log { source(src); filter(f_is_debug); destination(debuglog); };
#
# *.emerg *
#
log { source(src); filter(f_emerg); destination(allusers); };
#
# uncomment this to log all writes to /dev/console to /var/log/console.log
# console.info /var/log/console.log
#
#log { source(src); filter(f_console); filter(f_info); destination(consolelog); };
#
# uncomment this to enable logging of all log messages to /var/log/all.log
# touch /var/log/all.log and chmod it to mode 600 before it will work
# *.* /var/log/all.log
#
#log { source(src); destination(all); };
#
# uncomment this to enable logging to a remote loghost named loghost
# *.* @loghost
#
#log { source(src); destination(loghost); };
#
# uncomment these if you're running inn
# news.crit /var/log/news/news.crit
# news.err /var/log/news/news.err
# news.notice /var/log/news/news.notice
#
#log { source(src); filter(f_news); filter(f_crit); destination(newscrit); };
#log { source(src); filter(f_news); filter(f_err); destination(newserr); };
#log { source(src); filter(f_news); filter(f_notice); destination(newsnotice); };
#
# !startslip
# *.* /var/log/slip.log
#
log { source(src); filter(f_slip); destination(slip); };
#
# !ppp
# *.* /var/log/ppp.log
#
log { source(src); filter(f_ppp); destination(ppp); };

View file

@ -0,0 +1,46 @@
#!/bin/sh
#
# $FreeBSD: head/sysutils/syslog-ng/files/syslog-ng.in 340872 2014-01-24 00:14:07Z mat $
#
# PROVIDE: syslogd
# REQUIRE: mountcritremote cleanvar ldconfig
# BEFORE: SERVERS
#
# Add the following line to /etc/rc.conf.local or /etc/rc.conf
# to enable this service:
#
#syslog_ng_enable="YES"
#syslog_ng_config="-u daemon"
#syslog_ng_pid="/var/run/syslog-ng.pid"
#
syslog_ng_purgeklog=${syslog_ng_purgeklog-"NO"}
. /etc/rc.subr
name=syslog_ng
rcvar=syslog_ng_enable
command=%%PREFIX%%/sbin/syslog-ng
required_files=%%PREFIX%%/etc/syslog-ng.conf
extra_commands=reload
if checkyesno syslog_ng_purgeklog; then
start_precmd="echo \"Purging klog(9)\" && sysctl -w kern.msgbuf_clear=1 $start_precmd";
fi
stop_postcmd=stop_postcmd
load_rc_config $name
: ${syslog_ng_enable:="NO"}
pidfile=${syslog_ng_pid:-"/var/run/syslog.pid"}
command_args="-p ${pidfile} ${syslog_ng_config}"
stop_postcmd() {
rm -f $pidfile
}
run_rc_command "$1"

View file

@ -0,0 +1,17 @@
syslog-ng is an enhanced log daemon, supporting a wide range of input and
output methods: syslog, unstructured text, message queues, databases (SQL
and NoSQL alike) and more.
Key features:
* receive and send RFC3164 and RFC5424 style syslog messages
* work with any kind of unstructured data
* receive and send JSON formatted messages
* classify and structure logs with builtin parsers (csv-parser(),
db-parser(), ...)
* normalize, crunch and process logs as they flow through the system
* hand on messages for further processing using message queues (like
AMQP), files or databases (like PostgreSQL or MongoDB).
The official home page of syslog-ng is:
WWW: http://www.balabit.com/network-security/syslog-ng/

View file

@ -0,0 +1,315 @@
@unexec %D/etc/rc.d/syslog-ng.sh stop > /dev/null 2>&1 || true
@sample etc/scl.conf.sample
etc/syslog-ng.conf.dist
@sample etc/syslog-ng.conf.sample
bin/pdbtool
bin/loggen
bin/update-patterndb
bin/dqtool
include/syslog-ng/evtlog.h
include/syslog-ng/evtmaps.h
include/syslog-ng/libtest/license_module_mock.h
include/syslog-ng/pe-versioning.h
include/syslog-ng/ivykis/iv_avl.h
include/syslog-ng/ivykis/iv_event.h
include/syslog-ng/ivykis/iv_event_raw.h
include/syslog-ng/ivykis/iv_list.h
include/syslog-ng/ivykis/iv_thread.h
include/syslog-ng/ivykis/iv_tls.h
include/syslog-ng/ivykis/iv_work.h
include/syslog-ng/ivykis/iv_fd_pump.h
include/syslog-ng/ivykis/iv_popen.h
include/syslog-ng/ivykis/iv_signal.h
include/syslog-ng/ivykis/iv_wait.h
include/syslog-ng/ivykis/iv.h
include/syslog-ng/compat/compat.h
include/syslog-ng/compat/getutent.h
include/syslog-ng/compat/glib.h
include/syslog-ng/compat/lfs.h
include/syslog-ng/compat/pio.h
include/syslog-ng/compat/socket.h
include/syslog-ng/compat/string.h
include/syslog-ng/compat/time.h
include/syslog-ng/control/control.h
include/syslog-ng/control/control-server.h
include/syslog-ng/scanner/csv-scanner/csv-scanner.h
include/syslog-ng/debugger/debugger.h
include/syslog-ng/debugger/tracer.h
include/syslog-ng/debugger/debugger-main.h
include/syslog-ng/filter/filter-expr.h
include/syslog-ng/filter/filter-op.h
include/syslog-ng/filter/filter-cmp.h
include/syslog-ng/filter/filter-in-list.h
include/syslog-ng/filter/filter-tags.h
include/syslog-ng/filter/filter-netmask.h
include/syslog-ng/filter/filter-netmask6.h
include/syslog-ng/filter/filter-call.h
include/syslog-ng/filter/filter-re.h
include/syslog-ng/filter/filter-pri.h
include/syslog-ng/filter/filter-pipe.h
include/syslog-ng/filter/filter-expr-parser.h
include/syslog-ng/libtest/testutils.h
include/syslog-ng/libtest/msg_parse_lib.h
include/syslog-ng/libtest/template_lib.h
include/syslog-ng/libtest/proto_lib.h
include/syslog-ng/libtest/persist_lib.h
include/syslog-ng/libtest/mock-transport.h
include/syslog-ng/logmsg/gsockaddr-serialize.h
include/syslog-ng/logmsg/logmsg.h
include/syslog-ng/logmsg/serialization.h
include/syslog-ng/logmsg/logmsg-serialize.h
include/syslog-ng/logmsg/logmsg-serialize-fixup.h
include/syslog-ng/logmsg/nvtable.h
include/syslog-ng/logmsg/nvtable-serialize.h
include/syslog-ng/logmsg/nvtable-serialize-endianutils.h
include/syslog-ng/logmsg/tags-serialize.h
include/syslog-ng/logmsg/timestamp-serialize.h
include/syslog-ng/logmsg/tags.h
include/syslog-ng/logproto/logproto-client.h
include/syslog-ng/logproto/logproto-server.h
include/syslog-ng/logproto/logproto-buffered-server.h
include/syslog-ng/logproto/logproto-dgram-server.h
include/syslog-ng/logproto/logproto-framed-client.h
include/syslog-ng/logproto/logproto-framed-server.h
include/syslog-ng/logproto/logproto-text-client.h
include/syslog-ng/logproto/logproto-text-server.h
include/syslog-ng/logproto/logproto-indented-multiline-server.h
include/syslog-ng/logproto/logproto-regexp-multiline-server.h
include/syslog-ng/logproto/logproto-record-server.h
include/syslog-ng/logproto/logproto-builtins.h
include/syslog-ng/logproto/logproto-multiline-server.h
include/syslog-ng/logproto/logproto.h
include/syslog-ng/parser/parser-expr.h
include/syslog-ng/parser/parser-expr-parser.h
include/syslog-ng/syslog-ng-config.h
include/syslog-ng/afinter.h
include/syslog-ng/alarms.h
include/syslog-ng/apphook.h
include/syslog-ng/atomic.h
include/syslog-ng/block-ref-parser.h
include/syslog-ng/cache.h
include/syslog-ng/cfg.h
include/syslog-ng/cfg-grammar.h
include/syslog-ng/cfg-lexer.h
include/syslog-ng/cfg-lexer-subst.h
include/syslog-ng/cfg-args.h
include/syslog-ng/cfg-parser.h
include/syslog-ng/cfg-tree.h
include/syslog-ng/reloc.h
include/syslog-ng/children.h
include/syslog-ng/crypto.h
include/syslog-ng/dnscache.h
include/syslog-ng/driver.h
include/syslog-ng/fdhelpers.h
include/syslog-ng/file-perms.h
include/syslog-ng/find-crlf.h
include/syslog-ng/gprocess.h
include/syslog-ng/gsockaddr.h
include/syslog-ng/gsocket.h
include/syslog-ng/hostname.h
include/syslog-ng/host-resolve.h
include/syslog-ng/logmatcher.h
include/syslog-ng/logmpx.h
include/syslog-ng/logpipe.h
include/syslog-ng/logqueue-fifo.h
include/syslog-ng/logqueue.h
include/syslog-ng/logreader.h
include/syslog-ng/logsource.h
include/syslog-ng/logstamp.h
include/syslog-ng/logthrdestdrv.h
include/syslog-ng/logwriter.h
include/syslog-ng/mainloop.h
include/syslog-ng/mainloop-call.h
include/syslog-ng/mainloop-worker.h
include/syslog-ng/mainloop-io-worker.h
include/syslog-ng/module-config.h
include/syslog-ng/memtrace.h
include/syslog-ng/messages.h
include/syslog-ng/ml-batched-timer.h
include/syslog-ng/msg-format.h
include/syslog-ng/parse-number.h
include/syslog-ng/pathutils.h
include/syslog-ng/persist-state.h
include/syslog-ng/persistable-state-header.h
include/syslog-ng/persistable-state-presenter.h
include/syslog-ng/plugin.h
include/syslog-ng/plugin-types.h
include/syslog-ng/poll-events.h
include/syslog-ng/poll-fd-events.h
include/syslog-ng/pragma-parser.h
include/syslog-ng/presented-persistable-state.h
include/syslog-ng/rcptid.h
include/syslog-ng/run-id.h
include/syslog-ng/scratch-buffers.h
include/syslog-ng/serialize.h
include/syslog-ng/service-management.h
include/syslog-ng/seqnum.h
include/syslog-ng/str-format.h
include/syslog-ng/str-utils.h
include/syslog-ng/syslog-names.h
include/syslog-ng/syslog-ng.h
include/syslog-ng/string-list.h
include/syslog-ng/timeutils.h
include/syslog-ng/tls-support.h
include/syslog-ng/thread-utils.h
include/syslog-ng/tlscontext.h
include/syslog-ng/type-hinting.h
include/syslog-ng/uuid.h
include/syslog-ng/userdb.h
include/syslog-ng/utf8utils.h
include/syslog-ng/versioning.h
include/syslog-ng/bookmark.h
include/syslog-ng/ringbuffer.h
include/syslog-ng/ack_tracker.h
include/syslog-ng/rewrite/rewrite-expr.h
include/syslog-ng/rewrite/rewrite-set-tag.h
include/syslog-ng/rewrite/rewrite-set.h
include/syslog-ng/rewrite/rewrite-unset.h
include/syslog-ng/rewrite/rewrite-subst.h
include/syslog-ng/rewrite/rewrite-expr-parser.h
include/syslog-ng/rewrite/rewrite-groupset.h
include/syslog-ng/host-id.h
include/syslog-ng/resolved-configurable-paths.h
include/syslog-ng/stats/stats.h
include/syslog-ng/stats/stats-counter.h
include/syslog-ng/stats/stats-cluster.h
include/syslog-ng/stats/stats-csv.h
include/syslog-ng/stats/stats-log.h
include/syslog-ng/stats/stats-registry.h
include/syslog-ng/stats/stats-syslog.h
include/syslog-ng/template/templates.h
include/syslog-ng/template/macros.h
include/syslog-ng/template/function.h
include/syslog-ng/template/simple-function.h
include/syslog-ng/template/repr.h
include/syslog-ng/template/compiler.h
include/syslog-ng/template/user-function.h
include/syslog-ng/template/escaping.h
include/syslog-ng/template/common-template-typedefs.h
include/syslog-ng/transport/logtransport.h
include/syslog-ng/transport/transport-aux-data.h
include/syslog-ng/transport/transport-tls.h
include/syslog-ng/transport/transport-file.h
include/syslog-ng/transport/transport-pipe.h
include/syslog-ng/transport/transport-socket.h
include/syslog-ng/value-pairs/value-pairs.h
include/syslog-ng/value-pairs/transforms.h
include/syslog-ng/value-pairs/cmdline.h
include/syslog-ng/value-pairs/evttag.h
include/syslog-ng/iv.h
include/syslog-ng/iv_avl.h
include/syslog-ng/iv_event.h
include/syslog-ng/iv_event_raw.h
include/syslog-ng/iv_fd_pump.h
include/syslog-ng/iv_inotify.h
include/syslog-ng/iv_list.h
include/syslog-ng/iv_popen.h
include/syslog-ng/iv_signal.h
include/syslog-ng/iv_thread.h
include/syslog-ng/iv_tls.h
include/syslog-ng/iv_wait.h
include/syslog-ng/iv_work.h
include/syslog-ng/compat/openssl_support.h
include/syslog-ng/modules/add-contextual-data/add-contextual-data-parser.h
include/syslog-ng/modules/add-contextual-data/add-contextual-data-selector.h
include/syslog-ng/modules/add-contextual-data/add-contextual-data-template-selector.h
include/syslog-ng/modules/add-contextual-data/add-contextual-data.h
include/syslog-ng/modules/add-contextual-data/context-info-db.h
include/syslog-ng/modules/add-contextual-data/contextual-data-record-scanner.h
include/syslog-ng/modules/add-contextual-data/csv-contextual-data-record-scanner.h
include/syslog-ng/str-repr/decode.h
include/syslog-ng/str-repr/encode.h
include/syslog-ng/compat/pcre.h
include/syslog-ng/control/control-commands.h
include/syslog-ng/control/control-main.h
include/syslog-ng/scanner/kv-scanner/kv-scanner.h
include/syslog-ng/scanner/list-scanner/list-scanner.h
include/syslog-ng/stats/stats-cluster-logpipe.h
include/syslog-ng/stats/stats-cluster-single.h
include/syslog-ng/stats/stats-control.h
include/syslog-ng/stats/stats-query-commands.h
include/syslog-ng/stats/stats-query.h
lib/libevtlog-3.12.so.0
lib/libevtlog-3.12.so.0.0.0
lib/libevtlog.so
lib/libsyslog-ng-3.12.so.0.0.0
lib/libsyslog-ng-3.12.so.0
lib/libsyslog-ng.so
lib/libsyslog-ng-native-connector.a
lib/syslog-ng/libtest/libsyslog-ng-test.a
lib/syslog-ng/libsyslogformat.so
lib/syslog-ng/libadd-contextual-data.so
lib/syslog-ng/libcef.so
lib/syslog-ng/libdate.so
lib/syslog-ng/libdisk-buffer.so
lib/syslog-ng/libafsocket.so
lib/syslog-ng/libaffile.so
lib/syslog-ng/libafprog.so
lib/syslog-ng/libafuser.so
lib/syslog-ng/libafamqp.so
lib/syslog-ng/libcsvparser.so
lib/syslog-ng/libconfgen.so
lib/syslog-ng/libsystem-source.so
lib/syslog-ng/liblinux-kmsg-format.so
lib/syslog-ng/libbasicfuncs.so
lib/syslog-ng/libcryptofuncs.so
lib/syslog-ng/libdbparser.so
lib/syslog-ng/libafstomp.so
lib/syslog-ng/libpseudofile.so
lib/syslog-ng/libgraphite.so
lib/syslog-ng/libkvformat.so
lib/syslog-ng/libmap-value-pairs.so
lib/syslog-ng/libsnmptrapd-parser.so
lib/syslog-ng/libstardate.so
lib/syslog-ng/libtfgetent.so
lib/syslog-ng/libtags-parser.so
lib/syslog-ng/libxml.so
libdata/pkgconfig/syslog-ng.pc
libdata/pkgconfig/syslog-ng-test.pc
libdata/pkgconfig/syslog-ng-native-connector.pc
libdata/pkgconfig/syslog-ng-add-contextual-data.pc
man/man1/loggen.1.gz
man/man1/pdbtool.1.gz
man/man1/syslog-ng-ctl.1.gz
man/man5/syslog-ng.conf.5.gz
man/man8/syslog-ng.8.gz
man/man1/dqtool.1.gz
man/man1/syslog-ng-debun.1.gz
sbin/syslog-ng-debun
sbin/syslog-ng
sbin/syslog-ng-ctl
share/syslog-ng/include/scl/system/plugin.conf
share/syslog-ng/include/scl/pacct/plugin.conf
share/syslog-ng/include/scl/syslogconf/convert-syslogconf.awk
share/syslog-ng/include/scl/syslogconf/README
share/syslog-ng/include/scl/syslogconf/plugin.conf
share/syslog-ng/include/scl/rewrite/cc-mask.conf
share/syslog-ng/include/scl/nodejs/plugin.conf
share/syslog-ng/include/scl/graphite/README
share/syslog-ng/include/scl/graphite/plugin.conf
share/syslog-ng/include/scl/solaris/plugin.conf
share/syslog-ng/include/scl/mbox/mbox.conf
share/syslog-ng/include/scl/elasticsearch/plugin.conf
share/syslog-ng/include/scl/kafka/plugin.conf
share/syslog-ng/include/scl/hdfs/plugin.conf
share/syslog-ng/include/scl/apache/apache.conf
share/syslog-ng/include/scl/loggly/loggly.conf
share/syslog-ng/include/scl/logmatic/logmatic.conf
share/syslog-ng/include/scl/cisco/plugin.conf
share/syslog-ng/include/scl/snmptrap/snmptrapd-source.conf
share/syslog-ng/include/scl/osquery/plugin.conf
share/syslog-ng/include/scl/windowseventlog/plugin.conf
share/syslog-ng/include/scl/windowseventlog/windowseventlog.xml
share/syslog-ng/tools/lex-rules.am
share/syslog-ng/tools/cfg-grammar.y
share/syslog-ng/tools/merge-grammar.py
share/syslog-ng/tools/system-expand.sh
share/syslog-ng/xsd/patterndb-1.xsd
share/syslog-ng/xsd/patterndb-2.xsd
share/syslog-ng/xsd/patterndb-3.xsd
share/syslog-ng/xsd/patterndb-4.xsd
share/syslog-ng/xsd/patterndb-5.xsd
%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
%%PORTDOCS%%%%DOCSDIR%%/COPYING
%%PORTDOCS%%%%DOCSDIR%%/NEWS.md
@dir etc/patterndb.d