devel/py-pytest-timeout: Update to 1.3.1
Changelog:
17415e95a8 (chg-README)
- Update PORTVERSION and distinfo checksum to 1.3.1
- Add a patch to fix build with Python 3.x in the C locale [0]
[0] https://bitbucket.org/pytest-dev/pytest-timeout/pull-requests/15/use-utf-8-encoding-to-open-the-readme-file/
Reviewed by: koobs
Approved by: koobs (mentor)
Differential Revision: https://reviews.freebsd.org/D16567
This commit is contained in:
parent
2c919aac09
commit
ae236a1fea
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=476397
3 changed files with 21 additions and 4 deletions
|
@ -2,7 +2,7 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= pytest-timeout
|
||||
PORTVERSION= 1.3.0
|
||||
PORTVERSION= 1.3.1
|
||||
CATEGORIES= devel python
|
||||
MASTER_SITES= CHEESESHOP
|
||||
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
TIMESTAMP = 1532067067
|
||||
SHA256 (pytest-timeout-1.3.0.tar.gz) = 08b550b498b9251901a3747f02aa2624ed53a9c8285ca482551346c85b47d641
|
||||
SIZE (pytest-timeout-1.3.0.tar.gz) = 14649
|
||||
TIMESTAMP = 1533178931
|
||||
SHA256 (pytest-timeout-1.3.1.tar.gz) = 4b261bec5782b603c98b4bb803484bc96bf1cdcb5480dae0999d21c7e0423a23
|
||||
SIZE (pytest-timeout-1.3.1.tar.gz) = 11412
|
||||
|
|
17
devel/py-pytest-timeout/files/patch-setup.py
Normal file
17
devel/py-pytest-timeout/files/patch-setup.py
Normal file
|
@ -0,0 +1,17 @@
|
|||
https://bitbucket.org/pytest-dev/pytest-timeout/pull-requests/15/use-utf-8-encoding-to-open-the-readme-file/
|
||||
|
||||
--- setup.py.orig 2018-08-02 04:04:34 UTC
|
||||
+++ setup.py
|
||||
@@ -1,10 +1,11 @@
|
||||
from setuptools import setup
|
||||
+import io
|
||||
|
||||
|
||||
setup(
|
||||
name='pytest-timeout',
|
||||
description='py.test plugin to abort hanging tests',
|
||||
- long_description=open("README").read(),
|
||||
+ long_description=io.open('README', encoding='utf-8').read(),
|
||||
version='1.3.1',
|
||||
author='Floris Bruynooghe',
|
||||
author_email='flub@devork.be',
|
Loading…
Reference in a new issue