Update to 0.3.1

PR:		ports/20430
Submitted by:	Patrick Seal <patseal@hyperhost.net> (MAINTAINER)
This commit is contained in:
Neil Blakey-Milner 2000-08-06 15:29:04 +00:00
parent 66807aabd2
commit ae2b7b3aab
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=31342
6 changed files with 80 additions and 26 deletions

View file

@ -6,11 +6,16 @@
#
PORTNAME= biblereader
PORTVERSION= 0.2.2
PORTVERSION= 0.3.1
CATEGORIES= deskutils
MASTER_SITES= ftp://ftp.whitevine.com/biblereader/
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} kjv.tar.gz
#EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
.if defined(WITH_TRANSLATIONS)
DISTFILES+= asv.tar.gz darby.tar.gz
.endif
.if defined(WITH_SUPPLEMENTS)
DISTFILES+= easton.tar.gz mhc.tar.gz
.endif
MAINTAINER= patseal@hyperhost.net
@ -18,10 +23,43 @@ LIB_DEPENDS= gtk12.2:${PORTSDIR}/x11-toolkits/gtk12
USE_X_PREFIX= yes
MAKE_ENV= GTK_CONFIG=${GTK_CONFIG}
PLIST= ${WRKDIR}/PLIST
DATAFILES= ${WRKDIR}/kjv/kjv
.if defined(WITH_TRANSLATIONS)
DATAFILES+= ${WRKDIR}/asv/asv ${WRKDIR}/darby/darby
PLISTS+= ${PKGDIR}/PLIST.translations
.endif
.if defined(WITH_SUPPLEMENTS)
DATAFILES+= ${WRKDIR}/easton/easton.dict ${WRKDIR}/mhc/mhc
PLISTS+= ${PKGDIR}/PLIST.supplements
.endif
PLISTS+= ${PKGDIR}/PLIST
GTK_CONFIG?= ${X11BASE}/bin/gtk12-config
post-extract:
${CP} ${WRKDIR}/kjv/kjv ${WRKSRC}/kjv.txt
.if !defined(WITH_TRANSLATIONS)
pre-fetch:
@${ECHO_MSG}
@${ECHO_MSG} "If you want to download/install additional tranlations use"
@${ECHO_MSG} "\"make -DWITH_TRANSLATIONS\""
@${ECHO_MSG}
.endif
.if !defined(WITH_SUPPLEMENTS)
@${ECHO_MSG}
@${ECHO_MSG} "If you want download/install commentary and dictionary files please use"
@${ECHO_MSG} "\"make -DWITH_SUPPLEMENTS\""
@${ECHO_MSG}
.endif
do-install:
@echo ${DATAFILES}
${INSTALL_PROGRAM} ${WRKSRC}/biblereader ${PREFIX}/bin/biblereader
${MKDIR} ${PREFIX}/share/biblereader
@for file in ${DATAFILES}; do \
${INSTALL_DATA} $${file} ${PREFIX}/share/biblereader; \
done
@cat ${PLISTS} > ${PLIST}
.include <bsd.port.mk>

View file

@ -1,2 +1,6 @@
MD5 (biblereader-0.2.2.tar.gz) = 557bd8990e682c892ec7dea74462365f
MD5 (biblereader-0.3.1.tar.gz) = 4bc3a84a861aad78617db55621637d94
MD5 (kjv.tar.gz) = 2f0c9c5902e10e8640b30b2f220a44ca
MD5 (asv.tar.gz) = a61c435c5b1605d170f602d85587a473
MD5 (darby.tar.gz) = ebe0b6690ea01a202a1ed79348e9a174
MD5 (easton.tar.gz) = 3da6786ba207b50f92b7ce9dfe17f644
MD5 (mhc.tar.gz) = a228c3c8e82adbec2ddc3e4f923adbc0

View file

@ -1,11 +1,17 @@
--- Makefile.orig Sun Jul 30 12:17:21 2000
+++ Makefile Sun Jul 30 12:18:34 2000
@@ -1,6 +1,6 @@
CFLAGS=-Wall
-CFLAGS+=`gtk-config --cflags`
-LIBS=`gtk-config --libs gtk`
+CFLAGS+=`${GTK_CONFIG} --cflags`
+LIBS=`${GTK_CONFIG} --libs gtk`
OBJS=biblereader.o books.o regex.o font.o gui/gladesig.o gui/gladesrc.o prefs.o format.o
PREFIX?=/usr/local
*** Makefile.orig Thu Jul 27 05:07:53 2000
--- Makefile Mon Jul 31 10:54:11 2000
***************
*** 1,6 ****
CFLAGS=-Wall -g
! CFLAGS+=`gtk-config --cflags`
! LIBS=`gtk-config --libs gtk`
OBJS=biblereader.o books.o dictionary.o font.o history.o notes.o gui/dict_dialog.o gui/gtktextbible.o gui/gladesig.o gui/gladesrc.o gui/prefs_dialog.o prefs.o format.o
PREFIX?=/usr/local
TRANSLATION?=kjv
--- 1,6 ----
CFLAGS=-Wall -g
! CFLAGS+=`${GTK_CONFIG} --cflags`
! LIBS=`${GTK_CONFIG} --libs gtk`
OBJS=biblereader.o books.o dictionary.o font.o history.o notes.o gui/dict_dialog.o gui/gtktextbible.o gui/gladesig.o gui/gladesrc.o gui/prefs_dialog.o prefs.o format.o
PREFIX?=/usr/local
TRANSLATION?=kjv

View file

@ -1,12 +1,16 @@
BibleReader is a Bible browsing/searching program for Linux/X. It uses
the popular Gtk+ widget set. Currently, BibleReader has the capacity to
find a passage by reference, search for a phrase using regular
expressions, and has a filter which enables searches to be limited to a
selection of books. BibleReader comes with the King James Version
(otherwise known as the Authorised Version) of the Bible. The BibleReader
program is distributed under the GNU General Public License. The actual
Bible text that is currently packaged with BibleReader (i.e. the KJV text
of the Bible) is not copyrighted, as it's copyright has expired.
BibleReader is a Bible study program for Linux/X, as well as any POSIX
system which supports gtk+. It uses the popular Gtk+ widget set.
Currently, BibleReader has the capacity to find a passage by reference,
search for a phrase using an intuitive combination of boolean searching
and regular expressions, and has a filter which enables searches to be
limited to a selection of books.
The latest version of BibleReader is a great improvement over previous
versions. It includes a range of new features, including support for
notes/commentaries, such as the Matthew Henry Commentary which has been
made available in BibleReader format. Also, Bible dictionaries are now
supported, and Easton's Bible dictionary has been placed in BibleReader
format.
WWW: http://www.whitevine.com/biblereader/

View file

@ -1,3 +1,3 @@
bin/biblereader
share/biblereader/kjv.txt
share/biblereader/kjv
@dirrm share/biblereader

View file

@ -0,0 +1,2 @@
share/biblereader/darby
share/biblereader/asv