Add partial OPENLDAP support
Submitted by: Gerhard Schmidt <estartu@augusta.de>
This commit is contained in:
parent
1ee1609b89
commit
ae343f6dbd
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=243252
2 changed files with 30 additions and 0 deletions
|
@ -22,6 +22,7 @@ OPTIONS= MANPAGES "Install manpages" on\
|
|||
LIBSPF2 "Include SPF support" off\
|
||||
GEOIP "Include GeoIP support" off\
|
||||
CURL "Include curl support" off\
|
||||
OPENLDAP "Include OpenLDAP support" off\
|
||||
POSTFIX "Use Postfix instead of Sendmail" off
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
@ -57,6 +58,10 @@ CONFIGURE_ARGS+= --with-libGeoIP=${LOCALBASE}
|
|||
BUILD_DEPENDS+= curl>=7.18:${PORTSDIR}/ftp/curl
|
||||
CONFIGURE_ARGS+= --with-libcurl=${LOCALBASE}
|
||||
.endif
|
||||
.if defined(WITH_OPENLDAP)
|
||||
USE_OPENLDAP=yes
|
||||
CONFIGURE_ARGS+= --with-openldap
|
||||
.endif
|
||||
.if defined(WITH_POSTFIX)
|
||||
CONFIGURE_ARGS+= --enable-postfix
|
||||
.else
|
||||
|
|
25
mail/milter-greylist/files/patch-ldapcheck.c
Normal file
25
mail/milter-greylist/files/patch-ldapcheck.c
Normal file
|
@ -0,0 +1,25 @@
|
|||
--- ldapcheck.c.orig 2009-04-09 05:26:46.000000000 +0200
|
||||
+++ ldapcheck.c 2009-10-23 23:57:42.000000000 +0200
|
||||
@@ -58,6 +58,22 @@
|
||||
#include "prop.h"
|
||||
#include "ldapcheck.h"
|
||||
|
||||
+#ifndef SIMPLEQ_HEAD
|
||||
+# define SIMPLEQ_HEAD STAILQ_HEAD
|
||||
+# define SIMPLEQ_HEAD_INITIALIZER STAILQ_HEAD_INITIALIZER
|
||||
+# define SIMPLEQ_ENTRY STAILQ_ENTRY
|
||||
+# define SIMPLEQ_INIT STAILQ_INIT
|
||||
+# define SIMPLEQ_INSERT_HEAD STAILQ_INSERT_HEAD
|
||||
+# define SIMPLEQ_INSERT_TAIL STAILQ_INSERT_TAIL
|
||||
+# define SIMPLEQ_INSERT_AFTER STAILQ_INSERT_AFTER
|
||||
+# define SIMPLEQ_REMOVE_HEAD STAILQ_REMOVE_HEAD
|
||||
+# define SIMPLEQ_FOREACH STAILQ_FOREACH
|
||||
+# define SIMPLEQ_EMPTY STAILQ_EMPTY
|
||||
+# define SIMPLEQ_FIRST STAILQ_FIRST
|
||||
+# define SIMPLEQ_NEXT STAILQ_NEXT
|
||||
+# define SIMPLEQ_REMOVE STAILQ_REMOVE
|
||||
+#endif
|
||||
+
|
||||
struct ldapconf_entry {
|
||||
char *lc_url;
|
||||
char *lc_dn;
|
Loading…
Reference in a new issue