Upgrade to 2.2.2.

PR:		4699
Submitted by:	Justin M. Seger <jseger@freebsd.scds.com>
This commit is contained in:
Thomas Gellekum 1997-10-07 09:20:12 +00:00
parent c4f87c3016
commit ae3c2d150f
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=8152
8 changed files with 67 additions and 217 deletions

View file

@ -1,22 +1,17 @@
# New ports collection makefile for: gcl
# Version required: 2.0
# Version required: 2.2.2
# Date created: Wed Feb 8 01:49:11 1995
# Whom: hsu
#
# $Id: Makefile,v 1.7 1996/11/12 02:18:17 obrien Exp $
# $Id: Makefile,v 1.8 1997/03/05 12:24:46 asami Exp $
#
DISTNAME= gcl-2.0
DISTNAME= gcl-2.2.2
CATEGORIES= lang
MASTER_SITES= ftp://ftp.cli.com/pub/gcl/ ftp://math.utexas.edu/pub/gcl/
EXTRACT_SUFX= .tgz
MASTER_SITES= ftp://ftp.ma.utexas.edu/pub/gcl/ \
${MASTER_SITE_GNU}
MAINTAINER= ports@FreeBSD.org
MAINTAINER= jseger@freebsd.scds.com
BROKEN= "Seems to depend on old version of tcl/tk"
MAKEFILE= makefile
do-install:
@(cd ${WRKSRC}; ${MAKE} PREFIX_DIR=${PREFIX} ${MAKE_FLAGS} ${MAKEFILE} ${INSTALL_TARGET})
.include <bsd.port.mk>

View file

@ -1 +1 @@
MD5 (gcl-2.0.tgz) = 8170f61bcfa60b5a352aad7db857b661
MD5 (gcl-2.2.2.tar.gz) = 89e418c1ac255f30fe4ca8ba8743daf1

View file

@ -1,27 +0,0 @@
--- ./add-defs.org Sun Apr 9 20:07:22 1995
+++ ./add-defs Wed Mar 5 04:10:37 1997
@@ -35,21 +35,21 @@
#Usage: xbin/add-dir ITEM LIST-OF-DIRECTORIES VARIABLE-SETTING-TEMPLATE
-xbin/add-dir tk.tcl "/usr/lib/tk ${PUBLIC}/lib/tk /usr/local/lib/tk /usr/lib/X11/tk" \
+xbin/add-dir tk.tcl "/usr/lib/tk ${PUBLIC}/lib/tk /usr/local/lib/tk4.1 /usr/lib/X11/tk" \
'TK_LIBRARY=$v'
xbin/add-dir X11/Xlib.h "/usr/include ${PUBLIC}/X11/include /usr/X11/include /usr/X11R6/include /usr/openwin/include" 'X11_INCLUDE_DIR=-I$v'
xbin/add-dir tk.h "/usr/include/tcl ${PUBLIC}/include/tcl /usr/local/include /usr/local/include/tcl /usr/include ${PUBLIC}/include " 'TK_INCLUDE_DIR=-I$v'
-xbin/add-dir 'libtk.*' "/usr/lib /usr/X11/lib ${PUBLIC}/X11/lib /usr/X11R6/lib ${PUBLIC}/lib /usr/local/lib" 'TK_LIBS=-L$v -ltk'
+xbin/add-dir 'libtk41.*' "/usr/lib /usr/X11/lib ${PUBLIC}/X11/lib /usr/X11R6/lib ${PUBLIC}/lib /usr/local/lib" 'TK_LIBS=-L$v -ltk'
xbin/add-dir 'libtcl.*' "/usr/lib /usr/X11/lib /usr/X11R6/lib ${PUBLIC}/X11/lib ${PUBLIC}/lib /usr/local/lib " 'TCL_LIBS=-L$v -ltcl'
xbin/add-dir 'libX11.*' '/usr/openwin/lib /usr/lib /usr/X11/lib /usr/X11R6/lib ${PUBLIC}/X11/lib ${PUBLIC}/lib /usr/local/lib ' \
'X11_LIBS=-L$v -lX11'
-xbin/add-dir '*.el*' '/usr/lib/emacs/site-lisp /usr/local/lib/emacs/site-lisp ${PUBLIC}/lib/emacs/site-lisp ${PUBLIC}/X11/lib ' 'EMACS_SITE_LISP=$v'
+xbin/add-dir '*.el*' '/usr/lib/emacs/site-lisp /usr/local/share/emacs/site-lisp ${PUBLIC}/lib/emacs/site-lisp ${PUBLIC}/X11/lib ' 'EMACS_SITE_LISP=$v'
xbin/add-dir 'dir' '/usr/info /usr/local/info ${PUBLIC}/info ' 'INFO_DIR=$v'

View file

@ -1,157 +1,38 @@
*** makefile.0 Mon Apr 10 03:14:48 1995
--- makefile Mon Apr 10 23:12:23 1995
***************
*** 29,44 ****
LBINDIR=/usr/local/bin
! OFLAG = -O
! LIBS = -lm
! ODIR_DEBUG= -O4
# This CC string will be used for compilation of the system,
# and also in the compiler::*cc* variable for later compilation of
# lisp files.
# (the -pipe is just since our file system is slow..)
! CC = gcc -pipe -fwritable-strings -DVOL=volatile -I$(GCLDIR)/o
! LDCC=${CC} -static
# Enable the fastloading mechanism which does not use ld -A
# requires c/rel_.. machine dependent code.
--- 29,44 ----
LBINDIR=/usr/local/bin
! OFLAG = -O
! LIBS = -lm
! ODIR_DEBUG= -O4
# This CC string will be used for compilation of the system,
# and also in the compiler::*cc* variable for later compilation of
# lisp files.
# (the -pipe is just since our file system is slow..)
! CC = gcc -pipe -fwritable-strings -DVOL=volatile -I$(GCLDIR)/o
! LDCC=${CC} -static
# Enable the fastloading mechanism which does not use ld -A
# requires c/rel_.. machine dependent code.
***************
*** 46,52 ****
RSYM = rsym
SFASL = $(ODIR)/sfasl.o
! # Use the mp.s file on 68k machine
# new gcc doesn't make a good .s file using optimisations.
# so either use $(MPDIR)/mpi.o $(MPDIR)/libmport.a
--- 46,52 ----
RSYM = rsym
SFASL = $(ODIR)/sfasl.o
! # Use the mp.s file on 68k machine
# new gcc doesn't make a good .s file using optimisations.
# so either use $(MPDIR)/mpi.o $(MPDIR)/libmport.a
***************
*** 66,72 ****
# the make to use for saved_kcp the profiler.
KCP=kcp-bsd
! # dont add the .data
CAT=true
# end makedefs
--- 66,72 ----
# the make to use for saved_kcp the profiler.
KCP=kcp-bsd
! # dont add the .data
CAT=true
# end makedefs
***************
*** 132,138 ****
echo '#' other options: -load "/tmp/foo.o" -load "jo.lsp" -eval '"(joe 3)"' >> ${PREFIX_DIR}/bin/gcl
chmod a+x ${PREFIX_DIR}/bin/gcl
! install:
make install1 "INSTALL_LIB_DIR=${PREFIX_DIR}/lib/gcl-`cat majvers`.`cat minvers`" "PREFIX_DIR=${PREFIX_DIR}"
INSTALL_LIB_DIR=
install1:
--- 132,138 ----
echo '#' other options: -load "/tmp/foo.o" -load "jo.lsp" -eval '"(joe 3)"' >> ${PREFIX_DIR}/bin/gcl
chmod a+x ${PREFIX_DIR}/bin/gcl
! install:
make install1 "INSTALL_LIB_DIR=${PREFIX_DIR}/lib/gcl-`cat majvers`.`cat minvers`" "PREFIX_DIR=${PREFIX_DIR}"
INSTALL_LIB_DIR=
install1:
***************
*** 142,148 ****
make install-command "INSTALL_LIB_DIR=${INSTALL_LIB_DIR}" "PREFIX_DIR=${PREFIX_DIR}"
rm -f ${PREFIX_DIR}/bin/gcl.exe
tar cvf - unixport/saved_gcl info/*info* doc/*.el ${LISP_LIB} \
! gcl-tk/gcl.tcl gcl-tk/gcltkaux | (cd ${INSTALL_LIB_DIR} ;tar xvf -)
ln ${SYMB} ${INSTALL_LIB_DIR}/unixport/saved_gcl \
${PREFIX_DIR}/bin/gcl.exe
cat gcl-tk/gcltksrv | \
--- 142,149 ----
make install-command "INSTALL_LIB_DIR=${INSTALL_LIB_DIR}" "PREFIX_DIR=${PREFIX_DIR}"
rm -f ${PREFIX_DIR}/bin/gcl.exe
tar cvf - unixport/saved_gcl info/*info* doc/*.el ${LISP_LIB} \
! h/cmpinclude.h gcl-tk/gcl.tcl gcl-tk/gcltkaux | \
! (cd ${INSTALL_LIB_DIR} ;tar xvf -)
ln ${SYMB} ${INSTALL_LIB_DIR}/unixport/saved_gcl \
${PREFIX_DIR}/bin/gcl.exe
cat gcl-tk/gcltksrv | \
***************
*** 161,167 ****
foo:
cat gcl-tk/gcltksrv | \
sed -e "s:#put correct dir:DIR=${INSTALL_LIB_DIR}/gcl-tk:g" \
! -e "s:TK_LIBRARY=.*:TK_LIBRARY=${TK_LIBRARY}:g"
install-elisp-files:
(cd doc ; make install)
--- 162,168 ----
foo:
cat gcl-tk/gcltksrv | \
sed -e "s:#put correct dir:DIR=${INSTALL_LIB_DIR}/gcl-tk:g" \
! -e "s:TK_LIBRARY=.*:TK_LIBRARY=${TK_LIBRARY}:g"
install-elisp-files:
(cd doc ; make install)
***************
*** 173,179 ****
(cd $(CMPDIR); make clean)
(cd $(PORTDIR); make clean)
(cd gcl-tk ; make clean)
!
CMPINCLUDE_FILES=${HDIR}cmpincl1.h ${HDIR}compbas.h ${HDIR}enum.h ${HDIR}object.h ${HDIR}vs.h \
--- 174,180 ----
(cd $(CMPDIR); make clean)
(cd $(PORTDIR); make clean)
(cd gcl-tk ; make clean)
!
CMPINCLUDE_FILES=${HDIR}cmpincl1.h ${HDIR}compbas.h ${HDIR}enum.h ${HDIR}object.h ${HDIR}vs.h \
***************
*** 181,187 ****
${HDIR}lex.h ${HDIR}eval.h ${HDIR}funlink.h \
${HDIR}att_ext.h ${HDIR}compbas2.h ${HDIR}/compat.h ${HDIR}/cmponly.h
! OTHERS=${HDIR}notcomp.h ${HDIR}rgbc.h ${HDIR}stacks.h
${HDIR}cmpinclude.h: ${CMPINCLUDE_FILES} ${HDIR}config.h
cat ${HDIR}config.h | sed -e "1,/Begin for cmpincl/d" \
--- 182,188 ----
${HDIR}lex.h ${HDIR}eval.h ${HDIR}funlink.h \
${HDIR}att_ext.h ${HDIR}compbas2.h ${HDIR}/compat.h ${HDIR}/cmponly.h
! OTHERS=${HDIR}notcomp.h ${HDIR}rgbc.h ${HDIR}stacks.h
${HDIR}cmpinclude.h: ${CMPINCLUDE_FILES} ${HDIR}config.h
cat ${HDIR}config.h | sed -e "1,/Begin for cmpincl/d" \
--- makefile.orig Sat Mar 22 16:47:17 1997
+++ makefile Sun Oct 5 14:17:32 1997
@@ -120,7 +120,7 @@
merge:
${CC} -o merge merge.c
-LISP_LIB=cmpnew/collectfn.o lsp/gprof.lsp lsp/info.o lsp/profile.lsp gcl-tk/tkl.o gcl-tk/tinfo.o gcl-tk/demos/*.lsp gcl-tk/demos/*.lisp gcl-tk/demos/*.o
+LISP_LIB=cmpnew/collectfn.o lsp/gprof.lsp lsp/info.o lsp/profile.lsp
install-command:
rm -f ${PREFIX_DIR}/bin/gcl
@@ -141,21 +141,15 @@
-if [ -d "${PREFIX_DIR}/lib" ] ;then true; else mkdir ${PREFIX_DIR}/lib ; fi
-if [ -d "${PREFIX_DIR}/bin" ] ;then true; else mkdir ${PREFIX_DIR}/bin ; fi
-if [ -d "${INSTALL_LIB_DIR}" ] ; then true; else mkdir ${INSTALL_LIB_DIR} ;fi
+ -if [ -d "${PREFIX_DIR}/info" ] ; then true; else mkdir ${PREFIX_DIR}/info; fi
+ -if [ -d "${PREFIX_DIR}/info/gcl-2.2.2" ] ; then true; else mkdir ${PREFIX_DIR}/info/gcl-2.2.2; fi
make install-command "INSTALL_LIB_DIR=${INSTALL_LIB_DIR}" "PREFIX_DIR=${PREFIX_DIR}"
rm -f ${PREFIX_DIR}/bin/gcl.exe
- tar cvf - unixport/saved_gcl info/*info* doc/*.el ${LISP_LIB} \
- gcl-tk/gcl.tcl gcl-tk/gcltkaux | (cd ${INSTALL_LIB_DIR} ;tar xvf -)
+ tar cvf - unixport/saved_gcl ${LISP_LIB} \
+ | (cd ${INSTALL_LIB_DIR} ;tar xvf -)
+ (cd info; tar cvf - *si.info* | (cd ${PREFIX_DIR}/info/gcl-2.2.2 ; tar xvf -))
ln ${SYMB} ${INSTALL_LIB_DIR}/unixport/saved_gcl \
${PREFIX_DIR}/bin/gcl.exe
- -cat gcl-tk/gcltksrv | \
- sed -e "s:GCL_TK_DIR=.*:GCL_TK_DIR=${INSTALL_LIB_DIR}/gcl-tk:g" \
- -e "s:TK_LIBRARY=.*:TK_LIBRARY=${TK_LIBRARY}:g" > \
- ${INSTALL_LIB_DIR}/gcl-tk/gcltksrv
- -if [ "${TK_CONFIG_PREFIX}" != "unknown" ] ; then \
- chmod a+x ${INSTALL_LIB_DIR}/gcl-tk/gcltksrv ; fi
- -if [ "${TK_CONFIG_PREFIX}" != "unknown" ] ; then \
- (cd ${INSTALL_LIB_DIR}/gcl-tk/demos ; \
- echo '(load "../tkl.o")(TK::GET-AUTOLOADS (directory "*.lisp"))' | ${PREFIX_DIR}/bin/gcl) ; fi
(cd info ; make ; make install)
clean:

View file

@ -1,19 +0,0 @@
*** lsp/makefile.0 Mon Apr 10 03:14:50 1995
--- lsp/makefile Mon Apr 10 23:31:48 1995
***************
*** 15,21 ****
COMPILE_FILE=$(PORTDIR)/saved_gcl $(PORTDIR) -system-p -c-file -data-file \
-o-file nil -h-file -compile
! CFLAGS = -c -O -I../h
.lsp.c:
@ ../xbin/if-exists $(PORTDIR)/saved_gcl \
--- 15,21 ----
COMPILE_FILE=$(PORTDIR)/saved_gcl $(PORTDIR) -system-p -c-file -data-file \
-o-file nil -h-file -compile
! CFLAGS = -c -I../h
.lsp.c:
@ ../xbin/if-exists $(PORTDIR)/saved_gcl \

View file

@ -1 +1 @@
GNU Common Lisp.
GNU Common Lisp

View file

@ -4,3 +4,6 @@ and Masami Hagiya in 1984. The AKCL system work was begun in 1987
by William Schelter and continued through 1994. In 1994 AKCL was
released as GCL (GNU Common Lisp) under the GNU public library
license.
NOTE: The FreeBSD port has no tcl/tk support due do the fact that gcl-2.2.2 is
designed to use tcl7.3 and tk 3.6 which are no longer supported under FreeBSD.

View file

@ -1,2 +1,19 @@
bin/gcl
lib/gcl-2.0
bin/gcl.exe
info/gcl-2.2.2/gcl-si.info
info/gcl-2.2.2/gcl-si.info-1
info/gcl-2.2.2/gcl-si.info-2
info/gcl-2.2.2/gcl-si.info-3
info/gcl-2.2.2/gcl-si.info-4
info/gcl-2.2.2/gcl-si.info-5
info/gcl-2.2.2/gcl-si.info-6
lib/gcl-2.2.2/cmpnew/collectfn.o
lib/gcl-2.2.2/lsp/gprof.lsp
lib/gcl-2.2.2/lsp/info.o
lib/gcl-2.2.2/lsp/profile.lsp
lib/gcl-2.2.2/unixport/saved_gcl
@dirrm lib/gcl-2.2.2/unixport
@dirrm lib/gcl-2.2.2/lsp
@dirrm lib/gcl-2.2.2/cmpnew
@dirrm lib/gcl-2.2.2
@dirrm info/gcl-2.2.2