Remove expired port:
2007-02-01 net/happystats: Disappeared from the internet Approved by: erwin (mentor, implicit)
This commit is contained in:
parent
99a1e0ad56
commit
ae550c8a1a
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=185469
8 changed files with 1 additions and 121 deletions
1
MOVED
1
MOVED
|
@ -2836,3 +2836,4 @@ math/vtk43-headers||2007-02-18|Has expired: Please use vtk 4.4 or 5.x.
|
|||
math/vtk43||2007-02-18|Has expired: Please use vtk 4.4 or 5.x.
|
||||
textproc/ruby-htmlcompact||2007-02-18|Has expired: distfile and homepage disappeared
|
||||
textproc/ruby-rwv2||2007-02-18|Has expired: distfile disappeared and has no homepage
|
||||
net/happystats||2007-02-18|Has expired: Disappeared from the internet
|
||||
|
|
|
@ -173,7 +173,6 @@
|
|||
SUBDIR += gstreamer-plugins-libmms80
|
||||
SUBDIR += gtic
|
||||
SUBDIR += gutenfetch
|
||||
SUBDIR += happystats
|
||||
SUBDIR += haproxy
|
||||
SUBDIR += hawknl
|
||||
SUBDIR += hawknl-devel
|
||||
|
|
|
@ -1,54 +0,0 @@
|
|||
# New ports collection makefile for: happystats
|
||||
# Date created: 2004-01-12
|
||||
# Whom: Xavier Beaudouin <kiwi@oav.net>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= happystats
|
||||
PORTVERSION= 0.5.0
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= net
|
||||
MASTER_SITES= http://www.happystats.org/srcs/
|
||||
EXTRACT_SUFX= .tgz
|
||||
|
||||
MAINTAINER= kiwi@oav.net
|
||||
COMMENT= Universal log converter into graph
|
||||
|
||||
BUILD_DEPENDS= imake:${X_IMAKE_PORT}
|
||||
LIB_DEPENDS= pcre.0:${PORTSDIR}/devel/pcre \
|
||||
xml2.5:${PORTSDIR}/textproc/libxml2 \
|
||||
rrd.2:${PORTSDIR}/net/rrdtool
|
||||
|
||||
USE_GETOPT_LONG= yes
|
||||
|
||||
MAN1= happystats.1
|
||||
MANCOMPRESSED= yes
|
||||
DOCS= AUTHORS INSTALL TODO
|
||||
|
||||
DEPRECATED= Disappeared from the internet
|
||||
EXPIRATION_DATE=2007-02-01
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
do-configure:
|
||||
@cd ${WRKSRC} && ${MAKE} dep
|
||||
|
||||
post-configure:
|
||||
.if ${OSVERSION} > 500041
|
||||
@${REINPLACE_CMD} -E -e 's|-lgnugetopt||g' ${WRKSRC}/Makefile
|
||||
.endif
|
||||
|
||||
do-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/happystats ${PREFIX}/bin
|
||||
${INSTALL_MAN} ${WRKSRC}/man/happystats.1.gz ${MAN1PREFIX}/man/man1
|
||||
@${MKDIR} ${PREFIX}/www/cgi-bin
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/happystats.cgi ${PREFIX}/www/cgi-bin
|
||||
@${MKDIR} ${EXAMPLESDIR}
|
||||
${INSTALL_DATA} ${WRKSRC}/samples/* ${EXAMPLESDIR}
|
||||
.if !defined(NOPORTDOCS)
|
||||
@${MKDIR} ${DOCSDIR}
|
||||
cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS} ${DOCSDIR}
|
||||
.endif
|
||||
|
||||
.include <bsd.port.post.mk>
|
|
@ -1,3 +0,0 @@
|
|||
MD5 (happystats-0.5.0.tgz) = f2b015b6998e22266f363bbd0ff6c69f
|
||||
SHA256 (happystats-0.5.0.tgz) = d2a0a5133b01961e533b62594628c61e464413b28268ebed7f7fb3c29ba91d8e
|
||||
SIZE (happystats-0.5.0.tgz) = 38289
|
|
@ -1,23 +0,0 @@
|
|||
--- Makefile.orig Sat Mar 6 01:22:22 2004
|
||||
+++ Makefile Sat Mar 6 01:24:19 2004
|
||||
@@ -1,15 +1,9 @@
|
||||
# $Id: Makefile,v 1.4 2004/02/22 12:26:25 ofredj Exp $ #
|
||||
|
||||
-PREFIX=/usr/local
|
||||
-CC=gcc
|
||||
-LD=/usr/bin/ld
|
||||
-#DEBUG=-ggdb
|
||||
-CARGS=-O2 -pipe -ansi -Wall -pedantic
|
||||
-COPTS= -ffast-math -ffloat-store -funroll-all-loops -funroll-loops
|
||||
-IFLAGS=-I/usr/local/include `xml2-config --cflags`
|
||||
-LDFLAGS=-L/usr/local/lib/ -lpcre -lrrd `xml2-config --libs`
|
||||
-CFLAGS=${CARGS} ${IFLAGS} ${COPTS}
|
||||
+IFLAGS=`xml2-config --cflags`
|
||||
+LDFLAGS+=`xml2-config --libs` -lpcre -lrrd -lgnugetopt
|
||||
+CFLAGS+=${CPPFLAGS} ${IFLAGS}
|
||||
|
||||
SRCS= getopt.c date.c file.c common.c xmlparser.c pcre.c rrd.c main.c syslog.c ims.c exim.c clf.c alerts.c smtpclient.c
|
||||
OBJS= getopt.o date.o file.o common.o xmlparser.o pcre.o rrd.o main.o syslog.o ims.o exim.o clf.o alerts.o smtpclient.o
|
||||
|
||||
CGISRCS= cgi_xmlparser.c cgi.c rrdgraph.c
|
||||
CGIOBJS= file.o common.o cgi_xmlparser.o cgi.o rrdgraph.o
|
|
@ -1,19 +0,0 @@
|
|||
--- rrdgraph.c.orig Sun Feb 8 20:18:11 2004
|
||||
+++ rrdgraph.c Tue May 10 12:44:14 2005
|
||||
@@ -13,6 +13,7 @@
|
||||
char **calcpr;
|
||||
int xsize, ysize ;
|
||||
/* int end ; */
|
||||
+ double ymin, ymax;
|
||||
|
||||
short unit_sec ;
|
||||
|
||||
@@ -237,7 +238,7 @@
|
||||
/* Create Graph from rrd file and config */
|
||||
optind = 0;
|
||||
rrd_clear_error();
|
||||
- rc = rrd_graph(rrdargc,rrdcmd,&calcpr, &xsize, &ysize);
|
||||
+ rc = rrd_graph(rrdargc,rrdcmd,&calcpr, &xsize, &ysize, NULL, &ymin, &ymax);
|
||||
|
||||
|
||||
/* Check for Errors */
|
|
@ -1,4 +0,0 @@
|
|||
Happystats is a universal tool to convert logs into graphs.
|
||||
Useful for mail stats for example.
|
||||
|
||||
WWW: http://www.happystats.org/
|
|
@ -1,17 +0,0 @@
|
|||
|
||||
@comment $FreeBSD$
|
||||
bin/happystats
|
||||
www/cgi-bin/happystats.cgi
|
||||
%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
|
||||
%%PORTDOCS%%%%DOCSDIR%%/INSTALL
|
||||
%%PORTDOCS%%%%DOCSDIR%%/TODO
|
||||
%%PORTDOCS%%@dirrm %%DOCSDIR%%
|
||||
%%EXAMPLESDIR%%/happystats.conf
|
||||
%%EXAMPLESDIR%%/happystats.courrier.xml
|
||||
%%EXAMPLESDIR%%/happystats.exim.natif.xml
|
||||
%%EXAMPLESDIR%%/happystats.exim.syslog.xml
|
||||
%%EXAMPLESDIR%%/happystats.ims.xml
|
||||
%%EXAMPLESDIR%%/happystats.postfix.xml
|
||||
%%EXAMPLESDIR%%/happystats.sendmail.xml
|
||||
@dirrm %%EXAMPLESDIR%%
|
||||
@dirrmtry www/cgi-bin
|
Loading…
Reference in a new issue