- Update to 2.3.10

PR:		127462
Submitted by:	"Andrei V. Shetuhin" <reki@reki.ru> (maintainer)
This commit is contained in:
Martin Wilke 2008-09-26 09:40:46 +00:00
parent cb65eb4592
commit ae565c752e
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=220813
4 changed files with 6 additions and 60 deletions

View file

@ -6,8 +6,7 @@
# #
PORTNAME= ctpp2 PORTNAME= ctpp2
PORTVERSION= 2.3.5 PORTVERSION= 2.3.10
PORTREVISION= 1
CATEGORIES= textproc devel CATEGORIES= textproc devel
MASTER_SITES= http://ctpp.havoc.ru/download/ \ MASTER_SITES= http://ctpp.havoc.ru/download/ \
LOCAL/glarkin LOCAL/glarkin
@ -20,46 +19,4 @@ USE_LDCONFIG= yes
USE_GETTEXT= yes USE_GETTEXT= yes
USE_ICONV= yes USE_ICONV= yes
.include <bsd.port.pre.mk> .include <bsd.port.mk>
# Let me explain - GCC 3.4 does not support -mtune=generic, so
# TUNE_PARAM is set to the platform-specific value. If the platform
# is not i386 nor amd64, just disable -mtune altogether.
#
# If the system GCC 4.2+, simply use -mtune=generic for i386 and
# amd64. Once again, disable -mtune for other platforms.
.if ${OSVERSION} < 700042
. if ${ARCH} == "i386"
TUNE_PARAM=i686
HASHMARK=
. elif ${ARCH} == "amd64"
TUNE_PARAM=athlon64
HASHMARK=
. else
TUNE_PARAM=
HASHMARK=\#
. endif
.else
. if ${ARCH} == "i386" || ${ARCH} == "amd64"
TUNE_PARAM=generic
HASHMARK=
. else
TUNE_PARAM=
HASHMARK=\#
. endif
.endif
#
# This is not ideal, but because of the way CMakeLists.txt is structured,
# I have to apply a 2nd patch if -mtune is not used at all (non-i386 and
# non-amd64 arch).
#
.if ${TUNE_PARAM} == ""
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-CMakeLists.txt
.endif
post-patch:
@${REINPLACE_CMD} -e 's,%%TUNE_PARAM%%,${TUNE_PARAM},' \
-e 's,%%HASHMARK%%,${HASHMARK},' ${WRKSRC}/CMakeLists.txt
.include <bsd.port.post.mk>

View file

@ -1,3 +1,3 @@
MD5 (ctpp2-2.3.5.tar.gz) = cd65c95100fd6bcae39aac35dd6dc8dc MD5 (ctpp2-2.3.10.tar.gz) = f4d388c3761d8e7f4a8449346085f8d9
SHA256 (ctpp2-2.3.5.tar.gz) = 57363827b305514ef3d42ab6998e53f5e443141d2f84a9a3e9786e76179b8617 SHA256 (ctpp2-2.3.10.tar.gz) = f0c43b35cf283df9648f2b8c696be740c5a19026544cddf513a4bca54039668b
SIZE (ctpp2-2.3.5.tar.gz) = 135090 SIZE (ctpp2-2.3.10.tar.gz) = 139093

View file

@ -1,11 +0,0 @@
--- CMakeLists.txt.orig 2008-08-29 11:03:56.000000000 -0400
+++ CMakeLists.txt 2008-08-29 11:04:01.000000000 -0400
@@ -20,7 +20,7 @@
OPTION(SKIP_RELINK_RPATH "Skip relinking and full RPATH for the install tree" OFF)
# uild optimized code for following CPU (default i386)
-SET(CPU_TUNE "i686")
+%%HASHMARK%%SET(CPU_TUNE "%%TUNE_PARAM%%")
SET(CTPP_FLOAT_PRECISION 12)

View file

@ -48,7 +48,7 @@ include/ctpp2/VMSyscall.hpp
lib/libctpp2-st.a lib/libctpp2-st.a
lib/libctpp2.so lib/libctpp2.so
lib/libctpp2.so.2 lib/libctpp2.so.2
lib/libctpp2.so.2.3.5 lib/libctpp2.so.2.3.10
share/locale/ru_RU.CP1251/LC_MESSAGES/ctpp2.mo share/locale/ru_RU.CP1251/LC_MESSAGES/ctpp2.mo
share/locale/ru_RU.KOI8-R/LC_MESSAGES/ctpp2.mo share/locale/ru_RU.KOI8-R/LC_MESSAGES/ctpp2.mo
@dirrmtry share/locale/ru_RU.KOI8-R/LC_MESSAGES @dirrmtry share/locale/ru_RU.KOI8-R/LC_MESSAGES