Back out to 5.5.6.

Submitted by:	marcus (portmgr)
This commit is contained in:
Norikatsu Shigemura 2003-09-10 17:02:41 +00:00
parent 59f64fda70
commit ae73475092
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=88953
9 changed files with 465 additions and 668 deletions

View file

@ -6,8 +6,8 @@
#
PORTNAME= ImageMagick
PORTVERSION= 5.5.7.10
PORTREVISION= 0
PORTVERSION= 5.5.6
PORTREVISION= 3
CATEGORIES= graphics perl5
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
http://imagemagick.sourceforge.net/http/ \
@ -26,13 +26,10 @@ MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
ftp://ftp.fifi.org/pub/%SUBDIR%/ \
ftp://ftp.simplesystems.org/pub/%SUBDIR%/
MASTER_SITE_SUBDIR= ${PORTNAME:L} ${PORTNAME}
DISTNAME= ${PORTNAME}-${PORTVERSION:R}-${PORTVERSION:E}
MAINTAINER= ports@FreeBSD.org
COMMENT= Image processing tools (interactive optional--misc/display conflict)
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:R}
USE_PERL5= yes
USE_BZIP2= yes
USE_GMAKE= yes
@ -73,11 +70,6 @@ CONFIGURE_ARGS+= --without-threads
# Faster, but poor quality
.if defined(WITHOUT_IMAGEMAGICK_16BIT_PIXEL)
CONFIGURE_ARGS+= --with-quantum-depth=8
PLIST_SUB+= Q8=''
PLIST_SUB+= Q16='@comment '
.else
PLIST_SUB+= Q8='@comment '
PLIST_SUB+= Q16=''
.endif
# Produce standard (small) GIFs

View file

@ -1 +1 @@
MD5 (ImageMagick-5.5.7-10.tar.bz2) = efef0bbe92f5aa816bf59f5202542d3d
MD5 (ImageMagick-5.5.6.tar.bz2) = eac3971f0704059dcf2f7a5737b7daa8

View file

@ -0,0 +1,12 @@
--- Magick++/lib/Makefile.in.orig Mon Feb 24 15:03:18 2003
+++ Magick++/lib/Makefile.in Mon Feb 24 15:07:51 2003
@@ -331,8 +331,7 @@
# Add -no-undefined once Cygwin supports throwing C++ exceptions from DLLs.
libMagick___la_LDFLAGS = \
- -release $(MAJOR_VERSION).$(MINOR_VERSION).$(MICRO_VERSION)-Q$(QuantumDepth) \
- -version-info 0:0:0
+ -version-info $(MAJOR_VERSION):$(MINOR_VERSION):0
libMagick___la_LIBADD = ../../magick/libMagick.la

View file

@ -1,7 +1,8 @@
--- coders/jp2.c.orig Sat Oct 12 23:41:32 2002
+++ coders/jp2.c Wed Jan 22 21:11:31 2003
@@ -639,5 +639,14 @@
@@ -498,6 +498,15 @@
}
#if defined(HasJP2)
+
+#ifndef JAS_IMAGE_CM_GRAY

View file

@ -1,6 +1,6 @@
--- configure.orig Sun Jun 23 12:18:35 2002
+++ configure Sun Jun 23 12:23:23 2002
@@ -22001,6 +22001,7 @@
@@ -14689,6 +14689,7 @@
# This can be used to rebuild libtool when needed
LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"

View file

@ -0,0 +1,12 @@
--- magick/Makefile.in.orig Mon Feb 24 15:12:11 2003
+++ magick/Makefile.in Mon Feb 24 15:12:46 2003
@@ -353,8 +353,7 @@
ALLMANPAGES = Magick-config.1
libMagick_la_LDFLAGS = -no-undefined \
- -release $(MAJOR_VERSION).$(MINOR_VERSION).$(MICRO_VERSION)-Q$(QuantumDepth) \
- -version-info 0:0:0
+ -version-info $(MAJOR_VERSION):$(MINOR_VERSION):0
#AM_CFLAGS = @LIBRARY_EXTRA_CPPFLAGS@

View file

@ -0,0 +1,7 @@
--- magick/xwindow.h Thu Sep 5 15:50:03 2002
+++ magick/xwindow.h Wed Oct 16 11:08:11 2002
@@ -43,4 +43,2 @@
#if defined(HasSharedMemory)
-#include <sys/ipc.h>
-#include <sys/shm.h>
#include <X11/extensions/XShm.h>

View file

@ -0,0 +1,19 @@
--- magick/xwindow.c.old Sun Nov 24 15:07:53 2002
+++ magick/xwindow.c Sun Nov 24 15:08:16 2002
@@ -57,6 +57,16 @@
#include "log.h"
#include "utility.h"
#include "version.h"
+#if defined(HasSharedMemory)
+#include <machine/param.h>
+
+#if __FreeBSD__ >= 5
+typedef unsigned short ushort; /* needed for sys/ipc.h at the moment */
+#endif
+#include <sys/types.h>
+#include <sys/ipc.h>
+#include <sys/shm.h>
+#endif
#include "xwindow.h"
#if defined(HasX11)

File diff suppressed because it is too large Load diff