audio/libaudec: Remove tests from build

This fixes the i386 build.

Reported by:	fallout (failed on i386)
This commit is contained in:
Yuri Victorovich 2020-05-20 19:07:11 +00:00
parent 4668408464
commit ae9f0898b0
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=536016
2 changed files with 15 additions and 2 deletions

View file

@ -19,6 +19,8 @@ USE_GITHUB= yes
GH_ACCOUNT= alex-tee
USE_LDCONFIG= yes
MESON_ARGS= -Dbuild-tests=false
PLIST_FILES= bin/audec \
include/audec/audec.h \
lib/libaudec.so \

View file

@ -1,6 +1,6 @@
--- meson.build.orig 2020-01-06 04:43:34 UTC
--- meson.build.orig 2020-05-16 11:50:13 UTC
+++ meson.build
@@ -160,7 +160,7 @@ config_h_dep = declare_dependency (
@@ -177,7 +177,7 @@ config_h_dep = declare_dependency (
)
audec_deps += config_h_dep
@ -9,3 +9,14 @@
'audec',
sources: srcs,
dependencies: [
@@ -212,7 +212,9 @@ audec_exe = executable (
install: not meson.is_subproject(),
)
-subdir('tests')
+if get_variable('build-tests', true)
+ subdir('tests')
+endif
summary = [
'',