New port: games/marblemarcher: Marble Marcher: Community Edition
This commit is contained in:
parent
d1efc10f55
commit
aeb3628206
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=568715
6 changed files with 209 additions and 0 deletions
|
@ -596,6 +596,7 @@
|
|||
SUBDIR += manaplus
|
||||
SUBDIR += mancala
|
||||
SUBDIR += mangband
|
||||
SUBDIR += marblemarcher
|
||||
SUBDIR += mari0
|
||||
SUBDIR += masterserver
|
||||
SUBDIR += maxr
|
||||
|
|
33
games/marblemarcher/Makefile
Normal file
33
games/marblemarcher/Makefile
Normal file
|
@ -0,0 +1,33 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= marblemarcher
|
||||
DISTVERSION= 1.4.5
|
||||
CATEGORIES= games
|
||||
|
||||
MAINTAINER= yuri@FreeBSD.org
|
||||
COMMENT= Marble Marcher: Community Edition
|
||||
|
||||
LICENSE= GPLv2
|
||||
LICENSE_FILE= ${WRKSRC}/LICENSE
|
||||
|
||||
BUILD_DEPENDS= glm>0:math/glm
|
||||
LIB_DEPENDS= libAntTweakBar.so:graphics/anttweakbar \
|
||||
libsfml-system.so:devel/sfml
|
||||
|
||||
USES= cmake compiler:c++17-lang eigen:3 gl localbase:ldflags
|
||||
USE_GL= gl glew glu
|
||||
|
||||
USE_GITHUB= yes
|
||||
GH_ACCOUNT= WAUthethird
|
||||
GH_PROJECT= Marble-Marcher-Community-Edition
|
||||
|
||||
CMAKE_ARGS= -DFREEBSD_DATADIR=${DATADIR}
|
||||
|
||||
post-install:
|
||||
@(echo "#!/bin/sh"; \
|
||||
echo ""; \
|
||||
echo "cd ${DATADIR} && ./MarbleMarcher \"$$"@"\"" \
|
||||
) > ${STAGEDIR}${PREFIX}/bin/MarbleMarcher
|
||||
@${CHMOD} +x ${STAGEDIR}${PREFIX}/bin/MarbleMarcher
|
||||
|
||||
.include <bsd.port.mk>
|
3
games/marblemarcher/distinfo
Normal file
3
games/marblemarcher/distinfo
Normal file
|
@ -0,0 +1,3 @@
|
|||
TIMESTAMP = 1616030168
|
||||
SHA256 (WAUthethird-Marble-Marcher-Community-Edition-1.4.5_GH0.tar.gz) = a10cf10bad56857396860306181c383c7e2eaec3de8347cb80fa9bdff2a551af
|
||||
SIZE (WAUthethird-Marble-Marcher-Community-Edition-1.4.5_GH0.tar.gz) = 77759331
|
28
games/marblemarcher/files/patch-CMakeLists.txt
Normal file
28
games/marblemarcher/files/patch-CMakeLists.txt
Normal file
|
@ -0,0 +1,28 @@
|
|||
--- CMakeLists.txt.orig 2021-01-03 11:14:42 UTC
|
||||
+++ CMakeLists.txt
|
||||
@@ -122,7 +122,7 @@ elseif(UNIX)
|
||||
${OPENGL_LIBRARIES}
|
||||
libAntTweakBar.so
|
||||
${GLEW_LIBRARIES}
|
||||
- stdc++fs
|
||||
+ #stdc++fs
|
||||
libsfml-system.so
|
||||
libsfml-window.so
|
||||
libsfml-graphics.so
|
||||
@@ -130,12 +130,12 @@ elseif(UNIX)
|
||||
)
|
||||
install(TARGETS MarbleMarcher
|
||||
COMPONENT linapp
|
||||
- RUNTIME DESTINATION "/home/MMCE"
|
||||
- LIBRARY DESTINATION "/home/MMCE"
|
||||
- DESTINATION "/home/MMCE"
|
||||
+ RUNTIME DESTINATION ${FREEBSD_DATADIR}
|
||||
+ LIBRARY DESTINATION ${FREEBSD_DATADIR}
|
||||
+ DESTINATION ${FREEBSD_DATADIR}
|
||||
)
|
||||
|
||||
- install(DIRECTORY "${PROJECT_SOURCE_DIR}/game_folder/" DESTINATION "/home/MMCE")
|
||||
+ install(DIRECTORY "${PROJECT_SOURCE_DIR}/game_folder/" DESTINATION ${FREEBSD_DATADIR})
|
||||
|
||||
set(CPACK_PACKAGE_NAME "MarbleMarcher")
|
||||
set(CPACK_PACKAGE_VENDOR "MarbleMarcher")
|
8
games/marblemarcher/pkg-descr
Normal file
8
games/marblemarcher/pkg-descr
Normal file
|
@ -0,0 +1,8 @@
|
|||
This is the community edition of Marble Marcher, a procedurally rendered fractal
|
||||
physics marble game in which you must get to the flag in each level as fast as
|
||||
you can. With 24 levels to unlock and an active speedrunning community, along
|
||||
with a fully-featured level editor, there's always new features being developed.
|
||||
If you complete all levels, you can use cheats to create and enhance a more
|
||||
exploratory experience.
|
||||
|
||||
WWW: https://github.com/WAUthethird/Marble-Marcher-Community-Edition
|
136
games/marblemarcher/pkg-plist
Normal file
136
games/marblemarcher/pkg-plist
Normal file
|
@ -0,0 +1,136 @@
|
|||
bin/MarbleMarcher
|
||||
%%DATADIR%%/MarbleMarcher
|
||||
%%DATADIR%%/assets/Inconsolata-Bold.ttf
|
||||
%%DATADIR%%/assets/NotoSansJP-Bold.otf
|
||||
%%DATADIR%%/assets/NotoSansJP-Regular.otf
|
||||
%%DATADIR%%/assets/NotoSansSC-Bold.otf
|
||||
%%DATADIR%%/assets/NotoSansSC-Regular.otf
|
||||
%%DATADIR%%/assets/OFL.txt
|
||||
%%DATADIR%%/assets/Orbitron-Bold.ttf
|
||||
%%DATADIR%%/assets/Roboto-Bold.ttf
|
||||
%%DATADIR%%/assets/Roboto-Regular.ttf
|
||||
%%DATADIR%%/images/MarbleMarcher.png
|
||||
%%DATADIR%%/images/add.png
|
||||
%%DATADIR%%/images/arrow.png
|
||||
%%DATADIR%%/images/box_0.png
|
||||
%%DATADIR%%/images/box_1.png
|
||||
%%DATADIR%%/images/clear.png
|
||||
%%DATADIR%%/images/credits/Bryce.png
|
||||
%%DATADIR%%/images/credits/codeparade.jpg
|
||||
%%DATADIR%%/images/credits/michaelmoroz.jpg
|
||||
%%DATADIR%%/images/credits/wauthethird.png
|
||||
%%DATADIR%%/images/delete.png
|
||||
%%DATADIR%%/images/done.png
|
||||
%%DATADIR%%/images/edit.png
|
||||
%%DATADIR%%/images/icon.ico
|
||||
%%DATADIR%%/images/icon.png
|
||||
%%DATADIR%%/images/outline_delete_black_36dp.png
|
||||
%%DATADIR%%/images/priority.png
|
||||
%%DATADIR%%/images/star.png
|
||||
%%DATADIR%%/levels/Around_The_Citadel.lvl
|
||||
%%DATADIR%%/levels/Around_The_World.lvl
|
||||
%%DATADIR%%/levels/Asteroid_Field.lvl
|
||||
%%DATADIR%%/levels/Beware_Of_Bumps.lvl
|
||||
%%DATADIR%%/levels/Build_Up_Speed.lvl
|
||||
%%DATADIR%%/levels/Building_Bridges.lvl
|
||||
%%DATADIR%%/levels/Bunny_Hops.lvl
|
||||
%%DATADIR%%/levels/Don't_Get_Crushed.lvl
|
||||
%%DATADIR%%/levels/Everest.lvl
|
||||
%%DATADIR%%/levels/Expressways.lvl
|
||||
%%DATADIR%%/levels/Fatal_Fissures.lvl
|
||||
%%DATADIR%%/levels/Grid_pylons.lvl
|
||||
%%DATADIR%%/levels/Hole_In_One.lvl
|
||||
%%DATADIR%%/levels/Jump_The_Crater.lvl
|
||||
%%DATADIR%%/levels/Lily_Pads.lvl
|
||||
%%DATADIR%%/levels/Mega_Citadel.lvl
|
||||
%%DATADIR%%/levels/Mental_labyrinth.lvl
|
||||
%%DATADIR%%/levels/Mind_The_Gap.lvl
|
||||
%%DATADIR%%/levels/Mountain_Climbing.lvl
|
||||
%%DATADIR%%/levels/Planet_Crusher.lvl
|
||||
%%DATADIR%%/levels/Pylon_Palace.lvl
|
||||
%%DATADIR%%/levels/Ride_The_Gecko.lvl
|
||||
%%DATADIR%%/levels/The_Catwalk.lvl
|
||||
%%DATADIR%%/levels/The_Crown_Jewels.lvl
|
||||
%%DATADIR%%/levels/The_Hills_Are_Alive.lvl
|
||||
%%DATADIR%%/levels/The_Sponge.lvl
|
||||
%%DATADIR%%/levels/Too_Many_Trees.lvl
|
||||
%%DATADIR%%/levels/Top_Of_The_Citadel.lvl
|
||||
%%DATADIR%%/levels/Tunnel.lvl
|
||||
%%DATADIR%%/levels/World_tree.lvl
|
||||
%%DATADIR%%/levels/best_runs/readme.txt
|
||||
%%DATADIR%%/locals/Chinese.loc
|
||||
%%DATADIR%%/locals/Danish.loc
|
||||
%%DATADIR%%/locals/English.loc
|
||||
%%DATADIR%%/locals/French.loc
|
||||
%%DATADIR%%/locals/German.loc
|
||||
%%DATADIR%%/locals/Japanese.loc
|
||||
%%DATADIR%%/locals/Polish.loc
|
||||
%%DATADIR%%/locals/Ukrainian.loc
|
||||
%%DATADIR%%/screenshots/screenshot1568810155.jpg
|
||||
%%DATADIR%%/shaders/compute/1_main.cfg
|
||||
%%DATADIR%%/shaders/compute/2_PTGI.cfg
|
||||
%%DATADIR%%/shaders/compute/3_original.cfg
|
||||
%%DATADIR%%/shaders/compute/4_simple.cfg
|
||||
%%DATADIR%%/shaders/compute/NEON.cfg
|
||||
%%DATADIR%%/shaders/compute/PTGI/Direct.glsl
|
||||
%%DATADIR%%/shaders/compute/PTGI/GI.glsl
|
||||
%%DATADIR%%/shaders/compute/PTGI/GI.glsl_error.txt
|
||||
%%DATADIR%%/shaders/compute/PTGI/GISurfaceRender.glsl
|
||||
%%DATADIR%%/shaders/compute/PTGI/PathTrace.glsl
|
||||
%%DATADIR%%/shaders/compute/PathTracing.cfg
|
||||
%%DATADIR%%/shaders/compute/auto_exposure/auto_exposure_weighting.glsl
|
||||
%%DATADIR%%/shaders/compute/main/Final_step.glsl
|
||||
%%DATADIR%%/shaders/compute/main/Illumination_step.glsl
|
||||
%%DATADIR%%/shaders/compute/main/Shading_step.glsl
|
||||
%%DATADIR%%/shaders/compute/main/simple_shading.glsl
|
||||
%%DATADIR%%/shaders/compute/multires_marching/MRRM1.glsl
|
||||
%%DATADIR%%/shaders/compute/multires_marching/MRRM2.glsl
|
||||
%%DATADIR%%/shaders/compute/neon/neon_shading.glsl
|
||||
%%DATADIR%%/shaders/compute/noise/noise.glsl
|
||||
%%DATADIR%%/shaders/compute/noise_test.cfg
|
||||
%%DATADIR%%/shaders/compute/original/original_functions.glsl
|
||||
%%DATADIR%%/shaders/compute/original/original_shading.glsl
|
||||
%%DATADIR%%/shaders/compute/post_processing/Bloom_horiz.glsl
|
||||
%%DATADIR%%/shaders/compute/post_processing/Bloom_vertic.glsl
|
||||
%%DATADIR%%/shaders/compute/post_processing/TXAA.glsl
|
||||
%%DATADIR%%/shaders/compute/post_processing/Temporal_Denoiser.glsl
|
||||
%%DATADIR%%/shaders/compute/post_processing/bilateral_filter.glsl
|
||||
%%DATADIR%%/shaders/compute/post_processing/bilateral_filter_wnormals.glsl
|
||||
%%DATADIR%%/shaders/compute/post_processing/downsampling.glsl
|
||||
%%DATADIR%%/shaders/compute/utility/RNG.glsl
|
||||
%%DATADIR%%/shaders/compute/utility/bloom.glsl
|
||||
%%DATADIR%%/shaders/compute/utility/camera.glsl
|
||||
%%DATADIR%%/shaders/compute/utility/compute_shader_header.glsl
|
||||
%%DATADIR%%/shaders/compute/utility/definitions.glsl
|
||||
%%DATADIR%%/shaders/compute/utility/distance_estimators.glsl
|
||||
%%DATADIR%%/shaders/compute/utility/interpolation.glsl
|
||||
%%DATADIR%%/shaders/compute/utility/path_tracing.glsl
|
||||
%%DATADIR%%/shaders/compute/utility/random_stuff.glsl
|
||||
%%DATADIR%%/shaders/compute/utility/ray_marching.glsl
|
||||
%%DATADIR%%/shaders/compute/utility/shading.glsl
|
||||
%%DATADIR%%/shaders/compute/utility/shading_functions.glsl
|
||||
%%DATADIR%%/shaders/compute/utility/uniforms.glsl
|
||||
%%DATADIR%%/shaders/shader_documentation.md
|
||||
%%DATADIR%%/shaders/textures/1.png
|
||||
%%DATADIR%%/shaders/textures/2.png
|
||||
%%DATADIR%%/shaders/textures/readme.txt
|
||||
%%DATADIR%%/sound/fx/bounce1.wav
|
||||
%%DATADIR%%/sound/fx/bounce2.wav
|
||||
%%DATADIR%%/sound/fx/bounce3.wav
|
||||
%%DATADIR%%/sound/fx/count_down.wav
|
||||
%%DATADIR%%/sound/fx/count_go.wav
|
||||
%%DATADIR%%/sound/fx/goal.wav
|
||||
%%DATADIR%%/sound/fx/menu_click.wav
|
||||
%%DATADIR%%/sound/fx/menu_hover.wav
|
||||
%%DATADIR%%/sound/fx/screenshot.wav
|
||||
%%DATADIR%%/sound/fx/shatter.wav
|
||||
%%DATADIR%%/sound/music/LICENSE.txt
|
||||
%%DATADIR%%/sound/music/calmmenutheme_by_panorrrama.ogg
|
||||
%%DATADIR%%/sound/music/credits.ogg
|
||||
%%DATADIR%%/sound/music/level1.ogg
|
||||
%%DATADIR%%/sound/music/level2.ogg
|
||||
%%DATADIR%%/sound/music/level3.ogg
|
||||
%%DATADIR%%/sound/music/level4.ogg
|
||||
%%DATADIR%%/sound/music/leveltheme5_by_panorrrama.ogg
|
||||
%%DATADIR%%/sound/music/leveltheme_by_panorrrama.ogg
|
||||
%%DATADIR%%/sound/music/menu.ogg
|
Loading…
Reference in a new issue