- Update to revision 1.0.2841

- Enable build on sparc64
- Fix indentation in Makefile
- Chase a few compiler warnings
This commit is contained in:
Pietro Cerutti 2009-05-26 20:41:43 +00:00
parent 3ea8cd6d2a
commit aed0c30268
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=234589
5 changed files with 144 additions and 13 deletions

View file

@ -17,7 +17,7 @@ LIB_DEPENDS= curl.5:${PORTSDIR}/ftp/curl
OPTIONS= CSCOPE "Enable CScope integration" OFF
USE_WX= 2.8
USE_WX= 2.8
WX_UNICODE= yes
USE_GNOME= gtk20
USE_GMAKE= yes
@ -25,9 +25,9 @@ HAS_CONFIGURE= yes
.include <bsd.port.pre.mk>
ONLY_FOR_ARCHS= i386 amd64
ONLY_FOR_ARCHS= i386 amd64 sparc64
SVN_REVISION= 2822
SVN_REVISION= 2841
.if defined(WITH_CSCOPE)
RUN_DEPENDS+= cscope:${PORTSDIR}/devel/cscope
@ -37,8 +37,7 @@ post-patch:
.if ${ARCH} == "amd64"
${REINPLACE_CMD} -e '58s|=|= -fPIC|' ${WRKSRC}/configure
.endif
${REINPLACE_CMD} -e 's|wx-config|${WX_CONFIG}|g' \
${WRKSRC}/configure
${REINPLACE_CMD} -e 's|wx-config|${WX_CONFIG}|g' ${WRKSRC}/configure
# Configure script does not respect --prefix
${REINPLACE_CMD} -e '/^prefix/s|/usr|${PREFIX}|; \
/^plugins_dir/s|/usr/lib/codelite|${DATADIR}/plugins|' \

View file

@ -1,3 +1,3 @@
MD5 (codelite-1.0.2822.tar.gz) = 09606f2e75c666c606afebda0e37c71e
SHA256 (codelite-1.0.2822.tar.gz) = 41d42903c9ea7bc4148c222780cdea81fc9bb8f03f79b94de8344b818dcaab32
SIZE (codelite-1.0.2822.tar.gz) = 5842101
MD5 (codelite-1.0.2841.tar.gz) = 0e1ad0ff13ae593a2a4c625f0da32102
SHA256 (codelite-1.0.2841.tar.gz) = 727f7b7bfa944a717f37e146c10e26d4b20c5361cb6152ef55a419e1dfd99c66
SIZE (codelite-1.0.2841.tar.gz) = 5864114

View file

@ -0,0 +1,38 @@
--- CodeLite/clindexerprotocol.cpp.orig 2009-05-26 14:27:26.000000000 +0200
+++ CodeLite/clindexerprotocol.cpp 2009-05-26 14:30:37.000000000 +0200
@@ -25,7 +25,7 @@
}
if (actual_read != sizeof(buff_len)) {
- fprintf(stderr, "ERROR: ReadReply: Protocol error: expected %d bytes, got %d. reason: %d\n",
+ fprintf(stderr, "ERROR: ReadReply: Protocol error: expected %zu bytes, got %zu. reason: %d\n",
sizeof(buff_len),
actual_read,
conn->getLastError());
@@ -39,7 +39,7 @@
size_t bytes_read(0);
while (bytes_left > 0) {
if ( !conn->read(data+bytes_read, bytes_left, &actual_read, 10000) ) {
- fprintf(stderr, "ERROR: Protocol error: expected %d bytes, got %d\n", buff_len, actual_read);
+ fprintf(stderr, "ERROR: Protocol error: expected %zu bytes, got %zu\n", buff_len, actual_read);
return false;
}
bytes_left -= actual_read;
@@ -71,7 +71,7 @@
}
if (actual_read != sizeof(buff_len)) {
- fprintf(stderr, "ERROR: Protocol error: expected %d bytes, got %d\n", sizeof(buff_len), actual_read);
+ fprintf(stderr, "ERROR: Protocol error: expected %zu bytes, got %zu\n", sizeof(buff_len), actual_read);
return false;
}
@@ -82,7 +82,7 @@
size_t bytes_read(0);
while (bytes_left > 0) {
if ( !conn->read(data+bytes_read, bytes_left, &actual_read, -1) ) {
- fprintf(stderr, "ERROR: [%s] Protocol error: expected %d bytes, got %d\n", __PRETTY_FUNCTION__, buff_len, actual_read);
+ fprintf(stderr, "ERROR: [%s] Protocol error: expected %zu bytes, got %zu\n", __PRETTY_FUNCTION__, buff_len, actual_read);
return false;
}
bytes_left -= actual_read;

View file

@ -0,0 +1,47 @@
--- sdk/wxpropgrid/src/propgrid.cpp.orig 2009-05-26 14:57:08.000000000 +0200
+++ sdk/wxpropgrid/src/propgrid.cpp 2009-05-26 15:03:13.000000000 +0200
@@ -1610,7 +1610,7 @@
}
// Slots of utility flags are NULL
-const int gs_propFlagToStringSize = 14;
+const unsigned int gs_propFlagToStringSize = 14;
static const wxChar* gs_propFlagToString[gs_propFlagToStringSize] = {
NULL,
@@ -7110,7 +7110,7 @@
wxPropertyGridState* state = m_pState;
int splitterHit;
- int splitterHitOffset;
+ int splitterHitOffset = 0;
int columnHit = state->HitTestH( x, &splitterHit, &splitterHitOffset );
wxPGProperty* p = DoGetItemAtY(y);
@@ -7326,7 +7326,7 @@
wxPropertyGridState* state = m_pState;
int splitterHit;
- int splitterHitOffset;
+ int splitterHitOffset = 0;
int columnHit = state->HitTestH( x, &splitterHit, &splitterHitOffset );
int splitterX = x - splitterHitOffset;
@@ -7957,7 +7957,7 @@
return;
}
- int secondAction;
+ int secondAction = 0;
int action = KeyEventToActions(event, &secondAction);
if ( m_selected )
@@ -10509,7 +10509,7 @@
wxPropertyGridHitTestResult wxPropertyGridState::HitTest( const wxPoint&pt ) const
{
- wxPropertyGridHitTestResult result;
+ wxPropertyGridHitTestResult result = {0};
result.column = HitTestH( pt.x, &result.splitter, &result.splitterHitOffset );
result.property = DoGetItemAtY( pt.y );
return result;

View file

@ -3,7 +3,6 @@ bin/codelite_exec
bin/codelite_fix_files
bin/codelite_indexer
bin/codelite_kill_children
%%DATADIR%%/src/unittest++1.3.tar.gz
%%DATADIR%%/astyle.sample
%%DATADIR%%/config/accelerators.conf.default
%%DATADIR%%/config/build_settings.xml.default
@ -64,6 +63,7 @@ bin/codelite_kill_children
%%DATADIR%%/plugins/resources/wxfb_ok.png
%%DATADIR%%/plugins/wxformbuilder.so
%%DATADIR%%/rc/menu.xrc
%%DATADIR%%/src/unittest++1.3.tar.gz
%%DATADIR%%/svnreport.html
%%DATADIR%%/templates/formbuilder/DialogTemplate.fbp
%%DATADIR%%/templates/formbuilder/DialogTemplateWithButtons.fbp
@ -80,34 +80,82 @@ bin/codelite_kill_children
%%DATADIR%%/templates/gizmos/wxmain.project.wizard
%%DATADIR%%/templates/gizmos/wxproject.project.wizard
%%DATADIR%%/templates/projects/UnitTest++/UnitTest++.project
%%DATADIR%%/templates/projects/UnitTest++/icon.png
%%DATADIR%%/templates/projects/UnitTest++/main.cpp
%%DATADIR%%/templates/projects/custom-makefile/custom-makefile.project
%%DATADIR%%/templates/projects/custom-makefile/icon.png
%%DATADIR%%/templates/projects/dynamic-library-wx-enabled/dynamic-library-wx-enabled.project
%%DATADIR%%/templates/projects/dynamic-library-wx-enabled/icon.png
%%DATADIR%%/templates/projects/dynamic-library/dynamic-library.project
%%DATADIR%%/templates/projects/dynamic-library/icon.png
%%DATADIR%%/templates/projects/executable-console-wx-enabled/executable-console-wx-enabled.project
%%DATADIR%%/templates/projects/executable-console-wx-enabled/icon.png
%%DATADIR%%/templates/projects/executable-console-wx-enabled/main.cpp
%%DATADIR%%/templates/projects/executable-gcc/executable-gcc.project
%%DATADIR%%/templates/projects/executable-gcc/icon.png
%%DATADIR%%/templates/projects/executable-gcc/main.c
%%DATADIR%%/templates/projects/executable-qt-enabled/executable-qt-enabled.project
%%DATADIR%%/templates/projects/executable-qt-enabled/icon.png
%%DATADIR%%/templates/projects/executable-qt-enabled/main.cpp
%%DATADIR%%/templates/projects/executable-qt-qmake-enabled/executable-qt-qmake-enabled.project
%%DATADIR%%/templates/projects/executable-qt-qmake-enabled/icon.png
%%DATADIR%%/templates/projects/executable-qt-qmake-enabled/main.cpp
%%DATADIR%%/templates/projects/executable-wx-dialog/executable-wx-dialog.project
%%DATADIR%%/templates/projects/executable-wx-dialog/gui.cpp
%%DATADIR%%/templates/projects/executable-wx-dialog/gui.fbp
%%DATADIR%%/templates/projects/executable-wx-dialog/gui.h
%%DATADIR%%/templates/projects/executable-wx-dialog/icon.png
%%DATADIR%%/templates/projects/executable-wx-dialog/main.cpp
%%DATADIR%%/templates/projects/executable-wx-dialog/main.h
%%DATADIR%%/templates/projects/executable-wx-enabled/executable-wx-enabled.project
%%DATADIR%%/templates/projects/executable-wx-enabled/icon.png
%%DATADIR%%/templates/projects/executable-wx-enabled/main.cpp
%%DATADIR%%/templates/projects/executable-wx-frame/executable-wx-frame.project
%%DATADIR%%/templates/projects/executable-wx-frame/gui.cpp
%%DATADIR%%/templates/projects/executable-wx-frame/gui.fbp
%%DATADIR%%/templates/projects/executable-wx-frame/gui.h
%%DATADIR%%/templates/projects/executable-wx-frame/icon.png
%%DATADIR%%/templates/projects/executable-wx-frame/main.cpp
%%DATADIR%%/templates/projects/executable-wx-frame/main.h
%%DATADIR%%/templates/projects/executable/executable.project
%%DATADIR%%/templates/projects/executable/icon.png
%%DATADIR%%/templates/projects/executable/main.cpp
%%DATADIR%%/templates/projects/non-code-project/icon.png
%%DATADIR%%/templates/projects/non-code-project/non-code.project
%%DATADIR%%/templates/projects/static-library-wx-enabled/icon.png
%%DATADIR%%/templates/projects/static-library-wx-enabled/static-library-wx-enabled.project
%%DATADIR%%/templates/projects/static-library/icon.png
%%DATADIR%%/templates/projects/static-library/static-library.project
%%DATADIR%%/templates/projects/vc-dynamic-library/icon.png
%%DATADIR%%/templates/projects/vc-dynamic-library/vc-dynamic-library.project
%%DATADIR%%/templates/projects/vc-executable/icon.png
%%DATADIR%%/templates/projects/vc-executable/vc-executable.project
%%DATADIR%%/templates/projects/vc-static-lib/icon.png
%%DATADIR%%/templates/projects/vc-static-lib/vc-static-lib.project
share/applications/codelite.desktop
@dirrm %%DATADIR%%/templates/projects/non-code-project
@dirrm %%DATADIR%%/templates/projects/custom-makefile
@dirrm %%DATADIR%%/templates/projects/vc-static-lib
@dirrm %%DATADIR%%/templates/projects/vc-executable
@dirrm %%DATADIR%%/templates/projects/vc-dynamic-library
@dirrm %%DATADIR%%/templates/projects/static-library-wx-enabled
@dirrm %%DATADIR%%/templates/projects/static-library
@dirrm %%DATADIR%%/templates/projects/non-code-project
@dirrm %%DATADIR%%/templates/projects/executable-wx-frame
@dirrm %%DATADIR%%/templates/projects/executable-wx-enabled
@dirrm %%DATADIR%%/templates/projects/executable-wx-dialog
@dirrm %%DATADIR%%/templates/projects/executable-qt-qmake-enabled
@dirrm %%DATADIR%%/templates/projects/executable-qt-enabled
@dirrm %%DATADIR%%/templates/projects/executable-gcc
@dirrm %%DATADIR%%/templates/projects/executable-console-wx-enabled
@dirrm %%DATADIR%%/templates/projects/executable
@dirrm %%DATADIR%%/templates/projects/dynamic-library-wx-enabled
@dirrm %%DATADIR%%/templates/projects/dynamic-library
@dirrm %%DATADIR%%/templates/projects/custom-makefile
@dirrm %%DATADIR%%/templates/projects/UnitTest++
@dirrm %%DATADIR%%/templates/projects
@dirrm %%DATADIR%%/templates/gizmos
@dirrm %%DATADIR%%/templates/formbuilder
@dirrm %%DATADIR%%/templates
@dirrm %%DATADIR%%/src
@dirrm %%DATADIR%%/rc
@dirrm %%DATADIR%%/plugins/resources
@dirrm %%DATADIR%%/plugins/debuggers
@ -115,8 +163,7 @@ share/applications/codelite.desktop
@dirrm %%DATADIR%%/lexers/Default
@dirrm %%DATADIR%%/lexers/BlackTheme
@dirrm %%DATADIR%%/lexers
@dirrm %%DATADIR%%/config
@dirrm %%DATADIR%%/images
@dirrm %%DATADIR%%/src
@dirrm %%DATADIR%%/config
@dirrm %%DATADIR%%
@dirrmtry share/applications