lang/rexx-regina: Upgrade version 3.8 => 3.8.2
PR: 191824 Submitted by: Ports Fury
This commit is contained in:
parent
ec27a9c399
commit
af3d00bc7a
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=364478
4 changed files with 28 additions and 61 deletions
|
@ -2,7 +2,7 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= regina
|
||||
PORTVERSION= 3.8
|
||||
PORTVERSION= 3.8.2
|
||||
CATEGORIES= lang
|
||||
MASTER_SITES= SF/${PORTNAME}-rexx/${PORTNAME}-rexx/${PORTVERSION}
|
||||
PKGNAMEPREFIX= rexx-
|
||||
|
@ -13,19 +13,23 @@ COMMENT= Rexx interpreter
|
|||
|
||||
LICENSE= LGPL21 # (or later)
|
||||
|
||||
USES= gmake iconv
|
||||
USES= gmake iconv tar:bzip2
|
||||
USE_RC_SUBR= rxstack
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ENV= ac_cv_c_char_unsigned=yes
|
||||
CONFIGURE_ARGS= --with-addon-dir=${PREFIX}/lib/Regina-REXX/addons
|
||||
USE_LDCONFIG= yes
|
||||
MAKE_JOBS_UNSAFE= yes
|
||||
|
||||
DATADIR= ${PREFIX}/share/Regina-REXX
|
||||
EXAMPLESDIR= ${PREFIX}/share/examples/Regina-REXX
|
||||
|
||||
CONFLICTS= rexx-imc-[0-0]* oorexx-[0-9]*
|
||||
|
||||
BROKEN_powerpc= Does not link on powerpc
|
||||
|
||||
OPTIONS_DEFINE= EXAMPLES
|
||||
|
||||
.include <bsd.port.options.mk>
|
||||
|
||||
.if ${ARCH} == i386
|
||||
|
@ -37,6 +41,7 @@ post-patch:
|
|||
'/$${CFLAGS}/s|^|#| ; \
|
||||
s|"-lpthread"|"-pthread"|' ${WRKSRC}/configure
|
||||
@${REINPLACE_CMD} -e \
|
||||
'/$$(sysconfdir)/s|^|#|' ${WRKSRC}/Makefile.in
|
||||
'/^examplesdir/s|=.*|= $$(datadir)/examples/$$(PACKAGE)| ; \
|
||||
/$$(sysconfdir)/s|^|#|' ${WRKSRC}/Makefile.in
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,2 +1,2 @@
|
|||
SHA256 (Regina-REXX-3.8.tar.gz) = 3701d537677cb6a0c5e9fef99329615d80c144f2587d69db5cda3264b3ece309
|
||||
SIZE (Regina-REXX-3.8.tar.gz) = 1194563
|
||||
SHA256 (Regina-REXX-3.8.2.tar.bz2) = 7a83b5caccdd14aa0cef71971af41fc3eaeb14b842c35ff8dda4c673d354a78b
|
||||
SIZE (Regina-REXX-3.8.2.tar.bz2) = 1006856
|
||||
|
|
|
@ -1,43 +1,11 @@
|
|||
--- configure.orig 2014-07-05 22:07:04.000000000 +0000
|
||||
+++ configure
|
||||
@@ -3483,6 +3483,13 @@ case "$target" in
|
||||
osis64bit=yes
|
||||
fi
|
||||
;;
|
||||
+ *-dragonfly*)
|
||||
+ mach="`uname -m`"
|
||||
+ if test "$mach" = "x86_64"; then
|
||||
+ bitflag="64"
|
||||
+ osis64bit=yes
|
||||
+ fi
|
||||
+ ;;
|
||||
*-freebsd*)
|
||||
mach="`uname -m`"
|
||||
if test "$mach" = "amd64"; then
|
||||
@@ -6178,7 +6185,7 @@ $as_echo_n "checking whether Posix Threa
|
||||
save_cflags="$CFLAGS"
|
||||
pthread_libs="pthreads pthread c_r c"
|
||||
case "$target" in
|
||||
- *freebsd*)
|
||||
+ *freebsd*|*dragonfly*)
|
||||
CFLAGS="$CFLAGS -pthread"
|
||||
;;
|
||||
esac
|
||||
@@ -6232,7 +6239,7 @@ rm -f core conftest.err conftest.$ac_obj
|
||||
;;
|
||||
*linux*)
|
||||
;;
|
||||
- *freebsd*)
|
||||
+ *freebsd*|*dragonfly*)
|
||||
THREADING_COMPILE="-pthread -D_REENTRANT -DPOSIX -DREGINA_REENTRANT"
|
||||
THREADING_LINK="-pthread"
|
||||
;;
|
||||
@@ -8654,7 +8661,13 @@ case "$target" in
|
||||
--- configure.orig 2012-10-16 06:34:08.000000000 +0200
|
||||
+++ configure 2013-02-04 21:07:09.000000000 +0100
|
||||
@@ -8654,7 +8654,13 @@
|
||||
SHLPRE="lib"
|
||||
SHL_LD="ld -assert pure-text -o ${SHLPRE}${SHLFILE}${SHLPST} "'$('SHOFILES')'
|
||||
;;
|
||||
- *-freebsd* | *openbsd*)
|
||||
+ *freebsd*|*dragonfly*)
|
||||
+ *freebsd*)
|
||||
+ LD_RXLIB_A1="$ac_cv_prog_CC -shared ${LDFLAGS} -o \$(@)"
|
||||
+ LD_RXLIB_A2="$ac_cv_prog_CC -shared ${LDFLAGS} -o \$(@)"
|
||||
+ LD_RXLIB_UTILA="$ac_cv_prog_CC -shared ${LDFLAGS} -o \$(@)"
|
||||
|
@ -47,12 +15,3 @@
|
|||
if test "$ac_cv_prog_CC" = "gcc" -o "$ac_cv_prog_CC" = "g++" -o "$ac_cv_prog_CC" = "clang"; then
|
||||
LD_RXLIB_A1="$ac_cv_prog_CC -shared ${LDFLAGS} -o \$(@)"
|
||||
LD_RXLIB_A2="$ac_cv_prog_CC -shared ${LDFLAGS} -o \$(@)"
|
||||
@@ -9403,7 +9416,7 @@ $as_echo_n "checking OS distribution nam
|
||||
$as_echo "$MYDISTRO" >&6; }
|
||||
else
|
||||
case "$target" in
|
||||
- *freebsd* | *openbsd*)
|
||||
+ *freebsd* | *openbsd* | *dragonfly*)
|
||||
MYDISTRO="`echo $target | cut -f3 -d-`"
|
||||
;;
|
||||
*darwin*)
|
||||
|
|
|
@ -4,29 +4,32 @@ bin/rexx
|
|||
bin/rxqueue
|
||||
bin/rxstack
|
||||
include/rexxsaa.h
|
||||
lib/Regina-REXX/addons/libregutil.so
|
||||
lib/Regina-REXX/addons/librxtest1.so
|
||||
lib/Regina-REXX/addons/librxtest2.so
|
||||
lib/libregina.a
|
||||
lib/libregina.so
|
||||
lib/libregutil.so
|
||||
lib/librxtest1.so
|
||||
lib/librxtest2.so
|
||||
man/man1/regina.1.gz
|
||||
man/man1/regina-config.1.gz
|
||||
man/man1/rxqueue.1.gz
|
||||
man/man1/rxstack.1.gz
|
||||
%%DATADIR%%/animal.rexx
|
||||
%%DATADIR%%/block.rexx
|
||||
%%DATADIR%%/dateconv.rexx
|
||||
%%DATADIR%%/de.mtb
|
||||
%%DATADIR%%/dynfunc.rexx
|
||||
%%DATADIR%%/en.mtb
|
||||
%%DATADIR%%/es.mtb
|
||||
%%DATADIR%%/newstr.rexx
|
||||
%%DATADIR%%/no.mtb
|
||||
%%DATADIR%%/pl.mtb
|
||||
%%DATADIR%%/pt.mtb
|
||||
%%DATADIR%%/regutil.rexx
|
||||
%%DATADIR%%/rexxcps.rexx
|
||||
%%DATADIR%%/sv.mtb
|
||||
%%DATADIR%%/timeconv.rexx
|
||||
%%DATADIR%%/tr.mtb
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/animal.rexx
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/block.rexx
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/dateconv.rexx
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/dynfunc.rexx
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/newstr.rexx
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/regutil.rexx
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rexxcps.rexx
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/timeconv.rexx
|
||||
%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%
|
||||
@dirrm %%DATADIR%%
|
||||
@dirrm lib/Regina-REXX/addons
|
||||
@dirrm lib/Regina-REXX
|
||||
|
|
Loading…
Reference in a new issue