Update port to v2.0.3
- Various fixes - Use GNU configure Approved by: pi@ (implicit) Sponsored by: Mellanox Technologies
This commit is contained in:
parent
5371e3549b
commit
af4f012889
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=531752
4 changed files with 23 additions and 20 deletions
|
@ -2,37 +2,26 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= rshim-user-space
|
||||
DISTVERSIONPREFIX= v
|
||||
DISTVERSION= 1.0-alpha.2
|
||||
|
||||
CATEGORIES= sysutils
|
||||
DISTVERSIONPREFIX= rshim-
|
||||
DISTVERSION= 2.0.3
|
||||
|
||||
MAINTAINER= hselasky@FreeBSD.org
|
||||
COMMENT= Userspace daemon for the Mellanox BlueField SoC
|
||||
|
||||
LICENSE= BSD3CLAUSE
|
||||
|
||||
CATEGORIES= sysutils
|
||||
|
||||
LIB_DEPENDS= libepoll-shim.so:devel/libepoll-shim \
|
||||
libpci.so:devel/libpci \
|
||||
libpciaccess.so:devel/libpciaccess
|
||||
|
||||
USES= gmake tar:bzip2
|
||||
USES= autoreconf localbase gmake tar:bzip2
|
||||
|
||||
USE_GITHUB= yes
|
||||
GH_ACCOUNT= Mellanox
|
||||
|
||||
OPTIONS_DEFINE= DEBUG
|
||||
|
||||
DEBUG_DESC= Build with debugging support
|
||||
DEBUG_MAKE_ARGS=HAVE_DEBUG=YES
|
||||
|
||||
PLIST_FILES= sbin/bfrshim
|
||||
|
||||
MAKE_ARGS+= CC="${CC}" \
|
||||
PREFIX="${PREFIX}" \
|
||||
LOCALBASE="${LOCALBASE}"
|
||||
|
||||
MAKEFILE= Makefile.freebsd
|
||||
GNU_CONFIGURE= yes
|
||||
|
||||
.include <bsd.port.options.mk>
|
||||
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
TIMESTAMP = 1570644061
|
||||
SHA256 (Mellanox-rshim-user-space-v1.0-alpha.2_GH0.tar.gz) = 89339449daa19efa57cb25b280e53fd06f69a84d1905a31cbc3038cb460e7b6f
|
||||
SIZE (Mellanox-rshim-user-space-v1.0-alpha.2_GH0.tar.gz) = 38178
|
||||
TIMESTAMP = 1586938283
|
||||
SHA256 (Mellanox-rshim-user-space-rshim-2.0.3_GH0.tar.gz) = 056e356bb52ee6eb2fb0d67382294c01e01060590ebe07b684c7d1559fe2236e
|
||||
SIZE (Mellanox-rshim-user-space-rshim-2.0.3_GH0.tar.gz) = 48283
|
||||
|
|
11
sysutils/rshim-user-space/files/patch-src_rshim__pcie.c
Normal file
11
sysutils/rshim-user-space/files/patch-src_rshim__pcie.c
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- src/rshim_pcie.c.orig 2020-04-15 08:20:11 UTC
|
||||
+++ src/rshim_pcie.c
|
||||
@@ -459,6 +459,8 @@ int rshim_pcie_enable(void *dev)
|
||||
|
||||
close(fd);
|
||||
return rc;
|
||||
+#else
|
||||
+ return 0;
|
||||
#endif
|
||||
}
|
||||
|
3
sysutils/rshim-user-space/pkg-plist
Normal file
3
sysutils/rshim-user-space/pkg-plist
Normal file
|
@ -0,0 +1,3 @@
|
|||
sbin/rshim
|
||||
share/doc/rshim/README.md
|
||||
man/man8/rshim.8.gz
|
Loading…
Reference in a new issue