initial import of zebedee port
Submitted by: Greg Hewgill <greg@hewgill.com>
This commit is contained in:
parent
0e32301528
commit
afa17e6669
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=24584
6 changed files with 114 additions and 0 deletions
39
security/zebedee/Makefile
Normal file
39
security/zebedee/Makefile
Normal file
|
@ -0,0 +1,39 @@
|
|||
# New ports collection makefile for: zebedee
|
||||
# Version required: 1.2.0
|
||||
# Date created: 4 January 2000
|
||||
# Whom: Greg Hewgill <greg@hewgill.com>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
DISTNAME= zebedee-1.2.0
|
||||
CATEGORIES= security
|
||||
MASTER_SITES= http://www.winton.org.uk/zebedee/ \
|
||||
http://www.hewgill.com/zebedee/
|
||||
|
||||
MAINTAINER= greg@hewgill.com
|
||||
|
||||
BUILD_DEPENDS= ${LOCALBASE}/include/openssl/blowfish.h:${PORTSDIR}/security/openssl \
|
||||
${LOCALBASE}/lib/libcrypto.a:${PORTSDIR}/security/openssl \
|
||||
${LOCALBASE}/lib/libbz2.a:${PORTSDIR}/archivers/bzip2
|
||||
|
||||
USE_PERL5= yes
|
||||
|
||||
MAN1= zebedee.1
|
||||
|
||||
do-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/zebedee ${PREFIX}/bin
|
||||
${INSTALL_MAN} ${WRKSRC}/zebedee.1 ${PREFIX}/man/man1
|
||||
${INSTALL_DATA} ${WRKSRC}/server.zbd ${PREFIX}/etc/server.zbd.sample
|
||||
${MKDIR} ${PREFIX}/share/examples/zebedee
|
||||
${INSTALL_DATA} ${WRKSRC}/vncviewer.zbd ${PREFIX}/share/examples/zebedee
|
||||
${INSTALL_DATA} ${WRKSRC}/vncserver.zbd ${PREFIX}/share/examples/zebedee
|
||||
${INSTALL_DATA} ${WRKSRC}/server.key ${PREFIX}/share/examples/zebedee
|
||||
${INSTALL_DATA} ${WRKSRC}/server.id ${PREFIX}/share/examples/zebedee
|
||||
${MKDIR} ${PREFIX}/share/doc/zebedee
|
||||
${INSTALL_DATA} ${WRKSRC}/README.txt ${PREFIX}/share/doc/zebedee
|
||||
${INSTALL_DATA} ${WRKSRC}/LICENCE.txt ${PREFIX}/share/doc/zebedee
|
||||
${INSTALL_DATA} ${WRKSRC}/CHANGES.txt ${PREFIX}/share/doc/zebedee
|
||||
${INSTALL_DATA} ${WRKSRC}/zebedee.html ${PREFIX}/share/doc/zebedee
|
||||
|
||||
.include <bsd.port.mk>
|
1
security/zebedee/distinfo
Normal file
1
security/zebedee/distinfo
Normal file
|
@ -0,0 +1 @@
|
|||
MD5 (zebedee-1.2.0.tar.gz) = 75183e084b4e983782f4ea248b89b78b
|
52
security/zebedee/files/patch-aa
Normal file
52
security/zebedee/files/patch-aa
Normal file
|
@ -0,0 +1,52 @@
|
|||
--- Makefile.orig Fri Nov 19 13:36:27 1999
|
||||
+++ Makefile Sat Jan 8 01:51:44 2000
|
||||
@@ -28,29 +28,30 @@
|
||||
# the use of bzip2 compression
|
||||
|
||||
#DEFINES = # Win32
|
||||
-DEFINES = -DHAVE_DEV_RANDOM -DHAVE_PTHREADS # Linux
|
||||
+#DEFINES = -DHAVE_DEV_RANDOM -DHAVE_PTHREADS # Linux
|
||||
+DEFINES = -DHAVE_DEV_RANDOM # FreeBSD
|
||||
#DEFINES = -DHAVE_PROC_FS -DHAVE_PTHREADS # Solaris
|
||||
|
||||
# Location of gmp include and library
|
||||
|
||||
-GMPINC = -I../gmp-2.0.2
|
||||
-GMPLIB = ../gmp-2.0.2/libgmp.a
|
||||
+GMPINC =
|
||||
+GMPLIB = -lgmp
|
||||
|
||||
# Location of Blowfish include and library
|
||||
|
||||
-BFINC = -I../blowfish
|
||||
-BFLIB = ../blowfish/libblowfish.a
|
||||
+BFINC = -I${PREFIX}/include/openssl
|
||||
+BFLIB = ${PREFIX}/lib/libcrypto.a
|
||||
|
||||
# Location of zlib include and library
|
||||
|
||||
-ZINC = -I../zlib-1.1.3
|
||||
-ZLIB = ../zlib-1.1.3/libz.a
|
||||
+ZINC =
|
||||
+ZLIB = -lz
|
||||
|
||||
# Location of bzlib include and library
|
||||
# Set these empty if you don't want bzib2 support
|
||||
|
||||
-BZINC = -I../bzip2-0.9.5d
|
||||
-BZLIB = ../bzip2-0.9.5d/libbz2.a
|
||||
+BZINC = -I${PREFIX}/include
|
||||
+BZLIB = ${PREFIX}/lib/libbz2.a
|
||||
|
||||
|
||||
# Suffix for executables
|
||||
@@ -61,7 +62,8 @@
|
||||
# Extra OS-specific libraries
|
||||
|
||||
#OSLIBS = -lwsock32 -lwinmm # Win32
|
||||
-OSLIBS = -lpthread # Linux
|
||||
+#OSLIBS = -lpthread # Linux
|
||||
+OSLIBS = # FreeBSD
|
||||
#OSLIBS = -lsocket -lnsl -lthread # Solaris
|
||||
|
||||
# Supplementary object files (Win32 ONLY)
|
1
security/zebedee/pkg-comment
Normal file
1
security/zebedee/pkg-comment
Normal file
|
@ -0,0 +1 @@
|
|||
Encrypted, secure compressed TCP tunnel
|
9
security/zebedee/pkg-descr
Normal file
9
security/zebedee/pkg-descr
Normal file
|
@ -0,0 +1,9 @@
|
|||
Zebedee is a simple program to establish an encrypted, compressed TCP/IP
|
||||
"tunnel" between two systems. This allows TCP-based traffic such as telnet,
|
||||
ftp and X to be protected from snooping as well as potentially gaining
|
||||
performance over low-bandwidth networks from compression.
|
||||
|
||||
WWW: http://www.winton.org.uk/zebedee/
|
||||
|
||||
- Greg Hewgill
|
||||
greg@hewgill.com
|
12
security/zebedee/pkg-plist
Normal file
12
security/zebedee/pkg-plist
Normal file
|
@ -0,0 +1,12 @@
|
|||
bin/zebedee
|
||||
etc/server.zbd.sample
|
||||
share/examples/zebedee/vncviewer.zbd
|
||||
share/examples/zebedee/vncserver.zbd
|
||||
share/examples/zebedee/server.key
|
||||
share/examples/zebedee/server.id
|
||||
share/doc/zebedee/README.txt
|
||||
share/doc/zebedee/LICENCE.txt
|
||||
share/doc/zebedee/CHANGES.txt
|
||||
share/doc/zebedee/zebedee.html
|
||||
@dirrm share/examples/zebedee
|
||||
@dirrm share/doc/zebedee
|
Loading…
Reference in a new issue