- Add gecko-sharp20, C# bindings for the Gecko rendering engine.
WWW: http://www.mono-project.com/GeckoSharp Approved by: mezz (co-mentor)
This commit is contained in:
parent
6283d52f55
commit
aff89f6bc7
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=143556
7 changed files with 93 additions and 0 deletions
|
@ -146,6 +146,7 @@
|
|||
SUBDIR += gallery2
|
||||
SUBDIR += gatling
|
||||
SUBDIR += gecko-sharp10
|
||||
SUBDIR += gecko-sharp20
|
||||
SUBDIR += geeklog
|
||||
SUBDIR += geneweb
|
||||
SUBDIR += geolizer
|
||||
|
|
53
www/gecko-sharp20/Makefile
Normal file
53
www/gecko-sharp20/Makefile
Normal file
|
@ -0,0 +1,53 @@
|
|||
# New ports collection makefile for: gecko-sharp
|
||||
# Date created: 20040825
|
||||
# Whom: Tom McLaughlin <tmclaugh@sdf.lonestar.org>
|
||||
#
|
||||
# $FreeBSD$
|
||||
# $Id: Makefile,v 1.6 2005/09/25 19:01:20 tmclau02 Exp $
|
||||
#
|
||||
|
||||
PORTNAME= gecko-sharp
|
||||
PORTVERSION= 0.11
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= www
|
||||
MASTER_SITES= http://go-mono.com/sources/gecko-sharp-2.0/
|
||||
DISTNAME= gecko-sharp-2.0-${PORTVERSION}
|
||||
|
||||
MAINTAINER= bsd-sharp-list@forge.novell.com
|
||||
COMMENT= Mono bindings for embeding mozilla
|
||||
|
||||
BUILD_DEPENDS= gapi2-parser:${PORTSDIR}/x11-toolkits/gtk-sharp20 \
|
||||
monodoc:${PORTSDIR}/devel/mono-tools
|
||||
RUN_DEPENDS= gapi2-parser:${PORTSDIR}/x11-toolkits/gtk-sharp20 \
|
||||
monodoc:${PORTSDIR}/devel/mono-tools \
|
||||
${X11BASE}/lib/${MOZILLA}/components/libwidget_gtk2.so:${PORTSDIR}/www/${MOZILLA}
|
||||
|
||||
.if !defined(WITH_MOZILLA)
|
||||
MOZILLA= mozilla
|
||||
.else
|
||||
.if ${WITH_MOZILLA}=="firefox"
|
||||
MOZILLA= firefox
|
||||
.else
|
||||
MOZILLA= mozilla
|
||||
.endif
|
||||
.endif
|
||||
|
||||
USE_GNOME= gnometarget
|
||||
LATEST_LINK= gecko-sharp20
|
||||
USE_REINPLACE= yes
|
||||
USE_X_PREFIX= yes
|
||||
GNU_CONFIGURE= yes
|
||||
USE_GMAKE= yes
|
||||
|
||||
pre-everything::
|
||||
@${ECHO_MSG} ""
|
||||
@${ECHO_MSG} " By default ${PORTNAME} uses www/mozilla for html rendering, but you can"
|
||||
@${ECHO_MSG} " change this by defining WITH_MOZILLA to one of the following values:"
|
||||
@${ECHO_MSG} ""
|
||||
@${ECHO_MSG} " firefox "
|
||||
@${ECHO_MSG} ""
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e 's|[(]prefix[)]/lib/pkgconfig|(prefix)/libdata/pkgconfig|g' ${WRKSRC}/Makefile.in
|
||||
|
||||
.include <bsd.port.mk>
|
2
www/gecko-sharp20/distinfo
Normal file
2
www/gecko-sharp20/distinfo
Normal file
|
@ -0,0 +1,2 @@
|
|||
MD5 (gecko-sharp-2.0-0.11.tar.gz) = 7362d710b7fe6a8b5f68a614279147de
|
||||
SIZE (gecko-sharp-2.0-0.11.tar.gz) = 177141
|
11
www/gecko-sharp20/files/patch-configure
Normal file
11
www/gecko-sharp20/files/patch-configure
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- configure.orig Fri May 13 19:46:41 2005
|
||||
+++ configure Mon May 16 20:24:13 2005
|
||||
@@ -2681,7 +2681,7 @@
|
||||
{ (exit 1); exit 1; }; }
|
||||
fi
|
||||
|
||||
-GACUTIL_FLAGS='/package gecko-sharp-2.0 /gacdir $(DESTDIR)$(prefix)/lib'
|
||||
+GACUTIL_FLAGS='/package gecko-sharp-2.0 /gacdir $(DESTDIR)$(libdir) /root $(DESTDIR)$(libdir)'
|
||||
|
||||
|
||||
winbuild=no
|
|
@ -0,0 +1,14 @@
|
|||
--- gtkmozembed/gecko-sharp.dll.config.in.orig Fri Apr 15 14:19:58 2005
|
||||
+++ gtkmozembed/gecko-sharp.dll.config.in Sun May 15 04:17:32 2005
|
||||
@@ -1,7 +1,7 @@
|
||||
<configuration>
|
||||
- <dllmap dll="libglib-2.0-0.dll" target="libglib-2.0@LIB_PREFIX@.0@LIB_SUFFIX@"/>
|
||||
- <dllmap dll="libgobject-2.0-0.dll" target="libgobject-2.0@LIB_PREFIX@.0@LIB_SUFFIX@"/>
|
||||
- <dllmap dll="libatk-1.0-0.dll" target="libatk-1.0@LIB_PREFIX@.0@LIB_SUFFIX@"/>
|
||||
- <dllmap dll="libgtk-win32-2.0-0.dll" target="libgtk-x11-2.0@LIB_PREFIX@.0@LIB_SUFFIX@"/>
|
||||
+ <dllmap dll="libglib-2.0-0.dll" target="libglib-2.0@LIB_PREFIX@@LIB_SUFFIX@"/>
|
||||
+ <dllmap dll="libgobject-2.0-0.dll" target="libgobject-2.0@LIB_PREFIX@@LIB_SUFFIX@"/>
|
||||
+ <dllmap dll="libatk-1.0-0.dll" target="libatk-1.0@LIB_PREFIX@@LIB_SUFFIX@"/>
|
||||
+ <dllmap dll="libgtk-win32-2.0-0.dll" target="libgtk-x11-2.0@LIB_PREFIX@@LIB_SUFFIX@"/>
|
||||
<dllmap dll="gtkembedmoz.dll" target="libgtkembedmoz@LIB_PREFIX@@LIB_SUFFIX@"/>
|
||||
</configuration>
|
2
www/gecko-sharp20/pkg-descr
Normal file
2
www/gecko-sharp20/pkg-descr
Normal file
|
@ -0,0 +1,2 @@
|
|||
C# language binding for the gtkembedmoz widget. You can use it to embed
|
||||
mozilla into C# programs.
|
10
www/gecko-sharp20/pkg-plist
Normal file
10
www/gecko-sharp20/pkg-plist
Normal file
|
@ -0,0 +1,10 @@
|
|||
lib/mono/gac/gecko-sharp/2.0.0.0__ccf7d78a55e9f021/gecko-sharp.dll
|
||||
lib/mono/gac/gecko-sharp/2.0.0.0__ccf7d78a55e9f021/gecko-sharp.dll.config
|
||||
lib/mono/gecko-sharp-2.0/gecko-sharp.dll
|
||||
lib/monodoc/sources/gecko-sharp-docs.source
|
||||
lib/monodoc/sources/gecko-sharp-docs.tree
|
||||
lib/monodoc/sources/gecko-sharp-docs.zip
|
||||
libdata/pkgconfig/gecko-sharp-2.0.pc
|
||||
@dirrm lib/mono/gecko-sharp-2.0
|
||||
@dirrm lib/mono/gac/gecko-sharp/2.0.0.0__ccf7d78a55e9f021
|
||||
@dirrm lib/mono/gac/gecko-sharp
|
Loading…
Reference in a new issue