- Upstream versions of mplayer and ffmpeg as of 2014-12-23

- Remove the following OPTIONS:
  - MEMALIGN (now used by default where supported)
  - PROFILE (shaky, unreliable, rarely used, nigh unsupportable)
  - DIRAC (codec support only via libschroedinger)
- Default-depends on external libdvdnav
  (mplayer no longer bundles internal dvd support libraries)
- Simplify CFLAGS handling
- Use -mstack-alignment=16 -mstackrealign on clang / i386
This commit is contained in:
Thomas Zander 2014-12-29 08:39:33 +00:00
parent 63e3a32208
commit b05605bc33
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=375775
11 changed files with 86 additions and 194 deletions

View file

@ -3,25 +3,23 @@
PORTNAME= mencoder
PORTVERSION= ${MPLAYER_PORT_VERSION}
PORTREVISION= 5
COMMENT= Convenient video file and movie encoder
.include "${.CURDIR}/../mplayer/Makefile.shared"
OPTIONS_DEFINE= AMR_NB AMR_WB BLURAY CDIO CDPARANOIA DEBUG DIRAC \
OPTIONS_DEFINE= AMR_NB AMR_WB BLURAY CDIO CDPARANOIA DEBUG \
DV FAAC FONTCONFIG FRIBIDI GIF GNUTLS GSM IPV6 JACK \
LADSPA LIBMNG LZO MAD MEMALIGN NAS OCFLAGS OPENAL \
OPENJPEG OPUS OTCHAIN PROFILE PULSEAUDIO REAL RTCPU RTMP \
LADSPA LIBMNG LZO MAD NAS OCFLAGS OPENAL \
OPENJPEG OPUS OTCHAIN PULSEAUDIO REAL RTCPU RTMP \
SCHROEDINGER SMB THEORA TWOLAME V4L VPX WIN32 X264 XVID
OPTIONS_DEFAULT=GIF GNUTLS IPV6 OCFLAGS RTCPU WIN32 X264 XVID
BLURAY_DESC?= BluRay support
LZO_DESC?= Enable external liblzo library
MEMALIGN_DESC?= Avoid memory alignment hacks (EXPERIMENTAL)
OCFLAGS_DESC?= Use optimized compiler flags
OTCHAIN_DESC?= Use gcc 4.6+ toolchain on legacy systems
OTCHAIN_DESC?= Use up-to-date gcc toolchain on legacy systems
REAL_DESC?= Enable realplayer plugin
RTCPU_DESC?= Use runtime CPU detection on supported archs
WIN32_DESC?= Install win32 binary codecs
@ -111,16 +109,16 @@ post-patch:
s|/dev/\\:(cdrom[[:alnum:]]*[[:>:]])|${DEFAULT_CDROM_DEVICE:S/dev\//dev\/\\\:/}|g'
do-install:
@${INSTALL_PROGRAM} ${WRKSRC}/mencoder ${STAGEDIR}${PREFIX}/bin
${INSTALL_PROGRAM} ${WRKSRC}/mencoder ${STAGEDIR}${PREFIX}/bin
post-install:
@${INSTALL_MAN} ${WRKSRC}/DOCS/man/en/mplayer.1 ${STAGEDIR}${MAN1PREFIX}/man/man1/mencoder.1
${INSTALL_MAN} ${WRKSRC}/DOCS/man/en/mplayer.1 ${STAGEDIR}${MAN1PREFIX}/man/man1/mencoder.1
@${MKDIR} ${STAGEDIR}${DATADIR}
@${CHMOD} 755 ${STAGEDIR}${DATADIR}
@${MKDIR} ${STAGEDIR}${DATADIR}/tools
@${CHMOD} 755 ${STAGEDIR}${DATADIR}/tools
.for tool in ${TOOLFILES}
@${INSTALL_SCRIPT} ${WRKSRC}/TOOLS/${tool} ${STAGEDIR}${DATADIR}/tools
${INSTALL_SCRIPT} ${WRKSRC}/TOOLS/${tool} ${STAGEDIR}${DATADIR}/tools
.endfor
.include <bsd.port.post.mk>

View file

@ -1,2 +1,2 @@
SHA256 (mplayer-1.1.20140824.tar.xz) = ea11e84bb3ea21904fccc2b661aee997e87d16c2d56659c1a439328c2d1d0745
SIZE (mplayer-1.1.20140824.tar.xz) = 11397312
SHA256 (mplayer-1.1.20141223.tar.xz) = 8d5ae2b77cdb6b86670a3741ea024b0ba8f7e4515221b224a10b690ee841d909
SIZE (mplayer-1.1.20141223.tar.xz) = 11408272

View file

@ -3,7 +3,6 @@
PORTNAME= mplayer
PORTVERSION= ${MPLAYER_PORT_VERSION}
PORTREVISION= 7
COMMENT= High performance media player supporting many formats
@ -11,11 +10,10 @@ COMMENT= High performance media player supporting many formats
OPTIONS_DEFINE= AALIB AMR_NB AMR_WB BLURAY CACA DEBUG DV \
ENCA FONTCONFIG FRIBIDI GIF GNUTLS GSM GUI IPV6 JACK \
LADSPA LIBMNG LIRC LZO MEMALIGN NAS OCFLAGS \
OPENAL OPENGL OPENJPEG OPUS OTCHAIN PROFILE \
PULSEAUDIO REAL RTC RTCPU RTMP SCHROEDINGER SDL \
SKINS SMB SVGALIB V4L VDPAU VPX WIN32 \
X11 X11DGA X11VM XINERAMA XVIDEO XVMC
LADSPA LIBMNG LIRC LZO NAS OCFLAGS OPENAL OPENGL \
OPENJPEG OPUS OTCHAIN PULSEAUDIO REAL RTC RTCPU RTMP \
SCHROEDINGER SDL SKINS SMB SVGALIB V4L VDPAU VPX \
WIN32 X11 X11DGA X11VM XINERAMA XVIDEO XVMC
OPTIONS_RADIO= RGCD
OPTIONS_RADIO_RGCD= CDIO CDPARANOIA
@ -26,9 +24,8 @@ OPTIONS_DEFAULT=FONTCONFIG FRIBIDI GNUTLS IPV6 OCFLAGS OPENGL RTCPU \
BLURAY_DESC?= BluRay support
ENCA_DESC?= Charset conversion via enca
LZO_DESC?= External liblzo support
MEMALIGN_DESC?= Avoid memory alignment hacks (EXPERIMENTAL)
OCFLAGS_DESC?= Use optimized compiler flags
OTCHAIN_DESC?= Use gcc 4.6+ toolchain on legacy systems
OTCHAIN_DESC?= Use up-to-date gcc toolchain on legacy systems
REAL_DESC?= Enable realplayer plugin
RTC_DESC?= Add support for kernel real time clock
RTCPU_DESC?= Use runtime CPU detection on supported archs

View file

@ -48,22 +48,12 @@ DEFAULT_KERN_HZ=1024
# Non-simplified OPTIONS handling
# ===============================
.if ${PORT_OPTIONS:MGNUTLS}
LIB_DEPENDS+= libgnutls.so:${PORTSDIR}/security/gnutls
CONFIGURE_ARGS+= --enable-gnutls
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-gnutls
.endif
.if ${PORT_OPTIONS:MIPV6}
CATEGORIES+= ipv6
.else
CONFIGURE_ARGS+= --disable-inet6
.endif
.if ${PORT_OPTIONS:MMEMALIGN}
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-memalign
.endif
.if ${PORT_OPTIONS:MRTMP}
LIB_DEPENDS+= librtmp.so:${PORTSDIR}/multimedia/librtmp
CONFIGURE_ARGS+= --enable-librtmp
@ -95,7 +85,7 @@ CONFIGURE_ARGS+= --disable-tv-v4l1 \
# =========================================
# Supported architectures for clang
.if ${ARCH} == "amd64" || ${ARCH} == "i386"
.if ${ARCH} == "amd64" || ${ARCH} == "i386" || ${ARCH} == "armv6"
MPLAYER_CLANG_SUPPORTED_ARCH= yes
.endif
@ -130,6 +120,11 @@ CC= clang
CXX= clang++
CPP= clang-cpp
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-clang-version
# Require 16 byte stack realignment on i386 to interface
# properly with hand crafted assembler code in ffmpeg
.if ${ARCH} == "i386"
CFLAGS+= -mstack-alignment=16 -mstackrealign
.endif # ${ARCH} == "i386"
.else
.if ${PORT_OPTIONS:MOTCHAIN}
USE_GCC?= yes
@ -142,40 +137,23 @@ EXTRA_PATCHES+= ${FILESDIR}/extra-patch-base_system_gcc
BUILD_DEPENDS+= ${LOCALBASE}/bin/as:${PORTSDIR}/devel/binutils
CONFIGURE_ENV+= COMPILER_PATH=${LOCALBASE}/bin
MAKE_ENV+= COMPILER_PATH=${LOCALBASE}/bin
.endif
.endif
.endif
.endif # ${ARCH} == "amd64"
.endif # ${PORT_OPTIONS:MOTCHAIN}
.endif # defined(WITH_BASE_CLANG)
# Extra build options for debugging and profiling
# ===============================================
# Extra build options for debugging and optimised CFLAGS
# ======================================================
#On i386, gcc runs out of general purpose registers when
#trying to compile a debug version with the default flags.
.if ${PORT_OPTIONS:MDEBUG}
WITH_DEBUG= yes
CONFIGURE_ARGS+= --enable-debug=3
.if ${ARCH} == "i386" && !defined(WITH_BASE_CLANG)
DEBUG_FLAGS= -g -fomit-frame-pointer
.endif
.else
.if ${PORT_OPTIONS:MOCFLAGS}
CFLAGS+= -O3 -fomit-frame-pointer -ffast-math
.else
CFLAGS+= -O -fomit-frame-pointer
.endif #OCFLAGS
.endif #DEBUG
.if ${PORT_OPTIONS:MPROFILE}
CONFIGURE_ARGS+= --enable-profile
LDFLAGS+= -pg
.if ${OSVERSION} >= 1100000
#Workaround a temporary bug in 11-CURRENT where
#using -pie does not work with -pthread
CONFIGURE_ARGS+= --disable-relocatable
.endif
.endif #PROFILE
# Edge case: binary codecs on i386, mostly superseded by internal ffmpeg
# ======================================================================

View file

@ -23,9 +23,6 @@ CDIO_CONFIGURE_OFF= --disable-libcdio
CDPARANOIA_LIB_DEPENDS= libcdda_paranoia.so:${PORTSDIR}/audio/cdparanoia
CDPARANOIA_CONFIGURE_OFF= --disable-cdparanoia
DIRAC_LIB_DEPENDS= libdirac_encoder.so:${PORTSDIR}/multimedia/dirac
DIRAC_CONFIGURE_OFF= --disable-libdirac-lavc
DV_LIB_DEPENDS= libdv.so:${PORTSDIR}/multimedia/libdv
DV_CONFIGURE_OFF= --disable-libdv
@ -44,6 +41,9 @@ FRIBIDI_CONFIGURE_OFF= --disable-fribidi
GIF_LIB_DEPENDS= libgif.so:${PORTSDIR}/graphics/giflib
GIF_CONFIGURE_OFF= --disable-gif
GNUTLS_LIB_DEPENDS= libgnutls.so:${PORTSDIR}/security/gnutls
GNUTLS_CONFIGURE_OFF= --disable-gnutls
GSM_LIB_DEPENDS= libgsm.so:${PORTSDIR}/audio/gsm
GSM_CONFIGURE_OFF= --disable-libgsm

View file

@ -4,7 +4,7 @@
#
# $FreeBSD$
MPLAYER_SNAPSHOT_DATE= 2014-08-24
MPLAYER_SNAPSHOT_DATE= 2014-12-23
MPLAYER_PORT_VERSION= 1.1.r${MPLAYER_SNAPSHOT_DATE:S/-//g}
CATEGORIES?= multimedia audio
MASTER_SITES= ${MASTER_SITE_LOCAL}
@ -17,7 +17,8 @@ MAINTAINER?= riggs@FreeBSD.org
LICENSE= GPLv2
LIB_DEPENDS= libpng.so:${PORTSDIR}/graphics/png \
libfreetype.so:${PORTSDIR}/print/freetype2
libfreetype.so:${PORTSDIR}/print/freetype2 \
libdvdnav.so:${PORTSDIR}/multimedia/libdvdnav
BUILD_DEPENDS= ${LOCALBASE}/bin/yasm:${PORTSDIR}/devel/yasm
@ -40,6 +41,7 @@ CONFIGURE_ARGS= --cc="${CC}" \
--disable-ggiwmh \
--disable-liba52 \
--disable-libbs2b \
--disable-libdirac-lavc \
--disable-libilbc \
--disable-libnut \
--disable-libvorbis \

View file

@ -1,2 +1,2 @@
SHA256 (mplayer-1.1.20140824.tar.xz) = ea11e84bb3ea21904fccc2b661aee997e87d16c2d56659c1a439328c2d1d0745
SIZE (mplayer-1.1.20140824.tar.xz) = 11397312
SHA256 (mplayer-1.1.20141223.tar.xz) = 8d5ae2b77cdb6b86670a3741ea024b0ba8f7e4515221b224a10b690ee841d909
SIZE (mplayer-1.1.20141223.tar.xz) = 11408272

View file

@ -1,69 +0,0 @@
--- configure.orig 2014-08-23 15:59:32.000000000 +0200
+++ configure 2014-11-20 20:21:23.123454188 +0100
@@ -387,6 +387,7 @@
--enable-ass-internal enable internal SSA/ASS subtitle support [autodetect]
--disable-ass disable SSA/ASS subtitle support [autodetect]
--enable-rpath enable runtime linker path for extra libs [disabled]
+ --disable-gnutls disable GnuTLS [autodetect]
Codecs:
--enable-gif enable GIF support [autodetect]
@@ -851,6 +852,7 @@
_inet6=auto
_sctp=auto
_gethostbyname2=auto
+_gnutls=auto
_ftp=auto
_musepack=no
_vstream=auto
@@ -1360,6 +1362,8 @@
--disable-ass-internal) ass_internal=no ;;
--enable-rpath) _rpath=yes ;;
--disable-rpath) _rpath=no ;;
+ --enable-gnutls) _gnutls=yes ;;
+ --disable-gnutls) _gnutls=no ;;
--enable-fribidi) _fribidi=yes ;;
--disable-fribidi) _fribidi=no ;;
@@ -4322,6 +4326,24 @@
fi
+echocheck "GnuTLS"
+if test "$_gnutls" = auto ; then
+ _gnutls=no
+ if $_pkg_config --exists gnutls ; then
+ statement_check gnutls/gnutls.h 'gnutls_global_init()' $($_pkg_config --libs --cflags gnutls) &&
+ _gnutls=yes
+ fi
+fi
+if test "$_gnutls" = yes ; then
+ def_gnutls='#define CONFIG_GNUTLS 1'
+ libavprotocols="$libavprotocols HTTPS_PROTOCOL TLS_PROTOCOL"
+ extra_cflags="$extra_cflags $($_pkg_config --cflags gnutls)"
+ extra_ldflags="$extra_ldflags $($_pkg_config --libs gnutls)"
+else
+ def_gnutls='#define CONFIG_GNUTLS 0'
+fi
+echores "$_gnutls"
+
echocheck "Samba support (libsmbclient)"
if test "$_smb" = yes; then
extra_ldflags="$extra_ldflags -lsmbclient"
@@ -8714,6 +8736,7 @@
CONFIG_BZLIB = $bzlib
CONFIG_CRYSTALHD= $crystalhd
CONFIG_ENCODERS = yes
+CONFIG_GNUTLS = $_gnutls
CONFIG_GPL = yes
CONFIG_ICONV = $_iconv
CONFIG_MLIB = $_mlib
@@ -9249,7 +9272,7 @@
#define CONFIG_FASTDIV 0
#define CONFIG_FFSERVER 0
#define CONFIG_FTRAPV 0
-#define CONFIG_GNUTLS 0
+$def_gnutls
#define CONFIG_GPL 1
#define CONFIG_GRAY 0
#define CONFIG_LIBMODPLUG 0

View file

@ -1,26 +0,0 @@
--- configure.orig 2014-08-23 15:59:32.000000000 +0200
+++ configure 2014-09-11 18:37:11.383671007 +0200
@@ -3766,17 +3766,17 @@
echores "$aligned_malloc"
-echocheck "memalign()"
+echocheck "aligned_alloc()"
# XXX restrict to x86 ? extend to other CPUs/cacheline sizes ?
-def_memalign_hack='#define CONFIG_MEMALIGN_HACK 0'
+def_memalign='#define HAVE_MEMALIGN 0'
_memalign=no
-statement_check malloc.h 'memalign(64, sizeof(char))' && _memalign=yes
+statement_check stdlib.h 'aligned_alloc(32, 32*sizeof(char))' && _memalign=yes
if test "$_memalign" = yes ; then
- def_memalign='#define HAVE_MEMALIGN 1'
+ def_map_memalign='#define memalign(a, b) aligned_alloc(a, b)'
+ def_memalign_hack='#define CONFIG_MEMALIGN_HACK 0'
else
- def_memalign='#define HAVE_MEMALIGN 0'
def_map_memalign='#define memalign(a, b) malloc(b)'
- darwin || def_memalign_hack='#define CONFIG_MEMALIGN_HACK 1'
+ def_memalign_hack='#define CONFIG_MEMALIGN_HACK 1'
fi
echores "$_memalign"

View file

@ -1,12 +1,6 @@
--- configure.orig 2014-08-23 15:59:32.000000000 +0200
+++ configure 2014-11-01 11:03:04.283806013 +0100
@@ -644,12 +644,13 @@
_armv6t2=auto
_armvfp=auto
vfpv3=auto
+setend=auto
neon=auto
armthumb=auto
--- configure.orig 2014-12-17 22:02:44.000000000 +0100
+++ configure 2014-12-23 15:09:25.965346239 +0100
@@ -646,7 +646,7 @@
_iwmmxt=auto
_mtrr=auto
_altivec=auto
@ -15,7 +9,7 @@
_ranlib=ranlib
_windres=windres
_cc=cc
@@ -999,7 +1000,7 @@
@@ -988,7 +988,7 @@
ld_static=''
;;
--enable-profile)
@ -24,7 +18,7 @@
;;
--disable-profile)
_profile=
@@ -1474,7 +1475,6 @@
@@ -1459,7 +1459,6 @@
*)
echo "Unknown parameter: $ac_option"
@ -32,7 +26,7 @@
;;
esac
@@ -1727,7 +1727,7 @@
@@ -1712,7 +1711,7 @@
case "$1" in
x86_64|amd64|i[3-9]86*|i86pc|x86|x86pc|k5|k6|k6_2|k6_3|k6-2|k6-3|pentium*|athlon*|i586_i686|i586-i686) host_arch=i386 ;;
ia64) host_arch=ia64 ;;
@ -41,7 +35,7 @@
alpha) host_arch=alpha ;;
sun4*|sparc*) host_arch=sparc ;;
parisc*|hppa*|9000*) host_arch=hppa ;;
@@ -1843,7 +1843,11 @@
@@ -1834,7 +1833,11 @@
cflag_check "" || die "Compiler is not functioning correctly. Check your installation and custom CFLAGS $CFLAGS ."
echo "yes"
@ -54,9 +48,9 @@
if test -z "$_target" ; then
cat > $TMPC << EOF
@@ -3152,6 +3156,13 @@
@@ -3164,6 +3167,13 @@
fi
echores "$vfpv3"
echores "$setend"
+ echocheck "ARM setend"
+ if test $setend = "auto" ; then
@ -68,24 +62,31 @@
echocheck "softfloat ABI"
softfloat=yes
cpp_condition_check '' 'defined(__ARM_PCS_VFP) || (!defined(__ARM_PCS) && !defined(__SOFTFP__))' && softfloat=no
@@ -3190,7 +3201,7 @@
echores "$_iwmmxt"
fi
@@ -3798,17 +3808,17 @@
echores "$aligned_malloc"
-cpuexts_all='ALTIVEC XOP AVX AVX2 FMA3 FMA4 MMX MMX2 MMXEXT AMD3DNOW AMD3DNOWEXT SSE SSE2 SSE3 SSSE3 SSE4 SSE42 FAST_CMOV I686 FAST_CLZ ARMV5TE ARMV6 ARMV6T2 VFP VFPV3 NEON IWMMXT MMI VIS MVI'
+cpuexts_all='ALTIVEC XOP AVX AVX2 FMA3 FMA4 MMX MMX2 MMXEXT AMD3DNOW AMD3DNOWEXT SSE SSE2 SSE3 SSSE3 SSE4 SSE42 FAST_CMOV I686 FAST_CLZ ARMV5TE ARMV6 ARMV6T2 VFP VFPV3 SETEND NEON IWMMXT MMI VIS MVI'
test "$_altivec" = yes && cpuexts="ALTIVEC $cpuexts"
test "$_mmx" = yes && cpuexts="MMX $cpuexts"
test "$_mmxext" = yes && cpuexts="MMX2 $cpuexts"
@@ -3216,6 +3227,7 @@
test "$_armv6t2" = yes && cpuexts="ARMV6T2 $cpuexts"
test "$_armvfp" = yes && cpuexts="VFP $cpuexts"
test "$vfpv3" = yes && cpuexts="VFPV3 $cpuexts"
+test "$setend" = yes && cpuexts="SETEND $cpuexts"
test "$neon" = yes && cpuexts="NEON $cpuexts"
test "$_iwmmxt" = yes && cpuexts="IWMMXT $cpuexts"
test "$_vis" = yes && cpuexts="VIS $cpuexts"
@@ -3882,7 +3894,7 @@
-echocheck "memalign()"
+echocheck "aligned_alloc()"
# XXX restrict to x86 ? extend to other CPUs/cacheline sizes ?
-def_memalign_hack='#define CONFIG_MEMALIGN_HACK 0'
+def_memalign='#define HAVE_MEMALIGN 0'
_memalign=no
-statement_check malloc.h 'memalign(64, sizeof(char))' && _memalign=yes
+statement_check stdlib.h 'aligned_alloc(32, 32*sizeof(char))' && _memalign=yes
if test "$_memalign" = yes ; then
- def_memalign='#define HAVE_MEMALIGN 1'
+ def_map_memalign='#define memalign(a, b) aligned_alloc(a, b)'
+ def_memalign_hack='#define CONFIG_MEMALIGN_HACK 0'
else
- def_memalign='#define HAVE_MEMALIGN 0'
def_map_memalign='#define memalign(a, b) malloc(b)'
- darwin || def_memalign_hack='#define CONFIG_MEMALIGN_HACK 1'
+ def_memalign_hack='#define CONFIG_MEMALIGN_HACK 1'
fi
echores "$_memalign"
@@ -3914,7 +3924,7 @@
if linux ; then
THREAD_CFLAGS=-D_REENTRANT
elif freebsd || netbsd || openbsd || bsdos ; then
@ -94,7 +95,7 @@
fi
if test "$_pthreads" = auto ; then
cat > $TMPC << EOF
@@ -3892,7 +3904,7 @@
@@ -3924,7 +3934,7 @@
EOF
_pthreads=no
if ! hpux ; then
@ -103,7 +104,7 @@
# for crosscompilation, we cannot execute the program, be happy if we can link statically
cc_check $THREAD_CFLAGS $ld_tmp && (tmp_run || test "$ld_static") && ld_pthread="$ld_tmp" && _pthreads=yes && break
done
@@ -4044,7 +4056,7 @@
@@ -4076,7 +4086,7 @@
# NOTE: -L/usr/lib is a hack to avoid issues due to a
# broken libiconv that e.g. macports installs into /opt/local/lib
# which might get addded to the search path later by e.g. SDL
@ -112,7 +113,7 @@
cc_check $ld_tmp && extra_ldflags="$extra_ldflags $ld_tmp" &&
ld_iconv="$ld_tmp" && _iconv=yes && break
done
@@ -5996,7 +6008,7 @@
@@ -6046,7 +6056,7 @@
elif dragonfly ; then
default_cdrom_device="/dev/cd0"
elif freebsd ; then
@ -121,7 +122,7 @@
elif openbsd ; then
default_cdrom_device="/dev/rcd0c"
elif sunos ; then
@@ -6009,7 +6021,7 @@
@@ -6059,7 +6069,7 @@
default_cdrom_device="/dev/cdrom"
fi
@ -130,7 +131,7 @@
default_dvd_device=$default_cdrom_device
elif darwin ; then
default_dvd_device="/dev/rdiskN"
@@ -6609,7 +6621,7 @@
@@ -6566,7 +6576,7 @@
echocheck "libgsm"
if test "$_libgsm" = auto ; then
_libgsm=no
@ -139,7 +140,7 @@
fi
if test "$_libgsm" = yes ; then
def_libgsm='#define CONFIG_LIBGSM 1'
@@ -7094,6 +7106,16 @@
@@ -7051,6 +7061,16 @@
nolibrtmp=no
def_librtmp='#define CONFIG_LIBRTMP 1'
inputmodules="librtmp $inputmodules"
@ -156,7 +157,7 @@
else
nolibrtmp=yes
_librtmp=no
@@ -7493,7 +7515,7 @@
@@ -7450,7 +7470,7 @@
echocheck "mencoder"
if test "$_mencoder" = no ; then
# mpeg1video for vf_lavc, snow for vf_uspp / vf_mcdeint,
@ -165,7 +166,7 @@
fi
echores "$_mencoder"
@@ -8422,7 +8444,7 @@
@@ -8329,7 +8349,7 @@
EXESUF = $_exesuf
EXESUFS_ALL = .exe

View file

@ -0,0 +1,11 @@
--- ffmpeg/libavcodec/arm/fft_vfp.S.orig 2014-12-09 19:20:07.000000000 +0100
+++ ffmpeg/libavcodec/arm/fft_vfp.S 2014-12-24 15:48:09.494735677 +0100
@@ -33,7 +33,7 @@
movrel a2, (fft_tab_vfp - 8)
ldr pc, [a2, ip, lsl #2]
endfunc
-const fft_tab_vfp, relocate=1
+const fft_tab_vfp
.word fft4_vfp
.word fft8_vfp
.word X(ff_fft16_vfp) @ this one alone is exported