Fix "patch" target: replace files/patch-configure with inline patch,

because "patch-configure" conflicts with repcached-2.2-1.2.8.patch
This commit is contained in:
Sergey Skvortsov 2009-07-14 17:23:30 +00:00
parent 9852204f8b
commit b0b4c66baf
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=237797
2 changed files with 3 additions and 29 deletions

View file

@ -44,6 +44,9 @@ CONFIGURE_ARGS+= --enable-replication --disable-threads
CONFIGURE_ARGS+= --enable-threads
.endif
post-patch:
${REINPLACE_CMD} -E -e 's!=(= "xyes")!\1!' ${WRKSRC}/configure
post-configure:
@${REINPLACE_CMD} -e 's#doc/memcached.1##' ${WRKSRC}/Makefile

View file

@ -1,29 +0,0 @@
--- configure.orig 2009-04-11 04:03:08.000000000 -0300
+++ configure 2009-04-25 13:06:44.000000000 -0300
@@ -3807,7 +3807,7 @@
enableval=$enable_dtrace;
fi
-if test "x$enable_dtrace" == "xyes"; then
+if test "x$enable_dtrace" = "xyes"; then
# Extract the first word of "dtrace", so it can be a program name with args.
set dummy dtrace; ac_word=$2
{ $as_echo "$as_me:$LINENO: checking for $ac_word" >&5
@@ -3880,7 +3880,7 @@
enableval=$enable_64bit;
fi
-if test "x$enable_64bit" == "xyes"
+if test "x$enable_64bit" = "xyes"
then
org_cflags=$CFLAGS
CFLAGS=-m64
@@ -5842,7 +5842,7 @@
enableval=$enable_threads;
fi
-if test "x$enable_threads" == "xyes"; then
+if test "x$enable_threads" = "xyes"; then
{ echo "$as_me:$LINENO: checking for library containing pthread_create" >&5
$as_echo_n "checking for library containing pthread_create... " >&6; }
if test "${ac_cv_search_pthread_create+set}" = set; then