New port: x11-toolkits/color-widgets-qt5: Qt (C++) widgets to manage color inputs
This commit is contained in:
parent
1b4d096c39
commit
b0cb8f3a86
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=542888
6 changed files with 97 additions and 0 deletions
|
@ -9,6 +9,7 @@
|
|||
SUBDIR += blt
|
||||
SUBDIR += bwidget
|
||||
SUBDIR += c++-gtk-utils
|
||||
SUBDIR += color-widgets-qt5
|
||||
SUBDIR += ctk
|
||||
SUBDIR += fltk
|
||||
SUBDIR += fox14
|
||||
|
|
26
x11-toolkits/color-widgets-qt5/Makefile
Normal file
26
x11-toolkits/color-widgets-qt5/Makefile
Normal file
|
@ -0,0 +1,26 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= color-widgets
|
||||
DISTVERSION= 2.2.0
|
||||
CATEGORIES= x11-toolkits
|
||||
PKGNAMESUFFIX= ${SUFFIX}
|
||||
|
||||
MAINTAINER= yuri@FreeBSD.org
|
||||
COMMENT= Qt (C++) widgets to manage color inputs
|
||||
|
||||
LICENSE= LGPL3
|
||||
LICENSE_FILE= ${WRKSRC}/COPYING
|
||||
|
||||
USES= cmake compiler:c++11-lang pkgconfig qt:5
|
||||
USE_QT= core gui widgets buildtools_build qmake_build
|
||||
USE_LDCONFIG= yes
|
||||
|
||||
SUFFIX= -qt5
|
||||
|
||||
USE_GITLAB= yes
|
||||
GL_SITE= https://gitlab.com/
|
||||
GL_ACCOUNT= mattia.basaglia
|
||||
GL_PROJECT= Qt-Color-Widgets
|
||||
GL_COMMIT= f2eca13bbc836cec09daae02579f10d5e85e71e8
|
||||
|
||||
.include <bsd.port.mk>
|
3
x11-toolkits/color-widgets-qt5/distinfo
Normal file
3
x11-toolkits/color-widgets-qt5/distinfo
Normal file
|
@ -0,0 +1,3 @@
|
|||
TIMESTAMP = 1595442377
|
||||
SHA256 (mattia.basaglia-Qt-Color-Widgets-f2eca13bbc836cec09daae02579f10d5e85e71e8_GL0.tar.gz) = 05e44a567393081781111a9bf64f1867ac12118baa53302fb1d199d8e312ee46
|
||||
SIZE (mattia.basaglia-Qt-Color-Widgets-f2eca13bbc836cec09daae02579f10d5e85e71e8_GL0.tar.gz) = 174238
|
|
@ -0,0 +1,14 @@
|
|||
--- src/QtColorWidgets/gradient_editor.cpp.orig 2020-05-31 15:42:28 UTC
|
||||
+++ src/QtColorWidgets/gradient_editor.cpp
|
||||
@@ -221,7 +221,10 @@ void GradientEditor::mouseDoubleClickEvent(QMouseEvent
|
||||
qreal highlighted_pos = p->paint_pos(p->stops[p->highlighted], this);
|
||||
qreal mouse_pos = orientation() == Qt::Vertical ? ev->pos().y() : ev->pos().x();
|
||||
qreal tolerance = 4;
|
||||
- if ( std::abs(mouse_pos - highlighted_pos) <= tolerance )
|
||||
+ auto xfabs = [](qreal r) { // see https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=248190
|
||||
+ return r>=0 ? r : -r;
|
||||
+ };
|
||||
+ if ( xfabs(mouse_pos - highlighted_pos) <= tolerance )
|
||||
{
|
||||
p->dialog_selected = p->highlighted;
|
||||
p->color_dialog.setColor(p->stops[p->highlighted].second);
|
4
x11-toolkits/color-widgets-qt5/pkg-descr
Normal file
4
x11-toolkits/color-widgets-qt5/pkg-descr
Normal file
|
@ -0,0 +1,4 @@
|
|||
Qt-Color-Widgets is a color dialog that is more user-friendly than the default
|
||||
QColorDialog and several other color-related widgets.
|
||||
|
||||
WWW: https://gitlab.com/mattia.basaglia/Qt-Color-Widgets
|
49
x11-toolkits/color-widgets-qt5/pkg-plist
Normal file
49
x11-toolkits/color-widgets-qt5/pkg-plist
Normal file
|
@ -0,0 +1,49 @@
|
|||
include/QtColorWidgets/AbstractWidgetList
|
||||
include/QtColorWidgets/BoundColorSelector
|
||||
include/QtColorWidgets/ColorDelegate
|
||||
include/QtColorWidgets/ColorDialog
|
||||
include/QtColorWidgets/ColorListWidget
|
||||
include/QtColorWidgets/ColorPreview
|
||||
include/QtColorWidgets/ColorSelector
|
||||
include/QtColorWidgets/ColorWheel
|
||||
include/QtColorWidgets/GradientEditor
|
||||
include/QtColorWidgets/GradientListModel
|
||||
include/QtColorWidgets/GradientSlider
|
||||
include/QtColorWidgets/HarmonyColorWheel
|
||||
include/QtColorWidgets/HueSlider
|
||||
include/QtColorWidgets/QtColorWidgets_version.h
|
||||
include/QtColorWidgets/abstract_widget_list.hpp
|
||||
include/QtColorWidgets/bound_color_selector.hpp
|
||||
include/QtColorWidgets/color_2d_slider.hpp
|
||||
include/QtColorWidgets/color_delegate.hpp
|
||||
include/QtColorWidgets/color_dialog.hpp
|
||||
include/QtColorWidgets/color_line_edit.hpp
|
||||
include/QtColorWidgets/color_list_widget.hpp
|
||||
include/QtColorWidgets/color_names.hpp
|
||||
include/QtColorWidgets/color_palette.hpp
|
||||
include/QtColorWidgets/color_palette_model.hpp
|
||||
include/QtColorWidgets/color_palette_widget.hpp
|
||||
include/QtColorWidgets/color_preview.hpp
|
||||
include/QtColorWidgets/color_selector.hpp
|
||||
include/QtColorWidgets/color_utils.hpp
|
||||
include/QtColorWidgets/color_wheel.hpp
|
||||
include/QtColorWidgets/color_wheel_private.hpp
|
||||
include/QtColorWidgets/colorwidgets_global.hpp
|
||||
include/QtColorWidgets/gradient_delegate.hpp
|
||||
include/QtColorWidgets/gradient_editor.hpp
|
||||
include/QtColorWidgets/gradient_helper.hpp
|
||||
include/QtColorWidgets/gradient_list_model.hpp
|
||||
include/QtColorWidgets/gradient_slider.hpp
|
||||
include/QtColorWidgets/harmony_color_wheel.hpp
|
||||
include/QtColorWidgets/hue_slider.hpp
|
||||
include/QtColorWidgets/swatch.hpp
|
||||
lib/cmake/QtColorWidgets-Qt52/QtColorWidgets-Qt52-%%CMAKE_BUILD_TYPE%%.cmake
|
||||
lib/cmake/QtColorWidgets-Qt52/QtColorWidgets-Qt52.cmake
|
||||
lib/cmake/QtColorWidgets-Qt52/qtcolorwidgets-qt52-config-version.cmake
|
||||
lib/cmake/QtColorWidgets-Qt52/qtcolorwidgets-qt52-config.cmake
|
||||
lib/cmake/QtColorWidgets-Qt52/qtcolorwidgets-qt52-targets-%%CMAKE_BUILD_TYPE%%.cmake
|
||||
lib/cmake/QtColorWidgets-Qt52/qtcolorwidgets-qt52-targets.cmake
|
||||
lib/libQtColorWidgets-Qt52.so
|
||||
lib/libQtColorWidgets-Qt52.so.2
|
||||
lib/libQtColorWidgets-Qt52.so.2.2.0
|
||||
libdata/pkgconfig/QtColorWidgets-Qt52.pc
|
Loading…
Reference in a new issue