- Update to 2.8.0.4537
Release notes: http://codelite.org/forum/viewtopic.php?f=9&t=1169
This commit is contained in:
parent
178b094b17
commit
b0d9fa717d
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=264412
4 changed files with 21 additions and 43 deletions
|
@ -6,7 +6,7 @@
|
|||
#
|
||||
|
||||
PORTNAME= codelite
|
||||
DISTVERSION= 2.7.0.${SVN_REVISION}
|
||||
DISTVERSION= 2.8.0.${SVN_REVISION}
|
||||
CATEGORIES= editors
|
||||
MASTER_SITES= SF/${PORTNAME}/Releases/${PORTNAME}-${PORTVERSION:R:R}
|
||||
|
||||
|
@ -25,7 +25,7 @@ HAS_CONFIGURE= yes
|
|||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
SVN_REVISION= 4375
|
||||
SVN_REVISION= 4537
|
||||
|
||||
.if defined(WITH_CSCOPE)
|
||||
RUN_DEPENDS+= cscope:${PORTSDIR}/devel/cscope
|
||||
|
|
|
@ -1,3 +1,2 @@
|
|||
MD5 (codelite-2.7.0.4375.tar.gz) = 169427f810ee2dd09f8cf015da7153d5
|
||||
SHA256 (codelite-2.7.0.4375.tar.gz) = 38806e6321f6386880a04697352a7eb295d6a35a13b3fbd48293ccd9bc3cff67
|
||||
SIZE (codelite-2.7.0.4375.tar.gz) = 5919663
|
||||
SHA256 (codelite-2.8.0.4537.tar.gz) = f8a7c25a68ccba1f2f24c9b96ee997b59ba2700a1b331323d2d92831bfc3ef72
|
||||
SIZE (codelite-2.8.0.4537.tar.gz) = 6010439
|
||||
|
|
|
@ -1,38 +0,0 @@
|
|||
--- sdk/codelite_indexer/network/clindexerprotocol.cpp.orig 2010-09-15 11:53:03.000000000 +0000
|
||||
+++ sdk/codelite_indexer/network/clindexerprotocol.cpp 2010-09-15 11:54:50.000000000 +0000
|
||||
@@ -36,7 +36,7 @@
|
||||
}
|
||||
|
||||
if (actual_read != sizeof(buff_len)) {
|
||||
- fprintf(stderr, "ERROR: ReadReply: Protocol error: expected %u bytes, got %u. reason: %d\n",
|
||||
+ fprintf(stderr, "ERROR: ReadReply: Protocol error: expected %zu bytes, got %zu. reason: %d\n",
|
||||
sizeof(buff_len),
|
||||
actual_read,
|
||||
conn->getLastError());
|
||||
@@ -55,7 +55,7 @@
|
||||
size_t bytes_read(0);
|
||||
while (bytes_left > 0) {
|
||||
if ( !conn->read(data+bytes_read, bytes_left, &actual_read, 10000) ) {
|
||||
- fprintf(stderr, "ERROR: Protocol error: expected %u bytes, got %u\n", buff_len, actual_read);
|
||||
+ fprintf(stderr, "ERROR: Protocol error: expected %zu bytes, got %zu\n", buff_len, actual_read);
|
||||
return false;
|
||||
}
|
||||
bytes_left -= actual_read;
|
||||
@@ -78,7 +78,7 @@
|
||||
}
|
||||
|
||||
if (actual_read != sizeof(buff_len)) {
|
||||
- fprintf(stderr, "ERROR: Protocol error: expected %u bytes, got %u\n", sizeof(buff_len), actual_read);
|
||||
+ fprintf(stderr, "ERROR: Protocol error: expected %zu bytes, got %zu\n", sizeof(buff_len), actual_read);
|
||||
return false;
|
||||
}
|
||||
|
||||
@@ -92,7 +92,7 @@
|
||||
size_t bytes_read(0);
|
||||
while (bytes_left > 0) {
|
||||
if ( !conn->read(data+bytes_read, bytes_left, &actual_read, -1) ) {
|
||||
- fprintf(stderr, "ERROR: [%s] Protocol error: expected %u bytes, got %u\n", __PRETTY_FUNCTION__, buff_len, actual_read);
|
||||
+ fprintf(stderr, "ERROR: [%s] Protocol error: expected %zu bytes, got %zu\n", __PRETTY_FUNCTION__, buff_len, actual_read);
|
||||
return false;
|
||||
}
|
||||
bytes_left -= actual_read;
|
17
editors/codelite/files/patch-CodeLite_unixprocess_impl.cpp
Normal file
17
editors/codelite/files/patch-CodeLite_unixprocess_impl.cpp
Normal file
|
@ -0,0 +1,17 @@
|
|||
--- CodeLite/unixprocess_impl.cpp.orig 2010-11-11 11:14:08.000000000 +0000
|
||||
+++ CodeLite/unixprocess_impl.cpp 2010-11-11 11:14:57.000000000 +0000
|
||||
@@ -12,8 +12,14 @@
|
||||
#include <sys/wait.h>
|
||||
|
||||
#ifdef __WXGTK__
|
||||
+#ifdef __FreeBSD__
|
||||
+# include <sys/ioctl.h>
|
||||
+# include <termios.h>
|
||||
+# include <libutil.h>
|
||||
+#else
|
||||
# include <pty.h>
|
||||
# include <utmp.h>
|
||||
+#endif
|
||||
#else
|
||||
# include <util.h>
|
||||
#endif
|
Loading…
Reference in a new issue