x11/x3270: update to 4.0ga11

Various cleanups to the port, fix clang 11 build.
Take maintainer per PR 244138 comment #2.

Changelog for 4.0 series: https://x3270.miraheze.org/wiki/Release_Notes

Sponsored by:	BBOX.io
This commit is contained in:
Kevin Bowling 2020-08-28 21:12:56 +00:00
parent 4a3af9e39d
commit b0e4fc2267
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=546832
5 changed files with 46 additions and 19 deletions

View file

@ -2,19 +2,22 @@
# $FreeBSD$
PORTNAME= x3270
PORTVERSION= 3.6
PORTVERSION= 4.0
CATEGORIES= x11 net
MASTER_SITES= http://x3270.bgp.nu/download/03.06/
DISTFILES= suite3270-${PORTVERSION}ga8-src.tgz
MASTER_SITES= http://x3270.bgp.nu/download/04.00/
DISTFILES= suite3270-${PORTVERSION}ga11-src.tgz
MAINTAINER= ecrist@secure-computing.net
MAINTAINER= kbowling@FreeBSD.org
COMMENT= 3270 Terminal emulator
LICENSE= BSD3CLAUSE
BUILD_DEPENDS= bdftopcf:x11-fonts/bdftopcf \
mkfontscale:x11-fonts/mkfontscale \
tclsh:lang/tcl-wrapper
LIB_DEPENDS= libexpat.so:textproc/expat2
USES= cpe iconv fonts gmake readline tcl xorg
USES= cpe iconv fonts gmake readline shebangfix tcl xorg
USE_XORG= ice sm x11 xaw xext xmu xt xorgproto
# Conflict due to x3270if
@ -24,32 +27,28 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-fontdir=${FONTSDIR} \
--disable-dbcs \
--with-x=${LOCALBASE} \
ac_cv_search_libiconv=${ICONV_LIB}
CPPFLAGS+= -I${LOCALBASE}/include
LIBS+= -L${LOCALBASE}/lib
--enable-unix \
--enable-c3270
.if defined(WITHOUT_OPENSSL)
CONFIGURE_ARGS+= --disable-ssl
.else
USES+= ssl
.endif
MAKE_ARGS+= COMPRESSMANCMD="${DO_NADA}" \
INSTALL="${INSTALL}" INSTALLFLAGS="${COPY}" \
INSTPGMFLAGS="${STRIP} -m ${BINMODE}" \
INSTBINFLAGS="-m ${BINMODE}" \
INSTDATFLAGS="-m ${SHAREMODE}" \
INSTMANFLAGS="-m ${MANMODE}"
CPE_VENDOR= paul_mattes
WRKSRC= ${WRKDIR}/suite3270-${PORTVERSION}
#PORTDOCS= x3270/README x3270/README.dbcs
PORTEXAMPLES= *
OPTIONS_DEFINE= DOCS EXAMPLES
SHEBANG_FILES= x3270/x3270a.in
post-install:
.for m in x3270/x3270-script.man x3270/x3270.man s3270/x3270if.man
.for m in b3270/b3270.man c3270/c3270.man pr3287/pr3287.man s3270/s3270.man \
tcl3270/tcl3270.man x3270/x3270-script.man x3270/x3270.man \
x3270if/x3270if.man
@(cd ${WRKSRC} ; ${INSTALL_MAN} ${m} ${STAGEDIR}${MAN1PREFIX}/man/man1/)
.endfor
${INSTALL_MAN} ${WRKSRC}/c3270/ibm_hosts.man ${STAGEDIR}${MAN5PREFIX}/man/man5/

View file

@ -1,3 +1,3 @@
TIMESTAMP = 1581764930
SHA256 (suite3270-3.6ga8-src.tgz) = a174114ba42fd1644e39adc532d893da8c40692cf46fd5ef02bb83d5704c66bf
SIZE (suite3270-3.6ga8-src.tgz) = 3296047
TIMESTAMP = 1598505775
SHA256 (suite3270-4.0ga11-src.tgz) = 48cf5966e52439b829c9d074e209b351572e0083cf81eba855336908c2c77f6c
SIZE (suite3270-4.0ga11-src.tgz) = 3312781

View file

@ -0,0 +1,10 @@
--- Common/print_command.c.orig 2020-08-27 23:10:43 UTC
+++ Common/print_command.c
@@ -34,6 +34,7 @@
#include <errno.h>
#include <fcntl.h>
#include <assert.h>
+#include <sys/wait.h>
#include "popups.h"
#include "print_command.h"

View file

@ -0,0 +1,11 @@
--- x3270/Makefile.obj.in.orig 2020-08-28 17:21:58 UTC
+++ x3270/Makefile.obj.in
@@ -107,7 +107,7 @@ install:: x3270
install:: x3270a
[ -d $(DESTDIR)$(BINDIR) ] || \
mkdir -p $(DESTDIR)$(BINDIR)
- $(INSTALL_PROGRAM) x3270a $(DESTDIR)$(BINDIR)/x3270a
+ $(INSTALL) x3270a $(DESTDIR)$(BINDIR)/x3270a
install:: ibm_hosts
[ -d $(DESTDIR)$(LIBX3270DIR) ] || \
mkdir -p $(DESTDIR)$(LIBX3270DIR)

View file

@ -1,8 +1,10 @@
bin/b3270
bin/c3270
bin/pr3287
bin/s3270
bin/tcl3270
bin/x3270
bin/x3270a
bin/x3270if
etc/x3270/ibm_hosts
%%FONTSDIR%%/3270-12.pcf.gz
@ -23,6 +25,11 @@ etc/x3270/ibm_hosts
%%FONTSDIR%%/3270gt8.pcf.gz
%%FONTSDIR%%/3270h.pcf.gz
@comment %%FONTSDIR%%/fonts.dir
man/man1/b3270.man.gz
man/man1/c3270.man.gz
man/man1/pr3287.man.gz
man/man1/s3270.man.gz
man/man1/tcl3270.man.gz
man/man1/x3270-script.man.gz
man/man1/x3270.man.gz
man/man1/x3270if.man.gz