Commons Codec provides implementations of common encoders and decoders
such as Base64, Hex, various phonetic encodings, and URLs. WWW: http://jakarta.apache.org/commons/codec/
This commit is contained in:
parent
0861192de6
commit
b13995d003
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=147090
5 changed files with 76 additions and 0 deletions
|
@ -56,6 +56,7 @@
|
|||
SUBDIR += jakarta-bcel
|
||||
SUBDIR += jakarta-commons-beanutils
|
||||
SUBDIR += jakarta-commons-cli
|
||||
SUBDIR += jakarta-commons-codec
|
||||
SUBDIR += jakarta-commons-collections
|
||||
SUBDIR += jakarta-commons-dbcp
|
||||
SUBDIR += jakarta-commons-discovery
|
||||
|
|
47
java/jakarta-commons-codec/Makefile
Normal file
47
java/jakarta-commons-codec/Makefile
Normal file
|
@ -0,0 +1,47 @@
|
|||
# Ports collection makefile for: Jakarta Commons Codec
|
||||
# Date created: 2 November 2005
|
||||
# Whom: Alex Dupre <ale@FreeBSD.org>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= commons-codec
|
||||
PORTVERSION= 1.3
|
||||
CATEGORIES= java converters
|
||||
MASTER_SITES= ${MASTER_SITE_APACHE_JAKARTA}
|
||||
MASTER_SITE_SUBDIR= commons/codec/source
|
||||
PKGNAMEPREFIX= jakarta-
|
||||
DISTNAME= ${PORTNAME}-${PORTVERSION}-src
|
||||
|
||||
MAINTAINER= ale@FreeBSD.org
|
||||
COMMENT= An implementations of common encoders and decoders
|
||||
|
||||
USE_JAVA= yes
|
||||
JAVA_VERSION= 1.2+
|
||||
USE_ANT= yes
|
||||
|
||||
NO_WRKSUBDIR= yes
|
||||
ALL_TARGET= dist
|
||||
|
||||
PLIST_FILES= %%JAVAJARDIR%%/${PORTNAME}.jar
|
||||
|
||||
.if !defined(NOPORTDOCS)
|
||||
PORTDOCS= LICENSE.txt RELEASE-NOTES.txt api
|
||||
.endif
|
||||
|
||||
do-install:
|
||||
@${ECHO_MSG} -n ">> Installing JAR file as ${JAVAJARDIR}/${PORTNAME}.jar..."
|
||||
@${INSTALL_DATA} ${WRKSRC}/dist/${PORTNAME}-${PORTVERSION}.jar \
|
||||
${JAVAJARDIR}/${PORTNAME}.jar
|
||||
@${ECHO_MSG} " [DONE]"
|
||||
.if !defined(NOPORTDOCS)
|
||||
@${ECHO_MSG} -n ">> Installing documentation..."
|
||||
@${MKDIR} ${DOCSDIR}
|
||||
@cd ${WRKSRC}/dist/docs && ${FIND} api \
|
||||
| ${CPIO} -pdmu -R ${SHAREOWN}:${SHAREGRP} ${DOCSDIR} > /dev/null 2>&1
|
||||
@${INSTALL_DATA} ${WRKSRC}/dist/LICENSE.txt ${WRKSRC}/dist/RELEASE-NOTES.txt \
|
||||
${DOCSDIR}/
|
||||
@${ECHO_MSG} " [DONE]"
|
||||
.endif
|
||||
|
||||
.include <bsd.port.mk>
|
2
java/jakarta-commons-codec/distinfo
Normal file
2
java/jakarta-commons-codec/distinfo
Normal file
|
@ -0,0 +1,2 @@
|
|||
MD5 (commons-codec-1.3-src.tar.gz) = ac19a5dc22b1293b39d0445ad08c4ce7
|
||||
SIZE (commons-codec-1.3-src.tar.gz) = 88242
|
19
java/jakarta-commons-codec/files/patch-build.xml
Normal file
19
java/jakarta-commons-codec/files/patch-build.xml
Normal file
|
@ -0,0 +1,19 @@
|
|||
--- build.xml.orig Mon May 24 01:30:33 2004
|
||||
+++ build.xml Thu Nov 3 07:59:01 2005
|
||||
@@ -90,14 +90,14 @@
|
||||
</target>
|
||||
<target name="dist" depends="compile,javadoc" description="Create binary distribution">
|
||||
<mkdir dir="${dist.home}"/>
|
||||
- <copy file="../LICENSE" todir="${dist.home}"/>
|
||||
+ <copy file="${basedir}/LICENSE.txt" todir="${dist.home}"/>
|
||||
<copy file="${basedir}/RELEASE-NOTES.txt" todir="${dist.home}"/>
|
||||
<antcall target="jar"/>
|
||||
</target>
|
||||
<target name="jar" depends="compile" description="Create jar">
|
||||
<mkdir dir="${dist.home}"/>
|
||||
<mkdir dir="${build.home}/classes/META-INF"/>
|
||||
- <copy file="../LICENSE" tofile="${build.home}/classes/META-INF/LICENSE.txt"/>
|
||||
+ <copy file="${basedir}/LICENSE.txt" tofile="${build.home}/classes/META-INF/LICENSE.txt"/>
|
||||
<jar jarfile="${dist.home}/${final.name}.jar" basedir="${build.home}/classes" manifest="${build.home}/conf/MANIFEST.MF"/>
|
||||
</target>
|
||||
<target name="install-jar" depends="jar" description="--> Installs jar file in ${lib.repo}">
|
7
java/jakarta-commons-codec/pkg-descr
Normal file
7
java/jakarta-commons-codec/pkg-descr
Normal file
|
@ -0,0 +1,7 @@
|
|||
Commons Codec provides implementations of common encoders and decoders
|
||||
such as Base64, Hex, various phonetic encodings, and URLs.
|
||||
|
||||
WWW: http://jakarta.apache.org/commons/codec/
|
||||
|
||||
- Alex Dupre
|
||||
ale@FreeBSD.org
|
Loading…
Reference in a new issue