lang/rust: Fix link issue and build failure
[1] Linking fails with missing reference to __morestack symbol [2] gpy fails with error about missing sem implementation PR: 189357 [1] PR: 191927 [2] Submitted by: bertrand.augereau (gmail) [1] Submitted by: maintainer: mitsuruike (gmail) [2]
This commit is contained in:
parent
e431088631
commit
b13d6b9703
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=363270
2 changed files with 15 additions and 0 deletions
|
@ -3,6 +3,7 @@
|
|||
|
||||
PORTNAME= rust
|
||||
PORTVERSION= 0.11.0
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= lang
|
||||
MASTER_SITES= http://static.rust-lang.org/dist/:src \
|
||||
http://static.rust-lang.org/stage0-snapshots/:bootstrap
|
||||
|
@ -59,5 +60,7 @@ post-install:
|
|||
@${RM} ${STAGEDIR}${PREFIX}/lib/rustlib/manifest
|
||||
@${STRIP_CMD} `${GREP} -v -e '^@dirrm' -e '^man' -e 'rlib$$' \
|
||||
${PLIST} | ${SED} 's:^:${STAGEDIR}${PREFIX}/:'`
|
||||
@${STRIP_CMD} `${GREP} -v -e '^@dirrm' -e '^man' -e 'rlib$$' \
|
||||
-e '\.a$$' ${PLIST} | ${SED} 's:^:${STAGEDIR}${PREFIX}/:g'`
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
|
|
12
lang/rust/files/patch-src__libuv__gyp_uv.py
Normal file
12
lang/rust/files/patch-src__libuv__gyp_uv.py
Normal file
|
@ -0,0 +1,12 @@
|
|||
--- ./src/libuv/gyp_uv.py.orig 2014-06-28 04:53:11.000000000 +0900
|
||||
+++ ./src/libuv/gyp_uv.py 2014-07-17 12:32:13.000000000 +0900
|
||||
@@ -96,6 +96,9 @@
|
||||
|
||||
if sys.platform == 'darwin' and '-DOS=android' in sys.argv[1:]:
|
||||
sys.platform='linux'
|
||||
+
|
||||
+ if sys.platform.startswith('freebsd'):
|
||||
+ args.append('--no-parallel')
|
||||
|
||||
gyp_args = list(args)
|
||||
print gyp_args
|
Loading…
Reference in a new issue