Add a new `WITH_THREADS' option to build perl with support for threads and
fix threaded build on 5.x. Approved by: maintainer
This commit is contained in:
parent
40b8494325
commit
b169298681
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=77916
10 changed files with 100 additions and 10 deletions
|
@ -51,6 +51,13 @@ CONFIGURE_ARGS+= -Dusemymalloc=y
|
|||
CONFIGURE_ARGS+= -Dusemymalloc=n
|
||||
.endif
|
||||
|
||||
.if defined(WITH_THREADS)
|
||||
CONFIGURE_ARGS+= -Dusethreads=y
|
||||
PKGNAMESUFFIX= -threaded
|
||||
.else
|
||||
CONFIGURE_ARGS+= -Dusethreads=n
|
||||
.endif
|
||||
|
||||
INCLUDEDIR= /usr/include
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
|
|
@ -1,7 +1,8 @@
|
|||
|
||||
$FreeBSD$
|
||||
|
||||
--- hints/freebsd.sh.orig Sat Jun 1 19:03:12 2002
|
||||
+++ hints/freebsd.sh Sat Jul 20 22:51:05 2002
|
||||
--- hints/freebsd.sh.orig Sat Jun 1 20:03:12 2002
|
||||
+++ hints/freebsd.sh Tue Apr 1 14:17:18 2003
|
||||
@@ -98,6 +98,13 @@
|
||||
;;
|
||||
esac
|
||||
|
@ -25,3 +26,13 @@ $FreeBSD$
|
|||
;;
|
||||
esac
|
||||
|
||||
@@ -223,6 +230,9 @@
|
||||
4.*) # 4.x has gethostbyaddr_r but it is
|
||||
# "Temporary function, not threadsafe"...
|
||||
d_gethostbyaddr_r="undef"
|
||||
+ d_gethostbyaddr_r_proto="undef"
|
||||
+ ;;
|
||||
+ 5.*) d_gethostbyaddr_r="undef"
|
||||
d_gethostbyaddr_r_proto="undef"
|
||||
;;
|
||||
esac
|
||||
|
|
|
@ -51,6 +51,13 @@ CONFIGURE_ARGS+= -Dusemymalloc=y
|
|||
CONFIGURE_ARGS+= -Dusemymalloc=n
|
||||
.endif
|
||||
|
||||
.if defined(WITH_THREADS)
|
||||
CONFIGURE_ARGS+= -Dusethreads=y
|
||||
PKGNAMESUFFIX= -threaded
|
||||
.else
|
||||
CONFIGURE_ARGS+= -Dusethreads=n
|
||||
.endif
|
||||
|
||||
INCLUDEDIR= /usr/include
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
|
|
@ -1,7 +1,8 @@
|
|||
|
||||
$FreeBSD$
|
||||
|
||||
--- hints/freebsd.sh.orig Sat Jun 1 19:03:12 2002
|
||||
+++ hints/freebsd.sh Sat Jul 20 22:51:05 2002
|
||||
--- hints/freebsd.sh.orig Sat Jun 1 20:03:12 2002
|
||||
+++ hints/freebsd.sh Tue Apr 1 14:17:18 2003
|
||||
@@ -98,6 +98,13 @@
|
||||
;;
|
||||
esac
|
||||
|
@ -25,3 +26,13 @@ $FreeBSD$
|
|||
;;
|
||||
esac
|
||||
|
||||
@@ -223,6 +230,9 @@
|
||||
4.*) # 4.x has gethostbyaddr_r but it is
|
||||
# "Temporary function, not threadsafe"...
|
||||
d_gethostbyaddr_r="undef"
|
||||
+ d_gethostbyaddr_r_proto="undef"
|
||||
+ ;;
|
||||
+ 5.*) d_gethostbyaddr_r="undef"
|
||||
d_gethostbyaddr_r_proto="undef"
|
||||
;;
|
||||
esac
|
||||
|
|
|
@ -51,6 +51,13 @@ CONFIGURE_ARGS+= -Dusemymalloc=y
|
|||
CONFIGURE_ARGS+= -Dusemymalloc=n
|
||||
.endif
|
||||
|
||||
.if defined(WITH_THREADS)
|
||||
CONFIGURE_ARGS+= -Dusethreads=y
|
||||
PKGNAMESUFFIX= -threaded
|
||||
.else
|
||||
CONFIGURE_ARGS+= -Dusethreads=n
|
||||
.endif
|
||||
|
||||
INCLUDEDIR= /usr/include
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
|
|
@ -1,7 +1,8 @@
|
|||
|
||||
$FreeBSD$
|
||||
|
||||
--- hints/freebsd.sh.orig Sat Jun 1 19:03:12 2002
|
||||
+++ hints/freebsd.sh Sat Jul 20 22:51:05 2002
|
||||
--- hints/freebsd.sh.orig Sat Jun 1 20:03:12 2002
|
||||
+++ hints/freebsd.sh Tue Apr 1 14:17:18 2003
|
||||
@@ -98,6 +98,13 @@
|
||||
;;
|
||||
esac
|
||||
|
@ -25,3 +26,13 @@ $FreeBSD$
|
|||
;;
|
||||
esac
|
||||
|
||||
@@ -223,6 +230,9 @@
|
||||
4.*) # 4.x has gethostbyaddr_r but it is
|
||||
# "Temporary function, not threadsafe"...
|
||||
d_gethostbyaddr_r="undef"
|
||||
+ d_gethostbyaddr_r_proto="undef"
|
||||
+ ;;
|
||||
+ 5.*) d_gethostbyaddr_r="undef"
|
||||
d_gethostbyaddr_r_proto="undef"
|
||||
;;
|
||||
esac
|
||||
|
|
|
@ -51,6 +51,13 @@ CONFIGURE_ARGS+= -Dusemymalloc=y
|
|||
CONFIGURE_ARGS+= -Dusemymalloc=n
|
||||
.endif
|
||||
|
||||
.if defined(WITH_THREADS)
|
||||
CONFIGURE_ARGS+= -Dusethreads=y
|
||||
PKGNAMESUFFIX= -threaded
|
||||
.else
|
||||
CONFIGURE_ARGS+= -Dusethreads=n
|
||||
.endif
|
||||
|
||||
INCLUDEDIR= /usr/include
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
|
|
@ -1,7 +1,8 @@
|
|||
|
||||
$FreeBSD$
|
||||
|
||||
--- hints/freebsd.sh.orig Sat Jun 1 19:03:12 2002
|
||||
+++ hints/freebsd.sh Sat Jul 20 22:51:05 2002
|
||||
--- hints/freebsd.sh.orig Sat Jun 1 20:03:12 2002
|
||||
+++ hints/freebsd.sh Tue Apr 1 14:17:18 2003
|
||||
@@ -98,6 +98,13 @@
|
||||
;;
|
||||
esac
|
||||
|
@ -25,3 +26,13 @@ $FreeBSD$
|
|||
;;
|
||||
esac
|
||||
|
||||
@@ -223,6 +230,9 @@
|
||||
4.*) # 4.x has gethostbyaddr_r but it is
|
||||
# "Temporary function, not threadsafe"...
|
||||
d_gethostbyaddr_r="undef"
|
||||
+ d_gethostbyaddr_r_proto="undef"
|
||||
+ ;;
|
||||
+ 5.*) d_gethostbyaddr_r="undef"
|
||||
d_gethostbyaddr_r_proto="undef"
|
||||
;;
|
||||
esac
|
||||
|
|
|
@ -51,6 +51,13 @@ CONFIGURE_ARGS+= -Dusemymalloc=y
|
|||
CONFIGURE_ARGS+= -Dusemymalloc=n
|
||||
.endif
|
||||
|
||||
.if defined(WITH_THREADS)
|
||||
CONFIGURE_ARGS+= -Dusethreads=y
|
||||
PKGNAMESUFFIX= -threaded
|
||||
.else
|
||||
CONFIGURE_ARGS+= -Dusethreads=n
|
||||
.endif
|
||||
|
||||
INCLUDEDIR= /usr/include
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
|
|
@ -1,7 +1,8 @@
|
|||
|
||||
$FreeBSD$
|
||||
|
||||
--- hints/freebsd.sh.orig Sat Jun 1 19:03:12 2002
|
||||
+++ hints/freebsd.sh Sat Jul 20 22:51:05 2002
|
||||
--- hints/freebsd.sh.orig Sat Jun 1 20:03:12 2002
|
||||
+++ hints/freebsd.sh Tue Apr 1 14:17:18 2003
|
||||
@@ -98,6 +98,13 @@
|
||||
;;
|
||||
esac
|
||||
|
@ -25,3 +26,13 @@ $FreeBSD$
|
|||
;;
|
||||
esac
|
||||
|
||||
@@ -223,6 +230,9 @@
|
||||
4.*) # 4.x has gethostbyaddr_r but it is
|
||||
# "Temporary function, not threadsafe"...
|
||||
d_gethostbyaddr_r="undef"
|
||||
+ d_gethostbyaddr_r_proto="undef"
|
||||
+ ;;
|
||||
+ 5.*) d_gethostbyaddr_r="undef"
|
||||
d_gethostbyaddr_r_proto="undef"
|
||||
;;
|
||||
esac
|
||||
|
|
Loading…
Reference in a new issue