New port: www/jonah - a portal and content collection system

Jonah is the Horde content and display manager.

	It has been designed to manage a portal-like site using RDF,
	RSS and Syndicated XML backend content.

PR:		ports/33312
Submitted by:	Thierry Thomas <thierry@pompo.net>
This commit is contained in:
Edwin Groothuis 2003-01-17 04:09:01 +00:00
parent 4292a42f1e
commit b17ecb3c12
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=73303
9 changed files with 248 additions and 0 deletions

View file

@ -125,6 +125,7 @@
SUBDIR += jdresolve
SUBDIR += jesred
SUBDIR += jetty
SUBDIR += jonah
SUBDIR += junkbuster
SUBDIR += kannel
SUBDIR += knowledgekit

111
www/jonah/Makefile Normal file
View file

@ -0,0 +1,111 @@
# Ports collection makefile for: Jonah
# Date created: Mon Dec 17, 2001
# Whom: Thierry Thomas <thierry@pompo.net>
#
# $FreeBSD$
#
PORTNAME= jonah
PORTVERSION= 0.0.3.020629
CATEGORIES= www
MASTER_SITES= http://pompo.net/horde/jonah/
MAINTAINER= thierry@pompo.net
WRKSRC= ${WRKDIR}/${PORTNAME}
RUN_DEPENDS= ${LOCALBASE}/www/horde/index.php:${PORTSDIR}/www/horde2 \
${LOCALBASE}/bin/php:${PORTSDIR}/lang/php4
IS_INTERACTIVE= 'need to build php4 with XML support.'
NO_BUILD= yes
USE_REINPLACE= yes
REINPLACE_ARGS= -i.beforeJonah
DOCS= COPYING README docs/CHANGES docs/CREDITS docs/HELP \
docs/INSTALL
CONFFILE= channels.php conf.php html.php
SUB_DIRS= config graphics lib scripts templates
LHORDEDIR?= www/horde
LJONAHDIR?= ${LHORDEDIR}/jonah
RSS_HTML?= /var/jonah
PHPSADIR?= ${LOCALBASE}/etc/php.standalone
PLIST_SUB= HORDEDIR=${LHORDEDIR} JONAHDIR=${LJONAHDIR}
HORDEDIR= ${PREFIX}/${LHORDEDIR}
JONAHDIR= ${PREFIX}/${LJONAHDIR}
CONFDIR= ${JONAHDIR}/config
HORDE_INC= ${LOCALBASE}/etc/horde
HORDE_CNF= ${HORDEDIR}/config/horde.php
PHPSA_INI= ${PHPSADIR}/php.ini
pre-install:
@if ! ${LDCONFIG} -r | ${GREP} -q -e "expat.2"; then \
${ECHO_MSG} "" ; \
${ECHO_MSG} "Please configure PHP with XML support." ; \
${ECHO_MSG} "" ; \
${FALSE} ; \
fi
do-install:
@${MKDIR} ${JONAHDIR}
.for REP in ${SUB_DIRS}
@${CP} -Rp ${WRKSRC}/${REP} ${JONAHDIR}
.endfor
@${CP} -p ${WRKSRC}/*.php ${JONAHDIR}
@${MV} ${JONAHDIR}/scripts/cli-backend.php ${PREFIX}/bin
.for FILE in ${CONFFILE}
@if [ ! -f ${CONFDIR}/${FILE} ]; then \
${CP} ${CONFDIR}/${FILE}.dist ${CONFDIR}/${FILE} ; \
fi
.endfor
@${REINPLACE_CMD} -e "s:/var/jonah:${RSS_HTML}:" ${CONFDIR}/conf.php
@${RM} ${CONFDIR}/conf.php.beforeJonah
@${REINPLACE_CMD} -e "s:%%JONAHDIR%%:'${JONAHDIR}':" \
${PREFIX}/bin/cli-backend.php
@${RM} ${PREFIX}/bin/cli-backend.php.beforeJonah
@${CHOWN} -R www:www ${JONAHDIR}
@${CHMOD} -R o-rwx ${CONFDIR}
@${CP} -p ${FILESDIR}/httpd.conf.jonah ${HORDE_INC}
@${REINPLACE_CMD} -e "s:/home/httpd/html/horde/jonah:${JONAHDIR}:g" \
${HORDE_INC}/httpd.conf.jonah
@${RM} ${HORDE_INC}/httpd.conf.jonah.beforeJonah
@${REINPLACE_CMD} -e "s://UNCOMMENTWHENINSTJONAH::" \
${HORDEDIR}/config/registry.php
@${CP} -p ${HORDEDIR}/config/registry.php \
${HORDEDIR}/config/registry.php.afterJonah
@${MKDIR} ${RSS_HTML}/html ${RSS_HTML}/rss
@${CHOWN} -R root:www ${RSS_HTML}
@if ${GREP} -q -e "conf\['auth'\]\['admins'\] = array()" ${HORDE_CNF} ; then \
${ECHO_MSG} "===> Defining admin in ${HORDE_CNF}" ; \
${REINPLACE_CMD} -e "s:admins'] = array():admins'] = array('admin'):" ${HORDE_CNF} ; \
${CP} -p ${HORDE_CNF} ${HORDE_CNF}.afterJonah ; \
fi
@if [ ! -f ${PHPSA_INI} ]; then \
${ECHO_MSG} "===> Creating ${PHPSA_INI} for PHP standalone" ; \
${CP} ${PHPSA_INI}-dist ${PHPSA_INI} ; \
fi
@if ! ${GREP} -q -e '^include_path' ${PHPSA_INI} ; then \
${ECHO_MSG} "===> Configuring ${PHPSA_INI} for PHP standalone" ; \
${REINPLACE_CMD} -e 's!;include_path = ".:/php/includes"!include_path = "${LOCALBASE}/include/php:.:${LOCALBASE}/lib/php"!' ${PHPSA_INI} ; \
${CP} -p ${PHPSA_INI} ${PHPSA_INI}.afterJonah ; \
fi
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
.for FILE in ${DOCS}
@${INSTALL_DATA} ${WRKSRC}/${FILE} ${DOCSDIR}
.endfor
@${ECHO_MSG} "===> Documentation installed in ${DOCSDIR}."
.endif
post-install:
@${ECHO_MSG}
@${CAT} ${PKGMESSAGE} | \
${SED} -e "s:%%JONAHDIR%%:${JONAHDIR}:g;s:%%PORTSDIR%%:${PORTSDIR}:g;s:%%CONFDIR%%:${CONFDIR}:g;s:%%PREFIX%%:${PREFIX}:"
@${ECHO_MSG}
.include <bsd.port.mk>

1
www/jonah/distinfo Normal file
View file

@ -0,0 +1 @@
MD5 (jonah-0.0.3.020629.tar.gz) = e33ecae03344b4e84cbc57c7715e1216

View file

@ -0,0 +1,23 @@
# This is included in Apache's httpd.conf for Jonah
#
# For security, don't serve pages from the Jonah configuration and
# library directories.
#
<Directory "/home/httpd/html/horde/jonah/config">
order deny,allow
deny from all
</Directory>
<Directory "/home/httpd/html/horde/jonah/lib">
order deny,allow
deny from all
</Directory>
<Directory "/home/httpd/html/horde/jonah/scripts">
order deny,allow
deny from all
</Directory>
<Directory "/home/httpd/html/horde/jonah/templates">
order deny,allow
deny from all
</Directory>
# End of Jonah configuration ================

View file

@ -0,0 +1,11 @@
--- scripts/cli-backend.php.orig Wed Apr 17 20:00:46 2002
+++ scripts/cli-backend.php Sat Jun 29 17:04:47 2002
@@ -3,7 +3,7 @@
// $Horde: jonah/scripts/cli-backend.php,v 1.5 2002/04/17 18:00:46 jan Exp $
$self_contained_auth = true;
-define('JONAH_BASE', dirname(__FILE__) . '/..');
+define('JONAH_BASE', %%JONAHDIR%%);
// This shouldn't be callable via the web.
if (isset($_SERVER['SCRIPT_NAME']) ||

1
www/jonah/pkg-comment Normal file
View file

@ -0,0 +1 @@
Jonah is a portal and content collection system

6
www/jonah/pkg-descr Normal file
View file

@ -0,0 +1,6 @@
Jonah is the Horde content and display manager.
It has been designed to manage a portal-like site using RDF, RSS and
Syndicated XML backend content. It is still in the development stage.
WWW: http://horde.org/jonah/

23
www/jonah/pkg-message Normal file
View file

@ -0,0 +1,23 @@
************************************************************************
Jonah has been installed in %%JONAHDIR%% with your blank
configuration files.
Horde must be configured; if not, see:
- %%PORTSDIR%%/www/horde2/pkg-message
Then, you may have to tune the configuration files located in
%%CONFDIR%%/, specially the files conf.php.
Check in %%PREFIX%%/www/horde/config/horde.php that 'admin' is
treated as an administrator.
Finally, beeing root, you must run %%PREFIX%%/bin/cli-backend.php
to fetch the headlines. You might add an entry in your crontab to
refresh them (hourly, for example).
Then go to <URL:http://localhost/horde/>; and click on the newspaper
to see the channels.
There is a test script at <URL:http://localhost/horde/jonah/test.php>;.
To protect your configuration files, you have to restart Apache.
************************************************************************

71
www/jonah/pkg-plist Normal file
View file

@ -0,0 +1,71 @@
%%PORTDOCS%%share/doc/jonah/CHANGES
%%PORTDOCS%%share/doc/jonah/COPYING
%%PORTDOCS%%share/doc/jonah/CREDITS
%%PORTDOCS%%share/doc/jonah/HELP
%%PORTDOCS%%share/doc/jonah/INSTALL
%%PORTDOCS%%share/doc/jonah/README
%%JONAHDIR%%/backend.php
%%JONAHDIR%%/channels.php
%%JONAHDIR%%/config/channels.php
%%JONAHDIR%%/config/channels.php.dist
%%JONAHDIR%%/config/conf.php
%%JONAHDIR%%/config/conf.php.dist
%%JONAHDIR%%/config/html.php
%%JONAHDIR%%/config/html.php.dist
%%JONAHDIR%%/graphics/channels/DominoPowerRSSLogo.gif
%%JONAHDIR%%/graphics/channels/OSOlogotext.gif
%%JONAHDIR%%/graphics/channels/PythonPowered.gif
%%JONAHDIR%%/graphics/channels/WindowsCEPowerRSSLogo.gif
%%JONAHDIR%%/graphics/channels/button.jpg
%%JONAHDIR%%/graphics/channels/fm.mini.jpg
%%JONAHDIR%%/graphics/channels/gildot.gif
%%JONAHDIR%%/graphics/channels/gnome-logo-icon.gif
%%JONAHDIR%%/graphics/channels/kdedotnews_88x31.gif
%%JONAHDIR%%/graphics/channels/linuxplanet.gif
%%JONAHDIR%%/graphics/channels/mail-archive.gif
%%JONAHDIR%%/graphics/channels/moreover.gif
%%JONAHDIR%%/graphics/channels/motleyfool.gif
%%JONAHDIR%%/graphics/channels/mynetscape88.gif
%%JONAHDIR%%/graphics/channels/netcenterb.gif
%%JONAHDIR%%/graphics/channels/perl-news-small.gif
%%JONAHDIR%%/graphics/channels/salon.gif
%%JONAHDIR%%/graphics/channels/securityfocus.gif
%%JONAHDIR%%/graphics/channels/segvnowsjr.gif
%%JONAHDIR%%/graphics/channels/slashdotlg.gif
%%JONAHDIR%%/graphics/channels/userfriendly.gif
%%JONAHDIR%%/graphics/channels/wide_open_logo_sm.gif
%%JONAHDIR%%/graphics/jonah.gif
%%JONAHDIR%%/graphics/jonah_whale.gif
%%JONAHDIR%%/index.php
%%JONAHDIR%%/lib/Headlines.php
%%JONAHDIR%%/lib/base.php
%%JONAHDIR%%/lib/htmlgen.php
%%JONAHDIR%%/lib/version.php
%%JONAHDIR%%/scripts/cli-backend.php.orig
%%JONAHDIR%%/scripts/cli-backend.sh
%%JONAHDIR%%/templates/backend/menu.inc
%%JONAHDIR%%/templates/channels/bottom.inc
%%JONAHDIR%%/templates/channels/channels.inc
%%JONAHDIR%%/templates/channels/header.inc
%%JONAHDIR%%/templates/channels/top.inc
%%JONAHDIR%%/templates/common-footer.inc
%%JONAHDIR%%/templates/common-header.inc
%%JONAHDIR%%/templates/index/css.inc
%%JONAHDIR%%/templates/index/notconfigured.inc
%%JONAHDIR%%/test.php
bin/cli-backend.php
etc/horde/httpd.conf.jonah
@dirrm %%JONAHDIR%%/config
@dirrm %%JONAHDIR%%/graphics/channels
@dirrm %%JONAHDIR%%/graphics
@dirrm %%JONAHDIR%%/lib
@dirrm %%JONAHDIR%%/scripts
@dirrm %%JONAHDIR%%/templates/backend
@dirrm %%JONAHDIR%%/templates/channels
@dirrm %%JONAHDIR%%/templates/index
@dirrm %%JONAHDIR%%/templates
@dirrm %%JONAHDIR%%
%%PORTDOCS%%@dirrm share/doc/jonah
@unexec if cmp -s %D/www/horde/config/registry.php %D/www/horde/config/registry.php.afterJonah; then rm -f %D/www/horde/config/registry.php.afterJonah; mv %D/www/horde/config/registry.php.beforeJonah %D/www/horde/config/registry.php; fi
@unexec if cmp -s %D/www/horde/config/horde.php %D/www/horde/config/horde.php.afterJonah; then rm -f %D/www/horde/config/horde.php.afterJonah; mv %D/www/horde/config/horde.php.beforeJonah %D/www/horde/config/horde.php; fi
@unexec if cmp -s %D/etc/php.standalone/php.ini %D/etc/php.standalone/php.ini.afterJonah; then rm -f %D/etc/php.standalone/php.ini.afterJonah; mv %D/etc/php.standalone/php.ini.beforeJonah %D/etc/php.standalone/php.ini; fi