- Update to 0.1
PR: 126029 Submitted by: Alexander Logvinov <ports@logvinov.com>
This commit is contained in:
parent
b0425286eb
commit
b1c8dca0dc
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=218757
5 changed files with 27 additions and 62 deletions
|
@ -5,32 +5,22 @@
|
|||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= synce-gnomevfs
|
||||
PORTVERSION= 0.9.0
|
||||
PORTREVISION= 6
|
||||
PORTNAME= synce-gvfs
|
||||
PORTVERSION= 0.1
|
||||
CATEGORIES= palm
|
||||
MASTER_SITES= SF/synce
|
||||
|
||||
MAINTAINER= ports@logvinov.com
|
||||
COMMENT= Gnome VFS module for WinCE devices
|
||||
COMMENT= GVFS module for access Windows Mobile devices
|
||||
|
||||
LIB_DEPENDS= rapi.2:${PORTSDIR}/palm/synce-librapi2
|
||||
|
||||
USE_AUTOTOOLS= libtool:15
|
||||
USE_GNOME= gnomeprefix gnometarget gnomevfs2
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ARGS+= --with-librapi=${LOCALBASE} \
|
||||
--with-libsynce=${LOCALBASE}
|
||||
USE_GMAKE= yes
|
||||
USE_GETTEXT= yes
|
||||
USE_GNOME= gnomeprefix gnomehack gnometarget gvfs
|
||||
INSTALLS_ICONS= yes
|
||||
LDFLAGS+= -L${LOCALBASE}/lib
|
||||
CFLAGS+= -I${LOCALBASE}/include
|
||||
|
||||
BROKEN= No longer supported by developers
|
||||
DEPRECATED= ${BROKEN}
|
||||
EXPIRATION_DATE= 2008-08-24
|
||||
|
||||
USE_LDCONFIG= yes
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
post-patch:
|
||||
${REINPLACE_CMD} -e "s,-Werror,," ${WRKSRC}/src/Makefile.in
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
MD5 (synce-gnomevfs-0.9.0.tar.gz) = 1fa8d653297331479edcd5d983a0f75e
|
||||
SHA256 (synce-gnomevfs-0.9.0.tar.gz) = 2dc8d4905b81e4303e9131dd8f737e7facae9ca7065ec7f9faba15238774b5cd
|
||||
SIZE (synce-gnomevfs-0.9.0.tar.gz) = 303885
|
||||
MD5 (synce-gvfs-0.1.tar.gz) = 0ab01d4c520f7c1f419cfcd6e014f340
|
||||
SHA256 (synce-gvfs-0.1.tar.gz) = 9fd621534bdb200397e74ee4cf9bd17ac828c32c85b0f956fb80d2ab1dfeb7d5
|
||||
SIZE (synce-gvfs-0.1.tar.gz) = 461277
|
||||
|
|
|
@ -1,26 +0,0 @@
|
|||
--- src/libsyncevfs.c.orig Sun Aug 22 21:06:29 2004
|
||||
+++ src/libsyncevfs.c Sat Jan 8 18:40:37 2005
|
||||
@@ -126,8 +126,9 @@
|
||||
{
|
||||
if (!initialized_rapi)
|
||||
{
|
||||
+ HRESULT hr;
|
||||
MUTEX_LOCK (mutex);
|
||||
- HRESULT hr = CeRapiInit();
|
||||
+ hr = CeRapiInit();
|
||||
MUTEX_UNLOCK (mutex);
|
||||
|
||||
if (FAILED(hr))
|
||||
@@ -145,9 +146,10 @@
|
||||
|
||||
static int get_location(GnomeVFSURI *uri, gchar **location)/*{{{*/
|
||||
{
|
||||
- int result = INDEX_INVALID;
|
||||
- *location = NULL;
|
||||
+ int result;
|
||||
gchar **path = NULL;
|
||||
+ *location = NULL;
|
||||
+ result = INDEX_INVALID;
|
||||
|
||||
path = g_strsplit(gnome_vfs_unescape_string(gnome_vfs_uri_get_path(uri),"\\"), "/", 0);
|
||||
|
|
@ -1,5 +1,6 @@
|
|||
SynCE is a project for connecting to devices running Windows CE or Pocket PC.
|
||||
Gnomevfs gives Gnome applications like Nautilus the ability to access the file
|
||||
system on a Windows CE device via gnomevfs.
|
||||
This is an implementation of a gvfs backend for SynCE. Gvfs is a
|
||||
replacement for gnome-vfs, allowing applications to access a
|
||||
variety of filesystems in userspace, in this case a Windows
|
||||
Mobile device via SynCE.
|
||||
|
||||
WWW: http://synce.sourceforge.net/
|
||||
WWW: http://www.synce.org/moin/
|
||||
|
|
|
@ -1,9 +1,9 @@
|
|||
bin/synce-in-computer-folder
|
||||
etc/gnome-vfs-2.0/modules/synce-module.conf
|
||||
share/pixmaps/synce/synce-color.png
|
||||
share/synce/synce-in-computer-folder.sh
|
||||
lib/gnome-vfs-2.0/modules/libsyncevfs.a
|
||||
lib/gnome-vfs-2.0/modules/libsyncevfs.la
|
||||
lib/gnome-vfs-2.0/modules/libsyncevfs.so
|
||||
@dirrmtry share/pixmaps/synce
|
||||
@dirrmtry share/synce
|
||||
libexec/gvfsd-synce
|
||||
share/gvfs/mounts/synce.mount
|
||||
share/icons/gnome/48x48/apps/synce-gvfs.png
|
||||
@dirrmtry share/gvfs/mounts
|
||||
@dirrmtry share/gvfs
|
||||
@dirrmtry share/icons/gnome/48x48/apps
|
||||
@dirrmtry share/icons/gnome/48x48
|
||||
@dirrmtry share/icons/gnome
|
||||
@dirrmtry share/icons
|
||||
|
|
Loading…
Reference in a new issue