net-p2p/bitmessage: Update to 0.6.3.2; Fixes security vulnerability
Additional port changes: * Changed to DISTVERSION * Updated MAINTAINER * Added to RUN_DEPENDS * Moved lines to USExx section * Added USE_PYTHON=noflavors * Deleted the patch (not applicable any more) Testing: * Ran the app, it seems to work properly. 0.6.3.2 fixes the security vulnerability described here: https://github.com/Bitmessage/PyBitmessage/releases/tag/v0.6.3 CVE is not available. Reported by: portscout Approved by: tcberner (mentor, implicit) MFH: 2018Q1
This commit is contained in:
parent
10434e42d6
commit
b20f91f852
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=461843
3 changed files with 16 additions and 51 deletions
|
@ -2,31 +2,31 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= bitmessage
|
||||
PORTVERSION= 0.6.2
|
||||
DISTVERSIONPREFIX= v
|
||||
DISTVERSION= 0.6.3.2
|
||||
CATEGORIES= net-p2p
|
||||
|
||||
MAINTAINER= yuri@rawbw.com
|
||||
MAINTAINER= yuri@FreeBSD.org
|
||||
COMMENT= Secure P2P communications client
|
||||
|
||||
LICENSE= MIT
|
||||
LICENSE_FILE= ${WRKSRC}/LICENSE
|
||||
|
||||
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sqlite3>0:databases/py-sqlite3@${FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}qt4-core>=${PYQT4_VERSION}:devel/py-qt4-core@${FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}qt4-network>=${PYQT4_VERSION}:net/py-qt4-network@${FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}qt4-gui>=${PYQT4_VERSION}:x11-toolkits/py-qt4-gui@${FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}msgpack-python>0:devel/py-msgpack-python@${FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}pyopencl>0:devel/py-pyopencl@${FLAVOR}
|
||||
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sqlite3>0:databases/py-sqlite3@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}qt4-core>=${PYQT4_VERSION}:devel/py-qt4-core@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}qt4-network>=${PYQT4_VERSION}:net/py-qt4-network@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}qt4-gui>=${PYQT4_VERSION}:x11-toolkits/py-qt4-gui@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}gobject>0:devel/py-gobject@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}msgpack-python>0:devel/py-msgpack-python@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}notify2>0:devel/py-notify2@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}pyopencl>0:devel/py-pyopencl@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}qrcode>0:textproc/py-qrcode@${PY_FLAVOR}
|
||||
|
||||
USES= gmake python:2.7 pyqt:4 ssl
|
||||
USE_GITHUB= yes
|
||||
GH_ACCOUNT= Bitmessage
|
||||
GH_PROJECT= PyBitmessage
|
||||
|
||||
USES= gmake python:2.7 pyqt:4 ssl
|
||||
USE_PYQT= core_run gui_run network_run
|
||||
USE_PYTHON= distutils autoplist
|
||||
INSTALLS_ICONS= yes
|
||||
USE_PYTHON= distutils autoplist noflavors
|
||||
REINPLACE_ARGS= -i ''
|
||||
|
||||
post-patch:
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
TIMESTAMP = 1489654811
|
||||
SHA256 (Bitmessage-PyBitmessage-v0.6.2_GH0.tar.gz) = bc209725ef7c1b913ec8560557e3e862a11f664bd8c5fd2eea5adcd915acc2c6
|
||||
SIZE (Bitmessage-PyBitmessage-v0.6.2_GH0.tar.gz) = 1053815
|
||||
TIMESTAMP = 1518629386
|
||||
SHA256 (Bitmessage-PyBitmessage-0.6.3.2_GH0.tar.gz) = 1008d9b34070774267df005389d7e478b42131f79b63c40b1eb8212e67067ac3
|
||||
SIZE (Bitmessage-PyBitmessage-0.6.3.2_GH0.tar.gz) = 1118048
|
||||
|
|
|
@ -1,35 +0,0 @@
|
|||
--- setup.py.orig 2017-03-01 12:12:31 UTC
|
||||
+++ setup.py
|
||||
@@ -117,13 +117,7 @@ def detectOS():
|
||||
def detectPrereqs(missing=False):
|
||||
available = []
|
||||
for module in packageName.keys():
|
||||
- try:
|
||||
- import_module(module)
|
||||
- if not missing:
|
||||
- available.append(module)
|
||||
- except ImportError:
|
||||
- if missing:
|
||||
- available.append(module)
|
||||
+ available.append(module)
|
||||
return available
|
||||
|
||||
|
||||
@@ -146,7 +140,7 @@ def compilerToPackages():
|
||||
if __name__ == "__main__":
|
||||
detectOS.result = None
|
||||
detectPrereqs.result = None
|
||||
- if detectPrereqs(True) != [] and detectOS() in packageManager:
|
||||
+ if False and detectPrereqs(True) != [] and detectOS() in packageManager:
|
||||
if detectOS() is not None:
|
||||
print "It looks like you're using %s. " \
|
||||
"It is highly recommended to use the package manager " \
|
||||
@@ -159,7 +153,7 @@ if __name__ == "__main__":
|
||||
print "It looks like you're missing setuptools."
|
||||
sys.exit()
|
||||
|
||||
- if detectPrereqs(True) != []:
|
||||
+ if False and detectPrereqs(True) != []:
|
||||
print "Press Return to continue"
|
||||
try:
|
||||
nothing = raw_input()
|
Loading…
Reference in a new issue