Bobcat is an acronym of `Brokken's Own Base Classes And Templates'. It

is a shared library implementing C++ classes that are frequently used in
software developed by Frank Brokken.  Frank's existing programs will
depend on `bobcat' in the near future.

WWW: http://bobcat.sourceforge.net/

Approved by:	tabthorpe
This commit is contained in:
Gabor Pali 2009-03-09 16:22:04 +00:00
parent 6b5badef77
commit b2208169f5
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=229761
11 changed files with 234 additions and 0 deletions

View file

@ -597,6 +597,7 @@
SUBDIR += libbfd
SUBDIR += libbinio
SUBDIR += libbnr
SUBDIR += libbobcat
SUBDIR += libbonobo
SUBDIR += libbonobo-reference
SUBDIR += libbonobomm

75
devel/libbobcat/Makefile Normal file
View file

@ -0,0 +1,75 @@
# New ports collection makefile for: libbobcat
# Date created: March 4, 2009
# Whom: Gabor Pali <pgj@FreeBSD.org>
#
# $FreeBSD$
#
PORTNAME= libbobcat
PORTVERSION= 2.00.1
CATEGORIES= devel
MASTER_SITES= SF
DISTNAME= bobcat_${PORTVERSION}
EXTRACT_SUFX= .orig.tar.gz
MAINTAINER= pgj@FreeBSD.org
COMMENT= Brokken's Own Base Classes And Templates
BUILD_DEPENDS= icmake:${PORTSDIR}/devel/icmake \
${LOCALBASE}/include/X11/Xlib.h:${PORTSDIR}/x11/libX11 \
yodl>=2.0:${PORTSDIR}/textproc/yodl
MANCOMPRESSED= yes
MAN3= a2x.3bobcat align.3bobcat arg.3bobcat argconfig.3bobcat \
autoptr.3bobcat binarysearch.3bobcat cgi.3bobcat \
clientsocket.3bobcat cmdfinder.3bobcat cmdfinderbase.3bobcat \
configfile.3bobcat datetime.3bobcat errno.3bobcat \
fnwrap1.3bobcat fnwrap1c.3bobcat fnwrap2.3bobcat \
fnwrap2c.3bobcat foreach.3bobcat fork.3bobcat \
gethostent.3bobcat glob.3bobcat hash.3bobcat hostent.3bobcat \
hostname.3bobcat ifdstream.3bobcat ifdstreambuf.3bobcat \
indent.3bobcat inetaddress.3bobcat iostream.3bobcat \
iostreambuf.3bobcat irandstream.3bobcat level.3bobcat \
localclientsocket.3bobcat localserversocket.3bobcat \
localsocketbase.3bobcat log.3bobcat logbuffer.3bobcat \
mailheaders.3bobcat manipulators.3bobcat milter.3bobcat \
msg.3bobcat multistreambuf.3bobcat ofdstream.3bobcat \
ofdstreambuf.3bobcat onekey.3bobcat pattern.3bobcat \
pipe.3bobcat process.3bobcat randbuffer.3bobcat \
redirector.3bobcat refcount.3bobcat repeat.3bobcat \
selector.3bobcat serversocket.3bobcat socketbase.3bobcat \
stat.3bobcat string.3bobcat syslogbuf.3bobcat \
syslogstream.3bobcat table.3bobcat tablesupport.3bobcat \
typetrait.3bobcat user.3bobcat x2a.3bobcat xpointer.3bobcat
MAN7= bobcat.7
DOCSDIR= ${PREFIX}/share/doc/${PORTNAME}-${PORTVERSION}
PORTDOCS= *
USE_LDCONFIG= yes
WRKSRC= ${WRKDIR}/bobcat-${PORTVERSION}
post-patch:
@${REINPLACE_CMD} -e 's|"/usr"|"${PREFIX}"| ; \
s|"/share/doc/libbobcat2"|"/share/doc/${PORTNAME}-${PORTVERSION}"| ; \
s|"/share/doc/libbobcat2-dev"|"/share/doc/${PORTNAME}-${PORTVERSION}/dev"| ; \
s|"/share/man"|"/man"|' \
${WRKSRC}/INSTALL.im
@${REINPLACE_CMD} -e 's|#!/usr/bin/icmake|#!${LOCALBASE}/bin/icmake| ; \
s|"-Itmp -Wall -O3"|"-Itmp -I${LOCALBASE}/include -Wall ${CXXFLAGS}"|' \
${WRKSRC}/build
@${REINPLACE_CMD} -e 's|"cp -d |"cp -Pp | ; \
s|"cp -r |"cp -R |' \
${WRKSRC}/icmake/install
.if defined(NOPORTDOCS)
@${REINPLACE_CMD} -e 's|#define DOCOTHER||' \
${WRKSRC}/INSTALL.im
.endif
do-build:
@cd ${WRKSRC} && ./build libraries all strip && ./build man
do-install:
@cd ${WRKSRC} && ./build install
.include <bsd.port.mk>

3
devel/libbobcat/distinfo Normal file
View file

@ -0,0 +1,3 @@
MD5 (bobcat_2.00.1.orig.tar.gz) = 967356328cbc29f825f52d2f606e9c21
SHA256 (bobcat_2.00.1.orig.tar.gz) = cf652b66b9bd5542d979c1465f0c5478df6a441fde3c9d95bdef149313731710
SIZE (bobcat_2.00.1.orig.tar.gz) = 495892

View file

@ -0,0 +1,11 @@
--- INSTALL.im.orig 2008-11-21 15:06:28.000000000 +0100
+++ INSTALL.im 2009-03-04 20:15:22.000000000 +0100
@@ -9,8 +9,6 @@
// Install the headers, remove if not requested
#define MANPAGES
// Install the manpages, remove if not requested
-#define MANHTML
- // Install the html-versions of the manpages, remove if not requested
#define DOCOTHER
// Install remaining docs (README, examples, etc), remove if not requested

View file

@ -0,0 +1,10 @@
--- hostname/hostname.ih.orig 2007-02-13 13:29:39.000000000 +0100
+++ hostname/hostname.ih 2009-03-04 12:30:14.000000000 +0100
@@ -3,6 +3,7 @@
#include <bobcat/inetaddress>
#include <bobcat/gethostent>
#include <netdb.h>
+#include <sys/socket.h>
using namespace std;
using namespace FBB;

View file

@ -0,0 +1,29 @@
--- icmake/man.orig 2007-02-13 13:29:38.000000000 +0100
+++ icmake/man 2009-03-04 20:38:35.000000000 +0100
@@ -9,7 +9,7 @@
special(0, 0);
- md("tmp/man/man3 tmp/man/man7 tmp/manhtml");
+ md("tmp/man/man3 tmp/man/man7");
chdir("documentation/man");
@@ -35,8 +35,6 @@
run("yodl2man --no-warnings -o ../../tmp/man/man3/" +
base + ".3bobcat " + yodl);
- run("yodl2html --no-warnings -o ../../tmp/manhtml/" +
- base + ".3.html " + yodl);
}
}
@@ -44,8 +42,6 @@
{
run("yodl2man --no-warnings -o ../../tmp/man/man7/bobcat.7 "
"bobcat.yo");
- run("yodl2html --no-warnings -o ../../tmp/manhtml/bobcat.7.html "
- "bobcat.yo");
}
run("touch man-stamp");

View file

@ -0,0 +1,10 @@
--- inetaddress/inetaddress.orig 2009-03-05 23:39:43.000000000 +0100
+++ inetaddress/inetaddress 2009-03-05 23:37:27.000000000 +0100
@@ -4,6 +4,7 @@
#include <netinet/in.h>
#include <string>
#include <bobcat/errno>
+#include <sys/socket.h>
/*
int-info coming in or going out: host byte order

View file

@ -0,0 +1,10 @@
--- inetaddress/inetaddress.ih.orig 2007-02-13 13:29:39.000000000 +0100
+++ inetaddress/inetaddress.ih 2009-03-04 12:16:16.000000000 +0100
@@ -2,6 +2,7 @@
#include <netdb.h>
#include <bobcat/gethostent>
+#include <sys/socket.h>
using namespace std;
using namespace FBB;

View file

@ -0,0 +1,10 @@
--- process/process.ih.orig 2008-11-03 16:24:04.000000000 +0100
+++ process/process.ih 2009-03-04 12:19:54.000000000 +0100
@@ -6,6 +6,7 @@
#include <sys/types.h>
// #include <sys/stat.h>
#include <sys/wait.h>
+#include <signal.h>
#include <bobcat/errno>
#include <bobcat/redirector>

View file

@ -0,0 +1,6 @@
Bobcat is an acronym of `Brokken's Own Base Classes And Templates'. It
is a shared library implementing C++ classes that are frequently used in
software developed by Frank Brokken. Frank's existing programs will
depend on `bobcat' in the near future.
WWW: http://bobcat.sourceforge.net/

69
devel/libbobcat/pkg-plist Normal file
View file

@ -0,0 +1,69 @@
@comment $FreeBSD$
include/bobcat/xpointer
include/bobcat/milter
include/bobcat/argconfig
include/bobcat/cgi
include/bobcat/foreach
include/bobcat/repeat
include/bobcat/serversocket
include/bobcat/clientsocket
include/bobcat/socketbase
include/bobcat/inetaddress
include/bobcat/cmdfinderbase
include/bobcat/table
include/bobcat/process
include/bobcat/localserversocket
include/bobcat/localclientsocket
include/bobcat/level
include/bobcat/gethostent
include/bobcat/configfile
include/bobcat/cmdfinder
include/bobcat/arg
include/bobcat/user
include/bobcat/tablesupport
include/bobcat/syslogstream
include/bobcat/string
include/bobcat/stat
include/bobcat/selector
include/bobcat/redirector
include/bobcat/pipe
include/bobcat/pattern
include/bobcat/onekey
include/bobcat/ofdstream
include/bobcat/multistreambuf
include/bobcat/msg
include/bobcat/mailheaders
include/bobcat/log
include/bobcat/localsocketbase
include/bobcat/irandstream
include/bobcat/iostream
include/bobcat/ifdstream
include/bobcat/hostname
include/bobcat/glob
include/bobcat/fork
include/bobcat/fnwrap2c
include/bobcat/fnwrap2
include/bobcat/fnwrap1c
include/bobcat/fnwrap1
include/bobcat/autoptr
include/bobcat/x2a
include/bobcat/typetrait
include/bobcat/syslogbuf
include/bobcat/refcount
include/bobcat/randbuffer
include/bobcat/logbuffer
include/bobcat/ofdstreambuf
include/bobcat/iostreambuf
include/bobcat/indent
include/bobcat/ifdstreambuf
include/bobcat/hostent
include/bobcat/hash
include/bobcat/errno
include/bobcat/datetime
include/bobcat/align
include/bobcat/a2x
lib/libbobcat.a
lib/libbobcat.so.2.00.1
lib/libbobcat.so.2
lib/libbobcat.so
@dirrm include/bobcat