graphics/py-pandana: Allow build with py-tables 3.7.0
- Bump PORTREVISION for package change
This commit is contained in:
parent
f7c1fd3e0b
commit
b24a5b2302
2 changed files with 13 additions and 1 deletions
|
@ -2,6 +2,7 @@
|
|||
|
||||
PORTNAME= pandana
|
||||
PORTVERSION= 0.6.1
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= graphics python
|
||||
MASTER_SITES= CHEESESHOP
|
||||
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
|
||||
|
@ -18,7 +19,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}numpy>=1.8,1:math/py-numpy@${PY_FLAVOR} \
|
|||
${PYTHON_PKGNAMEPREFIX}pandas>=0.17,1:math/py-pandas@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}requests>=2.0:www/py-requests@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}scikit-learn>=0.18:science/py-scikit-learn@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}tables>=3.1<3.7:devel/py-tables@${PY_FLAVOR}
|
||||
${PYTHON_PKGNAMEPREFIX}tables>=3.1<3.8:devel/py-tables@${PY_FLAVOR}
|
||||
|
||||
USES= compiler:c++11-lang python:3.7+
|
||||
USE_PYTHON= autoplist concurrent cython distutils
|
||||
|
|
11
graphics/py-pandana/files/patch-setup.py
Normal file
11
graphics/py-pandana/files/patch-setup.py
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- setup.py.orig 2021-03-17 16:44:15 UTC
|
||||
+++ setup.py
|
||||
@@ -151,7 +151,7 @@ setup(
|
||||
'requests >=2.0',
|
||||
'scikit-learn >=0.18',
|
||||
'tables >=3.1, <3.6; python_version <"3.6"',
|
||||
- 'tables >=3.1, <3.7; python_version >="3.6"'
|
||||
+ 'tables >=3.1, <3.8; python_version >="3.6"'
|
||||
],
|
||||
cmdclass={
|
||||
'test': PyTest,
|
Loading…
Reference in a new issue