- Respect PREFIX and X11BASE which wasn't done in some binaries and scripts

- Fix problem with gcc 2.95 (add -fwritable-strings)
  - Fix problem with display depth when printing username below icon
    (white text on white background ;-)
  - Add some documentation (READMEs) with respect to NOPORTDOCS
  - Define of USE_NAS environment variable builds faces with
    NAS (auplay) support (default is rplay)
  - Correct pkg-plist
  - Shorten pkg-desc below 24 lines
  - Bump PORTREVISION to 1

Changes were stimulated by:  Mike Meyer <mwm@mired.org>
This commit is contained in:
Lars Koeller 2001-02-26 20:49:01 +00:00
parent 26121d15ae
commit b24ad43f2c
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=38811
6 changed files with 101 additions and 44 deletions

View file

@ -8,15 +8,25 @@
PORTNAME= faces
PORTVERSION= 1.6.1
PORTREVISION= 1
CATEGORIES= mail
MASTER_SITES= ftp://ftp.cs.indiana.edu/pub/faces/faces/
EXTRACT_SUFX= .tar.Z
MAINTAINER= Lars.Koeller@Uni-Bielefeld.DE
# Define USE_NAS for NAS audio support
.if defined(USE_NAS)
RUN_DEPENDS= auplay:${PORTSDIR}/audio/nas
SED_REPL=auplay
.else
RUN_DEPENDS= rplay:${PORTSDIR}/audio/rplay
SED_REPL=rplay
.endif
USE_XLIB= yes
INSTALLS_SHLIB= yes
WRKSRC= $(WRKDIR)/faces
WRKSRC= ${WRKDIR}/faces
MAN1= compface.1 faces.1 face_update.1
MAN3= compface.3
MLINKS= compface.1 uncompface.1 \
@ -25,4 +35,32 @@ MLINKS= compface.1 uncompface.1 \
pre-patch:
@${CP} ${WRKSRC}/Makefile.dist ${WRKSRC}/Makefile
post-patch:
for na in $$(find ${WRKSRC}/scripts -type f) \
${WRKSRC}/faces.man ${WRKSRC}/face_update.1 ; do \
${CP} $$na $$na.orig; \
${SED} "s%/usr/local%${PREFIX}%" $$na.orig > $$na; \
done; \
for na in ${WRKSRC}/Makefile ${WRKSRC}/Faces.ad; do \
${CP} $$na $$na.orig; \
${SED} "s%rplay%${SED_REPL}%" $$na.orig > $$na; \
done; \
for na in ${WRKSRC}/Makefile ${WRKSRC}/x11.c; do \
${CP} $$na $$na.orig2; \
${SED} "s%/usr/X11R6%${X11BASE}%" $$na.orig2 > $$na; \
done
.if !defined(NOPORTDOCS)
post-install:
if [ ! -e ${PREFIX}/share/doc/${PORTNAME} ]; then \
${MKDIR} ${PREFIX}/share/doc/${PORTNAME}; \
${CP} -f ${WRKSRC}/README ${PREFIX}/share/doc/${PORTNAME}; \
${CP} -f ${WRKSRC}/scripts/README.kinzler ${PREFIX}/share/doc/${PORTNAME}; \
${CP} -f ${WRKSRC}/scripts/from.allrc-eg ${PREFIX}/share/doc/${PORTNAME}; \
${MKDIR} ${PREFIX}/share/${PORTNAME}/lib; \
${ECHO} ";# See ${PREFIX}/share/doc/${PORTNAME}/from.allrc-eg for an example" \
> ${PREFIX}/share/${PORTNAME}/lib/allrc; \
fi
.endif
.include <bsd.port.mk>

View file

@ -107,7 +107,7 @@
$(TTEXT) $(TOPIX) $(UPDATE) $(USE_BZERO) $(USE_GETWD) \
$(X11R3) $(X11INCDIR) $(XVIEWINCDIR) $(DEBUG)
-CCOMP = -O
+CCOMP = -pipe -O2
+CCOMP = -pipe -O2 -fwritable-strings
CFLAGS = $(CCOMP) $(CDEFS)
#
#=======================================================================

View file

@ -1,6 +1,5 @@
diff -c -N ../faces/x11.c ./x11.c
*** ../faces/x11.c Tue Nov 19 05:00:50 1991
--- ./x11.c Tue Dec 10 20:43:06 1996
*** x11.c.orig Tue Nov 19 05:00:50 1991
--- x11.c Mon Feb 26 21:29:24 2001
***************
*** 58,64 ****
@ -84,12 +83,41 @@ diff -c -N ../faces/x11.c ./x11.c
CWBackPixel | CWBorderPixel | CWEventMask, &winattrs) ;
***************
*** 856,861 ****
--- 861,867 ----
*** 818,823 ****
--- 823,830 ----
int c, r ; /* Column and row position for this face. */
int x, y ; /* Position of start of this text string. */
int textwidth ;
+ Colormap cmap ;
+ XColor selcolor ;
c = column ;
r = row ;
***************
*** 852,861 ****
case RIGHT : x = (c + 1) * imagewidth - textwidth - 2 ;
y = (r + 1) * imageheight - 5 ;
}
! XSetFunction(dpy, gc, GXandInverted) ;
XFillRectangle(dpy, pr[(int) dtype], gc, x, y-9,
(unsigned int) textwidth+2, 13) ;
XSetFunction(dpy, gc, GXxor) ;
+ XSetForeground(dpy, gc, WhitePixel(dpy, screen));
! XSetFunction(dpy, gc, GXxor) ;
XDrawImageString(dpy, pr[(int) dtype], gc, x, y, str, len) ;
XSetFunction(dpy, gc, GXcopy) ;
}
--- 859,873 ----
case RIGHT : x = (c + 1) * imagewidth - textwidth - 2 ;
y = (r + 1) * imageheight - 5 ;
}
! XSetForeground(dpy, gc, WhitePixel(dpy, screen));
! XSetFunction(dpy, gc, GXcopy) ;
XFillRectangle(dpy, pr[(int) dtype], gc, x, y-9,
(unsigned int) textwidth+2, 13) ;
! XSetFunction(dpy, gc, GXcopy) ;
! cmap = DefaultColormap(dpy, screen);
! XParseColor(dpy, cmap, "red", &selcolor);
! XAllocColor(dpy, cmap, &selcolor) ;
! XSetForeground(dpy, gc, selcolor.pixel );
XDrawImageString(dpy, pr[(int) dtype], gc, x, y, str, len) ;
XSetFunction(dpy, gc, GXcopy) ;
}

20
mail/faces/files/patch-ea Normal file
View file

@ -0,0 +1,20 @@
--- scripts/from.faces.orig Tue Nov 19 05:05:58 1991
+++ scripts/from.faces Sun Feb 18 17:57:50 2001
@@ -17,7 +17,7 @@
$cols = 7;
-;# from.faces - alternate, experimental faces script to monitor one's mail
+;# from.faces - alternate, experimental faces script to monitor ones mail
;# spool file
;# Steve Kinzler, kinzler@cs.indiana.edu, 28 Jan 1991
@@ -58,7 +58,7 @@
($from, $wday, $mon, $mday, $time, $year) =
split(/\s+/, $hdr{'from'});
-#include "/usr/local/faces/lib/allrc";
+#include "/usr/local/share/faces/lib/allrc";
$from =~ s/.*<([^>]*)>.*/\1/;
$from =~ s/\(.*\)//;

View file

@ -1,41 +1,7 @@
What is faces?
--------------
This is the third general release of a "faces" server for monitoring a
list visually. Typically this is a list of incoming mail messages, jobs
in the print queue or users on a system.
Faces has five different modes of operation:
(a) The default will monitor for new mail. By default, only the last ten
messages are displayed. Using the left mouse button it is possible to
toggle the text in the faces window. This will either be the username
or the time the mail message arrived. The icon shows the image of the
last message to arrive.
(b) You can monitor the whole of a mail file. The open window will
automatically adjust it's size to correctly show the face icons. The
open window options are the username or the timestamp and number of
message from that user. The icon will display the image of the last
message, and a count of the total number of messages in the spool
file or mail folder.
(c) Monitoring a given print queue. This will generate a single face icon
showing the job at the top of the print queue, and the text message
will display the printer name plus the number of jobs to be printed.
Opening the window will show images of all the jobs in the queue. The
text on each image can be toggled, choices being the owners' name and
the size of the job in bytes.
(d) Monitoring users on a machine. For each user, a face image is displayed.
Text can be either the username or the time they logged on. The iconic
form displays the total number of users.
(e) Custom monitoring. You can specify a program or shell script to run.
The standard output from this program will be read by the faces program,
and the appropriate faces displayed using the information provided. The
format of this face information is given in the faces manual page.
Included with this release, is the ability to include a face image with
your mail message using an X-Face header line (plus continuation lines).
Faces expects this line to be in a certain compressed format, and

View file

@ -1,4 +1,3 @@
@cwd /usr/local
bin/compface
bin/uncompface
lib/libcompface.a
@ -29,6 +28,12 @@ bin/face_update
bin/faces.sendmail
share/faces/machine.tab
share/faces/people.tab
share/faces/lib/allrc
share/doc/faces/README
share/doc/faces/README.kinzler
share/doc/faces/from.allrc-eg
@dirrm share/faces
@dirrm share/faces/lib
@dirrm share/doc/faces
@cwd /usr/X11R6
lib/X11/app-defaults/Faces