Liblingoteach is a helper library for Lingoteach, language teacher program.

PR:		ports/58032
Submitted by:	Marcus von Appen <mva@sysfault.org>
Approved by:	adamw (mentor)
This commit is contained in:
Pav Lucistnik 2003-11-18 04:23:36 +00:00
parent b13871449d
commit b262602966
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=94228
6 changed files with 89 additions and 0 deletions

View file

@ -142,6 +142,7 @@
SUBDIR += latte
SUBDIR += libcroco
SUBDIR += libebml
SUBDIR += liblingoteach
SUBDIR += liblrdf
SUBDIR += libpathan
SUBDIR += libtre

View file

@ -0,0 +1,40 @@
# New ports collection makefile for: liblingoteach
# Date created: 14 October 2003
# Whom: Marcus von Appen
#
# $FreeBSD$
#
PORTNAME= liblingoteach
PORTVERSION= 0.2.0
CATEGORIES= textproc
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= lingoteach
MAINTAINER= mva@sysfault.org
COMMENT= A library for parsing lesson files based on the LingoTeach DTD
USE_GMAKE= yes
USE_GNOME= gnomehack gnometarget libxml2
USE_LIBTOOL= yes
INSTALLS_SHLIB= yes
.if defined(WITH_COMP)
CONFIGURE_ARGS+= --with-compression
.endif
.if defined(WITH_DEBUG)
CONFIGURE_ARGS+= --enable-debug
.endif
pre-everything::
@${ECHO_MSG} ""
@${ECHO_MSG} "liblingoteach can be used with the following switches:"
@${ECHO_MSG} ""
@${ECHO_MSG} " WITH_COMP=yes Enables zlib compression of"
@${ECHO_MSG} " the lesson files"
@${ECHO_MSG} " WITH_DEBUG=yes Enables additional debugging"
@${ECHO_MSG} " information and output"
@${ECHO_MSG} ""
.include <bsd.port.mk>

View file

@ -0,0 +1 @@
MD5 (liblingoteach-0.2.0.tar.gz) = 49c3824d1b74a3fd69bdec7ff689a877

View file

@ -0,0 +1,11 @@
--- doc/Makefile.in.orig Sun Oct 12 13:30:43 2003
+++ doc/Makefile.in Tue Oct 14 23:35:13 2003
@@ -88,7 +88,7 @@
am__quote = @am__quote@
install_sh = @install_sh@
-DOC_MODULE = liblingoteach-$(VERSION)
+DOC_MODULE = liblingoteach
HTML_DIR = $(datadir)/doc
subdir = doc
mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs

View file

@ -0,0 +1,5 @@
This is a port of liblingoteach, a library for special translation
lesson interaction. It uses the LingoTeach DTD format for general
validation.
WWW: http://www.lingoteach.org

View file

@ -0,0 +1,31 @@
include/lingoteach/lingdefs.h
include/lingoteach/lingoteach.h
lib/liblingoteach.a
lib/liblingoteach.so
lib/liblingoteach.so.0
libdata/pkgconfig/liblingoteach.pc
share/doc/liblingoteach/html/a00009.html
share/doc/liblingoteach/html/a00010.html
share/doc/liblingoteach/html/a00011.html
share/doc/liblingoteach/html/a00012.html
share/doc/liblingoteach/html/a00013.html
share/doc/liblingoteach/html/a00014.html
share/doc/liblingoteach/html/a00015.html
share/doc/liblingoteach/html/a00016.html
share/doc/liblingoteach/html/a00017.html
share/doc/liblingoteach/html/annotated.html
share/doc/liblingoteach/html/classes.html
share/doc/liblingoteach/html/doxygen.css
share/doc/liblingoteach/html/doxygen.png
share/doc/liblingoteach/html/files.html
share/doc/liblingoteach/html/functions.html
share/doc/liblingoteach/html/functions_vars.html
share/doc/liblingoteach/html/globals.html
share/doc/liblingoteach/html/globals_enum.html
share/doc/liblingoteach/html/globals_eval.html
share/doc/liblingoteach/html/globals_func.html
share/doc/liblingoteach/html/globals_type.html
share/doc/liblingoteach/html/index.html
@dirrm share/doc/liblingoteach/html
@dirrm share/doc/liblingoteach
@dirrm include/lingoteach