Support staging
This commit is contained in:
parent
bfddb9b21b
commit
b2c5327953
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=345070
2 changed files with 22 additions and 5 deletions
|
@ -11,12 +11,11 @@ COMMENT= A fully matured and stable set of printf and string functions
|
||||||
|
|
||||||
GNU_CONFIGURE= yes
|
GNU_CONFIGURE= yes
|
||||||
|
|
||||||
NO_STAGE= yes
|
OPTIONS_DEFINE= DOCS
|
||||||
|
|
||||||
post-install:
|
post-install:
|
||||||
.if !defined(NOPORTDOCS)
|
@${MKDIR} ${STAGEDIR}${DOCSDIR}
|
||||||
@${MKDIR} ${DOCSDIR}
|
|
||||||
cd ${WRKSRC} && ${FIND} doc | \
|
cd ${WRKSRC} && ${FIND} doc | \
|
||||||
${CPIO} -pdm -L -R ${SHAREOWN}:${SHAREGRP} ${DOCSDIR}
|
${CPIO} -pdm -L -R ${SHAREOWN}:${SHAREGRP} ${STAGEDIR}${DOCSDIR}
|
||||||
.endif
|
|
||||||
|
|
||||||
.include <bsd.port.mk>
|
.include <bsd.port.mk>
|
||||||
|
|
18
devel/trio/files/patch-Makefile.in
Normal file
18
devel/trio/files/patch-Makefile.in
Normal file
|
@ -0,0 +1,18 @@
|
||||||
|
--- ./Makefile.in.orig 2014-02-19 12:30:54.040272078 +0100
|
||||||
|
+++ ./Makefile.in 2014-02-19 12:31:21.743269418 +0100
|
||||||
|
@@ -43,11 +43,11 @@
|
||||||
|
./regression
|
||||||
|
|
||||||
|
install: $(TARGETLIB)
|
||||||
|
- $(MKDIR) $(libdir)
|
||||||
|
- $(MKDIR) $(includedir)
|
||||||
|
- $(INSTALL_DATA) $(TARGETLIB) $(libdir)/$(TARGETLIB)
|
||||||
|
+ $(MKDIR) $(DESTDIR)$(libdir)
|
||||||
|
+ $(MKDIR) $(DESTDIR)$(includedir)
|
||||||
|
+ $(INSTALL_DATA) $(TARGETLIB) $(DESTDIR)$(libdir)/$(TARGETLIB)
|
||||||
|
for i in $(TARGETINCS);do \
|
||||||
|
- (set -x;$(INSTALL_DATA) $(srcdir)/$$i $(includedir)); \
|
||||||
|
+ (set -x;$(INSTALL_DATA) $(srcdir)/$$i $(DESTDIR)$(includedir)); \
|
||||||
|
done
|
||||||
|
|
||||||
|
regression: regression.o $(TARGETLIB)
|
Loading…
Reference in a new issue