Add maude.
Maude is a high-performance reflective language and system supporting both equational and rewriting logic specification and programming for a wide range of applications. Maude has been influenced in important ways by the OBJ3 language, which can be regarded as an equational logic sublanguage. Besides supporting equational specification and programming, Maude also supports rewriting logic computation. Rewriting logic is a logic of concurrent change that can naturally deal with state and with concurrent computations. It has good properties as a general semantic framework for giving executable semantics to a wide range of languages and models of concurrency. In particular, it supports very well concurrent object-oriented computation. The same reasons making rewriting logic a good semantic framework make it also a good logical framework, that is, a metalogic in which many other logics can be naturally represented and executed. Maude supports in a systematic and efficient way logical reflection. This makes Maude remarkably extensible and powerful, supports an extensible algebra of module composition operations, and allows many advanced metaprogramming and metalanguage applications. Indeed, some of the most interesting applications of Maude are metalanguage applications, in which Maude is used to create executable environments for different logics, theorem provers, languages, and models of computation. WWW: http://maude.cs.uiuc.edu/ PR: ports/94986 Submitted by: Rick van der Zwet <rick@traffie.wzoeterwoude.net>
This commit is contained in:
parent
811d149205
commit
b2c604be3e
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=158902
6 changed files with 91 additions and 0 deletions
|
@ -135,6 +135,7 @@
|
|||
SUBDIR += lua-mode.el
|
||||
SUBDIR += lua4
|
||||
SUBDIR += lush
|
||||
SUBDIR += maude
|
||||
SUBDIR += mawk
|
||||
SUBDIR += mdk
|
||||
SUBDIR += metaocaml
|
||||
|
|
30
lang/maude/Makefile
Normal file
30
lang/maude/Makefile
Normal file
|
@ -0,0 +1,30 @@
|
|||
# New ports collection makefile for: maude
|
||||
# Date created: 25 Mar 2005
|
||||
# Whom: Rick van der Zwet <rick@wzoeterwoude.net>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= maude
|
||||
PORTVERSION= 2.2
|
||||
CATEGORIES= lang
|
||||
MASTER_SITES= http://maude.cs.uiuc.edu/download/current/
|
||||
DISTNAME= Maude-${PORTVERSION}
|
||||
|
||||
MAINTAINER= rick@wzoeterwoude.net
|
||||
COMMENT= A high-performance reflective language
|
||||
|
||||
BUILD_DEPENDS= bison:${PORTSDIR}/devel/bison
|
||||
LIB_DEPENDS= bdd:${PORTSDIR}/science/buddy \
|
||||
tecla:${PORTSDIR}/devel/libtecla \
|
||||
gmp:${PORTSDIR}/math/libgmp4
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
|
||||
CONFIGURE_ARGS= --datadir=${DATADIR}
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e 's|%%DATADIR%%|${DATADIR}|' \
|
||||
${WRKSRC}/src/Mixfix/main.cc
|
||||
|
||||
.include <bsd.port.mk>
|
3
lang/maude/distinfo
Normal file
3
lang/maude/distinfo
Normal file
|
@ -0,0 +1,3 @@
|
|||
MD5 (Maude-2.2.tar.gz) = c3b3cadec1ab792a64f0d441e56de15a
|
||||
SHA256 (Maude-2.2.tar.gz) = 7b85941cb8441eeca23ed3ea291ea6ac9571ce09a9a28a2193e8414b1ca13118
|
||||
SIZE (Maude-2.2.tar.gz) = 8243200
|
26
lang/maude/files/patch-src_Mixfix_main.cc
Normal file
26
lang/maude/files/patch-src_Mixfix_main.cc
Normal file
|
@ -0,0 +1,26 @@
|
|||
--- src/Mixfix/main.cc.orig Wed Apr 5 22:46:48 2006
|
||||
+++ src/Mixfix/main.cc Wed Apr 5 22:49:23 2006
|
||||
@@ -284,6 +284,11 @@
|
||||
directory = ".";
|
||||
return true;
|
||||
}
|
||||
+ if (directoryManager.checkAccess("%%DATADIR%%", fileName, R_OK))
|
||||
+ {
|
||||
+ directory = "%%DATADIR%%";
|
||||
+ return true;
|
||||
+ }
|
||||
IssueWarning(LineNumber(FileTable::AUTOMATIC) <<
|
||||
": unable to locate file: " << QUOTE(fileName));
|
||||
return false;
|
||||
@@ -307,6 +312,11 @@
|
||||
directoryManager.checkAccess(executableDirectory, fileName, R_OK, ext))
|
||||
{
|
||||
directory = executableDirectory;
|
||||
+ return true;
|
||||
+ }
|
||||
+ if (directoryManager.checkAccess("%%DATADIR%%", fileName, R_OK))
|
||||
+ {
|
||||
+ directory = "%%DATADIR%%";
|
||||
return true;
|
||||
}
|
||||
}
|
25
lang/maude/pkg-descr
Normal file
25
lang/maude/pkg-descr
Normal file
|
@ -0,0 +1,25 @@
|
|||
Maude is a high-performance reflective language and system supporting both
|
||||
equational and rewriting logic specification and programming for a wide range
|
||||
of applications. Maude has been influenced in important ways by the OBJ3
|
||||
language, which can be regarded as an equational logic sublanguage. Besides
|
||||
supporting equational specification and programming, Maude also supports
|
||||
rewriting logic computation.
|
||||
|
||||
Rewriting logic is a logic of concurrent change that can naturally deal with
|
||||
state and with concurrent computations. It has good properties as a general
|
||||
semantic framework for giving executable semantics to a wide range of
|
||||
languages and models of concurrency. In particular, it supports very well
|
||||
concurrent object-oriented computation. The same reasons making rewriting
|
||||
logic a good semantic framework make it also a good logical framework, that
|
||||
is, a metalogic in which many other logics can be naturally represented and
|
||||
executed.
|
||||
|
||||
Maude supports in a systematic and efficient way logical reflection. This
|
||||
makes Maude remarkably extensible and powerful, supports an extensible algebra
|
||||
of module composition operations, and allows many advanced metaprogramming and
|
||||
metalanguage applications. Indeed, some of the most interesting applications
|
||||
of Maude are metalanguage applications, in which Maude is used to create
|
||||
executable environments for different logics, theorem provers, languages, and
|
||||
models of computation.
|
||||
|
||||
WWW: http://maude.cs.uiuc.edu/
|
6
lang/maude/pkg-plist
Normal file
6
lang/maude/pkg-plist
Normal file
|
@ -0,0 +1,6 @@
|
|||
bin/maude
|
||||
%%DATADIR%%/linear.maude
|
||||
%%DATADIR%%/model-checker.maude
|
||||
%%DATADIR%%/prelude.maude
|
||||
%%DATADIR%%/socket.maude
|
||||
@dirrm %%DATADIR%%
|
Loading…
Reference in a new issue