Remove mozilla-vendor. Mozilla 1.4 is the new standard across the board.
This commit is contained in:
parent
ce778a39d1
commit
b2c746b041
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=83945
18 changed files with 0 additions and 538 deletions
|
@ -248,13 +248,10 @@
|
|||
SUBDIR += mozilla-devel-gtk2
|
||||
SUBDIR += mozilla-embedded
|
||||
SUBDIR += mozilla-embedded-devel
|
||||
SUBDIR += mozilla-embedded-vendor
|
||||
SUBDIR += mozilla-firebird
|
||||
SUBDIR += mozilla-gtk2
|
||||
SUBDIR += mozilla-headers
|
||||
SUBDIR += mozilla-headers-devel
|
||||
SUBDIR += mozilla-headers-vendor
|
||||
SUBDIR += mozilla-vendor
|
||||
SUBDIR += mplayer-plugin
|
||||
SUBDIR += nd
|
||||
SUBDIR += neon
|
||||
|
|
|
@ -1,60 +0,0 @@
|
|||
# New ports collection makefile for: mozilla-embedded
|
||||
# Date created: 16 August 2000
|
||||
# Whom: Maxim Sobolev <sobomax@FreeBSD.org>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= mozilla-embedded
|
||||
PORTVERSION= ${MAKE} -V PORTVERSION -f ${MAINDIR}/${MKFILE}
|
||||
PORTREVISION= ${MAKE} -V PORTREVISION -f ${MAINDIR}/${MKFILE}
|
||||
PORTEPOCH= ${MAKE} -V PORTEPOCH -f ${MAINDIR}/${MKFILE}
|
||||
CATEGORIES= www
|
||||
DISTFILES=
|
||||
|
||||
MAINTAINER= sobomax@FreeBSD.org
|
||||
COMMENT= The embeddable component of mozilla communicator web-surfboard
|
||||
|
||||
BUILD_DEPENDS= ${NONEXISTENT}:${PORTSDIR}/www/mozilla-vendor:build \
|
||||
zip:${PORTSDIR}/archivers/zip \
|
||||
unzip:${PORTSDIR}/archivers/unzip
|
||||
LIB_DEPENDS= ${MAKE} -V LIB_DEPENDS -f ${MAINDIR}/${MKFILE}
|
||||
RUN_DEPENDS= ${MAKE} -V RUN_DEPENDS -f ${MAINDIR}/${MKFILE}
|
||||
|
||||
USE_X_PREFIX= yes
|
||||
|
||||
LATEST_LINK= mozilla-embedded-vendor
|
||||
PLIST= ${WRKSRC}/pkg-plist
|
||||
MAINDIR= ${.CURDIR}/../mozilla-vendor
|
||||
MKFILE!= /usr/bin/basename ${MAKEFILE}
|
||||
PORTVERSION!= ${PORTVERSION}
|
||||
PORTREVISION!= ${PORTREVISION}
|
||||
PORTEPOCH!= ${PORTEPOCH}
|
||||
RUN_DEPENDS!= ${RUN_DEPENDS}
|
||||
LIB_DEPENDS!= ${LIB_DEPENDS}
|
||||
WRKSRC= ${WRKDIRPREFIX}${MAINDIR}/work/mozilla
|
||||
|
||||
do-build:
|
||||
@cd ${WRKSRC}/embedding/config && ${SETENV} ${MAKE_ENV} ${GMAKE} \
|
||||
${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} ${ALL_TARGET}
|
||||
@(cd ${WRKSRC}/dist/Embed; \
|
||||
${SETENV} LD_LIBRARY_PATH=. MOZILLA_FIVE_HOME=. ../bin/regxpcom; \
|
||||
${SETENV} LD_LIBRARY_PATH=. MOZILLA_FIVE_HOME=. ../bin/regchrome)
|
||||
@${FIND} ${WRKSRC}/dist/Embed -name "*.so" | ${XARGS} ${STRIP_CMD}
|
||||
|
||||
pre-install:
|
||||
${RM} -f ${PLIST}
|
||||
${TOUCH} -f ${PLIST}
|
||||
cd ${WRKSRC}/dist/Embed && ${FIND} -s * -type f -o -type l | \
|
||||
${SED} -e 's:^:lib/mozilla-embedded-vendor/:' >> ${PLIST} \
|
||||
&& ${FIND} -d * -type d | \
|
||||
${SED} -e 's:^:@dirrm lib/mozilla-embedded-vendor/:' >> ${PLIST}
|
||||
${ECHO_CMD} @dirrm lib/mozilla-embedded-vendor >> ${PLIST}
|
||||
|
||||
do-install:
|
||||
${MKDIR} ${PREFIX}/lib/mozilla-embedded-vendor
|
||||
${CHMOD} 755 ${PREFIX}/lib/mozilla-embedded-vendor
|
||||
cd ${WRKSRC}/dist/Embed && ${FIND} . | \
|
||||
cpio -pdm -L -R ${LIBOWN}:${LIBGRP} ${PREFIX}/lib/mozilla-embedded-vendor
|
||||
|
||||
.include <bsd.port.mk>
|
|
@ -1,3 +0,0 @@
|
|||
The embeddable component of mozilla communicator web-surfboard.
|
||||
|
||||
WWW: http://www.mozilla.org/
|
|
@ -1,53 +0,0 @@
|
|||
# New ports collection makefile for: mozilla-headers
|
||||
# Date created: 1 February 2001
|
||||
# Whom: Maxim Sobolev <sobomax@FreeBSD.org>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= mozilla-headers
|
||||
PORTVERSION= ${MAKE} -V PORTVERSION -f ${MAINDIR}/${MKFILE}
|
||||
PORTREVISION= ${MAKE} -V PORTREVISION -f ${MAINDIR}/${MKFILE}
|
||||
PORTEPOCH= ${MAKE} -V PORTEPOCH -f ${MAINDIR}/${MKFILE}
|
||||
CATEGORIES= www
|
||||
DISTFILES=
|
||||
|
||||
MAINTAINER= sobomax@FreeBSD.org
|
||||
COMMENT= Header files for mozilla communicator web-surfboard
|
||||
|
||||
BUILD_DEPENDS= ${NONEXISTENT}:${PORTSDIR}/www/mozilla-vendor:configure
|
||||
|
||||
USE_X_PREFIX= yes
|
||||
|
||||
LATEST_LINK= mozilla-headers-vendor
|
||||
PLIST= ${WRKSRC}/pkg-plist
|
||||
MAINDIR= ${.CURDIR}/../mozilla-vendor
|
||||
MKFILE!= /usr/bin/basename ${MAKEFILE}
|
||||
PORTVERSION!= ${PORTVERSION}
|
||||
PORTREVISION!= ${PORTREVISION}
|
||||
PORTEPOCH!= ${PORTEPOCH}
|
||||
WRKSRC= ${WRKDIRPREFIX}${MAINDIR}/work/mozilla
|
||||
USE_GMAKE= yes
|
||||
ALL_TARGET= export
|
||||
|
||||
.if defined(INCOWN) || defined(INCGRP)
|
||||
CPIOOWN= -R ${INCOWN}:${INCGRP}
|
||||
.endif
|
||||
|
||||
pre-install:
|
||||
${RM} -f ${PLIST}
|
||||
${TOUCH} -f ${PLIST}
|
||||
cd ${WRKSRC}/dist/include && ${FIND} -s * -type f -o -type l | \
|
||||
${SED} -e 's:^:include/mozilla-vendor/:' >> ${PLIST} \
|
||||
&& ${FIND} -d * -type d | \
|
||||
${SED} -e 's:^:@dirrm include/mozilla-vendor/:' >> ${PLIST}
|
||||
${ECHO_CMD} @dirrm include/mozilla-vendor >> ${PLIST}
|
||||
|
||||
do-install:
|
||||
-${RM} -fr ${PREFIX}/include/mozilla-vendor
|
||||
${MKDIR} ${PREFIX}/include/mozilla-vendor
|
||||
${CHMOD} 755 ${PREFIX}/include/mozilla-vendor
|
||||
cd ${WRKSRC}/dist/include && ${FIND} . | \
|
||||
cpio -pdm -L ${CPIOOWN} ${PREFIX}/include/mozilla-vendor
|
||||
|
||||
.include <bsd.port.mk>
|
|
@ -1,3 +0,0 @@
|
|||
Header files for mozilla communicator web-surfboard.
|
||||
|
||||
WWW: http://www.mozilla.org/
|
|
@ -1,166 +0,0 @@
|
|||
# New ports collection makefile for: mozilla
|
||||
# Date created: 31 Mar 1998
|
||||
# Whom: eivind/dima/jseger
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= mozilla
|
||||
PORTVERSION= 1.0.2
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= www
|
||||
MASTER_SITES= ${MASTER_SITE_MOZILLA} \
|
||||
${MASTER_SITE_LOCAL:S/$/:local/}
|
||||
MASTER_SITE_SUBDIR= mozilla/releases/${PORTNAME}${PORTVERSION:S/.rc/rc/}/src \
|
||||
marcus/:local
|
||||
DISTFILES= ${PORTNAME}-source-${PORTVERSION:S/.rc/rc/}${EXTRACT_SUFX} \
|
||||
libart_lgpl-${PORTVERSION}${EXTRACT_SUFX}:local
|
||||
|
||||
MAINTAINER= gnome@FreeBSD.org
|
||||
COMMENT= The open source, standards compliant web browser
|
||||
|
||||
BUILD_DEPENDS= zip:${PORTSDIR}/archivers/zip \
|
||||
freetype-config:${PORTSDIR}/print/freetype2
|
||||
LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
|
||||
png.5:${PORTSDIR}/graphics/png \
|
||||
mng.1:${PORTSDIR}/graphics/libmng \
|
||||
freetype.9:${PORTSDIR}/print/freetype2
|
||||
|
||||
WRKSRC= ${WRKDIR}/${PORTNAME}
|
||||
|
||||
WITHOUT_CHATZILLA= "Contains a buffer overflow reported at http://online.securityfocus.com/archive/1/270249"
|
||||
|
||||
LATEST_LINK= mozilla-vendor
|
||||
USE_BZIP2= yes
|
||||
EXTRACT_AFTER_ARGS= | ${TAR} -xf - --exclude */CVS/* \
|
||||
--exclude */macbuild/*\
|
||||
--exclude */package/* \
|
||||
--exclude .cvsignore \
|
||||
--exclude makefile.win \
|
||||
--exclude MANIFEST
|
||||
|
||||
USE_X_PREFIX= yes
|
||||
USE_PERL5= yes
|
||||
USE_GMAKE= yes
|
||||
USE_GNOME= orbit gtk12
|
||||
USE_REINPLACE= yes
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ARGS= \
|
||||
--disable-auto-deps \
|
||||
--enable-chrome-format=jar \
|
||||
--disable-cpp-exceptions \
|
||||
--disable-cpp-rtti \
|
||||
--enable-crypto \
|
||||
--disable-debug \
|
||||
--enable-default-toolkit=gtk \
|
||||
--enable-double-buffer \
|
||||
--enable-mathml \
|
||||
--disable-md \
|
||||
--disable-pedantic \
|
||||
--disable-plaintext-editor-only \
|
||||
--enable-strip \
|
||||
--enable-svg \
|
||||
--disable-tests \
|
||||
--disable-xterm-updates \
|
||||
--enable-xinerama \
|
||||
--with-system-jpeg=${LOCALBASE} \
|
||||
--with-system-mng=${LOCALBASE} \
|
||||
--with-system-png=${LOCALBASE} \
|
||||
--with-pthreads
|
||||
|
||||
PLIST= ${WRKSRC}/pkg-plist
|
||||
# LDAP is only used by mail and news so disable both together
|
||||
.if defined(WITHOUT_MAILNEWS)
|
||||
CONFIGURE_ARGS+= --disable-ldap --disable-mailnews
|
||||
.else
|
||||
# mail and news desired, but not LDAP
|
||||
.if defined(WITHOUT_LDAP)
|
||||
CONFIGURE_ARGS+= --disable-ldap --enable-mailnews
|
||||
.else
|
||||
CONFIGURE_ARGS+= --enable-ldap --enable-mailnews
|
||||
.endif
|
||||
.endif
|
||||
|
||||
.if !defined(WITHOUT_CHATZILLA)
|
||||
CONFIGURE_ARGS+= --enable-extensions=default,irc,xmlterm
|
||||
.else
|
||||
CONFIGURE_ARGS+= --enable-extensions=default,xmlterm
|
||||
.endif
|
||||
CONFIGURE_ENV= MOZ_INTERNAL_LIBART_LGPL=1
|
||||
|
||||
.if defined(WITH_JAVASCRIPT_DEBUGGER)
|
||||
CONFIGURE_ARGS+= --enable-jsd \
|
||||
--enable-dtd-debug
|
||||
.endif
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
MAKE_ENV= LD_LIBRARY_PATH=${WRKSRC}/dist/bin \
|
||||
MOZ_INTERNAL_LIBART_LGPL=1
|
||||
ALL_TARGET= default
|
||||
|
||||
.if ${ARCH} == "i386"
|
||||
CONFIGURE_ARGS+= --enable-reorder
|
||||
.endif
|
||||
|
||||
.if ${ARCH} == "alpha"
|
||||
BROKEN= "core dumps on alpha during post-build"
|
||||
.endif
|
||||
|
||||
.if exists(${LOCALBASE}/include/freetype/freetype.h)
|
||||
BROKEN="You must upgrade your freetype port to 1.3.1_2 or higher before installing Mozilla. If you have 1.3.1_2 installed, please remove ${LOCALBASE}/include/freetype, then build Mozilla"
|
||||
.endif
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g' \
|
||||
${WRKSRC}/build/unix/run-mozilla.sh
|
||||
|
||||
post-build:
|
||||
${SED} -e "s|%%PREFIX%%|${PREFIX}|g" \
|
||||
${FILESDIR}/mozilla.sh >${WRKSRC}/mozilla-vendor
|
||||
(cd ${WRKSRC}/dist/bin; \
|
||||
${SETENV} LD_LIBRARY_PATH=. MOZILLA_FIVE_HOME=. ./regxpcom; \
|
||||
${ECHO_CMD} skin,install,select,classic/1.0 >> chrome/installed-chrome.txt; \
|
||||
${ECHO_CMD} locale,install,select,en-US >> chrome/installed-chrome.txt; \
|
||||
${SETENV} LD_LIBRARY_PATH=. MOZILLA_FIVE_HOME=. ./regchrome)
|
||||
${FIND} ${WRKSRC}/dist/bin -type d | /usr/bin/sort -r | \
|
||||
${XARGS} ${RMDIR} 2> /dev/null || ${TRUE}
|
||||
|
||||
pre-install:
|
||||
${RM} -f ${PLIST}
|
||||
${TOUCH} -f ${PLIST}
|
||||
if [ ! -x ${PREFIX}/bin/mozilla -a ! -L ${PREFIX}/bin/mozilla ]; then \
|
||||
${ECHO_CMD} bin/mozilla >> ${PLIST} ; \
|
||||
fi
|
||||
${ECHO_CMD} bin/mozilla-vendor >> ${PLIST}
|
||||
if [ ! -L ${PREFIX}/lib/browser_plugins/libjavaplugin_oji.so ]; then \
|
||||
${ECHO_CMD} lib/browser_plugins/libjavaplugin_oji.so >> ${PLIST} ; \
|
||||
${ECHO_CMD} @dirrm lib/browser_plugins >> ${PLIST} ; \
|
||||
fi
|
||||
cd ${WRKSRC}/dist/bin && ${FIND} -s * -type f -o -type l | \
|
||||
${SED} -e 's:^:lib/mozilla-vendor/:' >> ${PLIST} \
|
||||
&& ${FIND} -d * -type d | \
|
||||
${SED} -e 's:^:@dirrm lib/mozilla-vendor/:' >> ${PLIST}
|
||||
${ECHO_CMD} @dirrm lib/mozilla-vendor >> ${PLIST}
|
||||
|
||||
do-install:
|
||||
${MKDIR} ${PREFIX}/lib/mozilla-vendor
|
||||
${CHMOD} 755 ${PREFIX}/lib/mozilla-vendor
|
||||
cd ${WRKSRC}/dist/bin && ${FIND} . | \
|
||||
cpio -pdm -L -R ${LIBOWN}:${LIBGRP} ${PREFIX}/lib/mozilla-vendor
|
||||
${INSTALL_SCRIPT} ${WRKSRC}/mozilla-vendor ${PREFIX}/bin
|
||||
if [ ! -x ${PREFIX}/bin/mozilla -a ! -L ${PREFIX}/bin/mozill ]; then \
|
||||
${LN} -sf ${PREFIX}/bin/mozilla-vendor ${PREFIX}/bin/mozilla ; \
|
||||
fi
|
||||
if [ ! -d ${PREFIX}/lib/browser_plugins ]; then \
|
||||
${MKDIR} ${PREFIX}/lib/browser_plugins ; \
|
||||
fi
|
||||
if [ ! -L ${PREFIX}/lib/browser_plugins/libjavaplugin_oji.so ]; then \
|
||||
${LN} -sf ${LOCALBASE}/jdk1.3.1/jre/plugin/i386/ns600/libjavaplugin_oji.so \
|
||||
${PREFIX}/lib/browser_plugins/libjavaplugin_oji.so ; \
|
||||
fi
|
||||
|
||||
post-install:
|
||||
@${CAT} ${PKGMESSAGE}
|
||||
|
||||
.include <bsd.port.post.mk>
|
|
@ -1,2 +0,0 @@
|
|||
MD5 (mozilla-source-1.0.2.tar.bz2) = 5a7da5cd31005f1b1286f3d8a6b8137c
|
||||
MD5 (libart_lgpl-1.0.2.tar.bz2) = f332c3c026adc1c2c0ceb3ac5847d5f5
|
|
@ -1,27 +0,0 @@
|
|||
#!/bin/sh
|
||||
|
||||
MOZILLA_DIR="%%PREFIX%%/lib/mozilla-vendor"
|
||||
MOZILLA_EXEC="mozilla"
|
||||
LOCATION='new-tab'
|
||||
|
||||
cd $MOZILLA_DIR || exit 1
|
||||
|
||||
case $1 in
|
||||
-mail)
|
||||
REMOTE_COMMAND="xfeDoCommand (openInbox)"
|
||||
;;
|
||||
-*)
|
||||
exec ./$MOZILLA_EXEC "$@"
|
||||
;;
|
||||
*)
|
||||
REMOTE_COMMAND="openURL($@, $LOCATION)"
|
||||
;;
|
||||
esac
|
||||
|
||||
# process found
|
||||
./$MOZILLA_EXEC -remote "ping()" &&
|
||||
./$MOZILLA_EXEC -remote "$REMOTE_COMMAND" && exit 0
|
||||
|
||||
# no existing process
|
||||
exec ./$MOZILLA_EXEC "$@"
|
||||
|
|
@ -1,25 +0,0 @@
|
|||
|
||||
$FreeBSD$
|
||||
|
||||
--- Makefile.in 2001/12/25 21:00:23 1.1
|
||||
+++ Makefile.in 2001/12/26 06:40:16
|
||||
@@ -64,8 +64,7 @@
|
||||
DIRS = $(NSPRPUB_DIR) \
|
||||
$(tier_0_dirs) \
|
||||
$(tier_1_dirs) \
|
||||
- $(tier_9_dirs) \
|
||||
- $(NULL)
|
||||
+ $(tier_9_dirs)
|
||||
|
||||
ifdef MOZ_LDAP_XPCOM
|
||||
DIRS += directory/c-sdk/ldap
|
||||
@@ -81,7 +80,8 @@
|
||||
DIRS += $(tier_98_dirs)
|
||||
endif
|
||||
|
||||
-DIRS += $(tier_99_dirs)
|
||||
+DIRS += $(tier_99_dirs) \
|
||||
+ $(NULL)
|
||||
|
||||
#
|
||||
# tier 0 - base build config dirs
|
|
@ -1,30 +0,0 @@
|
|||
--- build/unix/run-mozilla.sh.orig Wed Oct 23 00:40:21 2002
|
||||
+++ build/unix/run-mozilla.sh Wed Oct 23 00:41:01 2002
|
||||
@@ -355,7 +355,7 @@
|
||||
fi
|
||||
##
|
||||
## Set LD_LIBRARY_PATH
|
||||
-LD_LIBRARY_PATH=${MOZ_DIST_BIN}:${MOZ_DIST_BIN}/plugins:${MRE_HOME}${LD_LIBRARY_PATH+":$LD_LIBRARY_PATH"}
|
||||
+LD_LIBRARY_PATH=${MOZ_DIST_BIN}:${MOZ_DIST_BIN}/plugins:%%PREFIX%%/lib/browser_plugins:${MRE_HOME}${LD_LIBRARY_PATH+":$LD_LIBRARY_PATH"}
|
||||
if [ -n "$LD_LIBRARYN32_PATH" ]
|
||||
then
|
||||
LD_LIBRARYN32_PATH=${MOZ_DIST_BIN}:${MOZ_DIST_BIN}/plugins:${MRE_HOME}${LD_LIBRARYN32_PATH+":$LD_LIBRARYN32_PATH"}
|
||||
@@ -392,7 +392,7 @@
|
||||
export XSUNTRANSPORT XSUNSMESIZE
|
||||
fi
|
||||
# Font path for Xft
|
||||
-FONTCONFIG_PATH="/etc/fonts:${MOZILLA_FIVE_HOME}/res/Xft"
|
||||
+FONTCONFIG_PATH="%%PREFIX%%/etc/fonts:${MOZILLA_FIVE_HOME}/res/Xft"
|
||||
export FONTCONFIG_PATH
|
||||
|
||||
if [ "$moz_debug" -eq 1 ]
|
||||
@@ -426,6 +426,9 @@
|
||||
#
|
||||
export MOZILLA_FIVE_HOME LD_LIBRARY_PATH
|
||||
export SHLIB_PATH LIBPATH LIBRARY_PATH ADDON_PATH DYLD_LIBRARY_PATH
|
||||
+
|
||||
+MOZ_PLUGIN_PATH=%%PREFIX%%/lib/browser_plugins
|
||||
+export MOZ_PLUGIN_PATH
|
||||
|
||||
if [ $moz_debug -eq 1 ]
|
||||
then
|
|
@ -1,15 +0,0 @@
|
|||
--- config/rules.mk.orig Thu Jun 13 07:00:30 2002
|
||||
+++ config/rules.mk Sat Jan 25 16:48:21 2003
|
||||
@@ -467,6 +467,12 @@
|
||||
endif
|
||||
endif
|
||||
|
||||
+ifeq ($(OS_ARCH),FreeBSD)
|
||||
+ifdef IS_COMPONENT
|
||||
+EXTRA_DSO_LDOPTS += -Wl,-Bsymbolic
|
||||
+endif
|
||||
+endif
|
||||
+
|
||||
ifeq ($(OS_ARCH),NetBSD)
|
||||
ifneq (,$(filter arc cobalt hpcmips mipsco newsmips pmax sgimips,$(OS_TEST)))
|
||||
ifeq ($(MODULE),layout)
|
|
@ -1,32 +0,0 @@
|
|||
|
||||
$FreeBSD$
|
||||
|
||||
--- embedding/config/basebrowser-unix.orig Thu Feb 7 23:50:19 2002
|
||||
+++ embedding/config/basebrowser-unix Tue Mar 12 17:06:08 2002
|
||||
@@ -119,6 +119,7 @@
|
||||
|
||||
; layout
|
||||
components/libgkcontent.so
|
||||
+libmoz_art_lgpl.so
|
||||
res/dtd/*
|
||||
components/libgklayout.so
|
||||
components/libhtmlpars.so
|
||||
@@ -203,12 +204,12 @@
|
||||
components/unicharutil.xpt
|
||||
components/libchardet.so
|
||||
; optional - on english only systems
|
||||
-; components/libucvja.so for japanese
|
||||
-; components/libucvko.so for korean
|
||||
-; components/libucvcn.so for simplified chinese
|
||||
-; components/libucvtw.so for traditional chinese
|
||||
-; components/libucvtw2.so for traditional chinese
|
||||
-; components/libucvibm.so for ibm
|
||||
+components/libucvja.so
|
||||
+components/libucvko.so
|
||||
+components/libucvcn.so
|
||||
+components/libucvtw.so
|
||||
+components/libucvtw2.so
|
||||
+components/libucvibm.so
|
||||
|
||||
|
||||
res/language.properties
|
|
@ -1,14 +0,0 @@
|
|||
|
||||
$FreeBSD$
|
||||
|
||||
--- modules/libpref/src/unix/unix.js 2002/03/14 15:04:20 1.1
|
||||
+++ modules/libpref/src/unix/unix.js 2002/03/14 15:04:38
|
||||
@@ -227,7 +227,7 @@
|
||||
|
||||
// TrueType
|
||||
pref("font.FreeType2.enable", false);
|
||||
-pref("font.freetype2.shared-library", "libfreetype.so.6");
|
||||
+pref("font.freetype2.shared-library", "libfreetype.so.9");
|
||||
// if libfreetype was built without hinting compiled in
|
||||
// it is best to leave hinting off
|
||||
pref("font.FreeType2.autohinted", false);
|
|
@ -1,22 +0,0 @@
|
|||
Index: nsprpub/pr/src/pthreads/ptio.c
|
||||
diff -u nsprpub/pr/src/pthreads/ptio.c.orig nsprpub/pr/src/pthreads/ptio.c
|
||||
--- nsprpub/pr/src/pthreads/ptio.c.orig Fri Apr 12 03:14:39 2002
|
||||
+++ nsprpub/pr/src/pthreads/ptio.c Tue Jul 30 18:52:11 2002
|
||||
@@ -3414,6 +3414,17 @@
|
||||
if (osfd == -1) pt_MapError(_PR_MD_MAP_SOCKET_ERROR, errno);
|
||||
else
|
||||
{
|
||||
+#if (defined(_PR_INET6_PROBE) || defined(_PR_INET6)) && \
|
||||
+ defined(__FreeBSD__) && defined(IPV6_V6ONLY)
|
||||
+ if (domain == PR_AF_INET6) {
|
||||
+ int opt = 0;
|
||||
+ if (setsockopt(osfd, IPPROTO_IPV6, IPV6_V6ONLY,
|
||||
+ &opt, sizeof(opt))) {
|
||||
+ close(osfd);
|
||||
+ return NULL;
|
||||
+ }
|
||||
+ }
|
||||
+#endif
|
||||
fd = pt_SetMethods(osfd, ftype, PR_FALSE, PR_FALSE);
|
||||
if (fd == NULL) close(osfd);
|
||||
}
|
|
@ -1,36 +0,0 @@
|
|||
--- configure.orig Wed May 8 22:24:05 2002
|
||||
+++ configure Mon May 13 01:18:53 2002
|
||||
@@ -7489,7 +7489,7 @@
|
||||
EOF
|
||||
|
||||
if test "$ac_cv_have_dash_pthread" = "yes"; then
|
||||
- _PTHREAD_LDFLAGS=""
|
||||
+ _PTHREAD_LDFLAGS="-pthread"
|
||||
else
|
||||
_PTHREAD_LDFLAGS="-lc_r"
|
||||
fi
|
||||
@@ -9967,7 +9967,7 @@
|
||||
fi
|
||||
MOC=$HOST_MOC
|
||||
|
||||
- QT_CFLAGS="-I${QTDIR}${QTINCDIR} -DQT_GENUINE_STR"
|
||||
+ QT_CFLAGS="-I${QTDIR}/include/X11/qt -DQT_GENUINE_STR"
|
||||
QT_LIBS="-L/usr/X11R6/lib -L${QTDIR}/lib -lqt -lXext -lX11"
|
||||
|
||||
# Check whether --with-static-qt or --without-static-qt was given.
|
||||
@@ -10836,13 +10836,13 @@
|
||||
|
||||
|
||||
|
||||
-MOZ_EXTENSIONS_DEFAULT=" cookie wallet content-packs xml-rpc xmlextras help pref transformiix venkman inspector irc universalchardet"
|
||||
+MOZ_EXTENSIONS_DEFAULT=" cookie wallet content-packs xml-rpc xmlextras help pref transformiix venkman inspector universalchardet"
|
||||
|
||||
if test -n "$SUNCTL"; then
|
||||
MOZ_EXTENSIONS_DEFAULT="$MOZ_EXTENSIONS_DEFAULT ctl"
|
||||
fi
|
||||
|
||||
-MOZ_EXTENSIONS_ALL="$MOZ_EXTENSIONS_DEFAULT xmlterm access-builtin ctl p3p interfaceinfo"
|
||||
+MOZ_EXTENSIONS_ALL="$MOZ_EXTENSIONS_DEFAULT irc xmlterm access-builtin ctl p3p interfaceinfo"
|
||||
|
||||
# Check whether --enable-extensions or --disable-extensions was given.
|
||||
if test "${enable_extensions+set}" = set; then
|
|
@ -1,25 +0,0 @@
|
|||
|
||||
$FreeBSD$
|
||||
|
||||
--- security/coreconf/FreeBSD.mk.orig Sat Mar 9 00:17:36 2002
|
||||
+++ security/coreconf/FreeBSD.mk Tue Mar 12 17:19:15 2002
|
||||
@@ -35,9 +35,7 @@
|
||||
|
||||
include $(CORE_DEPTH)/coreconf/UNIX.mk
|
||||
|
||||
-DEFAULT_COMPILER = gcc
|
||||
-CC = gcc
|
||||
-CCC = g++
|
||||
+CCC = ${CXX}
|
||||
RANLIB = ranlib
|
||||
|
||||
ifeq ($(OS_TEST),alpha)
|
||||
@@ -70,7 +68,7 @@
|
||||
DLL_SUFFIX = so.1.0
|
||||
endif
|
||||
|
||||
-MKSHLIB = $(CC) $(DSO_LDOPTS)
|
||||
+MKSHLIB = $(CC) $(DSO_LDOPTS) -o $@
|
||||
ifdef MAPFILE
|
||||
# Add LD options to restrict exported symbols to those in the map file
|
||||
endif
|
|
@ -1,13 +0,0 @@
|
|||
This is the open source web browser, which forms the basis for
|
||||
Netscape Navigator 6 and higher. It should be fully compliant with all W3C
|
||||
standards, including HTML, CSS, XML, XSL, JavaScript, MathML,
|
||||
SVG and RDF. This version also supports SSL encryption, and Java
|
||||
and Java with the use of the FreeBSD native Java plug-in.
|
||||
|
||||
This version of mozilla is used by other vendors for browser development.
|
||||
It contains many fixes for security, stability, and dataloss as well
|
||||
as some performance problems. If you want the most stable release of
|
||||
Mozilla with no new features from version to version, this is the port to
|
||||
install.
|
||||
|
||||
WWW: http://www.mozilla.org/
|
|
@ -1,9 +0,0 @@
|
|||
###
|
||||
A symlink has been created for the Java plugin. However, in order for Java
|
||||
to function, you must first install the java/jdk13 port. If you do not
|
||||
do this, you will see the following error when starting Mozilla:
|
||||
|
||||
LoadPlugin: failed to initialize shared library /usr/local/jdk1.3.1/jre/plugin/i386/ns600/libjavaplugin_oji.so [Cannot open "/usr/local/jdk1.3.1/jre/plugin/i386/ns600/libjavaplugin_oji.so"]
|
||||
|
||||
If you do not want Java support, you can safely ignore this message.
|
||||
###
|
Loading…
Reference in a new issue