A graphical front end to the debugger present in the Bochs emulator.
Reviewed by: jim, jedgar
This commit is contained in:
parent
2928c0e737
commit
b308b2590e
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=25419
6 changed files with 56 additions and 0 deletions
31
emulators/bfe/Makefile
Normal file
31
emulators/bfe/Makefile
Normal file
|
@ -0,0 +1,31 @@
|
|||
# New ports collection makefile for: bfe
|
||||
# Version required: 991102
|
||||
# Date created: 02 February 2000
|
||||
# Whom: jhb
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
DISTNAME= bfe-${DATE}
|
||||
CATEGORIES= emulators
|
||||
MASTER_SITES= http://www.qzx.com/bfe/
|
||||
EXTRACT_SUFX= .tgz
|
||||
|
||||
MAINTAINER= jhb@FreeBSD.org
|
||||
|
||||
LIB_DEPENDS= xforms.0:${PORTSDIR}/x11-toolkits/xforms
|
||||
RUN_DEPENDS= bochs:${PORTSDIR}/emulators/bochs
|
||||
|
||||
USE_X_PREFIX= yes
|
||||
|
||||
DATE= 991102
|
||||
|
||||
WRKSRC= ${WRKDIR}/bfe
|
||||
|
||||
do-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/bfe ${PREFIX}/bin
|
||||
-@${MKDIR} ${PREFIX}/share/bfe
|
||||
${INSTALL_DATA} ${WRKSRC}/.bferc ${PREFIX}/share/bfe/bferc.sample
|
||||
${INSTALL_DATA} ${WRKSRC}/README.bferc ${PREFIX}/share/bfe
|
||||
|
||||
.include <bsd.port.mk>
|
1
emulators/bfe/distinfo
Normal file
1
emulators/bfe/distinfo
Normal file
|
@ -0,0 +1 @@
|
|||
MD5 (bfe-991102.tgz) = c4650d6509045558933d86d4982e497a
|
13
emulators/bfe/files/patch-aa
Normal file
13
emulators/bfe/files/patch-aa
Normal file
|
@ -0,0 +1,13 @@
|
|||
--- Makefile.orig Tue Oct 26 16:56:41 1999
|
||||
+++ Makefile Wed Feb 2 15:00:38 2000
|
||||
@@ -3,8 +3,8 @@
|
||||
CC = gcc
|
||||
LD = $(CC)
|
||||
CFLAGS = -O2 -Wall
|
||||
-LIBS = -L/usr/X11/lib -L/usr/local/lib -lX11 -lforms -lm
|
||||
-INCS = -I/usr/X11R6/include
|
||||
+LIBS = -L${X11BASE}/lib -L${PREFIX}/lib -lX11 -lxforms -lm
|
||||
+INCS = -I${X11BASE}/include
|
||||
|
||||
OBJS = globals.o pointer.o popen2.o parse.o updates.o buttons.o structures.o main.o
|
||||
PROG = bfe
|
1
emulators/bfe/pkg-comment
Normal file
1
emulators/bfe/pkg-comment
Normal file
|
@ -0,0 +1 @@
|
|||
X11 GUI for the bochs debugger
|
6
emulators/bfe/pkg-descr
Normal file
6
emulators/bfe/pkg-descr
Normal file
|
@ -0,0 +1,6 @@
|
|||
Bochs Frontend is a graphical interface for X11 to the bochs x86 emulator.
|
||||
|
||||
WWW: http://www.qzx.com/bfe/
|
||||
|
||||
- John
|
||||
jhb@FreeBSD.org
|
4
emulators/bfe/pkg-plist
Normal file
4
emulators/bfe/pkg-plist
Normal file
|
@ -0,0 +1,4 @@
|
|||
bin/bfe
|
||||
share/bfe/bferc.sample
|
||||
share/bfe/README.bferc
|
||||
@dirrm share/bfe
|
Loading…
Reference in a new issue