- Allow to work with php5.3.X

PR:		148009
Submitted by:	olli hauer <ohauer@gmx.de>
This commit is contained in:
Martin Wilke 2010-07-12 06:39:53 +00:00
parent cdd7cff9d6
commit b316d4c9ec
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=257663
2 changed files with 32 additions and 2 deletions

View file

@ -7,7 +7,7 @@
PORTNAME= Image_Graph
PORTVERSION= 0.7.2
PORTREVISION= 2
PORTREVISION= 3
CATEGORIES= graphics www pear
MAINTAINER= miwi@FreeBSD.org
@ -19,6 +19,7 @@ RUN_DEPENDS= ${PEARDIR}/Log.php:${PORTSDIR}/sysutils/pear-Log \
USE_PHP= yes
USE_DOS2UNIX= yes
DOS2UNIX_REGEX= .*php$$
CATEGORY= Image
FILES= Graph.php Graph/Axis.php Graph/Common.php Graph/Config.php \
@ -179,9 +180,27 @@ post-patch:
.if ${PHP_VER} != 4
.for file in ${FILES}
@if ${ECHO_CMD} ${file} | ${GREP} -q -e "php$$" ; then \
${REINPLACE_CMD} -e 's|parent::Image[^(]*|parent::__construct|' ${WRKSRC}/${file}; \
${REINPLACE_CMD} -e 's|parent::Image[^(]*|parent::__construct|' \
-e 's|PHP versions 4 and 5|PHP version 5|' ${WRKSRC}/${file}; \
fi
.endfor
# fix PHP Deprecated messages
# - Assigning the return value of new by reference
# - Call-time pass-by-reference has been deprecated
.for file in ${DOCS}
@if ${ECHO_CMD} ${file} | ${GREP} -q -e "php$$" ; then \
${REINPLACE_CMD} -e 's|=& |= |g' -e 's| &\$$| \$$|g' \
${WRKSRC}/docs/${file}; \
fi
.endfor
.for file in ${TESTS}
@if ${ECHO_CMD} ${file} | ${GREP} -q -e "php$$" ; then \
${REINPLACE_CMD} -e 's|PHP versions 4 and 5|PHP version 5|' \
${WRKSRC}/tests/${file}; \
fi
.endfor
@${REINPLACE_CMD} -e 's|=& new|= new|g' ${WRKSRC}/Graph.php
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-Graph__Layout.php
.endif
.include "${PORTSDIR}/devel/pear/bsd.pear.mk"

View file

@ -0,0 +1,11 @@
--- ./Graph/Layout.php.orig 2010-06-14 17:05:41.000000000 +0200
+++ ./Graph/Layout.php 2010-06-14 17:06:24.000000000 +0200
@@ -175,7 +175,7 @@
function _push($edge, $size = '100%')
{
$result = array();
- if (ereg("([0-9]*)\%", $size, $result)) {
+ if (preg_match("/([0-9]*)\%/", $size, $result)) {
$this->_alignSize[$edge] = array(
'value' => min(100, max(0, $result[1])),
'unit' => 'percentage'