Fix build error with gcc-4.2.
PR: ports/120606 Submitted by: NAKAJI Hiroyuki <nakaji@jp.freebsd.org>
This commit is contained in:
parent
e619ebaa0c
commit
b31beba8fc
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=209630
4 changed files with 55 additions and 4 deletions
|
@ -24,10 +24,6 @@ USE_LDCONFIG= yes
|
|||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if ${OSVERSION} >= 700042
|
||||
BROKEN= Broken with gcc 4.2
|
||||
.endif
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e 's,/usr/X11R6,${X11BASE},g' \
|
||||
${WRKSRC}/config/Project.tmpl \
|
||||
|
|
12
japanese/Wnn7-lib/files/patch-Wnn_etc_bdic.c
Normal file
12
japanese/Wnn7-lib/files/patch-Wnn_etc_bdic.c
Normal file
|
@ -0,0 +1,12 @@
|
|||
--- Wnn/etc/bdic.c.orig 2007-11-11 17:46:42.000000000 +0900
|
||||
+++ Wnn/etc/bdic.c 2007-11-11 17:47:41.000000000 +0900
|
||||
@@ -1015,9 +1015,6 @@
|
||||
#ifdef WNN_CHECK_INODE
|
||||
static
|
||||
#else
|
||||
-#ifdef JS
|
||||
-static
|
||||
-#endif
|
||||
#endif
|
||||
int
|
||||
change_file_uniq1(ofpter, file_type, file_passwd, file_uniq)
|
20
japanese/Wnn7-lib/files/patch-Wnn_jlib_jl.c
Normal file
20
japanese/Wnn7-lib/files/patch-Wnn_jlib_jl.c
Normal file
|
@ -0,0 +1,20 @@
|
|||
--- Wnn/jlib/jl.c.orig 2007-11-11 17:47:05.000000000 +0900
|
||||
+++ Wnn/jlib/jl.c 2007-11-11 17:47:24.000000000 +0900
|
||||
@@ -143,6 +143,8 @@
|
||||
#include "commonhd.h"
|
||||
#include "config.h"
|
||||
#include <stdio.h>
|
||||
+#include <stdlib.h>
|
||||
+#include <string.h>
|
||||
#include <sys/types.h>
|
||||
#ifdef SYSVR2
|
||||
# include <string.h>
|
||||
@@ -734,7 +736,7 @@
|
||||
js_close(js_id);
|
||||
}
|
||||
|
||||
-static void
|
||||
+void
|
||||
jl_disconnect_if_server_dead_body_by_jsid(jsid)
|
||||
register WNN_JSERVER_ID *jsid;
|
||||
{
|
23
japanese/Wnn7-lib/files/patch-Wnn_jlib_js.c
Normal file
23
japanese/Wnn7-lib/files/patch-Wnn_jlib_js.c
Normal file
|
@ -0,0 +1,23 @@
|
|||
--- Wnn/jlib/js.c.orig 2007-11-11 17:46:58.000000000 +0900
|
||||
+++ Wnn/jlib/js.c 2007-11-11 17:47:59.000000000 +0900
|
||||
@@ -159,9 +159,9 @@
|
||||
*/
|
||||
|
||||
|
||||
-extern char *malloc();
|
||||
-
|
||||
#include <stdio.h>
|
||||
+#include <stdlib.h>
|
||||
+#include <string.h>
|
||||
#include <ctype.h>
|
||||
#ifdef UX386
|
||||
#include <X11/Xos.h>
|
||||
@@ -199,8 +199,6 @@
|
||||
#include "../etc/pwd.c"
|
||||
|
||||
|
||||
-char *malloc();
|
||||
-
|
||||
typedef struct _host_address {
|
||||
int address_len;
|
||||
char *address;
|
Loading…
Reference in a new issue