- Update to version 1.1.10.r2

PR:		ports/64995
Submitted by:	maintainer
This commit is contained in:
Kirill Ponomarev 2004-03-31 19:40:28 +00:00
parent d891be0545
commit b31f33a73c
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=105800
7 changed files with 47 additions and 55 deletions

View file

@ -6,11 +6,11 @@
#
PORTNAME= exult
PORTVERSION= 1.00
PORTREVISION= 3
PORTVERSION= 1.1.10.r2
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
DISTNAME= ${PORTNAME}-1.1.10rc2
MAINTAINER= tiamat@comset.net
COMMENT= Ultima VII engine
@ -18,35 +18,25 @@ COMMENT= Ultima VII engine
RUN_DEPENDS= timidity:${PORTSDIR}/audio/timidity
USE_XLIB= yes
USE_SDL= sdl
USE_SDL= sdl mixer
USE_REINPLACE= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS=-I${X11BASE}/include \
LDFLAGS="-L${X11BASE}/lib"
CONFIGURE_ARGS= --with-x \
--disable-tools \
--disable-sdltest
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
MAN6= exult.6
MAN1= expack.1 ipack.1 shp2pcx.1 splitshp.1 textpack.1
MAN6= exult.6
post-patch:
@${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${REINPLACE_CMD} -e \
's|^DEBUG_FLAGS|#DEBUG_FLAGS|g'
@${REINPLACE_CMD} -e 's|desktop||' ${WRKSRC}/Makefile.in
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/exult ${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/docs/exult.6 ${MANPREFIX}/man/man6
@${MKDIR} ${DATADIR}
.for file in exult.flx exult_bg.flx exult_si.flx midisfx.flx
${INSTALL_DATA} ${WRKSRC}/data/${file} ${DATADIR}
.endfor
.if !defined(NOPORTDOCS)
post-install:
.ifndef (NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
.for file in FAQ NEWS README
${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
.for i in FAQ NEWS README
${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
.endfor
.endif
@${SED} 's:/usr/local:${PREFIX}:g' ${PKGMESSAGE}
@${SED} -e 's|%%DOCSDIR%%|${DOCSDIR}|' <${PKGMESSAGE}
.include <bsd.port.mk>

View file

@ -1,2 +1,3 @@
MD5 (exult-1.00.tar.gz) = f560b5f98ffcbb003a79d7989a612551
MD5 (exult-1.1.10rc2.tar.gz) = 7f53d976a9448cf59dcec447f291bfb5
SIZE (exult-1.1.10rc2.tar.gz) = 1813283
SIZE (exult-1.00.tar.gz) = 1475870

View file

@ -1,11 +1,11 @@
--- files/databuf.h.orig Thu May 23 07:24:04 2002
+++ files/databuf.h Sat Aug 16 17:54:30 2003
@@ -24,6 +24,9 @@
#ifdef MACOS
# include <cassert>
--- files/databuf.h.orig Sun Aug 31 21:32:25 2003
+++ files/databuf.h Wed Mar 31 13:37:08 2004
@@ -21,7 +21,9 @@
# include <cstdio>
# include <cstring>
#endif
+#if defined(__GNUC__) && __GNUC__ >= 3
+# include <cassert>
#include <cassert>
+#endif
#include <fstream>
#include <iomanip>

View file

@ -1,10 +1,12 @@
--- files/rwregress.cc.orig Tue Feb 5 06:01:24 2002
+++ files/rwregress.cc Sat Aug 16 17:30:00 2003
@@ -6,6 +6,7 @@
--- files/rwregress.cc.orig Tue Jun 24 21:20:55 2003
+++ files/rwregress.cc Wed Mar 31 13:39:13 2004
@@ -5,7 +5,9 @@
#include <iostream>
#include "utils.h"
#include <strstream>
+#include <cassert>
+#if defined(__GNUC__) && __GNUC__ >= 3
#include <cassert>
+#endif
#include "utils.h"
using std::cout;
using std::endl;

View file

@ -1,14 +0,0 @@
*** gumps/gump_utils.h~ Mon Feb 18 12:30:14 2002
--- gumps/gump_utils.h Mon Feb 18 12:28:58 2002
***************
*** 27,32 ****
--- 27,36 ----
#include <sys/types.h>
#endif
+ #ifdef __FreeBSD__
+ #include <string.h>
+ #endif
+
#include <unistd.h>
#include "mouse.h"

View file

@ -1,4 +1,4 @@
******************************************************************************
* Original Ultima VII data is required to run Exult
* Please, read ${PREFIX}/share/doc/exult/README for additional information
* Run Exult from directory, containing original Ultima VII data.
* Please, read %%DOCSDIR%%/README for additional information.
******************************************************************************

View file

@ -1,10 +1,23 @@
bin/expack
bin/exult
%%PORTDOCS%%%%DOCSDIR%%/FAQ
%%PORTDOCS%%%%DOCSDIR%%/NEWS
%%PORTDOCS%%%%DOCSDIR%%/README
bin/shp2pcx
bin/splitshp
bin/textpack
bin/ucc
bin/ucxt
%%DATADIR%%/exult.flx
%%DATADIR%%/exult_bg.flx
%%DATADIR%%/exult_si.flx
%%DATADIR%%/exultmsg.txt
%%DATADIR%%/midisfx.flx
@dirrm %%DATADIR%%
%%DATADIR%%/u7bgintrinsics.data
%%DATADIR%%/u7misc.data
%%DATADIR%%/u7opcodes.data
%%DATADIR%%/u7siintrinsics.data
%%PORTDOCS%%%%DOCSDIR%%/FAQ
%%PORTDOCS%%%%DOCSDIR%%/NEWS
%%PORTDOCS%%%%DOCSDIR%%/README
%%PORTDOCS%%@dirrm %%DOCSDIR%%
@dirrm %%DATADIR%%/estudio/new
@dirrm %%DATADIR%%/estudio
@dirrm %%DATADIR%%