devel/autoconf: Update to 2.72

PR:		277046
Exp-run by:	antoine
This commit is contained in:
Tijl Coosemans 2024-03-06 13:57:27 +01:00
parent 47e958459b
commit b346b48002
10 changed files with 67 additions and 14 deletions

View File

@ -88,8 +88,8 @@ _INCLUDE_USES_AUTORECONF_POST_MK= yes
_AUTORECONF= 2.69
BUILD_DEPENDS+= autoconf2.69>=2.69:devel/autoconf2.69
. else
_AUTORECONF= 2.71
BUILD_DEPENDS+= autoconf>=2.71:devel/autoconf
_AUTORECONF= 2.72
BUILD_DEPENDS+= autoconf>=${_AUTORECONF}:devel/autoconf
. endif
BUILD_DEPENDS+= automake>=1.16.5:devel/automake
@ -101,6 +101,7 @@ BUILD_DEPENDS+= libtoolize:devel/libtool
# In case autoconf-switch wrapper scripts are used during build.
CONFIGURE_ENV+= DEFAULT_AUTOCONF=${_AUTORECONF}
MAKE_ENV+= DEFAULT_AUTOCONF=${_AUTORECONF}
WRK_ENV+= DEFAULT_AUTOCONF=${_AUTORECONF}
. if ${autoreconf_ARGS:Nbuild:N2.69}
IGNORE= incorrect 'USES+=autoreconf:${autoreconf_ARGS}'\

View File

@ -0,0 +1,10 @@
--- configure.ac.orig 2021-11-25 09:41:46 UTC
+++ configure.ac
@@ -11,6 +11,7 @@ AC_DEFINE_UNQUOTED(PLATFORM, "$ac_cv_host",
[the type of system on which the package will run.])
# Checks for programs.
+AC_PROG_CPP
AC_PROG_CC
AC_PROG_GCC_TRADITIONAL
AC_PROG_INSTALL

View File

@ -1,6 +1,5 @@
PORTNAME= autoconf
PORTVERSION= 2.71
PORTREVISION= 1
DISTVERSION= 2.72
CATEGORIES= devel
MASTER_SITES= GNU
@ -21,9 +20,10 @@ BUILD_DEPENDS= gm4:devel/m4
RUN_DEPENDS= autoconf-switch>=0:devel/autoconf-switch \
gm4:devel/m4
VERSION= 2.71
USES= perl5 tar:xz
VERSION= ${DISTVERSION}
GNU_CONFIGURE= yes
GNU_CONFIGURE_MANPREFIX=${PREFIX}/share
CONFIGURE_ARGS= --program-suffix=${VERSION} \

View File

@ -1,3 +1,3 @@
TIMESTAMP = 1651493393
SHA256 (autoconf-2.71.tar.xz) = f14c83cfebcc9427f2c3cea7258bd90df972d92eb26752da4ddad81c87a0faa4
SIZE (autoconf-2.71.tar.xz) = 1292296
TIMESTAMP = 1709723659
SHA256 (autoconf-2.72.tar.xz) = ba885c1319578d6c94d46e9b0dceb4014caafe2490e437a0dbca3f270a223f5a
SIZE (autoconf-2.72.tar.xz) = 1389680

View File

@ -58,4 +58,4 @@ share/man/man1/ifnames%%VERSION%%.1.gz
%%DATADIR%%/m4sugar/m4sh.m4f
%%DATADIR%%/m4sugar/m4sugar.m4
%%DATADIR%%/m4sugar/m4sugar.m4f
%%DATADIR%%/m4sugar/version.m4
%%DATADIR%%/version.m4

View File

@ -0,0 +1,18 @@
--- configure.ac.orig 2022-12-06 08:23:41 UTC
+++ configure.ac
@@ -134,13 +134,13 @@ PKG_PROG_PKG_CONFIG(0.28) # latest version in buildroo
m4_ifndef([PKG_PROG_PKG_CONFIG],
[m4_fatal([please install pkg-config >= 0.28 before running autoconf/autogen])])
PKG_PROG_PKG_CONFIG(0.28) # latest version in buildroot
-AS_IF([test -z "$PKG_CONFIG"],
+AS_IF([test -z "$PKG_CONFIG"],[
AC_MSG_ERROR([
*** pkg-config with version >= 0.28 could not be found.
***
*** Make sure it is in your path, or set the PKG_CONFIG environment variable
*** to the full path to pkg-config.])
-)
+])
# glib2?
PKG_CHECK_MODULES(GLIB,glib-2.0 >= 2.58 gobject-2.0 gio-2.0)

View File

@ -38,7 +38,7 @@ post-extract:
${INSTALL_DATA} ${WRKSRC}/mu4e/obsolete/org-mu4e.el \
${WRKSRC}/mu4e/org-mu4e.el
pre-build:
post-configure:
${REINPLACE_CMD} -e '/.el.elc/,/^$$/d' ${BUILD_WRKSRC}/Makefile && \
${ECHO_CMD} '.include "${FILESDIR}/byte-compile.mk"' \
>> ${BUILD_WRKSRC}/Makefile

View File

@ -46,8 +46,19 @@
# asan is somewhat similar to valgrind, but has low enough overhead so it
# can be used during normal operation.
@@ -143,43 +143,13 @@ AS_IF([test -z "$PKG_CONFIG"],
)
@@ -134,52 +134,22 @@ PKG_PROG_PKG_CONFIG(0.28) # latest version in buildroo
m4_ifndef([PKG_PROG_PKG_CONFIG],
[m4_fatal([please install pkg-config >= 0.28 before running autoconf/autogen])])
PKG_PROG_PKG_CONFIG(0.28) # latest version in buildroot
-AS_IF([test -z "$PKG_CONFIG"],
+AS_IF([test -z "$PKG_CONFIG"],[
AC_MSG_ERROR([
*** pkg-config with version >= 0.28 could not be found.
***
*** Make sure it is in your path, or set the PKG_CONFIG environment variable
*** to the full path to pkg-config.])
-)
+])
# glib2?
-PKG_CHECK_MODULES(GLIB,glib-2.0 >= 2.58 gobject-2.0 gio-2.0)
@ -94,7 +105,7 @@
###############################################################################
# we set the set the version of the MuStore (Xapian database) layout
# here; it will become part of the db name, so we can automatically
@@ -247,24 +217,10 @@ AC_SUBST(MU_DOC_DIR, "${prefix}/share/doc/mu")
@@ -247,24 +217,10 @@ Makefile
AC_CONFIG_FILES([
Makefile

View File

@ -0,0 +1,10 @@
--- configure.ac.orig 2016-12-16 08:05:02 UTC
+++ configure.ac
@@ -35,6 +35,7 @@ AC_PROG_CXX
AM_INIT_AUTOMAKE([1.11.1 color-tests silent-rules tar-pax no-texinfo.tex -Wall -Wno-portability])
AM_SILENT_RULES([yes])
AC_PROG_CXX
+AC_PROG_GREP
AC_PROG_INSTALL
AC_PROG_RANLIB
AC_PROG_LN_S

View File

@ -19,7 +19,7 @@ LIB_DEPENDS= liblz4.so:archivers/liblz4 \
libxxhash.so:devel/xxhash \
libzstd.so:archivers/zstd
USES= cpe python shebangfix ssl autoreconf
USES= autoreconf:build cpe python shebangfix ssl
PYTHON_NO_DEPENDS= yes
CPE_VENDOR= samba
CPE_PRODUCT= rsync
@ -94,6 +94,9 @@ post-patch:
${WRKSRC}/rsync.1 ${WRKSRC}/rsyncd.conf.5
@${REINPLACE_CMD} -e 's|/usr/bin/rsync|${PREFIX}/bin/rsync|g' ${WRKSRC}/support/rrsync
pre-configure:
@(cd ${WRKSRC} && ${SETENVI} ${WRK_ENV} ${MAKE_CMD} -f prepare-source.mak)
post-install:
@${MKDIR} ${STAGEDIR}${ETCDIR}
${INSTALL_DATA} ${FILESDIR}/rsyncd.conf.sample ${STAGEDIR}${ETCDIR}/