New port: science/atom: Program for DFT calculations in atoms

This commit is contained in:
Yuri Victorovich 2018-09-04 15:05:19 +00:00
parent ab342e2c5d
commit b34d0ab7f7
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=478966
6 changed files with 61 additions and 0 deletions

1
LEGAL
View file

@ -238,3 +238,4 @@ sas2ircu-* sysutils/sas2ircu May not be redistributed. Must accept license to d
snes9x-* emulators/snes9x-gtk Commercial users must seek permission from copyright holders.
rainloop-1.*.zip mail/rainloop Redistribution in any form is prohibited
lha-114i.tar.gz archivers/lha Binary only redistribution is prohibited. Non-network redistribution such as CDROM requires prior notification to author. Commercial use whose main purpose is to provide the functions of this program is prohibited.
atom-*.tgz science/atom Redistribution in any form is prohibited

View file

@ -26,6 +26,7 @@
SUBDIR += afni
SUBDIR += aircraft-datcom
SUBDIR += antioch
SUBDIR += atom
SUBDIR += atompaw
SUBDIR += avogadro
SUBDIR += bddsolve

39
science/atom/Makefile Normal file
View file

@ -0,0 +1,39 @@
# $FreeBSD$
PORTNAME= atom
DISTVERSION= 4.2.7-100
CATEGORIES= science
MASTER_SITES= https://departments.icmab.es/leem/siesta/Pseudopotentials/Code/ \
https://departments.icmab.es/leem/siesta/Pseudopotentials/:lic
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} atom_licence.html:lic
EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= yuri@FreeBSD.org
COMMENT= Program for DFT calculations in atoms
LICENSE= ATOM_LICENSE
LICENSE_NAME= ATOM ACADEMIC LICENCE
LICENSE_FILE= ${DISTDIR}/atom_licence.html
LICENSE_PERMS= no-dist-mirror no-pkg-mirror no-pkg-mirror no-pkg-sell no-auto-accept
LIB_DEPENDS= libGridXC.so:science/libgridxc \
libxc.so:science/libxc \
libxmlf90.so:textproc/xmlf90
USES= fortran gmake tar:tgz
MAKE_ENV= XMLF90_ROOT=${LOCALBASE} GRIDXC_ROOT=${LOCALBASE} LIBXC_ROOT=${LOCALBASE}
MAKE_ARGS= FC=gfortran${GCC_DEFAULT} LDFLAGS="${LDFLAGS}"
ALL_TARGET= default
PLIST_FILES= bin/atm
NO_PACKAGE= Redistribution in any form is prohibited
post-patch:
@${CP} ${WRKSRC}/arch.make.sample ${WRKSRC}/arch.make
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/atm ${STAGEDIR}${PREFIX}/bin/
.include <bsd.port.mk>

5
science/atom/distinfo Normal file
View file

@ -0,0 +1,5 @@
TIMESTAMP = 1536071684
SHA256 (atom-4.2.7-100.tgz) = 266a4119e64ca398444df7bc2f5004513891f2189cba33595a1742c64f8f3edc
SIZE (atom-4.2.7-100.tgz) = 260386
SHA256 (atom_licence.html) = 93cc2ed5498d47c5439fcf45ea1501e4e0cadb8197aefc6235ecedd36c849d93
SIZE (atom_licence.html) = 5673

View file

@ -0,0 +1,11 @@
--- arch.make.sample.orig 2018-09-04 08:05:21 UTC
+++ arch.make.sample
@@ -20,7 +20,7 @@ ARCH=macosx-gfortran
# installation trees and use the appropriate path to the .mk file.
#
include $(XMLF90_ROOT)/share/org.siesta-project/xmlf90.mk
-include $(GRIDXC_ROOT)/gridxc.mk
+include $(GRIDXC_ROOT)/share/mk/gridxc.mk
#
# -----Compiler-dependent settings -------------------------------------
#

4
science/atom/pkg-descr Normal file
View file

@ -0,0 +1,4 @@
ATOM, a program for DFT calculations in atoms and pseudopotential
generation, maintained by Alberto Garcia.
WWW: https://departments.icmab.es/leem/siesta/