The jabber transports are now built as part of the jabber port and

are therefore no longer required as separate ports.
This commit is contained in:
Josef Karthauser 2001-06-16 14:22:16 +00:00
parent b1639793f4
commit b36af6e963
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=44068
31 changed files with 0 additions and 294 deletions

View file

@ -10,7 +10,6 @@
SUBDIR += ezbounce
SUBDIR += infobot
SUBDIR += irc
SUBDIR += irc-transport
SUBDIR += ircII
SUBDIR += ircatlite
SUBDIR += ircd-hybrid

View file

@ -1,37 +0,0 @@
# New ports collection makefile for: irc-transport
# Date created: 12 December 2000
# Whom: Yen-Ming Lee <leeym@cae.ce.ntu.edu.tw>
#
# $FreeBSD$
PORTNAME= irc-transport
PORTVERSION= 0.1b-1.40
CATEGORIES= irc
MASTER_SITES= http://download.jabber.org/dists/1.4/final/
DISTFILES= ${PORTNAME}-${PORTVERSION}.linux${EXTRACT_SUFX}
MAINTAINER= leeym@cae.ce.ntu.edu.tw
BUILD_DEPENDS= ${NONEXISTENT}:${JABBER_PORT}:configure
RUN_DEPENDS= jabberd:${JABBER_PORT}
.include <bsd.port.pre.mk>
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-jabberd=${JABBER_WRKSRC}
JABBER_PORT= ${PORTSDIR}/net/jabber
JABBER_WRKSRC!= cd ${JABBER_PORT} && ${MAKE} -V WRKSRC
do-install:
@${MKDIR} ${PREFIX}/lib/jabber/${PORTNAME}
@${INSTALL_PROGRAM} ${WRKSRC}/src/irc_transport.so ${PREFIX}/lib/jabber/${PORTNAME}
@${ECHO} ""
@${ECHO} "============================================================================="
@${ECHO} "Please read ${WRKSRC}/README first"
@${ECHO} "and add \"./${PORTNAME}/irc_transport.so\" ${PREFIX}/etc/jabber.xml"
@${ECHO} "then restart jabberd to enable ${PORTNAME}"
@${ECHO} "============================================================================="
@${ECHO} ""
.include <bsd.port.post.mk>

View file

@ -1 +0,0 @@
MD5 (irc-transport-0.1b-1.40.linux.tar.gz) = 5ccf1bb828e3d813380f100e4d11f7f6

View file

@ -1,19 +0,0 @@
--- src/Makefile.in.orig Thu Feb 8 02:31:02 2001
+++ src/Makefile.in Mon Feb 12 09:32:49 2001
@@ -31,6 +31,7 @@
mandir = @mandir@
includedir = @includedir@
oldincludedir = /usr/include
+localincludedir = /usr/local/include
DESTDIR =
@@ -72,7 +73,7 @@
VERSION = @VERSION@
CFLAGS = -g -fPIC -shared
-INCLUDES = -I$(JABBERD_INC) -I$(top_builddir)/include
+INCLUDES = -I$(JABBERD_INC) -I$(top_builddir)/include -I$(oldincludedir) -I$(localincludedir)
bin_PROGRAMS = irc_transport.so
irc_transport_so_SOURCES = util.c init.c irc_in.c irc_out.c

View file

@ -1 +0,0 @@
IRC-Transport for Jabber server

View file

@ -1,5 +0,0 @@
IRC-Transport allows Jabber users to communicate with IRC
servers and IRC users, by bridging the gap between the two networks
--
Yen-Ming Lee <leeym@cae.ce.ntu.edu.tw>

View file

@ -1,2 +0,0 @@
lib/jabber/irc-transport/irc_transport.so
@dirrm lib/jabber/irc-transport

View file

@ -9,7 +9,6 @@
SUBDIR += adns
SUBDIR += aggregate
SUBDIR += aim
SUBDIR += aim-transport
SUBDIR += airport
SUBDIR += amcl
SUBDIR += archie
@ -48,7 +47,6 @@
SUBDIR += coda_doc
SUBDIR += coda_intro
SUBDIR += coda_server
SUBDIR += conference
SUBDIR += confregdecode
SUBDIR += corkscrew
SUBDIR += crescendo
@ -150,7 +148,6 @@
SUBDIR += isc-dhcp3
SUBDIR += isic
SUBDIR += jabber
SUBDIR += jud
SUBDIR += jumpgate
SUBDIR += jwhois
SUBDIR += kdenetwork2
@ -191,7 +188,6 @@
SUBDIR += mrt
SUBDIR += mrtg
SUBDIR += msend
SUBDIR += msn-transport
SUBDIR += mtr
SUBDIR += mudix
SUBDIR += naim

View file

@ -1,36 +0,0 @@
# New ports collection makefile for: aim-transport
# Date created: 04 December 2000
# Whom: Yen-Ming Lee <leeym@cae.ce.ntu.edu.tw>
#
# $FreeBSD$
#
PORTNAME= aim-transport
PORTVERSION= 0.9.0
CATEGORIES= net
MASTER_SITES= http://download.jabber.org/dists/1.4/final/
MAINTAINER= leeym@cae.ce.ntu.edu.tw
BUILD_DEPENDS= ${NONEXISTENT}:${JABBER_PORT}:configure
RUN_DEPENDS= jabberd:${JABBER_PORT}
.include <bsd.port.pre.mk>
JABBER_PORT= ${PORTSDIR}/net/jabber
JABBER_WRKSRC!= cd ${JABBER_PORT} && ${MAKE} -V WRKSRC
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-jabberd=${JABBER_WRKSRC}/jabberd
do-install:
@${MKDIR} ${PREFIX}/lib/jabber/${PORTNAME}
@${INSTALL_PROGRAM} ${WRKSRC}/src/aimtrans.so ${PREFIX}/lib/jabber/${PORTNAME}
@${ECHO} ""
@${ECHO} "============================================================================="
@${ECHO} "Please read ${WRKSRC}/README first"
@${ECHO} "and add \"./${PORTNAME}/aimtrans.so\" into ${PREFIX}/etc/jabber.xml"
@${ECHO} "then restart jabberd to enable ${PORTNAME}"
@${ECHO} "============================================================================="
@${ECHO} ""
.include <bsd.port.post.mk>

View file

@ -1 +0,0 @@
MD5 (aim-transport-0.9.0.tar.gz) = 16af3cdaa008a30079f5a89ecc4dbc90

View file

@ -1 +0,0 @@
AIM Transport for Jabber server

View file

@ -1,16 +0,0 @@
AIM-Transport 0.9
-----------------
This version of the AIM Transport is designed specifically to work with the
Jabber server version 1.4. It will not work with previous versions due to the
way that it loads itself into the main jabberd binary.
To build the AIM Transport uncompress the tarball, if you uncompressed it into
the Jabber 1.4 directory you can run the configure directly and it will find
jabberd. Otherwise, you need to use the --with-jabberd=PATH option to
configure. At this point you can run make and it should build just fine. Note
this version of the AIM Transport no longer requires a seperate download of
libfaim.
--
Yen-Ming Lee <leeym@cae.ce.ntu.edu.tw>

View file

@ -1,2 +0,0 @@
lib/jabber/aim-transport/aimtrans.so
@dirrm lib/jabber/aim-transport

View file

@ -1,35 +0,0 @@
# New ports collection makefile for: conference
# Date created: 14 February 2001
# Whom: Yen-Ming Lee <leeym@cae.ce.ntu.edu.tw>
#
# $FreeBSD$
#
PORTNAME= conference
PORTVERSION= 0.4.1
CATEGORIES= net
MASTER_SITES= http://download.jabber.org/dists/1.4/final/
MAINTAINER= leeym@cae.ce.ntu.edu.tw
BUILD_DEPENDS= ${NONEXISTENT}:${JABBER_PORT}:configure
RUN_DEPENDS= jabberd:${JABBER_PORT}
.include <bsd.port.pre.mk>
JABBER_PORT= ${PORTSDIR}/net/jabber
JABBER_WRKSRC!= cd ${JABBER_PORT} && ${MAKE} -V WRKSRC
MAKE_ENV= JABBER_WRKSRC=${JABBER_WRKSRC}
do-install:
@${MKDIR} ${PREFIX}/lib/jabber/${PORTNAME}
@${INSTALL_PROGRAM} ${WRKSRC}/conference.so ${PREFIX}/lib/jabber/${PORTNAME}
@${ECHO} ""
@${ECHO} "============================================================================="
@${ECHO} "Please read ${WRKSRC}/README first"
@${ECHO} "and add \"./${PORTNAME}/conference.so\" into ${PREFIX}/etc/jabber.xml"
@${ECHO} "then restart jabberd to enable ${PORTNAME}"
@${ECHO} "============================================================================="
@${ECHO} ""
.include <bsd.port.post.mk>

View file

@ -1 +0,0 @@
MD5 (conference-0.4.1.tar.gz) = 01b825d9f917674f25fdba29255d081b

View file

@ -1,11 +0,0 @@
--- Makefile.orig Wed Feb 14 11:22:01 2001
+++ Makefile Wed Feb 14 11:22:12 2001
@@ -1,6 +1,6 @@
-include ../platform-settings
+include $(JABBER_WRKSRC)/platform-settings
-CFLAGS:=$(CFLAGS) -I../jabberd
+CFLAGS:=$(CFLAGS) -I$(JABBER_WRKSRC)/jabberd
conference_OBJECTS=conference.o conference_room.o conference_user.o

View file

@ -1 +0,0 @@
Conferencing/GroupChat service for Jabber server

View file

@ -1,4 +0,0 @@
This is the new conferencing/groupchat service for the 1.4 server.
--
Yen-Ming Lee <leeym@cae.ce.ntu.edu.tw>

View file

@ -1,2 +0,0 @@
lib/jabber/conference/conference.so
@dirrm lib/jabber/conference

View file

@ -1,35 +0,0 @@
# New ports collection makefile for: jud
# Date created: 04 December 2000
# Whom: Yen-Ming Lee <leeym@cae.ce.ntu.edu.tw>
#
# $FreeBSD$
#
PORTNAME= jud
PORTVERSION= 0.4
CATEGORIES= net
MASTER_SITES= http://download.jabber.org/dists/1.4/final/
MAINTAINER= leeym@cae.ce.ntu.edu.tw
BUILD_DEPENDS= ${NONEXISTENT}:${JABBER_PORT}:configure
RUN_DEPENDS= jabberd:${JABBER_PORT}
.include <bsd.port.pre.mk>
JABBER_PORT= ${PORTSDIR}/net/jabber
JABBER_WRKSRC!= cd ${JABBER_PORT} && ${MAKE} -V WRKSRC
MAKE_ENV= JABBER_WRKSRC=${JABBER_WRKSRC}
do-install:
@${MKDIR} ${PREFIX}/lib/jabber/${PORTNAME}
@${INSTALL_PROGRAM} ${WRKSRC}/jud.so ${PREFIX}/lib/jabber/${PORTNAME}
@${ECHO} ""
@${ECHO} "============================================================================="
@${ECHO} "Please read ${WRKSRC}/README first"
@${ECHO} "and add \"./${PORTNAME}/jud.so\" into ${PREFIX}/etc/jabber.xml"
@${ECHO} "then restart jabberd to enable ${PORTNAME}"
@${ECHO} "============================================================================="
@${ECHO} ""
.include <bsd.port.post.mk>

View file

@ -1 +0,0 @@
MD5 (jud-0.4.tar.gz) = a057e8dd5966fa0d26ded03697ba395a

View file

@ -1,10 +0,0 @@
--- Makefile.orig Thu Feb 1 17:46:54 2001
+++ Makefile Wed Feb 14 05:02:15 2001
@@ -1,5 +1,5 @@
-include ../platform-settings
+include $(JABBER_WRKSRC)/platform-settings
-CFLAGS:=$(CFLAGS) -I../jabberd
+CFLAGS:=$(CFLAGS) -I$(JABBER_WRKSRC)/jabberd
jud_OBJECTS=jud.o jud_reg.o jud_search.o

View file

@ -1 +0,0 @@
Jabber User Directory

View file

@ -1,4 +0,0 @@
This is the first public release of the simple JUD (Jabber User Directory).
--
Yen-Ming Lee <leeym@cae.ce.ntu.edu.tw>

View file

@ -1,2 +0,0 @@
lib/jabber/jud/jud.so
@dirrm lib/jabber/jud

View file

@ -1,38 +0,0 @@
# New ports collection makefile for: msn-transport
# Date created: 14 February 2000
# Whom: Yen-Ming Lee <leeym@cae.ce.ntu.edu.tw>
#
# $FreeBSD$
#
PORTNAME= msn-transport
PORTVERSION= 1.1
CATEGORIES= net
MASTER_SITES= http://download.jabber.org/dists/1.4/final/
MAINTAINER= leeym@cae.ce.ntu.edu.tw
BUILD_DEPENDS= ${NONEXISTENT}:${JABBER_PORT}:configure
RUN_DEPENDS= jabberd:${JABBER_PORT}
.include <bsd.port.pre.mk>
JABBER_PORT= ${PORTSDIR}/net/jabber
JABBER_WRKSRC!= cd ${JABBER_PORT} && ${MAKE} -V WRKSRC
MAKE_ENV= JABBER_WRKSRC=${JABBER_WRKSRC}
pre-build:
${PERL} -pi.org -e "s@-g@${CFLAGS}@g; s@-O2@${CFLAGS}@g; s@gcc@${CC}@g" ${WRKSRC}/Makefile
do-install:
@${MKDIR} ${PREFIX}/lib/jabber/${PORTNAME}
@${INSTALL_PROGRAM} ${BUILD_WRKSRC}/msntrans.so ${PREFIX}/lib/jabber/${PORTNAME}
@${ECHO} ""
@${ECHO} "============================================================================="
@${ECHO} "Please read ${WRKSRC}/README first"
@${ECHO} "and add \"./${PORTNAME}/msntrans.so\" into ${PREFIX}/etc/jabber.xml"
@${ECHO} "then restart jabberd to enable ${PORTNAME}"
@${ECHO} "============================================================================="
@${ECHO} ""
.include <bsd.port.post.mk>

View file

@ -1 +0,0 @@
MD5 (msn-transport-1.1.tar.gz) = 251cd4b6cfc6c52a0f15c3ff2bfbfff9

View file

@ -1,15 +0,0 @@
--- Makefile.orig Wed Feb 14 13:26:36 2001
+++ Makefile Wed Feb 14 13:26:47 2001
@@ -1,9 +1,9 @@
-include ../platform-settings
+include $(JABBER_WRKSRC)/platform-settings
CC=gcc
-CFLAGS:=$(CFLAGS) $(DEFINES) -I../jabberd/ -Wall -g -O2
+CFLAGS:=$(CFLAGS) $(DEFINES) -I$(JABBER_WRKSRC)/jabberd/ -Wall -g -O2
-msntrans_HEADERS=msntrans.h ../jabberd/jabberd.h
+msntrans_HEADERS=msntrans.h $(JABBER_WRKSRC)/jabberd/jabberd.h
msntrans_OBJECTS = \
cmd.o \

View file

@ -1 +0,0 @@
MSN-Transport for Jabber server

View file

@ -1,4 +0,0 @@
This is the msn transport for the 1.4 server.
--
Yen-Ming Lee <leeym@cae.ce.ntu.edu.tw>

View file

@ -1,2 +0,0 @@
lib/jabber/msn-transport/msntrans.so
@dirrm lib/jabber/msn-transport