emulators/qemu: fix build on powerpc64 elfv2
Clang doesn't like -mbig: cc -mbig -c -o spapr-rtas.o spapr-rtas.S cc: error: unknown argument: '-mbig' This file doesn't seem to be built on amd64, so removing -mbig doesn't cause a problem there. I also successfully built on powerpc64 elfv1 and it also builds. PR: 243188 Approved by: bofh (maintainer timeout)
This commit is contained in:
parent
fdaa50f481
commit
b3f15f1bc7
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=523823
1 changed files with 15 additions and 0 deletions
15
emulators/qemu/files/patch-pc-bios_spapr-rtas_Makefile
Normal file
15
emulators/qemu/files/patch-pc-bios_spapr-rtas_Makefile
Normal file
|
@ -0,0 +1,15 @@
|
|||
--- pc-bios/spapr-rtas/Makefile.orig 2020-01-08 10:52:05 UTC
|
||||
+++ pc-bios/spapr-rtas/Makefile
|
||||
@@ -15,10 +15,10 @@ $(call set-vpath, $(SRC_PATH)/pc-bios/spapr-rtas)
|
||||
build-all: spapr-rtas.bin
|
||||
|
||||
%.o: %.S
|
||||
- $(call quiet-command,$(CCAS) -mbig -c -o $@ $<,"CCAS","$(TARGET_DIR)$@")
|
||||
+ $(call quiet-command,$(CCAS) -c -o $@ $<,"CCAS","$(TARGET_DIR)$@")
|
||||
|
||||
%.img: %.o
|
||||
- $(call quiet-command,$(CC) -nostdlib -mbig -o $@ $<,"Building","$(TARGET_DIR)$@")
|
||||
+ $(call quiet-command,$(CC) -nostdlib -o $@ $<,"Building","$(TARGET_DIR)$@")
|
||||
|
||||
%.bin: %.img
|
||||
$(call quiet-command,$(OBJCOPY) -O binary -j .text $< $@,"Building","$(TARGET_DIR)$@")
|
Loading…
Reference in a new issue