Update to 2.7.6.

This commit is contained in:
Dmitry Sivachenko 2002-08-03 10:41:53 +00:00
parent 55940154be
commit b406ef2db5
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=63902
14 changed files with 426 additions and 94 deletions

View file

@ -6,41 +6,17 @@
#
PORTNAME= polygraph
PORTVERSION= 2.2.7
PORTVERSION= 2.7.6
CATEGORIES= benchmarks www
MASTER_SITES= http://polygraph.ircache.net/sources/tars/ \
http://www.chg.ru/~dima/
MASTER_SITES= http://www.web-polygraph.org/downloads/srcs/
DISTNAME= ${PORTNAME}-${PORTVERSION}-src
EXTRACT_SUFX= .tgz
MAINTAINER= demon@FreeBSD.org
BROKEN= "Does not build"
WRKSRC= ${WRKDIR}/polygraph
IS_INTERACTIVE= yes
GNU_CONFIGURE= YES
post-patch:
@ ${MV} ${WRKSRC}/src/exprep.pl ${WRKSRC}/src/exprep.pl.pre_sed
@ ${SED} -e 's#/usr/bin/perl#${PERL5}#' \
${WRKSRC}/src/exprep.pl.pre_sed > ${WRKSRC}/src/exprep.pl
@ ${MV} ${WRKSRC}/tools/BB/bb.pl ${WRKSRC}/tools/BB/bb.pl.pre_sed
@ ${SED} -e 's#/usr/bin/perl#${PERL5}#' \
-e 's#/usr/people/bakeoff/BB#${PREFIX}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/polygraph#' \
${WRKSRC}/tools/BB/bb.pl.pre_sed> ${WRKSRC}/tools/BB/bb.pl
do-install:
.for file in polyclt polysrv lr lx distr_test pop_test rng_test aka piper polymon
@ ${INSTALL_PROGRAM} ${WRKSRC}/src/$(file) ${PREFIX}/bin
.endfor
@ ${INSTALL_PROGRAM} ${WRKSRC}/src/udp2tcpd ${PREFIX}/sbin
@ ${INSTALL_SCRIPT} ${WRKSRC}/src/exprep.pl ${PREFIX}/bin/exprep
@ ${INSTALL_SCRIPT} ${WRKSRC}/tools/BB/bb.pl ${PREFIX}/bin
@ ${MKDIR} ${PREFIX}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/polygraph
.for file in Blob.pm Executer.pm Tools.pm Command.pm Logger.pm
@ ${INSTALL_SCRIPT} ${WRKSRC}/tools/BB/$(file) \
${PREFIX}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/polygraph
.endfor
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
.include <bsd.port.mk>

View file

@ -1 +1 @@
MD5 (polygraph-2.2.7-src.tar.gz) = 3c7451c35ccff4ef67ab2896030870e4
MD5 (polygraph-2.7.6-src.tgz) = e23cbb26939217d3ad295bce64a2096d

View file

@ -0,0 +1,22 @@
--- tools/ReportGen/Makefile.in.orig Tue Jun 12 02:04:12 2001
+++ tools/ReportGen/Makefile.in Sat Aug 3 13:55:53 2002
@@ -15,7 +15,7 @@
exec_prefix = @exec_prefix@
bindir = @bindir@
-rgen_dir = @prefix@/ReportGen
+rgen_dir = @prefix@/share/polygraph/ReportGen
INSTALL = @INSTALL@
INSTALL_PROGRAM = @INSTALL_PROGRAM@
@@ -42,8 +42,8 @@
fi
install_mkdirs:
- @for d in $(prefix) $(rgen_dir); do \
- if test ! -d $$d; then echo mkdir $$d; mkdir $$d; fi; \
+ @for d in $(rgen_dir); do \
+ if test ! -d $$d; then echo mkdir -p $$d; mkdir -p $$d; fi; \
done
clean:

View file

@ -0,0 +1,84 @@
--- workloads/Makefile.in.orig Sun Jul 29 06:45:59 2001
+++ workloads/Makefile.in Sat Aug 3 13:56:45 2002
@@ -45,55 +45,55 @@
default: all
datacomm-1.pg_install: install_dirs datacomm-1.pg
- $(INSTALL_DTA) datacomm-1.pg ${prefix}/workloads
+ $(INSTALL_DTA) datacomm-1.pg ${datadir}/polygraph/workloads
downtime-2.pg_install: install_dirs downtime-2.pg
- $(INSTALL_DTA) downtime-2.pg ${prefix}/workloads
+ $(INSTALL_DTA) downtime-2.pg ${datadir}/polygraph/workloads
nolb-l4-4.pg_install: install_dirs nolb-l4-4.pg
- $(INSTALL_DTA) nolb-l4-4.pg ${prefix}/workloads
+ $(INSTALL_DTA) nolb-l4-4.pg ${datadir}/polygraph/workloads
polyfill-2.pg_install: install_dirs polyfill-2.pg
- $(INSTALL_DTA) polyfill-2.pg ${prefix}/workloads
+ $(INSTALL_DTA) polyfill-2.pg ${datadir}/polygraph/workloads
polymix-1.pg_install: install_dirs polymix-1.pg
- $(INSTALL_DTA) polymix-1.pg ${prefix}/workloads
+ $(INSTALL_DTA) polymix-1.pg ${datadir}/polygraph/workloads
polymix-2.pg_install: install_dirs polymix-2.pg
- $(INSTALL_DTA) polymix-2.pg ${prefix}/workloads
+ $(INSTALL_DTA) polymix-2.pg ${datadir}/polygraph/workloads
polymix-3.pg_install: install_dirs polymix-3.pg
- $(INSTALL_DTA) polymix-3.pg ${prefix}/workloads
+ $(INSTALL_DTA) polymix-3.pg ${datadir}/polygraph/workloads
polymix-4.pg_install: install_dirs polymix-4.pg
- $(INSTALL_DTA) polymix-4.pg ${prefix}/workloads
+ $(INSTALL_DTA) polymix-4.pg ${datadir}/polygraph/workloads
pxylb-4.pg_install: install_dirs pxylb-4.pg
- $(INSTALL_DTA) pxylb-4.pg ${prefix}/workloads
+ $(INSTALL_DTA) pxylb-4.pg ${datadir}/polygraph/workloads
simple.pg_install: install_dirs simple.pg
- $(INSTALL_DTA) simple.pg ${prefix}/workloads
+ $(INSTALL_DTA) simple.pg ${datadir}/polygraph/workloads
srvlb-l4-4.pg_install: install_dirs srvlb-l4-4.pg
- $(INSTALL_DTA) srvlb-l4-4.pg ${prefix}/workloads
+ $(INSTALL_DTA) srvlb-l4-4.pg ${datadir}/polygraph/workloads
srvlb-l7-4.pg_install: install_dirs srvlb-l7-4.pg
- $(INSTALL_DTA) srvlb-l7-4.pg ${prefix}/workloads
+ $(INSTALL_DTA) srvlb-l7-4.pg ${datadir}/polygraph/workloads
test_csm.pg_install: install_dirs test_csm.pg
- $(INSTALL_DTA) test_csm.pg ${prefix}/workloads
+ $(INSTALL_DTA) test_csm.pg ${datadir}/polygraph/workloads
test_polypxy.pg_install: install_dirs test_polypxy.pg
- $(INSTALL_DTA) test_polypxy.pg ${prefix}/workloads
+ $(INSTALL_DTA) test_polypxy.pg ${datadir}/polygraph/workloads
webaxe-1.pg_install: install_dirs webaxe-1.pg
- $(INSTALL_DTA) webaxe-1.pg ${prefix}/workloads
+ $(INSTALL_DTA) webaxe-1.pg ${datadir}/polygraph/workloads
webaxe-3.pg_install: install_dirs webaxe-3.pg
- $(INSTALL_DTA) webaxe-3.pg ${prefix}/workloads
+ $(INSTALL_DTA) webaxe-3.pg ${datadir}/polygraph/workloads
webaxe-4.pg_install: install_dirs webaxe-4.pg
- $(INSTALL_DTA) webaxe-4.pg ${prefix}/workloads
+ $(INSTALL_DTA) webaxe-4.pg ${datadir}/polygraph/workloads
all: all_subdirs datacomm-1.pg downtime-2.pg nolb-l4-4.pg polyfill-2.pg polymix-1.pg polymix-2.pg polymix-3.pg polymix-4.pg pxylb-4.pg simple.pg srvlb-l4-4.pg srvlb-l7-4.pg test_csm.pg test_polypxy.pg webaxe-1.pg webaxe-3.pg webaxe-4.pg
@@ -122,7 +122,7 @@
install: install_subdirs datacomm-1.pg downtime-2.pg nolb-l4-4.pg polyfill-2.pg polymix-1.pg polymix-2.pg polymix-3.pg polymix-4.pg pxylb-4.pg simple.pg srvlb-l4-4.pg srvlb-l7-4.pg test_csm.pg test_polypxy.pg webaxe-1.pg webaxe-3.pg webaxe-4.pg
install_dirs:
- @for d in ${prefix}/workloads/; do \
+ @for d in ${datadir}/polygraph/workloads ; do \
if test ! -d $$d; then echo mkdir -p $$d; mkdir -p $$d; fi; \
done

View file

@ -0,0 +1,44 @@
--- workloads/include/Makefile.in.orig Sat Aug 3 14:23:13 2002
+++ workloads/include/Makefile.in Sat Aug 3 14:24:50 2002
@@ -45,25 +45,25 @@
default: all
benches.pg_install: install_dirs benches.pg
- $(INSTALL_DTA) benches.pg ${prefix}/workloads/include
+ $(INSTALL_DTA) benches.pg ${datadir}/polygraph/workloads/include
contents.pg_install: install_dirs contents.pg
- $(INSTALL_DTA) contents.pg ${prefix}/workloads/include
+ $(INSTALL_DTA) contents.pg ${datadir}/polygraph/workloads/include
phases.pg_install: install_dirs phases.pg
- $(INSTALL_DTA) phases.pg ${prefix}/workloads/include
+ $(INSTALL_DTA) phases.pg ${datadir}/polygraph/workloads/include
pipes.pg_install: install_dirs pipes.pg
- $(INSTALL_DTA) pipes.pg ${prefix}/workloads/include
+ $(INSTALL_DTA) pipes.pg ${datadir}/polygraph/workloads/include
polymix-3-guts.pg_install: install_dirs polymix-3-guts.pg
- $(INSTALL_DTA) polymix-3-guts.pg ${prefix}/workloads/include
+ $(INSTALL_DTA) polymix-3-guts.pg ${datadir}/polygraph/workloads/include
polymix-4-guts.pg_install: install_dirs polymix-4-guts.pg
- $(INSTALL_DTA) polymix-4-guts.pg ${prefix}/workloads/include
+ $(INSTALL_DTA) polymix-4-guts.pg ${datadir}/polygraph/workloads/include
webaxe-4-guts.pg_install: install_dirs webaxe-4-guts.pg
- $(INSTALL_DTA) webaxe-4-guts.pg ${prefix}/workloads/include
+ $(INSTALL_DTA) webaxe-4-guts.pg ${datadir}/polygraph/workloads/include
all: all_subdirs benches.pg contents.pg phases.pg pipes.pg polymix-3-guts.pg polymix-4-guts.pg webaxe-4-guts.pg
@@ -80,7 +80,7 @@
install: install_subdirs benches.pg contents.pg phases.pg pipes.pg polymix-3-guts.pg polymix-4-guts.pg webaxe-4-guts.pg
install_dirs:
- @for d in ${prefix}/workloads/include/; do \
+ @for d in ${datadir}/polygraph/workloads/include/; do \
if test ! -d $$d; then echo mkdir -p $$d; mkdir -p $$d; fi; \
done

View file

@ -7,7 +7,7 @@ hardware configurations, and comparing available proxy products.
Documentation can be found at http://polygraph.ircache.net/doc/
WWW: http://polygraph.ircache.net/
WWW: http://www.web-polygraph.org/
--Dima
dima@chg.ru

View file

@ -1,19 +1,59 @@
bin/polyclt
bin/polysrv
bin/lr
bin/lx
bin/aka
bin/cdb
bin/distr_test
bin/dns_cfg
bin/lr
bin/ltrace
bin/lx
bin/pgl2eng
bin/pgl_test
bin/polyclt
bin/polymon
bin/polyprobe
bin/polypxy
bin/polyrrd
bin/polysrv
bin/pop_test
bin/rng_test
bin/aka
bin/piper
bin/polymon
sbin/udp2tcpd
bin/exprep
bin/bb.pl
lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/polygraph/Blob.pm
lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/polygraph/Executer.pm
lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/polygraph/Tools.pm
lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/polygraph/Command.pm
lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/polygraph/Logger.pm
@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/polygraph
bin/udp2tcpd
share/polygraph/ReportGen/Globs.pm
share/polygraph/ReportGen/Line.pm
share/polygraph/ReportGen/ObjDbase.pm
share/polygraph/ReportGen/ObjManip.pm
share/polygraph/ReportGen/Opts.pm
share/polygraph/ReportGen/Plot.pm
share/polygraph/ReportGen/RepFormat.pm
share/polygraph/ReportGen/label_results
share/polygraph/ReportGen/make_card
share/polygraph/ReportGen/make_report
share/polygraph/ReportGen/plot_table
share/polygraph/ReportGen/plot_traces
share/polygraph/ReportGen/reportgen.cfg
share/polygraph/workloads/datacomm-1.pg
share/polygraph/workloads/downtime-2.pg
share/polygraph/workloads/include/benches.pg
share/polygraph/workloads/include/contents.pg
share/polygraph/workloads/include/phases.pg
share/polygraph/workloads/include/pipes.pg
share/polygraph/workloads/include/polymix-3-guts.pg
share/polygraph/workloads/include/polymix-4-guts.pg
share/polygraph/workloads/include/webaxe-4-guts.pg
share/polygraph/workloads/nolb-l4-4.pg
share/polygraph/workloads/polyfill-2.pg
share/polygraph/workloads/polymix-1.pg
share/polygraph/workloads/polymix-2.pg
share/polygraph/workloads/polymix-3.pg
share/polygraph/workloads/polymix-4.pg
share/polygraph/workloads/pxylb-4.pg
share/polygraph/workloads/simple.pg
share/polygraph/workloads/srvlb-l4-4.pg
share/polygraph/workloads/srvlb-l7-4.pg
share/polygraph/workloads/test_csm.pg
share/polygraph/workloads/test_polypxy.pg
share/polygraph/workloads/webaxe-1.pg
share/polygraph/workloads/webaxe-3.pg
share/polygraph/workloads/webaxe-4.pg
@dirrm share/polygraph/workloads/include
@dirrm share/polygraph/workloads
@dirrm share/polygraph/ReportGen
@dirrm share/polygraph

View file

@ -6,41 +6,17 @@
#
PORTNAME= polygraph
PORTVERSION= 2.2.7
PORTVERSION= 2.7.6
CATEGORIES= benchmarks www
MASTER_SITES= http://polygraph.ircache.net/sources/tars/ \
http://www.chg.ru/~dima/
MASTER_SITES= http://www.web-polygraph.org/downloads/srcs/
DISTNAME= ${PORTNAME}-${PORTVERSION}-src
EXTRACT_SUFX= .tgz
MAINTAINER= demon@FreeBSD.org
BROKEN= "Does not build"
WRKSRC= ${WRKDIR}/polygraph
IS_INTERACTIVE= yes
GNU_CONFIGURE= YES
post-patch:
@ ${MV} ${WRKSRC}/src/exprep.pl ${WRKSRC}/src/exprep.pl.pre_sed
@ ${SED} -e 's#/usr/bin/perl#${PERL5}#' \
${WRKSRC}/src/exprep.pl.pre_sed > ${WRKSRC}/src/exprep.pl
@ ${MV} ${WRKSRC}/tools/BB/bb.pl ${WRKSRC}/tools/BB/bb.pl.pre_sed
@ ${SED} -e 's#/usr/bin/perl#${PERL5}#' \
-e 's#/usr/people/bakeoff/BB#${PREFIX}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/polygraph#' \
${WRKSRC}/tools/BB/bb.pl.pre_sed> ${WRKSRC}/tools/BB/bb.pl
do-install:
.for file in polyclt polysrv lr lx distr_test pop_test rng_test aka piper polymon
@ ${INSTALL_PROGRAM} ${WRKSRC}/src/$(file) ${PREFIX}/bin
.endfor
@ ${INSTALL_PROGRAM} ${WRKSRC}/src/udp2tcpd ${PREFIX}/sbin
@ ${INSTALL_SCRIPT} ${WRKSRC}/src/exprep.pl ${PREFIX}/bin/exprep
@ ${INSTALL_SCRIPT} ${WRKSRC}/tools/BB/bb.pl ${PREFIX}/bin
@ ${MKDIR} ${PREFIX}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/polygraph
.for file in Blob.pm Executer.pm Tools.pm Command.pm Logger.pm
@ ${INSTALL_SCRIPT} ${WRKSRC}/tools/BB/$(file) \
${PREFIX}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/polygraph
.endfor
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
.include <bsd.port.mk>

View file

@ -1 +1 @@
MD5 (polygraph-2.2.7-src.tar.gz) = 3c7451c35ccff4ef67ab2896030870e4
MD5 (polygraph-2.7.6-src.tgz) = e23cbb26939217d3ad295bce64a2096d

View file

@ -0,0 +1,22 @@
--- tools/ReportGen/Makefile.in.orig Tue Jun 12 02:04:12 2001
+++ tools/ReportGen/Makefile.in Sat Aug 3 13:55:53 2002
@@ -15,7 +15,7 @@
exec_prefix = @exec_prefix@
bindir = @bindir@
-rgen_dir = @prefix@/ReportGen
+rgen_dir = @prefix@/share/polygraph/ReportGen
INSTALL = @INSTALL@
INSTALL_PROGRAM = @INSTALL_PROGRAM@
@@ -42,8 +42,8 @@
fi
install_mkdirs:
- @for d in $(prefix) $(rgen_dir); do \
- if test ! -d $$d; then echo mkdir $$d; mkdir $$d; fi; \
+ @for d in $(rgen_dir); do \
+ if test ! -d $$d; then echo mkdir -p $$d; mkdir -p $$d; fi; \
done
clean:

View file

@ -0,0 +1,84 @@
--- workloads/Makefile.in.orig Sun Jul 29 06:45:59 2001
+++ workloads/Makefile.in Sat Aug 3 13:56:45 2002
@@ -45,55 +45,55 @@
default: all
datacomm-1.pg_install: install_dirs datacomm-1.pg
- $(INSTALL_DTA) datacomm-1.pg ${prefix}/workloads
+ $(INSTALL_DTA) datacomm-1.pg ${datadir}/polygraph/workloads
downtime-2.pg_install: install_dirs downtime-2.pg
- $(INSTALL_DTA) downtime-2.pg ${prefix}/workloads
+ $(INSTALL_DTA) downtime-2.pg ${datadir}/polygraph/workloads
nolb-l4-4.pg_install: install_dirs nolb-l4-4.pg
- $(INSTALL_DTA) nolb-l4-4.pg ${prefix}/workloads
+ $(INSTALL_DTA) nolb-l4-4.pg ${datadir}/polygraph/workloads
polyfill-2.pg_install: install_dirs polyfill-2.pg
- $(INSTALL_DTA) polyfill-2.pg ${prefix}/workloads
+ $(INSTALL_DTA) polyfill-2.pg ${datadir}/polygraph/workloads
polymix-1.pg_install: install_dirs polymix-1.pg
- $(INSTALL_DTA) polymix-1.pg ${prefix}/workloads
+ $(INSTALL_DTA) polymix-1.pg ${datadir}/polygraph/workloads
polymix-2.pg_install: install_dirs polymix-2.pg
- $(INSTALL_DTA) polymix-2.pg ${prefix}/workloads
+ $(INSTALL_DTA) polymix-2.pg ${datadir}/polygraph/workloads
polymix-3.pg_install: install_dirs polymix-3.pg
- $(INSTALL_DTA) polymix-3.pg ${prefix}/workloads
+ $(INSTALL_DTA) polymix-3.pg ${datadir}/polygraph/workloads
polymix-4.pg_install: install_dirs polymix-4.pg
- $(INSTALL_DTA) polymix-4.pg ${prefix}/workloads
+ $(INSTALL_DTA) polymix-4.pg ${datadir}/polygraph/workloads
pxylb-4.pg_install: install_dirs pxylb-4.pg
- $(INSTALL_DTA) pxylb-4.pg ${prefix}/workloads
+ $(INSTALL_DTA) pxylb-4.pg ${datadir}/polygraph/workloads
simple.pg_install: install_dirs simple.pg
- $(INSTALL_DTA) simple.pg ${prefix}/workloads
+ $(INSTALL_DTA) simple.pg ${datadir}/polygraph/workloads
srvlb-l4-4.pg_install: install_dirs srvlb-l4-4.pg
- $(INSTALL_DTA) srvlb-l4-4.pg ${prefix}/workloads
+ $(INSTALL_DTA) srvlb-l4-4.pg ${datadir}/polygraph/workloads
srvlb-l7-4.pg_install: install_dirs srvlb-l7-4.pg
- $(INSTALL_DTA) srvlb-l7-4.pg ${prefix}/workloads
+ $(INSTALL_DTA) srvlb-l7-4.pg ${datadir}/polygraph/workloads
test_csm.pg_install: install_dirs test_csm.pg
- $(INSTALL_DTA) test_csm.pg ${prefix}/workloads
+ $(INSTALL_DTA) test_csm.pg ${datadir}/polygraph/workloads
test_polypxy.pg_install: install_dirs test_polypxy.pg
- $(INSTALL_DTA) test_polypxy.pg ${prefix}/workloads
+ $(INSTALL_DTA) test_polypxy.pg ${datadir}/polygraph/workloads
webaxe-1.pg_install: install_dirs webaxe-1.pg
- $(INSTALL_DTA) webaxe-1.pg ${prefix}/workloads
+ $(INSTALL_DTA) webaxe-1.pg ${datadir}/polygraph/workloads
webaxe-3.pg_install: install_dirs webaxe-3.pg
- $(INSTALL_DTA) webaxe-3.pg ${prefix}/workloads
+ $(INSTALL_DTA) webaxe-3.pg ${datadir}/polygraph/workloads
webaxe-4.pg_install: install_dirs webaxe-4.pg
- $(INSTALL_DTA) webaxe-4.pg ${prefix}/workloads
+ $(INSTALL_DTA) webaxe-4.pg ${datadir}/polygraph/workloads
all: all_subdirs datacomm-1.pg downtime-2.pg nolb-l4-4.pg polyfill-2.pg polymix-1.pg polymix-2.pg polymix-3.pg polymix-4.pg pxylb-4.pg simple.pg srvlb-l4-4.pg srvlb-l7-4.pg test_csm.pg test_polypxy.pg webaxe-1.pg webaxe-3.pg webaxe-4.pg
@@ -122,7 +122,7 @@
install: install_subdirs datacomm-1.pg downtime-2.pg nolb-l4-4.pg polyfill-2.pg polymix-1.pg polymix-2.pg polymix-3.pg polymix-4.pg pxylb-4.pg simple.pg srvlb-l4-4.pg srvlb-l7-4.pg test_csm.pg test_polypxy.pg webaxe-1.pg webaxe-3.pg webaxe-4.pg
install_dirs:
- @for d in ${prefix}/workloads/; do \
+ @for d in ${datadir}/polygraph/workloads ; do \
if test ! -d $$d; then echo mkdir -p $$d; mkdir -p $$d; fi; \
done

View file

@ -0,0 +1,44 @@
--- workloads/include/Makefile.in.orig Sat Aug 3 14:23:13 2002
+++ workloads/include/Makefile.in Sat Aug 3 14:24:50 2002
@@ -45,25 +45,25 @@
default: all
benches.pg_install: install_dirs benches.pg
- $(INSTALL_DTA) benches.pg ${prefix}/workloads/include
+ $(INSTALL_DTA) benches.pg ${datadir}/polygraph/workloads/include
contents.pg_install: install_dirs contents.pg
- $(INSTALL_DTA) contents.pg ${prefix}/workloads/include
+ $(INSTALL_DTA) contents.pg ${datadir}/polygraph/workloads/include
phases.pg_install: install_dirs phases.pg
- $(INSTALL_DTA) phases.pg ${prefix}/workloads/include
+ $(INSTALL_DTA) phases.pg ${datadir}/polygraph/workloads/include
pipes.pg_install: install_dirs pipes.pg
- $(INSTALL_DTA) pipes.pg ${prefix}/workloads/include
+ $(INSTALL_DTA) pipes.pg ${datadir}/polygraph/workloads/include
polymix-3-guts.pg_install: install_dirs polymix-3-guts.pg
- $(INSTALL_DTA) polymix-3-guts.pg ${prefix}/workloads/include
+ $(INSTALL_DTA) polymix-3-guts.pg ${datadir}/polygraph/workloads/include
polymix-4-guts.pg_install: install_dirs polymix-4-guts.pg
- $(INSTALL_DTA) polymix-4-guts.pg ${prefix}/workloads/include
+ $(INSTALL_DTA) polymix-4-guts.pg ${datadir}/polygraph/workloads/include
webaxe-4-guts.pg_install: install_dirs webaxe-4-guts.pg
- $(INSTALL_DTA) webaxe-4-guts.pg ${prefix}/workloads/include
+ $(INSTALL_DTA) webaxe-4-guts.pg ${datadir}/polygraph/workloads/include
all: all_subdirs benches.pg contents.pg phases.pg pipes.pg polymix-3-guts.pg polymix-4-guts.pg webaxe-4-guts.pg
@@ -80,7 +80,7 @@
install: install_subdirs benches.pg contents.pg phases.pg pipes.pg polymix-3-guts.pg polymix-4-guts.pg webaxe-4-guts.pg
install_dirs:
- @for d in ${prefix}/workloads/include/; do \
+ @for d in ${datadir}/polygraph/workloads/include/; do \
if test ! -d $$d; then echo mkdir -p $$d; mkdir -p $$d; fi; \
done

View file

@ -7,7 +7,7 @@ hardware configurations, and comparing available proxy products.
Documentation can be found at http://polygraph.ircache.net/doc/
WWW: http://polygraph.ircache.net/
WWW: http://www.web-polygraph.org/
--Dima
dima@chg.ru

View file

@ -1,19 +1,59 @@
bin/polyclt
bin/polysrv
bin/lr
bin/lx
bin/aka
bin/cdb
bin/distr_test
bin/dns_cfg
bin/lr
bin/ltrace
bin/lx
bin/pgl2eng
bin/pgl_test
bin/polyclt
bin/polymon
bin/polyprobe
bin/polypxy
bin/polyrrd
bin/polysrv
bin/pop_test
bin/rng_test
bin/aka
bin/piper
bin/polymon
sbin/udp2tcpd
bin/exprep
bin/bb.pl
lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/polygraph/Blob.pm
lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/polygraph/Executer.pm
lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/polygraph/Tools.pm
lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/polygraph/Command.pm
lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/polygraph/Logger.pm
@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/polygraph
bin/udp2tcpd
share/polygraph/ReportGen/Globs.pm
share/polygraph/ReportGen/Line.pm
share/polygraph/ReportGen/ObjDbase.pm
share/polygraph/ReportGen/ObjManip.pm
share/polygraph/ReportGen/Opts.pm
share/polygraph/ReportGen/Plot.pm
share/polygraph/ReportGen/RepFormat.pm
share/polygraph/ReportGen/label_results
share/polygraph/ReportGen/make_card
share/polygraph/ReportGen/make_report
share/polygraph/ReportGen/plot_table
share/polygraph/ReportGen/plot_traces
share/polygraph/ReportGen/reportgen.cfg
share/polygraph/workloads/datacomm-1.pg
share/polygraph/workloads/downtime-2.pg
share/polygraph/workloads/include/benches.pg
share/polygraph/workloads/include/contents.pg
share/polygraph/workloads/include/phases.pg
share/polygraph/workloads/include/pipes.pg
share/polygraph/workloads/include/polymix-3-guts.pg
share/polygraph/workloads/include/polymix-4-guts.pg
share/polygraph/workloads/include/webaxe-4-guts.pg
share/polygraph/workloads/nolb-l4-4.pg
share/polygraph/workloads/polyfill-2.pg
share/polygraph/workloads/polymix-1.pg
share/polygraph/workloads/polymix-2.pg
share/polygraph/workloads/polymix-3.pg
share/polygraph/workloads/polymix-4.pg
share/polygraph/workloads/pxylb-4.pg
share/polygraph/workloads/simple.pg
share/polygraph/workloads/srvlb-l4-4.pg
share/polygraph/workloads/srvlb-l7-4.pg
share/polygraph/workloads/test_csm.pg
share/polygraph/workloads/test_polypxy.pg
share/polygraph/workloads/webaxe-1.pg
share/polygraph/workloads/webaxe-3.pg
share/polygraph/workloads/webaxe-4.pg
@dirrm share/polygraph/workloads/include
@dirrm share/polygraph/workloads
@dirrm share/polygraph/ReportGen
@dirrm share/polygraph