- Rename obsolete symbol (s/last-command-char/last-command-event/) which

prevents it from working with Emacs 24.3.
- Minor style fixes.

Submitted by:	Yasuhiro KIMURA
PR:		ports/177498
Approved by:	portmgr (bdrewery)
This commit is contained in:
Hiroki Sato 2013-04-15 12:14:06 +00:00
parent 39e54f9efb
commit b43fb3c172
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=315801
7 changed files with 63 additions and 20 deletions

View file

@ -3,7 +3,7 @@
PORTNAME= tamago
PORTVERSION= 4.0.6.0.20041122.19
PORTREVISION= 3
PORTREVISION= 4
CATEGORIES= editors elisp
MASTER_SITES= ${MASTER_SITE_DEBIAN}
MASTER_SITE_SUBDIR= pool/main/e/egg
@ -29,8 +29,7 @@ PLIST_SUB= ELISPDIR="${EMACS_LIBDIR_WITH_VER}/site-lisp"
PORTDOCS= AUTHORS ChangeLog ChangeLog.1997-1998 \
ChangeLog.2000-2001 PROBLEMS README.ja.txt TODO \
README.Debian changelog.Debian
POSTPATCHES= ${FILESDIR}/post-patch-*
OPTIONS_DEFINE= DOCS
.include <bsd.port.pre.mk>
@ -44,9 +43,6 @@ pre-configure:
@${REINPLACE_CMD} -e 's|emacs/site-lisp|${EMACS_NAME}/${EMACS_VER}/site-lisp|g' \
${WRKSRC}/configure
post-patch:
cd ${PATCH_WRKSRC} && ${CAT} ${POSTPATCHES} | ${PATCH}
post-build:
cd ${WRKSRC}/helper && ${MAKE} egg-helper
${INSTALL_DATA} ${WRKSRC}/debian/changelog ${WRKSRC}/changelog.Debian

View file

@ -1,5 +1,5 @@
--- egg.el.orig 2012-08-04 09:27:19.000000000 +0900
+++ egg.el 2012-08-04 09:32:15.000000000 +0900
--- egg.el.orig 2013-03-30 17:08:47.000000000 +0900
+++ egg.el 2013-03-30 17:11:22.000000000 +0900
@@ -169,7 +169,8 @@
(setq egg-modeless-mode t))
(setq inactivate-current-input-method-function 'egg-mode)
@ -10,3 +10,12 @@
(add-hook 'input-method-activate-hook 'its-set-mode-line-title nil t)
(if (eq (selected-window) (minibuffer-window))
(add-hook 'minibuffer-exit-hook 'egg-exit-from-minibuffer))
@@ -184,7 +185,7 @@
(defun egg-self-insert-char ()
(interactive)
- (its-start last-command-char (and (eq last-command 'egg-use-context)
+ (its-start last-command-event (and (eq last-command 'egg-use-context)
egg-context)))
(defun egg-remove-all-text-properties (from to &optional object)

View file

@ -0,0 +1,20 @@
--- its.el.orig 2002-08-02 12:07:34.000000000 +0900
+++ its.el 2013-03-30 17:11:53.000000000 +0900
@@ -397,7 +397,7 @@
(defun its-self-insert-char ()
(interactive)
(let ((inhibit-read-only t)
- (key last-command-char)
+ (key last-command-event)
(cursor (get-text-property (point) 'its-cursor))
(syl (get-text-property (1- (point)) 'its-syl)))
(cond
@@ -1264,7 +1264,7 @@
(interactive "P")
(let ((syl (and (null (get-text-property (point) 'its-cursor))
(get-text-property (1- (point)) 'its-syl))))
- (if (its-keyseq-acceptable-p (vector last-command-char) syl)
+ (if (its-keyseq-acceptable-p (vector last-command-event) syl)
(its-self-insert-char)
(its-kick-convert-region n))))

View file

@ -0,0 +1,30 @@
--- menudiag.el.orig 2001-01-28 03:53:13.000000000 +0900
+++ menudiag.el 2013-03-30 17:12:23.000000000 +0900
@@ -296,7 +296,7 @@
(defun menudiag-goto-item ()
(interactive)
(menudiag-check-current-menu)
- (let ((ch last-command-char)
+ (let ((ch last-command-event)
(n 0))
(setq n (menudiag-char-to-item-num ch))
(if (>= n (length menudiag-line))
@@ -503,7 +503,8 @@
(make-local-variable 'inhibit-read-only)
(setq buffer-read-only t
inhibit-read-only nil)
- (make-local-hook 'post-command-hook)
+ (if (fboundp 'make-local-hook)
+ (eval '(make-local-hook 'post-command-hook)))
(add-hook 'post-command-hook 'menudiag-selection-align-to-item nil t)
(use-local-map menudiag-selection-map)
(setq mode-name "Menudiag Selection")
@@ -619,7 +620,7 @@
(unless (eq last-command 'menudiag-selection-goto)
(setq menudiag-goto-number-list nil
menudiag-original-point (point)))
- (setq menudiag-goto-number-list (cons (- last-command-char ?0)
+ (setq menudiag-goto-number-list (cons (- last-command-event ?0)
menudiag-goto-number-list))
(menudiag-selection-goto-internal))

View file

@ -1,12 +0,0 @@
--- menudiag.el.orig 2001-01-28 03:53:13.000000000 +0900
+++ menudiag.el 2012-08-04 09:32:34.000000000 +0900
@@ -503,7 +503,8 @@
(make-local-variable 'inhibit-read-only)
(setq buffer-read-only t
inhibit-read-only nil)
- (make-local-hook 'post-command-hook)
+ (if (fboundp 'make-local-hook)
+ (eval '(make-local-hook 'post-command-hook)))
(add-hook 'post-command-hook 'menudiag-selection-align-to-item nil t)
(use-local-map menudiag-selection-map)
(setq mode-name "Menudiag Selection")