Really update libarcus to 4.8
N.B. the wrinkle in cmake build here. find_package(Pythoninterp 3.4 REQUIRED) can find your install Python 3.9 instead of the DEFAULT Python. Force the correct one with a few patches. PR: ports/251236 Submitted by: sko@rostwald.de Reported by: trombik1973@gmail.com
This commit is contained in:
parent
f86c964117
commit
b4553f4060
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=561521
3 changed files with 34 additions and 8 deletions
|
@ -1,8 +1,7 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= libArcus
|
||||
PORTVERSION= 4.7.1
|
||||
PORTREVISION= 2
|
||||
PORTVERSION= 4.8.0
|
||||
PORTEPOCH= 1
|
||||
CATEGORIES= net cad
|
||||
DIST_SUBDIR= Ultimaker
|
||||
|
@ -20,6 +19,8 @@ USE_PYQT= sip pysip
|
|||
USE_GITHUB= yes
|
||||
GH_ACCOUNT= Ultimaker
|
||||
USE_LDCONFIG= yes
|
||||
GH_TAGNAME= 6a68d7e0
|
||||
#GH_TAGNAME= 3afb644
|
||||
|
||||
CMAKE_ARGS+= -DPYTHON_EXECUTABLE:STRING=${PYTHON_CMD} \
|
||||
-DPYTHON_INCLUDEDIR:STRING=${PYTHON_INCLUDEDIR}
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
TIMESTAMP = 1600556808
|
||||
SHA256 (Ultimaker/Ultimaker-libArcus-4.7.1-6a68d7e0_GH0.tar.gz) = c7408c07b1cc79cb17a817b49cba5432a23159082e66efe58776022a31d7541a
|
||||
SIZE (Ultimaker/Ultimaker-libArcus-4.7.1-6a68d7e0_GH0.tar.gz) = 31948
|
||||
TIMESTAMP = 1610493107
|
||||
SHA256 (Ultimaker/Ultimaker-libArcus-4.8.0_GH0.tar.gz) = f5a7234506c89a36adccdab2a3c410a75aaaa9e7c7f9533db834881c59001677
|
||||
SIZE (Ultimaker/Ultimaker-libArcus-4.8.0_GH0.tar.gz) = 31906
|
||||
|
|
|
@ -1,6 +1,31 @@
|
|||
--- CMakeLists.txt.orig 2020-10-11 05:33:17 UTC
|
||||
--- CMakeLists.txt.orig 2020-10-09 16:43:28 UTC
|
||||
+++ CMakeLists.txt
|
||||
@@ -94,7 +94,7 @@ endif()
|
||||
@@ -28,12 +28,21 @@ if(BUILD_PYTHON)
|
||||
# However currently on our CI server it finds the wrong Python version and then doesn't find the headers.
|
||||
find_package(PythonInterp 3.4 REQUIRED)
|
||||
find_package(PythonLibs 3.4 REQUIRED)
|
||||
-
|
||||
- find_package(SIP REQUIRED)
|
||||
+if(NOT PYTHON_EXECUTABLE STREQUAL "")
|
||||
+ set(Python3_EXECUTABLE ${PYTHON_EXECUTABLE})
|
||||
+ message("Using given PYTHON_EXECUTABLE")
|
||||
+endif()
|
||||
+if(NOT PYTHON_INCLUDE_DIR STREQUAL "")
|
||||
+ set(PYTHON_INCLUDE_DIR ${PYTHON_INCLUDE_DIR})
|
||||
+ message("Using given PYTHON_INCLUDE_DIR")
|
||||
+endif()
|
||||
+find_package(SIP REQUIRED)
|
||||
if(NOT DEFINED LIB_SUFFIX)
|
||||
set(LIB_SUFFIX "")
|
||||
endif()
|
||||
-
|
||||
+if(NOT PYTHON_INCLUDEDIR STREQUAL "")
|
||||
+ message("Setting Python3_INCLUDE_DIRS = ${PYTHON_INCLUDEDIR}")
|
||||
+endif()
|
||||
include_directories(python/ src/ ${SIP_INCLUDE_DIRS} ${Python3_INCLUDE_DIRS})
|
||||
endif()
|
||||
|
||||
@@ -88,7 +97,7 @@ endif()
|
||||
if(BUILD_PYTHON)
|
||||
set(SIP_EXTRA_FILES_DEPEND python/SocketListener.sip python/Types.sip python/PythonMessage.sip python/Error.sip)
|
||||
set(SIP_EXTRA_SOURCE_FILES python/PythonMessage.cpp)
|
||||
|
|
Loading…
Reference in a new issue