- Fix fallout from shebangfix conversion

- Remove two patches which are believed to be obsolete with new freeglut
This commit is contained in:
Rene Ladan 2013-07-17 00:09:16 +00:00
parent d7599bf7a5
commit b463af324c
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=323140
3 changed files with 9 additions and 22 deletions

View file

@ -44,6 +44,8 @@ INSTDIR= ${PREFIX}/share/games/${PORTNAME}
PORTDOCS= faq.html
BASH2FIX= src/linux/torcs.in Make-default.mk
DESKTOP_ENTRIES= "TORCS" \
"The Open Racing Car Simulator" \
"${INSTDIR}/Ticon.png" \
@ -57,6 +59,13 @@ OPTIONS_DEFINE= DOCS
EMPTYDIR= champ dtmrace endrace ncrace practice quickrace
# shebangfix does not catch these two (not at top of file):
post-patch:
.for FILE in ${BASH2FIX}
@${REINPLACE_CMD} -E -e "s|/bin/bash|${LOCALBASE}/bin/bash|" \
${WRKSRC}/${FILE}
.endfor
pre-install:
@${MKDIR} ${PREFIX}/share/games

View file

@ -1,11 +0,0 @@
--- src/libs/confscreens/Makefile.orig 2012-01-02 17:39:05.000000000 +0100
+++ src/libs/confscreens/Makefile 2012-01-09 20:41:34.000000000 +0100
@@ -28,7 +28,7 @@
EXPORTS = confscreens.h driverconfig.h joystickconfig.h mouseconfig.h controlconfig.h graphconfig.h\
simuconfig.h soundconfig.h openglconfig.h
-LIBS = -lplibjs
+LIBS = -lplibjs -lusbhid
src_PKGFILES = $(shell find * -maxdepth 0 -type f -print)

View file

@ -1,11 +0,0 @@
--- src/libs/tgfclient/Makefile.orig 2012-01-02 17:39:05.000000000 +0100
+++ src/libs/tgfclient/Makefile 2012-01-09 20:46:09.000000000 +0100
@@ -51,7 +51,7 @@
CONFIG = screen.xml
-LIBS = -lplibjs
+LIBS = -lplibjs -lusbhid
src_PKGFILES = $(shell find * -maxdepth 0 -type f -print)