Update to version xf331-p11a.
PR: 6021 Submitted by: maintainer
This commit is contained in:
parent
70ee500fe6
commit
b4a61e913e
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=10179
5 changed files with 35 additions and 70 deletions
|
@ -1,29 +1,28 @@
|
|||
# New ports collection makefile for: hanterm-xf86-v32
|
||||
# Version required: xf86-v32
|
||||
# New ports collection makefile for: hanterm-xf86
|
||||
# Version required: hanterm-xf331-p11a
|
||||
# Date created: 22 Mar 1997
|
||||
# Whom: Choi Jun Ho <junker@jazz.snu.ac.kr>
|
||||
# Whom: CHOI Junho <junker@jazz.snu.ac.kr>
|
||||
#
|
||||
# $Id: Makefile,v 1.1.1.1 1997/04/18 08:45:48 asami Exp $
|
||||
# $Id: Makefile,v 1.2 1997/09/22 16:21:51 max Exp $
|
||||
#
|
||||
|
||||
DISTNAME= hanterm-xf86-v32
|
||||
PKGNAME= ko-hanterm-xf86-3.2
|
||||
DISTNAME= hanterm-xf331-p11a
|
||||
PKGNAME= ko-hanterm-xf-3.3.1.11a
|
||||
CATEGORIES= korean x11
|
||||
MASTER_SITES= ftp://ftp.kaist.ac.kr/pub/hangul/incoming/ \
|
||||
ftp://jazz.snu.ac.kr/pub/unix/util/X11/
|
||||
EXTRACT_SUFX= .tgz
|
||||
|
||||
RUN_DEPENDS= ${PREFIX}/lib/X11/fonts/korean/johab:$(PORTSDIR)/korean/johabfonts
|
||||
MASTER_SITES= ftp://ftp.kaist.ac.kr/pub/hangul/incoming/
|
||||
|
||||
MAINTAINER= junker@jazz.snu.ac.kr
|
||||
|
||||
USE_IMAKE= yes
|
||||
NO_INSTALL_MANPAGES= yes
|
||||
RUN_DEPENDS= ${PREFIX}/lib/X11/fonts/korean/johab:${PORTSDIR}/korean/johabfonts
|
||||
|
||||
# rename app-defaults files
|
||||
post-extract:
|
||||
@cd ${WRKSRC}; \
|
||||
mv XTerm.ad Hanterm.ad; \
|
||||
mv XTerm-col.ad Hanterm-col.ad
|
||||
WRKSRC= ${WRKDIR}/hanterm-xf331-p11
|
||||
|
||||
USE_X11= yes
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ARGS= --with-x --build=i386--freebsd --prefix=${PREFIX}
|
||||
NO_INSTALL_MANPAGES= yes
|
||||
|
||||
post-install:
|
||||
@${INSTALL_DATA} ${WRKSRC}/Hanterm.ad ${PREFIX}/lib/X11/app-defaults/Hanterm
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1 +1 @@
|
|||
MD5 (hanterm-xf86-v32.tgz) = 0388949843ec689771ecdef8f136b10b
|
||||
MD5 (hanterm-xf331-p11a.tar.gz) = 5e583f06a8b3148a9128f00555c8ae56
|
||||
|
|
|
@ -1,41 +1,11 @@
|
|||
diff -c -r ../hanterm-xf86-v32-orig/Imakefile ./Imakefile
|
||||
*** ../hanterm-xf86-v32-orig/Imakefile Thu Mar 6 02:07:55 1997
|
||||
--- ./Imakefile Sat Mar 22 14:08:30 1997
|
||||
***************
|
||||
*** 90,97 ****
|
||||
MAINOBJ = main.o
|
||||
#endif
|
||||
#ifdef Hangul
|
||||
! EXTRASRC = hangul.c chat.c automata.c hanja.c
|
||||
! EXTRAOBJ = hangul.o chat.o automata.o hanja.o
|
||||
#endif
|
||||
SRCS1 = button.c charproc.c cursor.c data.c input.c \
|
||||
$(MAINSRC) menu.c misc.c screen.c scrollbar.c tabs.c \
|
||||
--- 90,97 ----
|
||||
MAINOBJ = main.o
|
||||
#endif
|
||||
#ifdef Hangul
|
||||
! EXTRASRC = hangul.c chat.c automata.c hanja.c
|
||||
! EXTRAOBJ = hangul.o chat.o automata.o hanja.o
|
||||
#endif
|
||||
SRCS1 = button.c charproc.c cursor.c data.c input.c \
|
||||
$(MAINSRC) menu.c misc.c screen.c scrollbar.c tabs.c \
|
||||
***************
|
||||
*** 183,190 ****
|
||||
NormalProgramTarget(resize,$(OBJS2),$(DEPLIBS2),NullParameter,$(TERMCAPLIB))
|
||||
InstallProgramWithFlags(resize,$(BINDIR),NullParameter)
|
||||
|
||||
! InstallAppDefaults(XTerm)
|
||||
! InstallAppDefaultsLong(XTerm-col,XTerm-color)
|
||||
! InstallManPage(xterm,$(MANDIR))
|
||||
InstallManPage(resize,$(MANDIR))
|
||||
DependTarget()
|
||||
--- 183,190 ----
|
||||
NormalProgramTarget(resize,$(OBJS2),$(DEPLIBS2),NullParameter,$(TERMCAPLIB))
|
||||
InstallProgramWithFlags(resize,$(BINDIR),NullParameter)
|
||||
|
||||
! InstallAppDefaults(Hanterm)
|
||||
! InstallAppDefaultsLong(Hanterm-col,Hanterm-color)
|
||||
! InstallManPage(hanterm,$(MANDIR))
|
||||
InstallManPage(resize,$(MANDIR))
|
||||
DependTarget()
|
||||
--- Makefile.in.old Sun Mar 15 21:11:33 1998
|
||||
+++ Makefile.in Sun Mar 15 21:11:18 1998
|
||||
@@ -10,7 +10,7 @@
|
||||
INSTALL_DATA = @INSTALL_DATA@
|
||||
|
||||
IMAKE_CFLAGS = @IMAKE_CFLAGS@
|
||||
-CFLAGS = @CFLAGS@ $(IMAKE_CFLAGS)
|
||||
+CFLAGS = @CFLAGS@ $(IMAKE_CFLAGS) $(CPPFLAGS)
|
||||
LIBS = @LIBS@
|
||||
|
||||
X_CFLAGS = @X_CFLAGS@
|
||||
|
|
|
@ -1,13 +1,10 @@
|
|||
Hanterm-xf86-v32
|
||||
----------------
|
||||
hanterm-xf
|
||||
----------
|
||||
|
||||
It is one of many variants of hanterm, a well-known program for managing
|
||||
Korean language in X11. This version is the best of all its variants now,
|
||||
such as automatic fonts detection, johab844 font support, and newly updated
|
||||
for XFree86-3.2(X11R6.1). In this version, there is no need to specifying
|
||||
hangul fonts for displaying(-ks and -kst, -jo8 options are deleted), existing
|
||||
in previous versions. In this version of hanterm, the scrollbar is displayed
|
||||
in right.
|
||||
Korean language in X11. This version supports the features
|
||||
such as automatic fonts detection, johab844 font support, and based on
|
||||
XFree86's xterm code. The scrollbar is displayed in right.
|
||||
|
||||
--
|
||||
Choi Jun Ho <junker@jazz.snu.ac.kr>
|
||||
CHOI Junho <junker@jazz.snu.ac.kr>
|
||||
|
|
|
@ -1,3 +1,2 @@
|
|||
lib/X11/app-defaults/Hanterm
|
||||
lib/X11/app-defaults/Hanterm-color
|
||||
bin/hanterm
|
||||
|
|
Loading…
Reference in a new issue