Update to 1.0
PR: ports/82781 Submitted by: maintainer
This commit is contained in:
parent
9c14a3d3a8
commit
b4bc14d8e5
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=138267
4 changed files with 12 additions and 60 deletions
|
@ -6,26 +6,28 @@
|
|||
#
|
||||
|
||||
PORTNAME= foremost
|
||||
PORTVERSION= 0.69
|
||||
PORTVERSION= 1.0
|
||||
CATEGORIES= sysutils
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
|
||||
MASTER_SITE_SUBDIR= ${PORTNAME}
|
||||
MASTER_SITES= http://${PORTNAME}.sourceforge.net/pkg/
|
||||
|
||||
MAINTAINER= onatan@gmail.com
|
||||
COMMENT= Console program to recover files based on their headers and footers
|
||||
|
||||
USE_GMAKE= yes
|
||||
ALL_TARGET= openbsd
|
||||
ALL_TARGET= freebsd
|
||||
MAN1= foremost.1
|
||||
USE_REINPLACE= yes
|
||||
|
||||
PLIST_FILES= bin/foremost etc/foremost.conf.sample
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e 's|PREFIX|${PREFIX}|' ${WRKSRC}/foremost.h
|
||||
@${REINPLACE_CMD} -e 's|gcc|${CC}|; s|-Wall -O2|${CFLAGS}|' ${WRKSRC}/Makefile
|
||||
@${REINPLACE_CMD} -e 's|/usr/local|${PREFIX}|' ${WRKSRC}/config.c
|
||||
@${REINPLACE_CMD} -e 's|/etc|${PREFIX}/etc|' ${WRKSRC}/${MAN1}
|
||||
|
||||
post-install:
|
||||
@${STRIP_CMD} ${PREFIX}/bin/foremost
|
||||
@${INSTALL} -Cm 644 ${WRKSRC}/foremost.conf ${PREFIX}/etc/foremost.conf.sample
|
||||
do-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
|
||||
${INSTALL_DATA} ${WRKSRC}/foremost.conf ${PREFIX}/etc/foremost.conf.sample
|
||||
${INSTALL_MAN} ${WRKSRC}/${MAN1} ${MAN1PREFIX}/man/man1
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,2 +1,2 @@
|
|||
MD5 (foremost-0.69.tar.gz) = c52a0aa87180a5331f28acbb6563e9b2
|
||||
SIZE (foremost-0.69.tar.gz) = 27719
|
||||
MD5 (foremost-1.0.tar.gz) = ced1de9efeea98730e3988907ae2aa92
|
||||
SIZE (foremost-1.0.tar.gz) = 50008
|
||||
|
|
|
@ -1,32 +0,0 @@
|
|||
--- Makefile.orig Fri Jan 9 13:45:23 2004
|
||||
+++ Makefile Wed Jun 16 21:36:33 2004
|
||||
@@ -1,5 +1,5 @@
|
||||
|
||||
-CC = gcc
|
||||
+CC?= gcc
|
||||
CC_OPTS = -Wall -O2
|
||||
GOAL = foremost
|
||||
|
||||
@@ -14,8 +14,9 @@
|
||||
#---------------------------------------------------------------------
|
||||
|
||||
# Where foremost gets installed
|
||||
-BIN = /usr/local/bin
|
||||
-MAN = /usr/local/man/man1
|
||||
+PREFIX ?= /usr/local
|
||||
+BIN = $(PREFIX)/bin
|
||||
+MAN = $(PREFIX)/man/man1
|
||||
|
||||
# This should be commented out when debugging is done
|
||||
#CC_OPTS += -D__DEBUG -ggdb
|
||||
@@ -55,8 +56,8 @@
|
||||
$(CC) -o $(GOAL) $(OBJS)
|
||||
|
||||
install: all
|
||||
- install -CDm 755 $(GOAL) $(BIN)/$(GOAL)
|
||||
- install -CDm 644 $(GOAL).1 $(MAN)/$(GOAL).1
|
||||
+ install -Cm 755 $(GOAL) $(BIN)/$(GOAL)
|
||||
+ install -Cm 644 $(GOAL).1 $(MAN)/$(GOAL).1
|
||||
|
||||
uninstall:
|
||||
rm -f $(BIN)/$(GOAL) $(MAN)/$(GOAL).1
|
|
@ -1,18 +0,0 @@
|
|||
--- foremost.h.orig Fri Jan 9 13:45:23 2004
|
||||
+++ foremost.h Wed Jun 16 22:51:42 2004
|
||||
@@ -40,6 +40,7 @@
|
||||
#define strtoull strtoul
|
||||
#include <sys/ttycom.h>
|
||||
#include <sys/param.h>
|
||||
+#include <libgen.h> /* for basename() */
|
||||
#endif /* ifdef __OPENBSD */
|
||||
|
||||
#ifdef __LINUX
|
||||
@@ -178,7 +179,7 @@
|
||||
#define FOREMOST_NOEXTENSION '\xFF'
|
||||
|
||||
#define FOREMOST_DEFAULT_WILDCARD '?'
|
||||
-#define FOREMOST_DEFAULT_CONFIG_FILE "foremost.conf"
|
||||
+#define FOREMOST_DEFAULT_CONFIG_FILE "PREFIX/etc/foremost.conf"
|
||||
|
||||
#define FOREMOST_DEFAULT_OUTPUT_DIR "foremost-output"
|
Loading…
Reference in a new issue