Variations on Rockdodger (VoR) is a fork of Paul Holt's little gem Rock

Dodger, which has now accumulated enough differences to be worth releasing
on its own.  The premise is simple: dodge the rocks until you die. No
shields, no weapons, no bonus lives, just pure rockdodgin' fun for your
spare moments. VoR has ray-traced rocks, a free-scrolling screen, and
"real" physics for your ship.  Warning: this game is, if anything, harder
than the original. It is intended to be a quickie game to kill a few spare
moments here and there, not an epic space adventure.

PR:		ports/85818
Submitted by:	Dmitry Marakasov <amdmi3@mail.ru>
This commit is contained in:
Pav Lucistnik 2005-09-10 23:16:02 +00:00
parent 8b11366af7
commit b4c545310b
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=142404
6 changed files with 169 additions and 0 deletions

View file

@ -556,6 +556,7 @@
SUBDIR += vectoroids
SUBDIR += virt
SUBDIR += viruskiller
SUBDIR += vor
SUBDIR += wanderer
SUBDIR += wargus
SUBDIR += wesnoth

52
games/vor/Makefile Normal file
View file

@ -0,0 +1,52 @@
# New ports collection makefile for: vor
# Date created: 07 Sep 2005
# Whom: Dmitry Marakasov <amdmi3@mail.ru>
#
# $FreeBSD$
#
PORTNAME= vor
PORTVERSION= 0.3
CATEGORIES= games
MASTER_SITES= http://qualdan.com/vor/
MAINTAINER= amdmi3@mail.ru
COMMENT= Dodge the rocks until you die
BUILD_DEPENDS= ${LOCALBASE}/include/argp.h:${PORTSDIR}/devel/argp-standalone
USE_SDL= mixer image sdl
USE_BZIP2= yes
USE_GMAKE= yes
USE_REINPLACE= yes
post-patch:
.for file in main.c shape.h sound.h
@${REINPLACE_CMD} -e 's|SDL/|SDL11/|' ${WRKSRC}/${file}
.endfor
.for file in shape.h score.c score.h debug.c
@${REINPLACE_CMD} -e 's|<stdint.h>|<inttypes.h>|' ${WRKSRC}/${file}
.endfor
@${REINPLACE_CMD} -e 's|sdl-config|${SDL_CONFIG}|g' ${WRKSRC}/Makefile
@${REINPLACE_CMD} -e 's|^\(my_objects.*\)$$|\1 ${LOCALBASE}/lib/libargp.a|' ${WRKSRC}/Makefile
@${REINPLACE_CMD} -e 's|/usr/share/vor|${PREFIX}/share/vor|g' ${WRKSRC}/config.h
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/vor ${PREFIX}/bin
${MKDIR} ${DATADIR}
${MKDIR} ${DATADIR}/banners
${MKDIR} ${DATADIR}/fonts
${MKDIR} ${DATADIR}/icons
${MKDIR} ${DATADIR}/indicators
${MKDIR} ${DATADIR}/music
${MKDIR} ${DATADIR}/sounds
${MKDIR} ${DATADIR}/sprites
${INSTALL_DATA} ${WRKSRC}/data/banners/* ${DATADIR}/banners/
${INSTALL_DATA} ${WRKSRC}/data/fonts/* ${DATADIR}/fonts/
${INSTALL_DATA} ${WRKSRC}/data/icons/* ${DATADIR}/icons/
${INSTALL_DATA} ${WRKSRC}/data/indicators/* ${DATADIR}/indicators/
${INSTALL_DATA} ${WRKSRC}/data/music/* ${DATADIR}/music/
${INSTALL_DATA} ${WRKSRC}/data/sounds/* ${DATADIR}/sounds/
${INSTALL_DATA} ${WRKSRC}/data/sprites/* ${DATADIR}/sprites/
.include <bsd.port.mk>

2
games/vor/distinfo Normal file
View file

@ -0,0 +1,2 @@
MD5 (vor-0.3.tar.bz2) = 814100a94a7881e58ef0238ec3eb4367
SIZE (vor-0.3.tar.bz2) = 444658

View file

@ -0,0 +1,26 @@
--- file.c.orig Wed Sep 7 05:00:47 2005
+++ file.c Wed Sep 7 05:01:01 2005
@@ -58,20 +58,19 @@
find_data_dir(void)
{
int i;
- char *data_options[3] = {
- "./data",
+ char *data_options[2] = {
getenv("VOR_DATA"),
DATA_PREFIX
};
- for(i=0; i<3; i++) {
+ for(i=0; i<2; i++) {
if(!data_options[i]) continue;
g_data_dir = strdup(data_options[i]);
if(is_dir(g_data_dir)) return true;
}
fprintf(stderr, "Can't find VoR data! Tried:\n");
- for(i=0; i<3; i++) {
+ for(i=0; i<2; i++) {
fprintf(stderr, "\t%s\n", data_options[i]);
}
return false;

12
games/vor/pkg-descr Normal file
View file

@ -0,0 +1,12 @@
Variations on Rockdodger (VoR) is a fork of Paul Holt's little gem Rock
Dodger, which has now accumulated enough differences to be worth releasing
on its own. The premise is simple: dodge the rocks until you die. No
shields, no weapons, no bonus lives, just pure rockdodgin' fun for your
spare moments. VoR has ray-traced rocks, a free-scrolling screen, and
"real" physics for your ship. Warning: this game is, if anything, harder
than the original. It is intended to be a quickie game to kill a few spare
moments here and there, not an epic space adventure.
WWW: http://herkamire.com/jason/vor
- Dmitry Marakasov <amdmi3@mail.ru>

76
games/vor/pkg-plist Normal file
View file

@ -0,0 +1,76 @@
bin/vor
%%DATADIR%%/indicators/life.png
%%DATADIR%%/music/4est_fulla3s.mod
%%DATADIR%%/music/getzznew.mod
%%DATADIR%%/music/magic.mod
%%DATADIR%%/banners/on.png
%%DATADIR%%/banners/game.png
%%DATADIR%%/banners/variations.png
%%DATADIR%%/banners/rockdodger.png
%%DATADIR%%/banners/over.png
%%DATADIR%%/sprites/ship.png
%%DATADIR%%/sprites/rock00.png
%%DATADIR%%/sprites/rock01.png
%%DATADIR%%/sprites/rock02.png
%%DATADIR%%/sprites/rock03.png
%%DATADIR%%/sprites/rock04.png
%%DATADIR%%/sprites/rock05.png
%%DATADIR%%/sprites/rock06.png
%%DATADIR%%/sprites/rock07.png
%%DATADIR%%/sprites/rock08.png
%%DATADIR%%/sprites/rock09.png
%%DATADIR%%/sprites/rock10.png
%%DATADIR%%/sprites/rock11.png
%%DATADIR%%/sprites/rock12.png
%%DATADIR%%/sprites/rock13.png
%%DATADIR%%/sprites/rock14.png
%%DATADIR%%/sprites/rock15.png
%%DATADIR%%/sprites/rock16.png
%%DATADIR%%/sprites/rock17.png
%%DATADIR%%/sprites/rock18.png
%%DATADIR%%/sprites/rock19.png
%%DATADIR%%/sprites/rock20.png
%%DATADIR%%/sprites/rock21.png
%%DATADIR%%/sprites/rock22.png
%%DATADIR%%/sprites/rock23.png
%%DATADIR%%/sprites/rock24.png
%%DATADIR%%/sprites/rock25.png
%%DATADIR%%/sprites/rock26.png
%%DATADIR%%/sprites/rock27.png
%%DATADIR%%/sprites/rock28.png
%%DATADIR%%/sprites/rock29.png
%%DATADIR%%/sprites/rock30.png
%%DATADIR%%/sprites/rock31.png
%%DATADIR%%/sprites/rock32.png
%%DATADIR%%/sprites/rock33.png
%%DATADIR%%/sprites/rock34.png
%%DATADIR%%/sprites/rock35.png
%%DATADIR%%/sprites/rock36.png
%%DATADIR%%/sprites/rock37.png
%%DATADIR%%/sprites/rock38.png
%%DATADIR%%/sprites/rock39.png
%%DATADIR%%/sprites/rock40.png
%%DATADIR%%/sprites/rock41.png
%%DATADIR%%/sprites/rock42.png
%%DATADIR%%/sprites/rock43.png
%%DATADIR%%/sprites/rock44.png
%%DATADIR%%/sprites/rock45.png
%%DATADIR%%/sprites/rock46.png
%%DATADIR%%/sprites/rock47.png
%%DATADIR%%/sprites/rock48.png
%%DATADIR%%/sprites/rock49.png
%%DATADIR%%/fonts/score.png
%%DATADIR%%/icons/spacerocks.xpm
%%DATADIR%%/icons/rockdodger.xpm
%%DATADIR%%/sounds/bzboom.wav
%%DATADIR%%/sounds/booom.wav
%%DATADIR%%/sounds/boom.wav
%%DATADIR%%/sounds/cboom.wav
@dirrm %%DATADIR%%/banners
@dirrm %%DATADIR%%/fonts
@dirrm %%DATADIR%%/icons
@dirrm %%DATADIR%%/indicators
@dirrm %%DATADIR%%/music
@dirrm %%DATADIR%%/sounds
@dirrm %%DATADIR%%/sprites
@dirrm %%DATADIR%%