lossy/lossless audio compressor
This commit is contained in:
Ying-Chieh Liao 2001-06-01 18:19:06 +00:00
parent 861aa673cc
commit b4e49faebe
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=43407
8 changed files with 75 additions and 0 deletions

View file

@ -10,6 +10,7 @@
SUBDIR += aureal-kmod
SUBDIR += autozen
SUBDIR += bladeenc
SUBDIR += bonk
SUBDIR += btc
SUBDIR += cam
SUBDIR += ccaudio

19
audio/bonk/Makefile Normal file
View file

@ -0,0 +1,19 @@
# ex:ts=8
# New ports collection makefile for: bonk
# Date created: Jun 1, 2001
# Whom: ijliao
#
# $FreeBSD$
#
PORTNAME= bonk
PORTVERSION= 0.4
CATEGORIES= audio
MASTER_SITES= http://yoyo.cc.monash.edu.au/~pfh/bonk/
MAINTAINER= ijliao@FreeBSD.org
post-patch:
@${PERL} -pi -e "s,%%INSTALL_PROGRAM%%,${INSTALL_PROGRAM},g" ${WRKSRC}/Makefile
.include <bsd.port.mk>

1
audio/bonk/distinfo Normal file
View file

@ -0,0 +1 @@
MD5 (bonk-0.4.tar.gz) = a27653de4fbcf2226d0926530a66c568

View file

@ -0,0 +1,15 @@
--- Makefile.orig Sat Jun 2 01:44:11 2001
+++ Makefile Sat Jun 2 01:44:46 2001
@@ -2,10 +2,10 @@
all : bonk
bonk : bonk.cc utility.h wav.h
- g++ -O3 -funroll-loops -o bonk bonk.cc
+ ${CXX} ${CXXFLAGS} -o bonk bonk.cc
install : bonk
- install bonk /usr/bin
+ %%INSTALL_PROGRAM%% bonk ${PREFIX}/bin
clean :
rm -f core bonk

View file

@ -0,0 +1,24 @@
--- bonk.cc.orig Sat Jun 2 02:06:22 2001
+++ bonk.cc Sat Jun 2 02:07:11 2001
@@ -30,7 +30,7 @@
#include <stdio.h>
#include <stdlib.h>
#include <time.h>
-#include <linux/soundcard.h>
+#include <sys/soundcard.h>
#include <sys/ioctl.h>
#include <sys/types.h>
#include <sys/stat.h>
@@ -41,6 +41,12 @@
#include "utility.h"
#include "wav.h"
+
+#if defined(_AIX) || defined(AIX)
+# define AFMT_S16_NE AFMT_S16_BE
+#else
+# define AFMT_S16_NE AFMT_S16_LE
+#endif
//Accuracy of fixed point calculations
const int lattice_shift = 10,

1
audio/bonk/pkg-comment Normal file
View file

@ -0,0 +1 @@
lossy/lossless audio compressor

13
audio/bonk/pkg-descr Normal file
View file

@ -0,0 +1,13 @@
Bonk is a an audio compression program that operates in both lossy and
lossless modes. The compression method Bonk uses is quite simple compared to
other lossy formats such as MP3, and is based on speech compression techniques.
It is nevertheless capable of producing a high compression ratio while
maintaining good sound quality.
In lossy mode, it averages 14:1 compression while remaining almost perceptually
lossless. This corresponds to 95 kbps for high quality audio.
In lossless mode the original audio file can be recovered exactly. Lossless
mode typically achieves around 2:1 compression.
WWW: http://yoyo.cc.monash.edu.au/~pfh/bonk/

1
audio/bonk/pkg-plist Normal file
View file

@ -0,0 +1 @@
bin/bonk