The absolute best that can be said here is that the license is somewhat

incompatible with how FreeBSD, and its ports, work.
This commit is contained in:
Ade Lovett 2007-12-12 08:06:37 +00:00
parent e174c2ae2a
commit b4f7e5ead9
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=203200
6 changed files with 0 additions and 308 deletions

View file

@ -74,7 +74,6 @@
SUBDIR += icewm
SUBDIR += ion
SUBDIR += ion-2
SUBDIR += ion-3
SUBDIR += jewel
SUBDIR += jwm
SUBDIR += kahakai

View file

@ -1,78 +0,0 @@
# New ports collection makefile for: ion3-ds
# Date created: 18 June 2005
# Whom: Ed Schouten <ed@fxq.nl>
#
# $FreeBSD$
#
PORTNAME= ion-3rc
PORTVERSION= 20070927
CATEGORIES= x11-wm
MASTER_SITES= http://modeemi.fi/~tuomov/dl/:ion3 \
${MASTER_SITE_LOCAL:S/$/:ion3/} \
http://wannabehacker.com/src/:xinerama
MASTER_SITE_SUBDIR= philip/:ion3
DISTFILES= ${DISTNAME}${EXTRACT_SUFX}:ion3
MAINTAINER= philip@FreeBSD.org
COMMENT= The development version of the Ion window manager
RUN_DEPENDS= run-mailcap:${PORTSDIR}/misc/mime-support
DEPRECATED= is more than 28 days old, which the author states violates his license. Do not contact author.
RESTRICTED= ${DEPRECATED}
EXPIRATION_DATE= 2008-01-12
CONFLICTS= ion-3ds-200*
USE_XLIB= yes
USE_GMAKE= yes
USE_LUA= 5.1
MAKE_ENV= DEFINES="${IONDEFINES}"
.if defined(WITHOUT_NLS)
IONDEFINES+= -DCF_NO_LOCALE
PLIST_SUB+= NLS="@comment "
.else
USE_GETTEXT= yes
PLIST_SUB+= NLS=""
.endif
.if !defined(WITH_XINERAMA)
PLIST_SUB+= XINERAMA="@comment "
.else
PLIST_SUB+= XINERAMA=""
DISTFILES+= mod_xinerama-20070719${EXTRACT_SUFX}:xinerama
.endif
MAN1= ion3.1 pwm3.1
MANLANG= "" fi cs
# Use our own system.mk, instead of the one generated by configure
do-configure:
.include <bsd.port.pre.mk>
post-extract:
.if defined(WITH_XINERAMA)
@${MV} ${WRKDIR}/mod_xinerama-3 ${WRKSRC}/mod_xinerama
.endif
post-patch:
.if defined(NOPORTDOCS)
@${REINPLACE_CMD} -e 's|^_install:|dont&|' ${WRKSRC}/Makefile
.endif
.if defined(WITHOUT_NLS)
@${REINPLACE_CMD} -e 's| po | |' ${WRKSRC}/Makefile
.endif
.if defined(WITH_XINERAMA)
@${REINPLACE_CMD} -e 's|^MODULE_LIST =|& mod_xinerama|' \
${WRKSRC}/modulelist.mk
.endif
post-install:
.if defined(WITH_XINERAMA) && !defined(NOPORTDOCS)
${INSTALL_DATA} ${WRKSRC}/mod_xinerama/README \
${DOCSDIR}/README.mod_xinerama
.endif
.include <bsd.port.post.mk>

View file

@ -1,3 +0,0 @@
MD5 (ion-3rc-20070927.tar.gz) = 85ed3dfe9d3707e383648eb5116dc599
SHA256 (ion-3rc-20070927.tar.gz) = a36cfccfdcc9e896cb0afadd73c3408e4d1f45e7db43399c87185f79ad057900
SIZE (ion-3rc-20070927.tar.gz) = 644789

View file

@ -1,122 +0,0 @@
--- system.mk.orig 2007-09-30 11:41:40.000000000 +0200
+++ system.mk 2007-09-30 11:46:18.000000000 +0200
@@ -7,7 +7,7 @@
## Installation paths
##
-PREFIX=/usr/local
+#PREFIX=/usr/local
# Unless you are creating a package conforming to some OS's standards, you
# probably do not want to modify the following directories:
@@ -17,11 +17,11 @@
# Configuration .lua files
ETCDIR=$(PREFIX)/etc/ion3
# Some .lua files and ion-* shell scripts
-SHAREDIR=$(PREFIX)/share/ion3
+SHAREDIR=$(PREFIX)/share/ion-3rc
# Manual pages
-MANDIR=$(PREFIX)/share/man
+MANDIR=$(MANPREFIX)/man
# Some documents
-DOCDIR=$(PREFIX)/share/doc/ion3
+DOCDIR=$(PREFIX)/share/doc/ion-3rc
# Nothing at the moment
INCDIR=$(PREFIX)/include/ion3
# Nothing at the moment
@@ -47,7 +47,7 @@
#PRELOAD_MODULES=1
# Flags to link with libdl.
-DL_LIBS=-ldl
+#DL_LIBS=-ldl
##
@@ -56,11 +56,11 @@
# If you have installed Lua 5.1 from the official tarball without changing
# paths, this should do it.
-LUA_DIR=/usr/local
-LUA_LIBS = -L$(LUA_DIR)/lib -llua
-LUA_INCLUDES = -I$(LUA_DIR)/include
-LUA=$(LUA_DIR)/bin/lua
-LUAC=$(LUA_DIR)/bin/luac
+LUA_DIR=$(LOCALBASE)
+LUA_LIBS = -L$(LUA_LIBDIR) -llua
+LUA_INCLUDES = -I$(LUA_INCDIR)
+LUA=$(LUA_BINDIR)/lua
+LUAC=$(LUA_BINDIR)/luac
# If you are using the Debian packages, the following settings should be
# what you want.
@@ -74,7 +74,7 @@
## X libraries, includes and options
##
-X11_PREFIX=/usr/X11R6
+X11_PREFIX=$(X11BASE)
# SunOS/Solaris
#X11_PREFIX=/usr/openwin
@@ -83,7 +83,7 @@
# XFree86 libraries up to 4.3.0 have a bug that can cause a segfault.
# The following setting should work around that situation.
-DEFINES += -DCF_XFREE86_TEXTPROP_BUG_WORKAROUND
+#DEFINES += -DCF_XFREE86_TEXTPROP_BUG_WORKAROUND
# Use the Xutf8 routines (XFree86 extension) instead of the Xmb routines
# in an UTF-8 locale. (No, you don't need this in UTF-8 locales, and
@@ -104,7 +104,7 @@
# asprintf and vasprintf in the c library. (gnu libc has.)
# If HAS_SYSTEM_ASPRINTF is not defined, an implementation
# in sprintf_2.2/ is used.
-#HAS_SYSTEM_ASPRINTF=1
+HAS_SYSTEM_ASPRINTF=1
# If you're on an archaic system (such as relatively recent *BSD releases)
# without even dummy multibyte/widechar and localisation support, you may
@@ -112,18 +112,18 @@
#DEFINES += -DCF_NO_LOCALE -DCF_NO_GETTEXT
# On some other systems you may something like this:
-#EXTRA_LIBS += -lintl
-#EXTRA_INCLUDES +=
+EXTRA_LIBS += -L$(LOCALBASE)/lib -lintl
+EXTRA_INCLUDES += -I$(LOCALBASE)/include
# clock_gettime for monotonic time
-EXTRA_LIBS += -lrt
+#EXTRA_LIBS += -lrt
##
## C compiler
##
-CC=gcc
+CC?=gcc
# Same as '-Wall -pedantic' without '-Wunused' as callbacks often
# have unused variables.
@@ -131,8 +131,8 @@
-Wtrigraphs -Wformat -Wchar-subscripts \
-Wparentheses -pedantic -Wuninitialized
-CFLAGS=-Os $(WARN) $(DEFINES) $(EXTRA_INCLUDES) $(INCLUDES)
-LDFLAGS=-Os $(EXTRA_LIBS) $(LIBS)
+CFLAGS+=$(WARN) $(DEFINES) $(EXTRA_INCLUDES) $(INCLUDES)
+LDFLAGS+=$(EXTRA_LIBS) $(LIBS)
EXPORT_DYNAMIC=-Xlinker --export-dynamic
# The following options are mainly for development use and can be used
@@ -146,7 +146,7 @@
#POSIX_SOURCE=-D_POSIX_C_SOURCE=200112L
# Most systems
-#XOPEN_SOURCE=-D_XOPEN_SOURCE -D_XOPEN_SOURCE_EXTENDED
+XOPEN_SOURCE=-D_XOPEN_SOURCE -D_XOPEN_SOURCE_EXTENDED
# SunOS, (Irix)
#XOPEN_SOURCE=-D__EXTENSIONS__

View file

@ -1,20 +0,0 @@
Ion (based on PWM) is a new kind of window manager that brings a
text-editorish, keyboard friendly user interface to window management.
Modern GUIs are unusable. Overlapping windows are hard to manage, especially
from the keyboard, and the user often ends up in a jungle. Not to mention the
application programs, which are even worse. Mouse-based search-and-click
interfaces are slow - keyboard is fast having learnt the commands. Ion (the
last three letters of vision =-) was written as an example and an experiment of
something presumably better (just the window manager, though).
Ion simply divides the screen into frames that take the whole screen. Big
displays have so much space that this is convenient and smaller displays
couldn't show more than one window at a time anyway. The frames can be split
and growing the size of one will shrink others. Alike in PWM, clients can be
moved between frames and multiple clients can be attached to one frame.
With Ion you will hardly ever have to touch the mouse again for navigation
between windows and the windows are always in order.
WWW: http://modeemi.cs.tut.fi/~tuomov/ion/

View file

@ -1,84 +0,0 @@
bin/ion3
bin/pwm3
etc/ion3/cfg_defaults.lua
etc/ion3/cfg_dock.lua
etc/ion3/cfg_ion.lua
etc/ion3/cfg_ioncore.lua
etc/ion3/cfg_kludges.lua
etc/ion3/cfg_layouts.lua
etc/ion3/cfg_menu.lua
etc/ion3/cfg_pwm.lua
etc/ion3/cfg_query.lua
etc/ion3/cfg_sp.lua
etc/ion3/cfg_statusbar.lua
etc/ion3/cfg_tiling.lua
etc/ion3/look.lua
etc/ion3/look_brownsteel.lua
etc/ion3/look_clean.lua
etc/ion3/look_cleanios.lua
etc/ion3/look_cleanviolet.lua
etc/ion3/look_dusky.lua
etc/ion3/look_greenlight.lua
etc/ion3/look_greyviolet.lua
etc/ion3/look_ios.lua
etc/ion3/look_newviolet.lua
etc/ion3/look_simpleblue.lua
etc/ion3/lookcommon_clean.lua
etc/ion3/lookcommon_emboss.lua
lib/ion3/bin/ion-completefile
lib/ion3/bin/ion-statusd
lib/ion3/lc/de.lc
lib/ion3/lc/ioncore_bindings.lc
lib/ion3/lc/ioncore_efbb.lc
lib/ion3/lc/ioncore_ext.lc
lib/ion3/lc/ioncore_luaext.lc
lib/ion3/lc/ioncore_menudb.lc
lib/ion3/lc/ioncore_misc.lc
lib/ion3/lc/ioncore_tabnum.lc
lib/ion3/lc/ioncore_wd.lc
lib/ion3/lc/ioncore_winprops.lc
lib/ion3/lc/mod_dock.lc
lib/ion3/lc/mod_menu.lc
lib/ion3/lc/mod_query.lc
lib/ion3/lc/mod_query_chdir.lc
lib/ion3/lc/mod_sm.lc
lib/ion3/lc/mod_sp.lc
lib/ion3/lc/mod_statusbar.lc
lib/ion3/lc/mod_tiling.lc
lib/ion3/lc/statusd_date.lc
lib/ion3/lc/statusd_load.lc
lib/ion3/lc/statusd_mail.lc
lib/ion3/mod/de.so
lib/ion3/mod/mod_dock.so
lib/ion3/mod/mod_menu.so
lib/ion3/mod/mod_query.so
lib/ion3/mod/mod_sm.so
lib/ion3/mod/mod_sp.so
lib/ion3/mod/mod_statusbar.so
lib/ion3/mod/mod_tiling.so
%%XINERAMA%%lib/ion3/lc/mod_xinerama.lc
%%XINERAMA%%lib/ion3/mod/mod_xinerama.so
%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
%%PORTDOCS%%%%DOCSDIR%%/LICENSE
%%PORTDOCS%%%%DOCSDIR%%/README
%%PORTDOCS%%%%DOCSDIR%%/RELNOTES
%%XINERAMA%%%%PORTDOCS%%%%DOCSDIR%%/README.mod_xinerama
%%DATADIR%%/ion-completeman
%%DATADIR%%/ion-runinxterm
%%DATADIR%%/welcome.cs.txt
%%DATADIR%%/welcome.fi.txt
%%DATADIR%%/welcome.txt
%%NLS%%share/locale/cs/LC_MESSAGES/ion3.mo
%%NLS%%share/locale/fi/LC_MESSAGES/ion3.mo
%%NLS%%share/locale/fr/LC_MESSAGES/ion3.mo
@dirrm lib/ion3/bin
@dirrm lib/ion3/lc
@dirrm lib/ion3/mod
@dirrm lib/ion3
@dirrm %%DATADIR%%
%%PORTDOCS%%@dirrm %%DOCSDIR%%
@dirrmtry etc/ion3
@dirrmtry man/cs/man1
@dirrmtry man/cs
@dirrmtry man/fi/man1
@dirrmtry man/fi